X
Toca aquí para ir a una versión del sitio para dispositivos móviles.

Foro de asistencia

I keep getting text blur / distortion

Publicadas

Recently parts of the text but not all the text on a webpage has started to blur or distort. Sometimes this distortion moves to the right. If i hover my mouse over the distortion or scroll the page it disappears. This is especially annoying on Facebook ect. I have not noticed this problem in IE or Chome but i havn't used either for prolonged periods to be honest. It's hard to test what causes it because the problem is intermittent, Facebook is affected the worst but have had this problem on other websites including this form and even in the Addon menu.

I have tried, running in safe mode, disabling plugins and clearing the cache none of which have solved the problem.

here's a screenshot of the distortion: http://img5.imageshack.us/img5/2128/facebookblur.png

Recently parts of the text but not all the text on a webpage has started to blur or distort. Sometimes this distortion moves to the right. If i hover my mouse over the distortion or scroll the page it disappears. This is especially annoying on Facebook ect. I have not noticed this problem in IE or Chome but i havn't used either for prolonged periods to be honest. It's hard to test what causes it because the problem is intermittent, Facebook is affected the worst but have had this problem on other websites including this form and even in the Addon menu. I have tried, running in safe mode, disabling plugins and clearing the cache none of which have solved the problem. here's a screenshot of the distortion: http://img5.imageshack.us/img5/2128/facebookblur.png

Datos adicionales del sistema

Plugins instalados

  • Shockwave Flash 11.6 r602
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.0.2
  • 5.1.10411.0
  • Windows Activation Technologies Plugin for Mozilla
  • NPWLPG
  • Contribute Firefox IBE Plugin DLL
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.69

Aplicación

  • Firefox 19.0.2
  • Agente de usuario: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • URL de asistencia: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Extensiones

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Adobe Contribute Toolbar 6.0 ({01A8CA0A-4C96-465b-A49B-65C46FAD54F9}) (inactivo)
  • Java Console 6.0.35 ({CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA}) (inactivo)

JavaScript

  • incrementalGCEnabled: True

Gráficos

  • adapterDescription: ATI Radeon HD 4600 Series
  • adapterDescription2:
  • adapterDeviceID: 0x9498
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 7-3-2012
  • driverDate2:
  • driverVersion: 8.970.100.3000
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4600 Series)
  • windowLayerManagerType: Direct3D 10

Preferencias modificadas

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Miscelánea

  • JS del usuario: no
  • Accesibilidad: no
Live2Mod 0 soluciones 2 respuestas
Publicadas

It's a known issue by now. I have the same problem after the 19 update, but when I disable Hardware Acceleration everything is fine. Click on orange Firefox button and then options > options > Advanced tab > General tab > and uncheck Use Hardware Acceleration When Available

This isn't much of a solution since the browsing speed is affected quite noticeable. On this support site they say you should update graphic drivers etc. to fix this, I did all that and still have the same problem so I'm 99.9% sure that this has to be a Firefox bug since it occurred just after I updated to Firefox ver 19

It's a known issue by now. I have the same problem after the 19 update, but when I disable Hardware Acceleration everything is fine. Click on orange Firefox button and then options > options > Advanced tab > General tab > and uncheck Use Hardware Acceleration When Available This isn't much of a solution since the browsing speed is affected quite noticeable. On this support site they say you should update graphic drivers etc. to fix this, I did all that and still have the same problem so I'm 99.9% sure that this has to be a Firefox bug since it occurred just after I updated to Firefox ver 19

Modificadas por Live2Mod el

cor-el
  • Top 10 Contributor
  • Moderator
16391 soluciones 147877 respuestas
Publicadas

Respuesta útil

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled. *http://kb.mozillazine.org/about:config

Autor de la pregunta

Thanks to both of you, i first turned off hardware acceleration and that seemed to solve the problem. I then turned hardware acceleration back on and set the gfx.content.azure.enabled pref to false and i haven't had the problem since cheers!

Thanks to both of you, i first turned off hardware acceleration and that seemed to solve the problem. I then turned hardware acceleration back on and set the gfx.content.azure.enabled pref to false and i haven't had the problem since cheers!
panin29 0 soluciones 1 respuestas
Publicadas

Respuesta útil

The "blurred text in forms" bug has been driving me mad over the last few days. Each time I'd scroll to a new paragraph, the text would be blurry. It very recently started (today is March 13) so I think mine came with the update too. It takes so long for the blurred text to resolve itself into something readable.

I did not want to try the hardware acceleration fix after I read above that it would slow down my browsing.

I tried gfx.content.azure.enabled fix instead and it was no-goodski. It turned portions of my browser's window, like the tab titles, black. I could not read them.

Next I tried gfx.direct2d.disabled. That worked! Thanks very much, cor-el! I hope disabling this preference will not have some as-yet-unseen negative affect on my ability to view things in the web browser?

For those of you who are as clueless as myself, here are some more details about doing this fix from cor-el:

1. type about:config directly into your URL address bar and press Enter.

2. You will see a long list of preferences. They are alphabetically sorted for the most part, so just scroll down to the G's to find the gfx ones.

3. Right click on the preference you want to change. "Toggle" means if it says "true," selecting "Toggle" will make it say "false" and vice-versa.

4. The preference takes effect almost immediately, but you do have to take some action first to see it. If you chose the "azure" fix, click on another open tab, and see if they turn black on you.

The "blurred text in forms" bug has been driving me mad over the last few days. Each time I'd scroll to a new paragraph, the text would be blurry. It very recently started (today is March 13) so I think mine came with the update too. It takes so long for the blurred text to resolve itself into something readable. I did not want to try the hardware acceleration fix after I read above that it would slow down my browsing. I tried '''gfx.content.azure.enabled''' fix instead and it was no-goodski. It turned portions of my browser's window, like the tab titles, black. I could not read them. Next I tried '''gfx.direct2d.disabled'''. That worked! Thanks very much, cor-el! I hope disabling this preference will not have some as-yet-unseen negative affect on my ability to view things in the web browser? For those of you who are as clueless as myself, here are some more details about doing this fix from cor-el: 1. type '''about:config''' directly into your URL address bar and press Enter. 2. You will see a long list of preferences. They are alphabetically sorted for the most part, so just scroll down to the G's to find the gfx ones. 3. Right click on the preference you want to change. "Toggle" means if it says "true," selecting "Toggle" will make it say "false" and vice-versa. 4. The preference takes effect almost immediately, but you do have to take some action first to see it. If you chose the "azure" fix, click on another open tab, and see if they turn black on you.

Modificadas por panin29 el

Live2Mod 0 soluciones 2 respuestas
Publicadas

I set gfx.direct2d.disabled to true and it fixed the blurry text without performance shortages. But some bookmarks sub-folders content in the bookmark toolbar are totally glitched and unreadable.

Please Mozilla team I know you can do it, fix this bug/issue. All this fixes are not a solution but more or less a temporary work around. Nothing glitched on my computer but Firefox after the 19 update, all the other browsers display stuff without a problem I don't know why should only Firefox be the black sheep among it's competitors.

I set '''gfx.direct2d.disabled''' to true and it fixed the blurry text without performance shortages. But some bookmarks sub-folders content in the bookmark toolbar are totally glitched and unreadable. Please Mozilla team I know you can do it, fix this bug/issue. All this fixes are not a solution but more or less a temporary work around. Nothing glitched on my computer but Firefox after the 19 update, all the other browsers display stuff without a problem I don't know why should only Firefox be the black sheep among it's competitors.

Modificadas por Live2Mod el

RedfishTheCat 0 soluciones 2 respuestas
Publicadas

I tried gfx.direct2d.disabled > true, but it make me loose smooth of the font... all text in web pages become unrefined, not pleasant to read.

:-/
I tried gfx.direct2d.disabled > true, but it make me loose smooth of the font... all text in web pages become unrefined, not pleasant to read. :-/

Modificadas por RedfishTheCat el

auriga81 0 soluciones 3 respuestas
Publicadas

Hi, I have the same problem with blurred fonts that disappear when scrolling. I don't want to disable hardware acceleration, because it has been always enabled until now and it worked perfectly.

However, I think I've found the cause of this mess... it's Internet Explorer 10! In fact the issue appeared after IE10 has been installed by Windows Update.

Try to uninstall it and the fonts in Firefox will be good again (hopefully Mozilla will fix this issue, though, as sooner or later we will have to update IE).

Hi, I have the same problem with blurred fonts that disappear when scrolling. I don't want to disable hardware acceleration, because it has been always enabled until now and it worked perfectly. However, I think I've found the cause of this mess... it's '''Internet Explorer 10'''! In fact the issue appeared after IE10 has been installed by Windows Update. Try to '''uninstall it and the fonts in Firefox will be good again''' (hopefully Mozilla will fix this issue, though, as sooner or later we will have to update IE).
auriga81 0 soluciones 3 respuestas
Publicadas

I found that at least the bug is known by Mozilla:

Bug #812695

I found that at least the bug is known by Mozilla: [https://bugzilla.mozilla.org/show_bug.cgi?id=812695 Bug #812695]
cor-el
  • Top 10 Contributor
  • Moderator
16391 soluciones 147877 respuestas
Publicadas

You can also try to uninstall Windows update KB2670838 if you have this update.

You can also try to uninstall Windows update KB2670838 if you have this update. *http://support.microsoft.com/kb/2670838
auriga81 0 soluciones 3 respuestas
Publicadas

Yes, thanks, it fixed the blur issue for now (but it uninstalled IE10 too of course)!

Yes, thanks, it fixed the blur issue for now (but it uninstalled IE10 too of course)!
Sonya Finkey 1 soluciones 9 respuestas
Publicadas

If you tried all the available fixes in about:config and Options|Advanced|General to no avail, there's one last thing to try. Get rid of the current Firefox in your system. That includes deleting the Mozilla folder from your Programs and from your User Application Data. Then down grade to a lower version of Firefox, such as 15.0, where the text in menus shows grayed out instead of smudgy. Then upgrade to the latest Firefox. This works n a Windows XP Pro 32-bit environment.

If you tried all the available fixes in about:config and Options|Advanced|General to no avail, there's one last thing to try. Get rid of the current Firefox in your system. That includes deleting the Mozilla folder from your Programs and from your User Application Data. Then down grade to a lower version of Firefox, such as 15.0, where the text in menus shows grayed out instead of smudgy. Then upgrade to the latest Firefox. This works n a Windows XP Pro 32-bit environment.
lksd 0 soluciones 2 respuestas
Publicadas

Same issue here since version 19. (Windows 7 x64 Firefox 21 32b, ATI 5145)

Disabling hardware acceleration or turning off direct2d as backend is hardly a solution, i won't even consider it as a workaround. I do realize that there are 'some' people with this issue, hardly worth looking into, but i would like to see this issue resolved, otherwise, like other people i will be forced to change browser not because i want to, i regard Firefox as being the best and have it heavily customized.

Could blurry fonts issue be resolved w/o disabling gpu backend ?

Same issue here since version 19. (Windows 7 x64 Firefox 21 32b, ATI 5145) Disabling hardware acceleration or turning off direct2d as backend is hardly a solution, i won't even consider it as a workaround. I do realize that there are 'some' people with this issue, hardly worth looking into, but i would like to see this issue resolved, otherwise, like other people i will be forced to change browser not because i want to, i regard Firefox as being the best and have it heavily customized. Could blurry fonts issue be resolved w/o disabling gpu backend ?
Sonya Finkey 1 soluciones 9 respuestas
Publicadas

Just an aside, no loss here for IE 10. One cannot customize the command bar. It's stiff, un-user friendly.

Just an aside, no loss here for IE 10. One cannot customize the command bar. It's stiff, un-user friendly.
osinac 0 soluciones 1 respuestas
Publicadas

deleting KB2670838 worked for me. How annoying Microsoft release updates that make things worse!! to delete go to control panel then programs and features then view installed updates (on the left) select KB2670838 and click uninstall.

deleting KB2670838 worked for me. How annoying Microsoft release updates that make things worse!! to delete go to control panel then programs and features then view installed updates (on the left) select KB2670838 and click uninstall.
Biffa 0 soluciones 1 respuestas
Publicadas

I've had the same problem and tried lots of things. I did the about:config as mentioned previously, checked drivers and altered acceleration without success.

I went into control panel and display and ran diagnostics.

At one point and I'm sorry I cannot remember exactly where, I got to tick a box for 'clear type'.

It was as simple as that. The font changed before my eyes.

Hope this helps as it certainly made mine perfectly clear

Biffa

I've had the same problem and tried lots of things. I did the about:config as mentioned previously, checked drivers and altered acceleration without success. I went into control panel and display and ran diagnostics. At one point and I'm sorry I cannot remember exactly where, I got to tick a box for 'clear type'. It was as simple as that. The font changed before my eyes. Hope this helps as it certainly made mine perfectly clear Biffa
lksd 0 soluciones 2 respuestas
Publicadas

I believe i have sorted it our for me. 1. about:config 2. searched for gfx and layer 3. restored all above to the default levels 4. did not have a problem since

So i turns out it was a Carbon[Human/Mine] error not Firefrox's :)

I believe i have sorted it our for me. 1. about:config 2. searched for gfx and layer 3. restored all above to the default levels 4. did not have a problem since So i turns out it was a Carbon[Human/Mine] error not Firefrox's :)
vessto 4 soluciones 65 respuestas
Publicadas

I just installed IE 10 at work (Win 7 x32) and got this porblem. I googled it and found this thread. If I had suspiction before now I'm sure IE 10 is the prob. Still I wish I keeped it and have it at home too (Win 8 x64). But if it will cause probs to MF (my main browser) then I must uninstall it. I hope MF engineers will find some solution soon and I'll be able to install IE 10 again.

PS. I uninstalled Windows update KB2670838 and IE 10 was gone too. Text is back to its normal.

I just installed IE 10 at work (Win 7 x32) and got this porblem. I googled it and found this thread. If I had suspiction before now I'm sure IE 10 is the prob. Still I wish I keeped it and have it at home too (Win 8 x64). But if it will cause probs to MF (my main browser) then I must uninstall it. I hope MF engineers will find some solution soon and I'll be able to install IE 10 again. PS. I uninstalled Windows update KB2670838 and IE 10 was gone too. Text is back to its normal.

Modificadas por vessto el

vessto 4 soluciones 65 respuestas
Publicadas

Just did the "clear type" settings without success.:(

Just did the "clear type" settings without success.:(

Modificadas por vessto el

CarliusAmigus 0 soluciones 1 respuestas
Publicadas

Disabling gfx.content.azure didn't work for me. Disabling gfx.direct2d did improve things a lot, although still not perfect I believe (as when disabling hardware acceleration, which slows down the browser). Hope this gets sorted out soon, any news? Using Windows 8 x64, AMD 5670 card.

Disabling gfx.content.azure didn't work for me. Disabling gfx.direct2d did improve things a lot, although still not perfect I believe (as when disabling hardware acceleration, which slows down the browser). Hope this gets sorted out soon, any news? Using Windows 8 x64, AMD 5670 card.

Modificadas por CarliusAmigus el

smartybritches 0 soluciones 1 respuestas
Publicadas

Am I the only one having this problem on Mac? I have put up with it for years and finally have had enough, but none of the proposed fixes here worked. I don't even see some of the config options mentioned. I really don't think I should have to completely remove and replace my browser to fix something as seemingly simple as this. Any other Mac users have a solution?

Am I the only one having this problem on Mac? I have put up with it for years and finally have had enough, but none of the proposed fixes here worked. I don't even see some of the config options mentioned. I really don't think I should have to completely remove and replace my browser to fix something as seemingly simple as this. Any other Mac users have a solution?