Buscar en Ayuda

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 'Plugin Check' and Java, need help

  • 4 respuestas
  • 35 tienen este problema
  • 5 visitas
  • Última respuesta de Curious Mew

more options

I'm a noob, hi :D

Okay, so I just barely reinstalled Windows 7 and overwhelmingly updated all there is to update on this Windows machine.. including Java, from a very annoying popup window (there is still another bubble popping up, but it doesn't give me any publisher name and I decline the option every time).

So going through the Firefox 'Plugin Check' checklist, Firefox is telling me that my Java still needs updating.. although the Java website tells me I am running the latest version?

Firefox Plugins:

  1. Java(TM) Platform SE 6 U32
  2. Java Deployment Toolkit

According to Java, it thinks I am running 32 bit Firefox --but my machine is a 64 bit, and says so in the 'about:support' html link. It says I am running WOW64, I guess I'm running 64 bit Firefox?

How do I make Firefox recognize Java? I have looked through my installed programs list and find these 3 Java programs:

  1. Java(TM) 6 Update 15 (64-bit), Installed 1/9/2010
  2. Java(TM) 6 Update 32, Installed 6/6/2012
  3. Java (TM) SE Development Kit 6 Update 15 (64-bit), Installed 1/9/2010

I don't think I downloaded the right version of Java.. but I'm really not sure how I should fix this?

I'm a noob, hi :D Okay, so I just barely reinstalled Windows 7 and overwhelmingly updated all there is to update on this Windows machine.. including Java, from a very annoying popup window (there is still another bubble popping up, but it doesn't give me any publisher name and I decline the option every time). So going through the Firefox 'Plugin Check' checklist, Firefox is telling me that my Java still needs updating.. although the Java website tells me I am running the latest version? Firefox Plugins: # Java(TM) Platform SE 6 U32 # Java Deployment Toolkit According to Java, it thinks I am running 32 bit Firefox --but my machine is a 64 bit, and says so in the 'about:support' html link. It says I am running WOW64, I guess I'm running 64 bit Firefox? How do I make Firefox recognize Java? I have looked through my installed programs list and find these 3 Java programs: # Java(TM) 6 Update 15 (64-bit), Installed 1/9/2010 # Java(TM) 6 Update 32, Installed 6/6/2012 # Java (TM) SE Development Kit 6 Update 15 (64-bit), Installed 1/9/2010 I don't think I downloaded the right version of Java.. but I'm really not sure how I should fix this?

Modificadas por Curious Mew el

Solución elegida

At this time, Firefox for Windows is a 32-bit application, regardless of the "bitness" of your Windows. For best compatibility, you may want to stick with 32-bit add-ons.

I suggest uninstalling all your Javas and grabbing the newest one, which actually is Java 7 (there is a gradual rollout of Java 7; Java 6 is still secure and up-to-date if you prefer).

The Java test page will lead you back to the download: http://www.java.com/en/download/testjava.jsp

Leer esta respuesta en su contexto 👍 1

Todas las respuestas (4)

more options

Solución elegida

At this time, Firefox for Windows is a 32-bit application, regardless of the "bitness" of your Windows. For best compatibility, you may want to stick with 32-bit add-ons.

I suggest uninstalling all your Javas and grabbing the newest one, which actually is Java 7 (there is a gradual rollout of Java 7; Java 6 is still secure and up-to-date if you prefer).

The Java test page will lead you back to the download: http://www.java.com/en/download/testjava.jsp

more options

Okay, um.. why didn't I ever see this window before? I just installed a 64-bit version of Java a few days ago, and the link you gave me there is telling me that an old version of Java has been detected on my system? I only have 4 versions of Java downloaded on my computer, surely one of them can do the job?

My list of Java:

  1. Java(TM) 6 Update 15 (64-bit) | Sun Microsystems, Inc. | 1/9/2010
  2. Java(TM) 6 Update 32 | Oracle | 6/6/2012
  3. Java(TM) 7 Update 4 (64-bit) | Oracle | 6/7/2012
  4. Java(TM) SE Development Kit 6 Update 15 (64-bit) | Sun Microsystems Inc. | 1/9/2010

I thought the Java website was giving me the updates I needed? I never knew about 7 :O

more options

Actually, scratch that! I just did as you said, and this is what my Java currently looks like:

  1. Java(TM) 7 Update 4 | Oracle | 6/10/2012
  2. JavaFX 2.1.0 | Oracle Corporation | 6/10/2012

I think I've got it right this time. I first installed the update in that link you provided, then uninstalled the 4 mentioned above. I am crossing my fingers that this update also gets rid of an annoying Java popup window (jucheck.exe) that I have been experiencing by default over the past 3-4 years.

Thanks jscher2000, i appreciate your advice!

more options

p.s. this also fixed the Firefox Plugin Check, now I'm completely up-to-date! >:D