X
Toca aquí para ir a una versión del sitio para dispositivos móviles.
¡Firefox no está actualizado y puede ser un riesgo para la seguridad! Actualiza Firefox

Foro de asistencia

AVG Secure Search appears when I use Google Search from my Home page only.

Publicadas

My home page is the Firefox default page with the Google searchbar. I like getting occasional messages from Firefox when I log in so I don't want to change my homepage. However, when I use the searchbar on my homepage only, I get the unsatisfactory AVG Secure Search results.

UPDATE: I now realize all the troubleshooting information I included in my original question appears under the "More System Details" link next to the question, not in the body of the question. I have copied it here to make it easier to see what I have already done to try to solve the problem, as well as describe the one clue I have that may be relevant:

I have tried all the fixes on various threads, but my about:config is now pristine (no avg or isearch mentions; keyword.url is default). Closest solution is that at https://support.mozilla.org/en-US/questions/866327 , which requires changing my home page.

Oddly, AVG Secure Search is not a problem when I use the Google toolbar or search from the Google website, only when I use the search bar that appears on my home (start) page. This is true even when I return to my home page--if I search from the Google search bar in the middle of the page, I get sent to AVG Safe Search. (isearch.avg.com).

I read in one thread a suggestion to delete my chromeappsstore.sqlite file in my Profile folder. As promised, Firefox created a new one when I restarted it; however, the search bar in the middle of my home home page did not work at all. Tried this three times before restoring my original.

I do not have an application that will open a sqlite file, but I tried doing so in Excel and found a cell containing the following:

emoh.:moz-safe-aboutsearch-engine{"name":"AVG Secure Search","searchUrl":"http://isearch.avg.com/search?cid={7A3C25A0-E345-4507-AA31-D98F596A81A9}&mid=c48135235ba247d18ac1d14b344db451-addd29eab2809954d5abdf0b991a5b911a297819&ds=is015&lang=en&v=10.0.0.7&pr=sa&d=&sap=dsp&q=_searchTerms_"}

I have no clue what that means, but it is the only thing I can find related to Firefox that still mentions AVG and isearch.avg.com.

At this point my best guess (but it is a guess) is that the chromeappsstore.sqlite file is a key to the complete solution, but I do not have enough knowledge to go beyond and address it. I appreciate any help you anyone can offer.

Modificadas por DrBB01 el

Solución elegida

I think I have solved the problem. As someone who has only occasionally used used Access and other database applications, I first needed to find a free app that would allow me to edit chromeappsstore.sqlite. Then I needed instruction on how to edit it. I found the answers to both these questions at https://support.mozilla.org/en-US/questions/779082 . Thanks Dr. Watson; you anticipated my needs 10 months ago!

I don't think I would have been able to articulate my questions clearly enough to find the solution without posting here first.

For others who try this solution not familiar with databases: make sure you backup a copy of chromeappsstore.sqlite before trying this fix; you cannot save a copy under a different name from within the sqlitebrowser application (or at least I could not find a "save as" feature).

Leer esta respuesta en su contexto 4

Datos adicionales del sistema

Ocurrió esto

Cada vez que Firefox se abre

Esto comenzó cuando...

Several weeks ago. I found several fixes involving removing AVG Safe Search from my search bar and changes to about:config that seemed to do the trick. I am unaware how the toolbar was installed however.

Plugins instalados

  • Shockwave Flash 11.2 r202
  • Google Update
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Cooliris embedded in a tab
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • Picasa plugin
  • 5.0.61118.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • HP Product Detection Plugin
  • GEPlugin
  • HP Active Check Plugin
  • Logitech Device Detection
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • NPWLPG
  • ActiveTouch General Plugin Container Version 105
  • Office Live Update v1.5
  • Windows Activation Technologies Plugin for Mozilla
  • 5.1.0.0
  • 2.0.0048.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • np-mswmp
  • Package Installer & Install Conduit
  • Office Plugin for Netscape Navigator
  • PDF-XChange Viewer Netscape Gecko Plugin

Aplicación

  • Agente de usuario: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

Más información

I have tried all the fixes on various threads, but my about:config is now pristine (no avg or isearch mentions; keyword.url is default). Closest solution is that at https://support.mozilla.org/en-US/questions/866327 , which requires changing my home page.
Oddly, AVG Secure Search is ''not'' a problem when I use the Google toolbar or search from the Google website, only when I use the search bar that appears on my home (start) page. This is true even when I return to my home page--if I search from the Google search bar in the middle of the page, I get sent to AVG Safe Search.
I also read in one thread a suggestion to delete my chromeappsstore.sqlite file in my Profile folder. As promised, Firefox created a new one when I restarted it; however, the search bar did not work at all. Tried this three times before restoring my original.
I do not have an application that will open a sqlite file, but I tried doing so in Excel and found a cell containing the following:
emoh.:moz-safe-aboutsearch-engine{"name":"AVG Secure Search","searchUrl":"http://isearch.avg.com/search?cid={7A3C25A0-E345-4507-AA31-D98F596A81A9}&mid=c48135235ba247d18ac1d14b344db451-addd29eab2809954d5abdf0b991a5b911a297819&ds=is015&lang=en&v=10.0.0.7&pr=sa&d=&sap=dsp&q=_searchTerms_"}
I have no clue what that means, but it is the only thing I can find that still mentions AVG and isearch.avg.com.
At this point my best guess (but it is a guess) is that the chromeappsstore.sqlite file is a key to the complete solution, but I do not have enough knowledge to go beyond and address it. I appreciate any help you anyone can offer.

Swarnava Sengupta 482 soluciones 3134 respuestas
Publicadas

See:

Modificadas por Swarnava Sengupta el

immorTal 0 soluciones 10 respuestas
Publicadas

Ugh, never mind. Apparently, the topic I started and clicked was not the topic that opened up.

Modificadas por immorTal el

Tyler Downer
  • Administrator
  • Moderator
1164 soluciones 6629 respuestas
Publicadas

Respuesta útil

If you install https://addons.mozilla.org/en-US/firefox/addon/searchreset/, does it help?

Autor de la pregunta

No. Thanks for the suggestion.

Tyler Downer
  • Administrator
  • Moderator
1164 soluciones 6629 respuestas
Publicadas

Ok, so just so I'm sure I'm understanding this correctly: You have your home page set to the Firefox default. But when you do searches from the search bar inside the home page (not the one in the upper right hand corner of the page) you get redirected to AVG Safe Search? is that correct?

Are you using AVG on your computer? there is an AVG uninstaller you can run if you wanted to switch to another anti-virus such as Microsoft Security Essentials, but only if you want to do that.

cor-el
  • Top 10 Contributor
  • Moderator
10737 soluciones 96600 respuestas
Publicadas

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  • Open the about:config page via the location bar
  • Type in the Filter bar: mstone
  • Right-click the browser.startup.homepage_override.mstone line and select: Reset
  • Close and restart Firefox

Solución elegida

I think I have solved the problem. As someone who has only occasionally used used Access and other database applications, I first needed to find a free app that would allow me to edit chromeappsstore.sqlite. Then I needed instruction on how to edit it. I found the answers to both these questions at https://support.mozilla.org/en-US/questions/779082 . Thanks Dr. Watson; you anticipated my needs 10 months ago!

I don't think I would have been able to articulate my questions clearly enough to find the solution without posting here first.

For others who try this solution not familiar with databases: make sure you backup a copy of chromeappsstore.sqlite before trying this fix; you cannot save a copy under a different name from within the sqlitebrowser application (or at least I could not find a "save as" feature).

Modificadas por DrBB01 el

Autor de la pregunta

Hi Tylerdowner-- As you see, I solved the problem. FYI, at some point, I installed a program and forgot to uncheck the AVG search bar installation that came along with it. That's started the ball rolling. However, I had found several threads with solutions--removing it from the search bar options, editing about:config, and removing all traces of AVG from my hard drive--that seemed to solve problem. That is, until I opened Firefox (home page is about:home) and did a search from the home page search bar and the results came up in isearch.avg.com!

I could not find any thread--except for the reference to chromeappsstore.sqlite and my subsequent discovery that text for "isearch.avg.com" was contained in it. After posting my question, I shifted my search to "chromeappsstore.sqlite," and that's how I found the solution.

That said, why this remnant of AVG Safe Search remained after addressing all the other solutions is beyond my knowledge. But I wouldn't be surprised if others may be experiencing something similar.

Thanks for your efforts! Much appreciated.

cor-el
  • Top 10 Contributor
  • Moderator
10737 soluciones 96600 respuestas
Publicadas

Deleting the browser.startup.homepage_override.mstone pref like I posted above([/questions/924840#answer-324871]) should have had the same effect and rebuild the chromeappsstore.sqlite database with the default search engine for the about:home page.

Autor de la pregunta

Thanks cor-el! I may test your solution at a later time because it is a simpler way to address the problem if it comes up again (and I'm sure it will...).  :-)

Much appreciated.

pressedham_d 0 soluciones 1 respuestas
Publicadas

I am experiencing the issue that DrBB01 has described here. cor-el's solution is not effective.

I also tried deleting chromeappsstore.sqlite, which also was not effective.

Modificadas por pressedham_d el

Autor de la pregunta

pressedham_d-- Try the other suggested solutions at: https://support.mozilla.org/en-US/questions/779082 , particularly those suggested by Dr. Watson and co-rel. The AVG Search Bar problem hit me several times on different computers, and solutions that worked the each time, didn't on succeeding times; however, at least one of these worked each time. In order, I would try editing chromeappsstore.sqlite, then editing about:home as co-rel recommends (also search about:config for "isearch" for other entries that may need resetting). If those fail, then delete chromeappsstore.sqlite. Hopefully, one of these will take care of the problem.

Now, if you are like me, without an sqlite editor, I found a Firefox add-on that allowed me to edit chromeappsstore.sqlite, SQLite Manager 0.7.7. It was pretty easy to use.

Good luck! --DrBB01

lithodora 0 soluciones 2 respuestas
Publicadas

Editing the database nearly worked. I had an issue where it wouldn't let me edit the value so I wrote my own SQL query:

INSERT INTO `webappsstore2` (`scope`, `key`, `value`, `secure`, `owner`) VALUES ('emoh.:moz-safe-about', 'search-engine', ' {"name":"Google","searchUrl":"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a"}', '0', );


Thanks

KerriB 0 soluciones 7 respuestas
Publicadas

Respuesta útil

Here is the way to get rid of the problem once and for all:

http://forums.avg.com/ww-en/avg-forums?sec=thread&act=show&id=196402#post_196402

Autor de la pregunta

KerriB-- Thanks for sharing another option. I hesitate to agree with the "once and for all" part, however, as one who has installed the AVG security bar unknowingly several times.  :-)

Of course, all of these solutions beg the following question: Why not make installation an "opt in" process, rather than opt out? At first glance, I'm sure it uses the browser add-on to collect information about browsing patterns it can use or sell--that is, it's potentially profitable. That must be counterbalanced against the loss of good will of thousands--even millions--of unhappy users who cannot easily remove the AVG search bar from their browsers: people like us! Frankly, there are enough excellent free anti-malware programs available that I will no longer consider AVG as an option. I suspect there are many others like me. Think about that, AVG!

KerriB 0 soluciones 7 respuestas
Publicadas

DrBB01 You're absolutely right! I was searching everywhere for the solution. Finally found it in the AVG forum. It seems they just posted the solution yesterday. I had to read thru 4 pages of very mad ppl at the forum, finally, AVG put a link to it. Thank GOD. It did work for me too.

KerriB 0 soluciones 7 respuestas
Publicadas

Excuse me, they made the solution to the problem in April or May, but they didn't put the link to the prob in that particular thread until yesterday. They just let ppl go on and on complaining for a couple of months.

quyennb 0 soluciones 1 respuestas
Publicadas

I have upgraded firefox to 13. flash of the machine that I have or even faulty iexin help me

[Spam removed by moderator. Please read Forum rules and guidelines, thanks.]

Modificadas por Chris Ilias el

noel_d3 0 soluciones 1 respuestas
Publicadas

The fastest and easiest solution to remove AVG as default research engine in mozilla :

write in the address bar: "about: config"

write in search filter: "avg"

Right click on each line and "reset".

Best,