Buscar en Ayuda

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I try to download Firefox 3.6.13 to my Mac OS X.3.9 computer, I get a message that says Firefox has failed to mount, reason is corrupt image. I don't know what this means or how to get the Firefox to downlaod to my computer.

  • 2 respuestas
  • 39 tienen este problema
  • 31 visitas
  • Última respuesta de cor-el

more options

I currently have Firefox 2.0.0.4 on my computer. It is running Mac OS X 10.3.9. I tried to download Firefox 3.6.13 and got a message saying the disk had failed to mount, reason corrupt record.

Todas las respuestas (2)

more options

Firefox 3.6 requires at least OS X 10.4, the last version that works on OS X 10.3.9 is Firefox 2.0.0.20 available from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.20/mac/en-US/

more options

Note that you have two older Flash 9 plugins installed.

  1. Shockwave Flash 9.0 r47
  2. Shockwave Flash 9.0 r16

You should remove them both and install the latest Flash 9 player.