Buscar en Ayuda

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Release 89.0 - How to Remove Excessive Bookmarks Padding

  • 5 respuestas
  • 1 tiene este problema
  • 55 visitas
  • Última respuesta de Toad-Hall

more options

Hi, I'm looking for assistance in removing/restyling the large line spacing between bookmark items added in release 89.0. Operating system is Windows 10. I've tried the workaround from another forum adding a userChrome.css file to the chrome folder in my user profiles folder with the following code:

/*** Tighten up drop-down/context/popup menu spacing ***/

menupopup > menuitem, menupopup > menu {

 padding-block: 4px !important;

}

root {
 --arrowpanel-menuitem-padding: 4px 8px !important;

}

This had no effect.

Any help would be appreciated. The added padding is not helpful, but makes for unnecessary scrolling to locate bookmarks.

Thank you! :)

Hi, I'm looking for assistance in removing/restyling the large line spacing between bookmark items added in release 89.0. Operating system is Windows 10. I've tried the workaround from another forum adding a userChrome.css file to the chrome folder in my user profiles folder with the following code: /*** Tighten up drop-down/context/popup menu spacing ***/ menupopup > menuitem, menupopup > menu { padding-block: 4px !important; } :root { --arrowpanel-menuitem-padding: 4px 8px !important; } This had no effect. Any help would be appreciated. The added padding is not helpful, but makes for unnecessary scrolling to locate bookmarks. Thank you! :)

Todas las respuestas (5)

more options

Workaround: 1. In Firefox, Open a tab and enter about:config, click OK after the warning 2. search for proton, a few will come up, change all the ones that are true to false. One was already false so I kept it, and the last one had a 3, which I kept. 3. Exit and open FF.

more options

Toad-Hall's solution doesn't work.

more options

It was working perfectly ok until I updated to version 91.0 I'm trying to find another solution, so will offer info when I've got an answer.

more options

I've got things working as normal again.

Basically Check a setting in Firefox about:config Access profile,create a folder, create a file and you do not need to write code because I have supplied the text, you just copy and paste. So work through instructions step by step. Note: I have added an image below to show process. If you cannot see details, access forum and click on image to enlarge.

  • Open 'about:config'

Info at link if unsure but basically type about:config in the address text bar. https://support.mozilla.org/en-US/kb/about-config-editor-firefox

  • in search type: legacy
  • look for: toolkit.legacyUserProfileCustomizations.stylesheets
  • make sure it is set to 'True'

Whilst in about:config I search for 'proton' and found 6 items which are all set to false.

Now access the profile itself:

  • Menu app icon > Help > More Troubleshooting Information
  • About 11th in list is 'Profile Folder' - click on the 'Open Folder' button

A new window opens showing the contents of your Firefox profile.

  • Create a new folder and call it chrome - it must be spelt correctly - all lowercase.
  • Open a text editor eg: Notepad
  • Copy all the text shown between the lines below and paste it into 'Notepad'.

I advise you double check the content shown in the email you receive is the same as the info posted in this forum question.


menupopup > menuitem, menupopup > menu {
  padding-block: 3px !important;
}
:root {
  --arrowpanel-menuitem-padding: 4px 8px !important;
}


  • Exit Firefox now - you need to close the browser; this is important.

The Notepad document:

  • File > Save As
  • Choose where to save it - it must be saved in the 'chrome' folder you just created.
  • Save the Notepad file with this name: userChrome.css

All lowercase except for the 'C' which is uppercase.

  • Make sure the 'Save as Type' is 'All files' - not a text document.
  • click on 'Save'

In the 'chrome' folder, it's type will be described as 'Cascading Style sheet.

Start Firefox

more options

Colleen6 Have you checked this preference as per info in my previous comment: toolkit.legacyUserProfileCustomizations.stylesheets - set to True.