Buscar en Ayuda

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox on macOS - multiple problems

  • 3 respuestas
  • 1 tiene este problema
  • 2 visitas
  • Última respuesta de FredMcD

more options

Well, where do I even start? Here's the various problems I've been having lately:

Firefox version 77.0 on macOS Catalina (10.15.5)...

  • Frequently won't start
  • Won't quit
  • Not responding (requiring a 'force quit')
  • Won't open ANY sites ('transferring data...' endlessly displaying in bottom left corner)

I've already tried some fixes, none of which have done any good:

  • Cleared history and cache
  • Restarted computer
  • Uninstalled then re-installed Firefox (3 times!)
  • Started in Safe Mode (the problems don't recur there, but that doesn't explain why 'normal' mode is so problematic)

There are never any error messages. Firefox for some reason is seriously screwed up and has become utterly unusable. There are no problems at all with my other browser (Safari).

Grateful for any help!

Todas las respuestas (3)

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration.
How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager.
Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again.

Let us know who the suspect is, detective.
more options

FredMcD,

Thanks for your response.

I have very few add-ons or plug-ins. I've disabled Shockwave Flash - will that do the trick? So far so good, but I've had these 'false starts' before. We'll see. Incidentally, I don't know how that got there. I certainly did not knowingly add it on.

That leaves the following still enabled:

  • Open H264 Video Codec (looks like that one might be mandatory, put there by Firefox itself)
  • Widevine Content Decryption Module provided by Google Inc. (again, I didn't add this - it's either 'required' by Google, or they've sneaked it on)
  • Adblock Plus
  • IBM Security Rapport (I am very reluctant to disable this, if the time comes to try it, as that's used for internet banking!)

I will see how it goes in the next few days, and report back...

Meantime, thank you.

more options

If the problem returns, try disabling Rapport next.