Visualiza archivos PDF en Firefox sin descargarlos | Cómo

Visualiza archivos PDF en Firefox sin descargarlos

Firefox incluye un visor de PDF para que puedas ver los archivos PDF dentro de la propia ventana del navegador. En este artículo te explicamos cómo utilizarlo, cómo elegir otro visor de PDF y cómo solucionar los problemas más comunes que puedas tener.

Utilizar el PDF Viewer integrado

Firefox ahora incluye un visor de archivos PDF integrado que te permite ver casi todos los archivos PDF que se encuentran en la web sin necesidad de utilizar ningún plugin. El visor de archivos PDF está activado por defecto.

PDF JS

Funciones de la barra de herramientas del visor de archivos PDF

  • Ver las imágenes en miniatura del documento o un guión. El botón de la izquierda abrirá un panel lateral donde podrás ver en miniatura las páginas que componen el documento. Algunos documentos también incluirán un guión del documento, lo que facilita aún más navegar y desplazarse por todo el documento.
    PDF Thumbnails
  • Avanzar o retroceder o pasar directamente a otra página. Puedes utilizar las flechas de arriba y abajo para desplazarte por el documento o escribir el número de la página que quieres ver.
    PDF Pager
  • Cambia el zoom del documento. Utiliza los botones de + y - para aumentar o disminuir el zoom del documento o elige el zoom que quieras desde el menú desplegable.
    PDF Zoom
  • Pantalla completa o modo presentación - Haz clic en el botón de pantalla completa para que el documento PDF ocupe toda la pantalla. Presiona ESC para salir del modo pantalla completa.
    PDF Fullscreen
  • Imprimir - Haz clic en el botón de imprimir para abrir la ventana de diálogo de impresión.
    PDF Print
  • Descargar - Haz clic en el botón Descargar para guardar el archivo PDF en tu ordenador o para abrirlo con un lector de PDF.
    PDF Download
  • Copiar la vista actual - Haz clic con el botón secundarioPresiona la tecla Ctrl mientras haces clic . El botón de vista actual sirve para abrir esa vista en otra pestaña o en otra ventana.
    PDF Copy

Accesos directos de teclado para el visor de PDF

Comando Acceso directo
Página siguiente N o K o
Página anterior P o J o
Aumentar zoom Ctrl + +comando + +
Alejar zoom Ctrl + -command + -
Zoom automático Ctrl + 0comando + 0
Rotar el documento en el sentido de las agujas del reloj R
Rotar en el sentido contrario a las agujas del reloj Shift + R

Solución de problemas con el visor de archivos PDF

  • Con ciertos tipos de archivos PDF, el visor de PDF puede no mostrar correctamente las fuentes, colores o el documento completo. Si algunos de esos archivos PDF no se renderizan bien o aparecen en blanco, haz clic en el botón de descarga de la parte derecha del título del documento para abrirlo con el visor PDF predeterminado de tu equipo.

Utilizar otro visor de PDF

Si quieres, puedes utilizar un visor de PDF diferente al que viene incorporado. Para cambiarlo, sigue estos pasos:

  1. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona Opciones.En la parte superior de la ventana de Firefox, haz clic en el menú Herramientas y selecciona Opciones.En la barra de menús, haz clic en el menú Firefox y selecciona Preferencias….En la parte superior de la ventana de Firefox, haz clic en el menú Editar y selecciona Preferencias.

    Haz clic en el botón Menú New Fx Menu y elige OpcionesPreferencias.

  2. Selecciona el panel de Aplicaciones.
  3. Busca (PDF) en la lista y haz clic en esa entrada para seleccionarla.
  4. Haz clic en la flecha desplegable, en la columna Acción. Si estás utilizando el visor PDF incorporado de Firefox, te aparecerá la opción Vista previa en Firefox
    • Para utilizar una aplicación externa, selecciona la entrada de la aplicación que quieras utilizar, como por ejemplo Utilizar vista previa o Utilizar Adobe Reader.
    • Para ver archivos PDF en Firefox con un plugin que esté disponible, selecciona la opción Utilizar nombre del plugin PDF (en Firefox).
Advertencia: Hay problemas conocidos en Firefox con el "Plugin NPAPI Adobe Acrobat". Para obtener más información, consulta el artículo Los archivos PDF se muestran en blanco y no pueden descargarse en un Mac.

Utilizar un plugin visor de PDF

En marzo de 2017, cuando se lance la versión 52 de Firefox, Mozilla dejará de ofrecer asistencia para todos los plugins NPAPI, excepto para Flash. Para obtener más detalles, consulta este artículo y este post.

Esta sección no se aplica a la versión 64-bit de Firefox, que tiene una asistencia limitada a los plugins.

Puedes utilizar un plugin de PDF, como Adobe Acrobat, Nitro PDF Reader o Sumatra PDF, como Adobe Acrobat, MozPlugger o el plugin KParts, si hay alguno disponible, para ver los archivos PDF en Firefox. Si ya tienes instalado un plugin visor de PDF, pero sigues teniendo problemas al utilizarlo en Firefox, prueba lo siguiente:

Activar el plugin PDF

Puede que tu plugin de PDF esté deshabilitado en Firefox. Para activarlo:

  1. En la parte superior de la ventana de Firefox, haz clic en el botón FirefoxEn la barra de menú, haz clic en HerramientasEn la parte superior de la ventana de Firefox, haz clic en el Herramientas y selecciona Complementos. Se abrirá la pestaña del Administrador de Complementos.Haz clic en el botón Menú New Fx Menu y elige Complementos. Se abrirá la pestaña del Administrador de Complementos.

  2. En la pestaña del Administrador de Complementos, selecciona el panel Plugins.
  3. Selecciona tu plugin PDF.
  4. En el menú desplegable, selecciona Activar siempre.

Restablecer las acciones de descarga

  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.Haz clic en el botón de menú New Fx Menu , en Ayuda Help-29 y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaAbrir carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona SalirEn la barra de menú, haz clic en el menú Firefox y selecciona Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón de menú New Fx Menu y selecciona SalirQuit Close 29 .

  5. Eliminar (o renombrar) el archivo mimetypes.rdf.

Otras soluciones

  • Si el plugin de PDF viene incluido con una aplicación, comprueba su configuración para ver si hay algún ajuste de Internet para activar el plugin o mostrar archivos PDF en el navegador.
  • Si el plugin de PDF viene incluido con una aplicación, desinstálala y vuelve a instalarla. Si la aplicación PDF es Adobe Reader, desinstala todas las versiones de Adobe Reader de tu equipo (consulta estas instrucciones para desinstalar las versiones 8 y superiores de Reader) y vuelve a instalar la última versión desde aquí. Si sigues sin poder ver los archivos PDF en Firefox con el plugin PDF de Adobe, consulta la página de ayuda de Adobe sobre cómo ver archivos PDF en la web.
¿Te resultó útil este artículo?

Espera por favor...

Esta gente maravillosa ayudó a escribir este artículo: RickieES, willyaranda, Breaking_Pitt, inma_610, avelper, xim88. Tú también puedes ayudar, descubre cómo hacerlo.

Ultima actualización: 2016-10-25

Obtener ayuda para otra plataforma:
Personalizar este artículo

Firefox