Text Color

Thunderbird version 68.10.1 (32-bit) When I click the icon to change the color of selected text, it correctly show me the last last such color chosen. But when I select i… (read more)

Thunderbird version 68.10.1 (32-bit)

When I click the icon to change the color of selected text, it correctly show me the last last such color chosen. But when I select it again and click "Ok", the font color does not change.

How can I fix this?

Asked by pskversk 6 days ago

Lightning Calendar: 3 priority levels vs. Eisenhower principle

Dear folks, there are three priority levels and the possibility of leaving it not specified in Lightning Calendar. Tasks with unspecified priority are shown in the task l… (read more)

Dear folks, there are three priority levels and the possibility of leaving it not specified in Lightning Calendar. Tasks with unspecified priority are shown in the task list on the same level as medium priority. My Problem: i would like to use the Eisenhower principle with

   important: yes / no     and
   urgent: yes / no

so that i need four levels instead of three. Does anyone see a possibility to implement this?

Kind regards, Eva

Asked by eva_lamparter 6 days ago

Emails not displaying, shows "no results"

All my folders in Thunderbird are showing "no results" for anything except brand new emails. I have 4 email accounts all hotmail or gmail and have used Thunderbird for ye… (read more)

All my folders in Thunderbird are showing "no results" for anything except brand new emails. I have 4 email accounts all hotmail or gmail and have used Thunderbird for years on these with no problems at all. Today in all the accounts I am getting "no result" display where I usually see the emails. I have compacted my folders and have rebuilt the global database with no change in what I see. On each of my folders if I right click the folder, click properties then repair folder, all the "missing" emails show and all looks normal. If I leave that folder to another folder and immediately come back, I again see "no results" Any ideas on what is going on and how to get back to normal?

Asked by rigduncan 2 days ago

Thunderbird with BTinternet e-mail

I am using Thunderbird (on Windows 10) to access my e-mail on btinternet.com and have used this successfully for years. The BT e-mail has used Yahoo e-mail and is in the … (read more)

I am using Thunderbird (on Windows 10) to access my e-mail on btinternet.com and have used this successfully for years. The BT e-mail has used Yahoo e-mail and is in the process of slowly migrating users onto its own e-mail system, but I am still on Yahoo. Last Saturday (11th July) my TB client failed to logon (error message - 'sending of password did not succeed'), even though nothing has been changed. I know the password is still correct because I can use a browser to logon to BT e-mail using the same password and get to Yahoo e-mail with all my up-to-date e-mails. My TB client settings have not changed. My wife's e-mail has the same setup in TB and has already been migrated from Yahoo to BT's own e-mail (some months ago) - there is no problem with accessing her e-mail using TB client (same settings as mine). I phoned BT support but they could not offer any help and could not tell me when I would be migrated from Yahoo. Something changed last Saturday, either in BT mail server or TB client, to disrupt the normal smooth operation. Has anyone else experienced this problem and/or does anyone have a solution? Thankyou, Robin

Asked by robin.john171 2 days ago

Thunderbird 68.10 on Catalina is not opening attachment on outgoing email

Thunderbird 68.10 (TB) sends attachments correctly but will not open the attachments when they are clicked on in the attachments area of the write window. In the same in… (read more)

Thunderbird 68.10 (TB) sends attachments correctly but will not open the attachments when they are clicked on in the attachments area of the write window. In the same instance TB will not open the attachment when sent to the sender's own email address.

TB displays the location of the attachment correctly and will rename the attachment, but fails silently on a double click or choosing "Open" from the context menu.

This is a new iMac with user installed via Apple's Migration Assistant. From Mac OS 10.11 to 10.15.

So permissions could be involved.

Asked by Samsung A70 2 days ago

Unpredictable severe temporary freeze

At random times, especially if I haven't been using Thunderbird (on Windows 7) for a while, it will freeze temporarily. During this time, the screen often turns gray to i… (read more)

At random times, especially if I haven't been using Thunderbird (on Windows 7) for a while, it will freeze temporarily. During this time, the screen often turns gray to indicate it's frozen. I can move to another app but Thunderbird is totally unresponsive for up to about 30 seconds. I can keep typing, and often I do. It'll fill in when it gets around to it.

I've had this problem in the past, but it had been gone for a year or more. It came back exactly when I recently upgraded to version 68.10.0 (32 bit).

It can happen at any time, for example, just now (briefly) when I switched to Thunderbird and opened the menu to check the version number.

I've reviewed startup apps on Windows, and cleaned out trash folders.

Any further troubleshooting tips? Thank you!

Ness

Asked by evekitas 2 days ago

Thunderbird 68.10.0 Sign/Encrypt of Mails is not working on Windows 10

Hi, As part of unit testing of our addon with Thunderbird 68.10.0 on Windows 10 ,we are facing issues while Sign/Encrypt the mail using our Smart Card. It has Authenticat… (read more)

Hi,

As part of unit testing of our addon with Thunderbird 68.10.0 on Windows 10 ,we are facing issues while Sign/Encrypt the mail using our Smart Card. It has Authentication,Sign and Encryption Certificates.

To provide more details of about the addon,basically it provides a PKCS library to Sign/Encrypt the mails and in fact we are trying to automatically integrate the same as part of Thunderbird.

Regarding the setup of Thunderbird for testing this feature, we followed the below instructions to configure our CA since it was not listed and In fact our Signing/Encryption certificates have been issued by the same Microsoft CA.

Instructions:


In order for the certificate authority (CA) to be trusted or your personal certificate, the CA that signed your certificate must have its certificate installed under Authorities in your certificate store. Thunderbird comes with some built in certificate authorities, but the list is hardly complete. It seems that there is a slant towards the major CAs whose first language is English and issue certificates to people in the U.S.

If your CA is not one of the built in certificate authorities and you are under Windows and have Internet Explorer (IE), you could import the certificate in this way:

Open IE and go to "Tools -> Internet Options -> Content -> Certificates -> Trusted Root Certificate Authorities". Highlight the certificate(s) that you would like to export. Click on "Export" and complete the export wizard. (DER encoded binary ".cer" files work as a file format.) While completing the wizard, remember where you saved the certificate. Now, open Thunderbird and go to "Tools -> Options -> Advanced -> Certificates -> Manage Certificates... -> Authorities". (In Mozilla Suite, go to "Edit -> Preferences -> Privacy & Security -> Certificates -> Manage Certificates... -> Authorities".) Select "Import", select the file you saved above, and click "Open". Read the warning and select for what purpose you trust the certificate. Click "OK" if you trust it. It should now be installed. Optionally, you may want to delete the ".cer" file. If that is not possible, because the CA isn't there, you will need to contact your CA and see if they can give you their authorities public certificate.

Following is the error we are facing during Signing and also I have attached the snapshot of the same. "Sending of the message failed. Unable to sign message. Please check that the certificates specified in Mail & Newsgroups Account Settings for this mail account are valid and trusted for mail."

As part of further analysis of the logs we figured out the APIs used by Thunderbird while performing Signing operation.

1. C_OpenSession 2. C_SignInit 3. C_GetAttributeValue (CRSAPrivateKey::GetOneAttributeValue - CKA_ALWAYS_AUTHENTICATE:) 4. C_Logout 5. C_Login (userType = CKU_USER) 6. C_Sign (SignKey = NULL)

Among the above APIs C_Logout is performed, not sure why after C_SignInit. Also if you look at the option to get SignKey CKA_ALWAYS_AUTHENTICATE, which forces the user to provide the PIN, in fact we are providing the same. But When C_Sign is called after Login, it seems the SignKey is NULL, due to earlier Logout operation.

Normally as per the PKCS standard with CKA_ALWAYS_AUTHENTICATE this would be the callflow.

1. C_OpenSession 2. C_SignInit 3. C_GetAttributeValue (CRSAPrivateKey::GetOneAttributeValue - CKA_ALWAYS_AUTHENTICATE:) 4. C_Login (userType = CKU_CONTEXT_SPECIFIC) 5. C_Sign (SignKey)

If PrivateKey with CKA_ALWAYS_AUTHENTICATE is used then C_Login should be immediately called with CKU_CONTEXT_SPECIFIC after C_SignInit operation. Please refer more details about the same from the PKCS standards.

“The CKA_ALWAYS_AUTHENTICATE attribute can be used to force re-authentication (i.e. force the user to provide a PIN) for each use of a private key. "Use" in this case means a cryptographic operation such as sign or decrypt. This attribute may only be set to CK_TRUE when CKA_PRIVATE is also CK_TRUE. Re-authentication occurs by calling C_Login with userType set to CKU_CONTEXT_SPECIFIC immediately after a cryptographic operation using the key has been initiated (e.g. after C_SignInit). In this call, the actual user type is implicitly given by the usage requirements of the active key. If C_Login returns CKR_OK the user was successfully authenticated and this sets the active key in an authenticated state that lasts until the cryptographic operation has successfully or unsuccessfully been completed (e.g. by C_Sign, C_SignFinal,..).”

Hence it would be great from Thunderbird community to help us to figure out the issue.

Please let me know if i am missing something.

Asked by vishal.babu 7 hours ago

Thunderbird Email Attachments

Hi, Since the latest Windows 10 update, I can no longer open any MS Office attachments sent to me on my Thunderbird email. Have tried various suggestions, but no succes… (read more)

Hi, Since the latest Windows 10 update, I can no longer open any MS Office attachments sent to me on my Thunderbird email. Have tried various suggestions, but no success. Looking for some real layman's terms help. Many thanks!!

Asked by fcarriere 6 hours ago

Version 78 no calendar

Hi Guys My Thunderbird was updated to version 78 64 bit and the calendar has stopped working. Lightning has vanished? Will things (lightning etc ) update automatically in… (read more)

Hi Guys

My Thunderbird was updated to version 78 64 bit and the calendar has stopped working. Lightning has vanished?

Will things (lightning etc ) update automatically in the next few days or have I jumped to early?

Many thanks

Paul

Asked by Paul 2 hours ago

Thunderbird e-mail suddenly is BLANK on the home page/ folders list is EMPTY

Thunderbird e-mail is BLANK on the folders page. The accounts ([email1]@execpc.com and [email2] @ execpc.com) are not even visible. "TOOLS'/ 'account settings' forms appe… (read more)

Thunderbird e-mail is BLANK on the folders page. The accounts ([email1]@execpc.com and [email2] @ execpc.com) are not even visible. "TOOLS'/ 'account settings' forms appears OK except that the top level form is BLANK (except for the 'outgoing server' which appears OK. I use NORTON backup which had a copy from 7/13/20. I made a backup copy of 'mail inbox' and mailusr1' and then restored the NORTON backup, but that didn't help. I am on a desktop with windows 10 and Thunderbird 68.10.0 (32-bit). Could I delete the account, create a new one, and then move all the backup files into place ? HELP You can email to '[email2]@execpc.com' which is used on a different server/laptop

Asked by Bernard Sandler 1 hour ago