How to migrate gmail-folders to other imap provider without duplicating emails?

Dear community, I have been using Thunderbird for many years and simply love it. (Now running v. 91.9.0, 64-bit for Mac-OS monterey v. 12.3.1). After having used G-suite … (read more)

Dear community,

I have been using Thunderbird for many years and simply love it. (Now running v. 91.9.0, 64-bit for Mac-OS monterey v. 12.3.1).

After having used G-suite gmail with my own domain name for years as well, I am now forced to upgrade to a google business offering or take my domain name email somewhere else :-(

So I signed up for an alternative provider, and have copied a couple of folders to the new email-account using Thunderbird. This works like a charm, but what happens when I copy over the AllMail folder? I believe I will then duplicate all the emails copied from the folders?

Is there a smart way of migrating from gmail to another imap-provider using Thunderbird which will take into account google obscure way of labelling emails? Or is there another way of migrating away from gmail?

Any help will be much appreciated.

Thanks, Fred Gjoertz.

Asked by fred116 1 hour ago

Last reply by david 12 minutes ago

[EXTERNAL MAIL] showing on messages and no sender address

I have the above showing on all my messages and no sender email address. It means I don't know who sent the message and I can't reply directly back. Another correspondent… (read more)

I have the above showing on all my messages and no sender email address. It means I don't know who sent the message and I can't reply directly back. Another correspondent mentioned I needed to turn off the VPN but the link he gave me I cannot find the settings to do it.

I have been bouncing around with this daily for about two weeks, I have searched the help topics and the internet and asked every forum I know. I am nearly in tears with this!

Can anyone help me in a way that I can fix this. I am not a computer engineer so can re-write strings etc.

Asked by nantymoelpharmacy 5 months ago

Last reply by pilot180 3 hours ago

How to make shift-delete actually delete (expunge) and not just mark as deleted?

For IMAP servers, the default action of Thunderbird's shift-delete is to bypass Trash and mark the message as deleted on the server. Thunderbird then does not show messag… (read more)

For IMAP servers, the default action of Thunderbird's shift-delete is to bypass Trash and mark the message as deleted on the server. Thunderbird then does not show messages that are marked as deleted. This is fine if you are only using Thunderbird because the emails don't appear in Trash and don't appear in the folder they were deleted from.

However, if you are using other mail clients eg Outlook Mobile, Samsung Email client, webmail, these mail clients do not seem to recognise the "marked as deleted" attribute (whatever that is) and they still show the email. So if I shift-delete a mail in Thunderbird these other clients still show the email plus I do not actually save any disk space.

In Thunderbird if I just delete an email (not shift-delete) then the mail is moved to Trash and is actually no longer in the original folder. It is not just marked as deleted from the original folder, it is actually gone. So these other mail clients, also can no longer see the mail.

How can I get Thunderbird to actually delete a mail when I use shift-delete instead of just marking it as deleted? I don't want to have to wait till I exit Thunderbird.

I have tried setting mail.imap.expunge_after_delete to true and mail.imap.expunge_option to 1 but these seem to have no effect

Asked by mjurgens_firefox 2 days ago

Last reply by Toad-Hall 5 hours ago

Eudora to Thunderbird--still multistep?

I have used Eudora for years, about 20 or more. Now I find myself with a dilemma. A secure email program I signed up for must have ports assigned to incoming and outgoi… (read more)

I have used Eudora for years, about 20 or more. Now I find myself with a dilemma. A secure email program I signed up for must have ports assigned to incoming and outgoing servers. Alas, not possible with Eudora, but possible with Thunderbird.

However, after reading several of the threads of migrating to Thunderbird from Eudora, it appears to be problematic--new addons, missing mailboxes, etc. It's hard to tell whether that's the norm or the exception. One of the threads I read was https://support.mozilla.org/en-US/questions/1228297 "Migrate Eudora mail to Thunderbird mail", which suggests starting with Thunderbird 17.0. That thread is from 3-1/2 years ago. Is this still the best way to migrate? Or is one of the Thunderbird migration tools a better and safer option.

I have literally thousands of saved emails and dozens of separate mailboxes and I don't want to lose them.

Asked by rosawood 1 month ago

Last reply by david 10 hours ago

The "Send" button is no longer visible on Tbird 52.9.1 (32-bit) !!

My Tbird no longer shows me a "Send" button once I have written a new email or am trying to reply to a received email. I've searched for possible settings regarding this… (read more)

My Tbird no longer shows me a "Send" button once I have written a new email or am trying to reply to a received email. I've searched for possible settings regarding this, but have not located any in Tbird's help section. How can I repaid this loss?

Asked by P_Puthorn 5 days ago

Last reply by Matt 13 hours ago

Need to login with oAuth2

Google has dictated that there will be no acceess to Gmail via thunderbird using password I have changed to Oauth2 and have used google to log in & get emails, so far… (read more)

Google has dictated that there will be no acceess to Gmail via thunderbird using password

I have changed to Oauth2 and have used google to log in & get emails, so far no problem.

Now I still want to use a password to get emails every time I use thunderbird now I have Oauth2 set there is no need to log in.

How do I make a change still using Oauth2 so that I still have to enter a password

Asked by x38class 2 days ago

Last reply by Matt 14 hours ago

Email account setup

Hi guys, I used for a long time Mozilla Thunderbird for multiple mailboxes. Now, when I try to access one of them, I get this message: "Unable to log in at server. Probab… (read more)

Hi guys,

I used for a long time Mozilla Thunderbird for multiple mailboxes. Now, when I try to access one of them, I get this message: "Unable to log in at server. Probably wrong configuration, username or password".

I use Zoho services for mailboxes, but all the other mailboxes are working properly with same settings. I changed password, deleted mailbox account in order to try to set it up again, but didn't work.

Can you please help?

Thanks, Catalin

Asked by popa_catalin1983 14 hours ago

Last reply by Matt 14 hours ago

Not able to add Google task list to TB 101b2

I'm not seeing my task lists in the Google calendar list when I add a new calendar. I still have the Provider add-on installed but it seems to be bypassed by the internal… (read more)

I'm not seeing my task lists in the Google calendar list when I add a new calendar. I still have the Provider add-on installed but it seems to be bypassed by the internal TB add calendar functionality. That is I don't see an add Google Calendar option any more only Computer and Network. Using Network and my gmail email address I get shown my Google calendars but not my task lists. I would like TB to catch up with tasks but can wait. Or am I missing some thing?

BTW I tried Mailbird and it shows me all my Google calendars and task lists, but its expensive so not an option.

Asked by MoriTuri 3 days ago

Last reply by Matt 14 hours ago

Popup when opening Thunderbird

I receive a popup message purporting to come from Google whenever I open Thunderbird. I can close it, but it keeps coming back. It asks me to sign in to my Google Account… (read more)

I receive a popup message purporting to come from Google whenever I open Thunderbird. I can close it, but it keeps coming back. It asks me to sign in to my Google Account. While it is up, I cannot use my email.

They image is too large to upload.

I believe this article describes what is happening. https://hackerone.com/reports/643274

I have not been able to find a fix for this online. Please help.

Joy Rushing

Asked by jrushing7 3 days ago

Last reply by Matt 14 hours ago

Firefox and Thunderbird NOT working since Updates

Since the recent Updates, I am having pronlems using Firefox and getting mail with Thunderbird. Firefox will open endless Tabs. After deleting about 5 or 6 of them, I c… (read more)

Since the recent Updates, I am having pronlems using Firefox and getting mail with Thunderbird. Firefox will open endless Tabs. After deleting about 5 or 6 of them, I can sometimes use one but just as often cannot use FF at all. Thunderbird refuses to OPEN! If after many trys, I can get Thunderbird open, I have trouble getting mail or, I get many of the same messages. It is a real fight to get any use out of Firefox and Thunderbird. If I knew how, I would revert to previous versions. I am using WINDOWS on a PC and have used both Firefox and Thunderbird for many years with never a problem until this recent update. bribling@yahoo.com

If you should reply to me, I will, no doubt, have trouble receiving the answer.

Asked by bribling 2 days ago

Last reply by Matt 14 hours ago

the new thunderbird doesn't open most browser links (but does open some)

Recently I installed the new Kubuntu 22.04 with the new thunderbird. It no longer opens browser links (at least it opens some, but most it doesn't). I tried opening it i… (read more)

Recently I installed the new Kubuntu 22.04 with the new thunderbird. It no longer opens browser links (at least it opens some, but most it doesn't).

I tried opening it in the console and got the following - the first parts when thunderbird opened and the last lines when I clicked on a link in an email message. The web address that it claims doesn't exist does, in fact, exist.

I've looked up all the help, suggestions about config.editor etc .... but none of it sees to work.

john@john-asus:~$ thunderbird [calBackendLoader] Using Thunderbird's libical backend [LDAPModuleLoader] Using LDAPDirectory.jsm [MsgSendModuleLoader] Using MessageSend.jsm [SmtpModuleLoader] Using SmtpService.jsm console.debug: "Trying to load /usr/lib/thunderbird/libotr.so" console.debug: "Trying to load libotr.so from system's standard library locations" console.debug: "Trying to load libotr.so.5 from system's standard library locations" console.debug: "Trying to load libotr.so from system's standard library locations" console.log: (new Error("Cannot load required OTR library", "resource:///modules/OTRLib.jsm", 109)) console.debug: "Successfully loaded OpenPGP library librnp.so version 0.16+git20220124.f06439f7.MZLA from /usr/lib/thunderbird/librnp.so" console.debug: "Found 0 public keys and 0 secret keys (0 protected, 0 unprotected)" console.debug: "Successfully loaded optional OpenPGP library libgpgme.so.11 from system's standard library locations" console.debug: "gpgme version: 1.16.0-unknown" console.warn: services.settings: thunderbird/hijack-blocklists has signature disabled IPDL protocol error: Handler returned error code!

      1. !!! [Parent][DispatchAsyncMessage] Error: PClientManager::Msg_ExpectFutureClientSource Processing error: message was deserialized, but the handler returned false (indicating failure)

IPDL protocol error: Handler returned error code!

      1. !!! [Parent][DispatchAsyncMessage] Error: PClientManager::Msg_ForgetFutureClientSource Processing error: message was deserialized, but the handler returned false (indicating failure)

env: ‘https://www.mimuw.edu.pl/wspomnienia’: No such file or directory

Asked by masson.noble 2 days ago

Last reply by Matt 14 hours ago

Thunderbird

On clicking on shortcut got "You have launched an older version etc" I didn't know I had more than one! Find I cannot get Tb any other way than downloading fresh copy. Ha… (read more)

On clicking on shortcut got "You have launched an older version etc" I didn't know I had more than one! Find I cannot get Tb any other way than downloading fresh copy. Have now lost all of calendar, and Tb now has "calendar" listed on left side, but no calendar present. How to get? Would it be a good idea to have the calendar stored somewhere separately so it can't be lost this way??

Regards, David

Asked by djfoster99 3 days ago

Last reply by Matt 15 hours ago

trash automatically empties TBird 91.x

TBird 91.x, POP3, Win 10 Spontaneously puts messages into trash (no reason) and trash spontaneously empties what's in trash. There had been a confIrmation script but I c… (read more)

TBird 91.x, POP3, Win 10 Spontaneously puts messages into trash (no reason) and trash spontaneously empties what's in trash. There had been a confIrmation script but I cancelled it and at least want it back. Or is there a way to rename the trash folder? Aside from other complications / time-wasting I lose important mail. Thank you,

Asked by 88tjt88 2 days ago

Last reply by Matt 15 hours ago

iCloud Custom Domain Setup

I'm trying to setup IMAP settings for an iCloud account using a custom domain. I'm running into a authentication problem. I don't get a lot of feedback from the error: Lo… (read more)

I'm trying to setup IMAP settings for an iCloud account using a custom domain. I'm running into a authentication problem. I don't get a lot of feedback from the error: Login to account "sss@yyy.com" failed Login to server imap.mail.me.com with username sss@yyy.com failed

I'm using an app specific password [0] and my iCloud account as the username which is also based on my custom specific domain yyy.com. I've also tried my iCloud alias which maps to aliasname@icloud.com as the username as well as "aliasname" without the @icloud.com. No luck with any of the permutations.

Any hints on troubleshooting this? Any issues people are seeing with iCloud IMAP and/or using custom domains with it that might help me with this?

[0] - https://support.apple.com/en-ca/HT204397

Asked by shopping24 2 days ago

Last reply by Matt 15 hours ago

Account woes after removing Virtual Identity.

I never could get Virtual Identity or Correct Identity to consistently work predictably, so after many months twiddling them, I removed them. Then I needed to test what I… (read more)

I never could get Virtual Identity or Correct Identity to consistently work predictably, so after many months twiddling them, I removed them. Then I needed to test what I had to do to live without them. There's a problem.

(The email addresses and accounts are fakes, but you'll get the idea.)

When I send this message to myself at a different account:

To: to@gmail.com
Reply-To: replyto@gmail.com

me.to gets the message fine. When I compose a reply, I expect this:

To: replyto@gmail.com
Reply-To: to@gmail.com

But I get this:

To: replyto@gmail.com
Reply-To: to+arf@gmail.com

to+arf@gmail.com was a virtual identity. So it appears that something is screwed. But what is screwed and how would I fix it?

Grateful for any ideas, Mark.

Asked by Mark Filipak 1 day ago

Last reply by Matt 15 hours ago

Thunderbird mail

My Thunderbird app has not received or notify me of any emails for the past two days. I've had to use it on google in able to see my emails. It just has a continuous load… (read more)

My Thunderbird app has not received or notify me of any emails for the past two days. I've had to use it on google in able to see my emails. It just has a continuous loading sign when i say get mail and nothing comes through. I have tried uninstalling the app and redownloading it too

Asked by PeakMSK 16 hours ago

Last reply by Matt 15 hours ago

Font size on opening page is too small - Thunderbird

I have searched the help to increase the size of the opening page fonts in - email subjects and account names. I am using the most recent update of Thunderbird. Per wha… (read more)

I have searched the help to increase the size of the opening page fonts in - email subjects and account names. I am using the most recent update of Thunderbird. Per what I saw in the help I went to layouts.css.devPixelsPerPx and changed -1.0 to 1.2. Closed the config editor and returned to email - no change. I shut down Thunderbird and opened it again - still no change in the font size. I reset the setting in Config Editor and tried 1.25 - still no change. Tried -1.25 still no change. Each time when I go back to this setting in config editor - the number has been changed - but does nothing to change the font.

None of the font settings in Preferences have any effect on the opening page of Thunderbird.

I have some visual impairment and need these fonts larger. There has to be a way to do it. At one time these fonts were larger. There must be a way to change these - and why it is not easily built in to Preferences is terrible - and makes Thunderbird useless to those with minor visually impairment.

I need help in resolving this - there has to be a way.

Asked by rrambrose 21 hours ago

Last reply by Matt 15 hours ago

Error when sending mail

Hello, I encounter an error when sending a message with an on-premises exchange server. With Windows, an error window appears and is automatically closed. On Linux, the w… (read more)

Hello,

I encounter an error when sending a message with an on-premises exchange server. With Windows, an error window appears and is automatically closed. On Linux, the window remains displayed, which is problematic. In both cases, the message is sent and copied to the sent messages folder The windows error message says "copy to sent folder error" (obviously wrong) In console the error raised after QUIT command of mailnews.smtp with the error code 2152398868.

the error was reported by several of our users and I was able to reproduce it.

Console Log : mailnews.smtp: Message sent successfully. SmtpClient.jsm:1293:21 mailnews.smtp: C: QUIT SmtpClient.jsm:579:19 mailnews.smtp: error { target: TCPSocket, isTrusted: true, name: "NetworkError", message: "Network", errorCode: 2152398868, srcElement: TCPSocket, currentTarget: TCPSocket, eventPhase: 2, bubbles: false, cancelable: false, … } SmtpClient.jsm:434:17 mailnews.send: Sending failed; Le message n’a pas pu être envoyé car la connexion au serveur sortant (SMTP) « ******* » a expiré. Veuillez essayer à nouveau., exitCode=2153066800, originalMsgURI= MessageSend.jsm:336:27 mailnews.smtp: S: 221 2.0.0 Service closing transmission channel SmtpClient.jsm:413:17 mailnews.smtp: Closing connection... 3 SmtpClient.jsm:153:17 mailnews.smtp: Socket closed.

Asked by Cedric.BONNIN 1 day ago

Last reply by Matt 16 hours ago