Showing questions tagged: Show all questions
  • Solved

Log ins lost every time I start FireFox - only started happening recently.

I've checked a couple of the "similar topics" before posting here. I'm not sure if I am having the same problem or something else. Back Story: I have a "few" windows and… (read more)

I've checked a couple of the "similar topics" before posting here. I'm not sure if I am having the same problem or something else.

Back Story: I have a "few" windows and tabs open in FireFox. I would finish what I was doing, shut down and then the next time I booted up and loaded FireFox, all sessions would be restored and all log ins honoured (kept). That is: I was still logged in.

(Moving to now) Yesterday I powered up and ALL sites were logged out. About 20 log ins were needed. Hmmmmm... gmail, and the rest.

"Ok... something happened. No problems, things should be ok from now. I've logged in, so all is sweet."

Today I power up: All logs ins lost. Had to go through it all again.

Gmail is throwing security alerts at me hand over fist. Yeah, that is good in some ways. I get that part. But I've logged in.

Seems - my thoughts - that the cookies aren't being saved. But why? I haven't touched them or their settings.

Yes, I did do a clean out of older cookies. But left the gmail ones, and other sites I know I use. I have `adblocker ultimate` installed.

Now I am logged in, if I open the `cookies` and look I should see them there for the sites to which I am logged in - yes?


To be clear: When I am done, I do NOT `exit` FireFox. All windows, tabs, sessions are left. I just shut down the machine. Then next time I load FireFox and they are re-loaded and log ins are maintained.

Asked by teeny_weeny 1 month ago

Answered by cor-el 1 month ago

  • Solved

How can version 98.0 be very outdated ??

I have been having problems accessing part of a membership site. Can't get past the first step, it doesn't work for me. Kubuntu 20.04.4 LTS Release: 20.04 Codename… (read more)

I have been having problems accessing part of a membership site. Can't get past the first step, it doesn't work for me.

Kubuntu 20.04.4 LTS Release: 20.04 Codename: focal Firefox Version 98.0 (64 bit)

Have been informed from the website owner that the IT person has tested this with Explorer, Safari and Chrome, and all work. The IT support person then goes on to state - "....... that the client needs to use a different browser as Firefox is very outdated."

So, I was using the latest version and it is "very outdated"  ???

How can I respond ? Is there a training course for the IT person to deepen their skill level ?

Asked by oygle 4 months ago

Answered by oygle 4 months ago

  • Solved
  • Archived

Cut and paste no longer works with Google Translate on linux

This problem has been around since the latest version of the old version, and has carried across into the new version. Ctrl+A, Ctrl+C and Ctrl+V no longer work with Goog… (read more)

This problem has been around since the latest version of the old version, and has carried across into the new version. Ctrl+A, Ctrl+C and Ctrl+V no longer work with Google Translate on linux. I have tested in other browsers and it they all work fine. Firefox on Windows also works fine, this problem seems specific to linux.

When you press any of the Ctrl combinations it simply deselects everything and moves the cursor to the end of the text. Mouse works, but it's not practical if you are cutting and pasting all day long.

Site: https://translate.google.com Firefox version: 89.0.2 (64-bit) OS: Ubuntu 20.04

Google Translation is critical to my work so my current solution is I no longer use Firefox. I hope that someone knows of a quick fix, or if it's a bug it's easy to fix as I'd hate to permanently move away from Firefox for something like this.

Thanks!

Asked by decaffeinated tea 1 year ago

Answered by decaffeinated tea 1 year ago

  • Solved
  • Archived

Where Does Firefox Store Locations of Used Websites?

This the second time I am entering this problem -- the first time Firefox refused to let me return to this site. First, I am running Firefox on Ubuntu, but Ubuntu is not … (read more)

This the second time I am entering this problem -- the first time Firefox refused to let me return to this site.

First, I am running Firefox on Ubuntu, but Ubuntu is not relevant because the same issue occurs in Windows.

Whenever I access a file, for example, one at https://species.wikimedia.org/wiki/Chioneosoma, its color (which is programmable) changes from a light bluish green to a deeper violet. Where is this color-difference stored? I have thousands of WikiSpecies files I have accessed, and they all show the violet "accessed" color if I ever have opened the file to read its contents. The problem is that when Ubuntu has to be reinstalled, I can add references to all my files, but the color-changes seem to be lost. This is a serious issue, because I currently have over 50,000 files referenced (and saved in my directory file:///home/jwill/Documents/WikiSpecies/Animalia_Plantae_8) and am still adding to them!

I think the storage location must be somewhere in one or more of the following files ('_' replaced '/'):

   _home_jwill_.mozilla
   _home_jwill_.cache_mozilla_firefox 
   _home_jwill_.cache_MM_firefox
   _usr_lib_firefox

Can you please tell me where the list of accessed files is stored? Whenever I enter a referenced directory, to access it, the color changes; so, Firefox must be able to store a reference to each new referenced directory name.

Asked by jwill1000000 8 months ago

Answered by jwill1000000 8 months ago

  • Solved

[SOLVED] cannot save page/file to local drive

Hi, I'm using version 101.0.1 (64 bit) for Ubuntu 22.04. When I open a link of a pdf file, the file is displayed in the built-in viewer, since I chose "Open in Firefox" i… (read more)

Hi, I'm using version 101.0.1 (64 bit) for Ubuntu 22.04. When I open a link of a pdf file, the file is displayed in the built-in viewer, since I chose "Open in Firefox" in my settings. But then if I click the download icon nothing happens. If I click the print icon and choose "print to pdf" in the popup, then clicking on "save" does nothing and I have to click "cancel" to dismiss the popup.

Actually there is no way to save a pdf file but setting PDF app to "Ask always" and then open it with "System handler", but then the file is saved into the default download folder, even though I selected the checkbox "Always ask me where to save files" in my settings.

EDIT: the issue was solved by installing the following packages, as shown in this question :

xdg-desktop-portal xdg-desktop-portal-gtk

Asked by gi4c0ph 1 month ago

Answered by jscher2000 - Support Volunteer 1 month ago

  • Solved
  • Archived

Firefox 91 menu button not working

Problem appeared in the last few days so I assume it is due to the recent update - 91.0.2 Clicking the Menu button (3 bars), the button goes grey but the application menu… (read more)

Problem appeared in the last few days so I assume it is due to the recent update - 91.0.2

Clicking the Menu button (3 bars), the button goes grey but the application menu does not appear. If I move the mouse around, I see flashes of the menu but that's all. A graphics problem?

I have also found that copying and pasting is inconsistent. Sometimes it works sometimes it doesn't. Sometimes it flashes. No problem in Thunderbird or other applications.

I have tried reinstalling Firefox - no difference I have tried Firefox in Safe Mode - no difference

Linux Ubuntu 21.04 Gigabyte B360M HD3 with integrated graphics

Any advice gratefully received

Asked by habana73 11 months ago

Answered by FredMcD 11 months ago

  • Solved
  • Archived

Audio mp3 only saved as html although extension

Hello, I always download mp3 files inside webs using "Save as" and ".mp3" method. Sometimes I had to explicitly save filename with ".mp3" extension to force audio downloa… (read more)

Hello, I always download mp3 files inside webs using "Save as" and ".mp3" method. Sometimes I had to explicitly save filename with ".mp3" extension to force audio download. However trying to download an audio no matter what format I write in file always download only webpage as .html never as .mp3. Looking at sourcecode (image attached) I found a detail containing "chrome" in webpage. Later, I tried downloading with Chromium at it worked properly. Does anyone know how to download this from Firefox?

Thanks in advance for your help. P.D. I am using Firefox 84.0.2 (64-bit) for Ubuntu canonical - 1.0.

Asked by blazeditch 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

Firefox hangs Ubuntu 20.04

After installing Ubuntu 20.04 LTS Clicking on Firefox or Thunderbird it hangs the computer and have to switch off the computer on main switch. Reinstall Mozilla once but … (read more)

After installing Ubuntu 20.04 LTS Clicking on Firefox or Thunderbird it hangs the computer and have to switch off the computer on main switch. Reinstall Mozilla once but no difference still hangs Ubuntu. Need help on this one Thank you

Asked by Lumaja 1 year ago

Answered by schnrl 1 year ago

  • Solved

Borders of some controls are white instead of none

I'm on Linux and I have a custom theme that has no borders for inputs & such (picture 1 is an example), however instead of them not appearing on Firefox, they appear … (read more)

I'm on Linux and I have a custom theme that has no borders for inputs & such (picture 1 is an example), however instead of them not appearing on Firefox, they appear white. I'm not gonna change my whole theme just to be able to have a pretty browser in 2022. How can I change these borders (picture 2) while keeping the GTK theme?

Asked by billyboybackdoor 5 months ago

Answered by billyboybackdoor 5 months ago

  • Solved

Unable to show File Picker

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it … (read more)

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it was nowhere near the top of Google's results, I thought I'll share my solution in the hopes that this would help someone facing this same issue.

The hardware:

  • Asus UM425IA Zenbook (AMD Ryzen 7 4700U CPU)

Worked in:

  • Ubuntu 20.04 LTS
  • Firefox provided by APT repository
  • Xorg display server

Not working in:

  • Ubuntu 22.04 LTS
  • Firefox 99.0.1 provided by snap
  • Wayland display server
  • File picker worked briefly on fresh install, but something (not sure what) quickly breaks file picker functionality

The symptoms:

  • Firefox stopped being able to open file picker dialogs
  • Right clicking an image and selecting "Save Image As..." does nothing
  • With forms that accept file upload (such as on this post question page "Add images (optional):"), clicking "Browse" does nothing
  • File downloads work correctly when set to "Save files to ..." under Settings, but nothing happens when set to "Always ask you where to save files"
  • No response to "Ctrl + O" open file shortcut

Similar questions and solutions:

Things I tried that did not work:

  • Disabling hardware acceleration
  • Starting with add-ons disabled
  • Troubleshoot mode
  • Clearing startup cache
  • Clearing cookies and site data
  • Clearing history
  • Refreshing Firefox
  • Creating and using a new profile
  • Deleting the `xulstore.json` file from the profile directory
  • Toggling all permissions under Ubuntu Settings > Applications > Firefox to off and then back to on
  • chmod 777 ~/Downloads
  • Disabling native file picker "ui.allow_platform_file_picker = false"

And finally, what fixed it for me was to go into "about:config" and change "widget.use-xdg-desktop-portal.file-picker" from "2" to "0". Credit to this post that clued me in.

I really hope this saves someone else 2 days of hair pulling and I would appreciate advice from someone more knowledgeable than me on:

  • Why this fixed the problem
  • Whether I should be opening a bug report either against Firefox, or Ubuntu
  • Whether I should also be changing "widget.use-xdg-desktop-portal.mime-handler" and "widget.use-xdg-desktop-portal.settings", both are currently set to "2"

Asked by James Fu 3 months ago

Answered by Kiki 3 weeks ago

  • Solved
  • Archived

Tab title causes resizing of tab content

When video/audio starts playing on a browser, the tab title displays 'playing' text. This additional line resizes the window height and causes the tab content to resize t… (read more)

When video/audio starts playing on a browser, the tab title displays 'playing' text. This additional line resizes the window height and causes the tab content to resize too. For example youtube starts resizing video window height and width - and this is very annoying. How do I remove 'playing' text from tab FOREVER?

Asked by smalex9 11 months ago

Answered by jonzn4SUSE 11 months ago

  • Solved
  • Archived

Firefox wont open file browser via websites

I'm running Linux Ubuntu 20.4 Whenever I try to use a website that has a browse button (e.g. youtube uploader, google drive, etc) I click it but nothing happens, no file … (read more)

I'm running Linux Ubuntu 20.4

Whenever I try to use a website that has a browse button (e.g. youtube uploader, google drive, etc) I click it but nothing happens, no file browser comes up.

As per previous discussions on this issue, I have tried Safe mode, refresh (in fact total new operating system and re-install of firefox) and disabling hardware acceleration, even turning off popup blocker and none of these have made any difference.

Asked by blackwhitehorse22 11 months ago

Answered by blackwhitehorse22 11 months ago

  • Solved

Firefox crash without crash file?

Youtube music on background and java-game playing(mahjong). After few hours, firefox crash after 'fetchmail' command on bash-terminal. This has happened now two times, bo… (read more)

Youtube music on background and java-game playing(mahjong). After few hours, firefox crash after 'fetchmail' command on bash-terminal. This has happened now two times, both times opening another program induced crash. No messages in logs, it would seem like POP3 port access/ssl/something makes firefox just exit.

LSB Version: core-11.1.0ubuntu2-noarch:printing-11.1.0ubuntu2-noarch:security-11.1.0ubuntu2-noarch Distributor ID: Ubuntu Description: Ubuntu 20.04.4 LTS Release: 20.04 Codename: focal

Asked by ossikoo 4 months ago

Answered by jonzn4SUSE 4 months ago

  • Solved

VPN issue on Firefox

Hello everyone, when I turn on my VPN and I want to use Firefox, it disconnects my connection and I can't open any web page and website! Instead when I open a private pag… (read more)

Hello everyone, when I turn on my VPN and I want to use Firefox, it disconnects my connection and I can't open any web page and website! Instead when I open a private page (incognito mode) everything is okay and Firefox works properly! Can you help me to figure out this issue?

Asked by Chino-Mohtajeb 5 months ago

Answered by jonzn4SUSE 5 months ago

  • Solved

Blank pdfs

For some reason, whenever I load a pdf from within Firefox, I get a new tab with the regular toolbar displayed on top of pdf files, but the document itself is completely … (read more)

For some reason, whenever I load a pdf from within Firefox, I get a new tab with the regular toolbar displayed on top of pdf files, but the document itself is completely blank (see attached screenshot). This issue just started today and I assume it was a result of an update, since I don't recall making any changes to my settings (I'm using Firefox 101.0.1 on Ubuntu 20.04).

I've tried opening multiple files from a variety of sites with the same result. All of them open fine using my system's pdf viewer, as well as from within Chromium. I've tried disabling my plugins, putting Firefox into safe mode and resetting all the handlers, to no avail. Any help would be much appreciated.

Asked by jesse20 1 month ago

Answered by jesse20 1 month ago

  • Solved

File upload dialog not appearing

I'm running Firefox 99.0.1 on Ubuntu 22.04. Recently (I think since I updated to Ubuntu 22.04 about a week ago), Firefox has been refusing to show me file upload dialogs.… (read more)

I'm running Firefox 99.0.1 on Ubuntu 22.04. Recently (I think since I updated to Ubuntu 22.04 about a week ago), Firefox has been refusing to show me file upload dialogs. When I click a button that's supposed to give me one, nothing happens.

This has been happening with: - The "attach files" button in Gmail - A file upload button on Gradescope (website for managing homework assignments) - File -> Open File... and Ctrl+O.

Dragging and dropping a file onto an email in Gmail does attach the file -- it's just that the button doesn't work.

I've tried restarting, and I've tried running Firefox in Troubleshoot Mode -- so far nothing has fixed the problem. What else should I do?

Asked by allispaul 3 months ago

Answered by jonzn4SUSE 3 months ago

  • Solved

Linux Firefox not accepted by online sales websites in Zorin OS and Linux Mint

Zorin16-Linux version 99.0 Ubuntu Canonical 1.0, -found in Help/About. Firefox recognition of version below says 91.0. Also have Linux Mint 19.3 (Tricia). Computer 15Y… (read more)

Zorin16-Linux version 99.0 Ubuntu Canonical 1.0, -found in Help/About. Firefox recognition of version below says 91.0. Also have Linux Mint 19.3 (Tricia). Computer 15YO Dell Dimension 900.

I've had no problems with Linux Firefox for many years. I do not use any other Non-Linux OSes. Linux Mint updates Firefox regularly and so do I in that OS. I'm currently in a free version of Zorin which doesn't seem to push out updates, so my Zorin Firefox may be sadly out of date.

At any rate, today in Zorin, when I went to several of the bigger online sales platforms, they refused to accept my Firefox and suggested Chrome, Opera, and Safari; Target suggested Firefox.

Went to Mozilla to try and upgrade, but it didn't offer the Linux browser automatically when it read my computer. I was only offered the Windows browser. This may be because the computer is an old Dell Windows machine that I converted to Linux or it may not. I've never had this happen before.

Yesterday in Linux Mint, in which Firefox is upgraded at least weekly, the same thing happened once with a big online retailer. They said my browser was outdated and unsafe.

What's going on? I'm wondering if Linux OSes are simply not being accepted when the big retailers are doing software upgrades, or is something going on with Firefox?

Asked by vineyridge 4 days ago

Answered by jonzn4SUSE 3 days ago

  • Solved
  • Archived

Migrating Firefox from Windows 7 to Ubuntu 20.04.1 LTS

The profile folder on the new installation is to be replaced with that from the old. So far so good, I've copied the profile folder from Windows and now want to exchange … (read more)

The profile folder on the new installation is to be replaced with that from the old. So far so good, I've copied the profile folder from Windows and now want to exchange it for the profile folder on the new Ubuntu computer. Problem is that this is the very latest Ubuntu version (only a few weeks old) and there IS no profiles folder in Firefox!

What there is, is a profiles.ini file but I am reluctant to put it in there because it does not appear to have anything to do with the contents of the ex-windows profile folder.

There is an option to create a new folder but I'm not at all sure what this would do.

Hope you can help

Blessed be Karma

Asked by Karma Singh 1 year ago

Answered by Karma Singh 1 year ago

  • Solved
  • Archived

Can't open links from other apps, error "Firefox is already running"

This question was asked 6 months ago and I have the same problem. Running Ubuntu Mate 21.04 (metacity), FF 91.0.2 (64-bit). I have it set up with two different profiles, … (read more)

This question was asked 6 months ago and I have the same problem.

Running Ubuntu Mate 21.04 (metacity), FF 91.0.2 (64-bit). I have it set up with two different profiles, with separate menu entries for each using "firefox -P [PROFILE NAME] -no-remote %u". One of them is set to always use private browsing mode and I use that profile as my default app in mate.

If if set chrome as my default browser, I can open links from other apps without a problem regardless of chrome being already running or not.

When I set FF as default, whenever it is already open and I try to open a link, I get a "Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile." error.

I've seen some comments about similar issues with wayland and tried setting MOZ_DBUS_REMOTE and even MOZ_ENABLE_WAYLAND to 1.

Can you help me?

Asked by vbm 11 months ago

Answered by FredMcD 11 months ago