Showing questions tagged: Show all questions

YouTube gets very laggy after a while - best way to restore performance?

I always keep two Youtube tabs open at all times on my computer. After a while of running, however, the site starts to get increasingly laggy, in a way that simply reload… (read more)

I always keep two Youtube tabs open at all times on my computer. After a while of running, however, the site starts to get increasingly laggy, in a way that simply reloading the tab does not fix. (I am aware that this is likely a result of one of the extensions I have installed that affects Youtube's behavior, specifically SponsorBlock and Return Youtube Dislike, but I am not willing to uninstall these.) I also know of a "force reload" - pressing ctrl + shift + R instead of just ctrl + R in order to clear the cache or something.

However, whenever Youtube starts getting really slow, I instead like to do something I call "crashing the tab" - I open my system monitor, look for the current most CPU-intensive "Isolated Web Co" process, and end it. This pops up an error message in Firefox that says "Gah - your tab just crashed!" and offering me the option to restore it. After restoring it from this window, the performance is back to normal.

My question is, is this beneficial, or is it functionally identical to a normal force-reload? Is the improvement I see between this method and force-reloading the page just placebo? And if not, is there a simpler way to do it without opening a second program?

Asked by alanwilson772 1 week ago

Last reply by Skgh12 1 week ago

Sound glitches in KDE after visit some sites in Firefox

Steps for reproduce: Turn ON PC Launch Audacious player Launch Firefox Visit to drupal.org And I have sound glitches like on radio tuning. From all software, … (read more)

Steps for reproduce:

  • Turn ON PC
  • Launch Audacious player
  • Launch Firefox
  • Visit to drupal.org

And I have sound glitches like on radio tuning. From all software, that have sounds: players, browser, messengers. Glitches disappear after restart. I find only 2 sites, that make it: drupal.org and my local bank. With Chrome - no problems.

Without Audacious glitches can be to, but not in 100% of cases.

OS: KDE Neon Plasma 6

Asked by Alexandr Vasilenko 2 weeks ago

Last reply by jonzn4SUSE 2 weeks ago

I want to have an automated task that sorts the incoming mail to separate folders

I want to have an automated task that sorts the incoming mail to separate folders. I have done this easily in Outlook, but Firefox's Thunderbird is different and I haven'… (read more)

I want to have an automated task that sorts the incoming mail to separate folders. I have done this easily in Outlook, but Firefox's Thunderbird is different and I haven't figured it out. Any help would be greatly appreciated.

George

Asked by George 2 weeks ago

Last reply by jonzn4SUSE 2 weeks ago

Availability for Ubuntu ARM64 via Orange Pi 5+

I know that there is a generic Linux iteration that can be downloaded, but it does not appear to allow for use on ARM64. Is there a way that I can download, install, and … (read more)

I know that there is a generic Linux iteration that can be downloaded, but it does not appear to allow for use on ARM64. Is there a way that I can download, install, and access Firefox on my Orange Pi 5 Plus?

Asked by Caleb 2 weeks ago

Last reply by jonzn4SUSE 2 weeks ago

Firefox DoH fails on Linux Mint XFCE and Fedora Kinoite

Hello, By default, DoH fails on Max Protection in the latest OS versions listed above. The workaround I've discovered is using https://1.1.1.1/dns-query, but I would rath… (read more)

Hello, By default, DoH fails on Max Protection in the latest OS versions listed above. The workaround I've discovered is using https://1.1.1.1/dns-query, but I would rather use the default settings.

Asked by coreywolfhart 2 weeks ago

Last reply by jonzn4SUSE 2 weeks ago

Browser crashes on opening certain filetypes (notably PDF)

Hi everyone, I'm running Firefox which I compiled with vaapi support because I was trying to use hardware acceleration for videos, so I think this bug may have something… (read more)

Hi everyone,

I'm running Firefox which I compiled with vaapi support because I was trying to use hardware acceleration for videos, so I think this bug may have something to do with that. Every time I open a pdf file my browser instantly crashes. When I use troubleshoot mode I have no such issue. I then tried with a fresh all-default user profile with no add-ons, nothing, and still I crash when loading a PDF. Any pointers would be appreciated.

Asked by jethro.rosette 3 weeks ago

Last reply by jonzn4SUSE 2 weeks ago

Having more details of the inspected element in the tool-tip

Hi there, thanks for your attention I'm a web developer and new to using firefox. I was using chrome for years and now just because firefox on android let's us install ad… (read more)

Hi there, thanks for your attention I'm a web developer and new to using firefox. I was using chrome for years and now just because firefox on android let's us install add-on like it's desktop version I'm switching to firefox. as a developer I need to learn about the features firefox offers to developers or ask for any features that are missing right now, so my current issue is about the pictures I will attach. I want to have more information about the element that I'm inspecting right in the tool-tip over it for example it's active font-family or things like that. It took me sometime to figure out how to find the active font of the target element thanks to This post. but in chrome it's showed in the tool-tip.

Asked by Matty 2 weeks ago

Last reply by cor-el 2 weeks ago

launching firefox in safemode just attaches to existing process instead of launching a new instance in safemode

Howdy, Workflow: I have a firefox instance already running. I want to launch a new firefox in safe-mode to test something without disrupting my existing firefox. Probl… (read more)

Howdy,

Workflow: I have a firefox instance already running. I want to launch a new firefox in safe-mode to test something without disrupting my existing firefox.

Problem: I try to launch a new firefox in safe mode using `firefox --safe-mode`, but firefox just opens a new window NOT in safe mode.

I think it may because firefox in safe-mode requires launching launching from a new instance rather than attaching to existing instance.

`firefox --help` shows a flag I can use:

--new-instance Open new instance, not a new window in running instance. --safe-mode Disables extensions and themes for this session.

So I run `firefox --safe-mode --new-instance`

now I get error popup with message:

"Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile."

Now I think what is the point of the flag "new-instance" if Firefox doesn't support multiple instances?

Regardless, how can I launch firefox in safe-mode without disrupting my existing firefox instance and without relying on creating a profile just for this?

Asked by furkansahin824 2 weeks ago

Last reply by cor-el 2 weeks ago

Firefox takes ~5 minutes to startup (even the Profile Manager and in every possible modes)

Firefox takes about 5 minutes to load every it launches, before working smoothly like it should. This problem occured first time yesterday morning, and I have no idea wha… (read more)

Firefox takes about 5 minutes to load every it launches, before working smoothly like it should. This problem occured first time yesterday morning, and I have no idea what could have caused it.

It happens :

  • when I launch firefox normally (whatever the profile)
  • when I launch it from the terminal (it provides no output at all)
  • when I tell it to launch the Profile Manager (5 minutes to see the Profile Manager appear, then 5 more minutes to launch firefox using the selected profile)

It does not happen :

  • when I click "New Window" inside an existing firefox process
  • when I call `firefox --help` from the terminal

Here's what I've tried :

  • First, I've seen pretty much every article from Mozilla Support, Reddit or SuperUser (writing this question is kind of my last resort)
  • I've tried removing and then reinstalling Firefox from Flatpak, from the Fedora repos (using `sudo dnf install firefox`) and using the manual install via the archive (v125)
  • I've tried downgrading firefox (when using the package manager install) from v125 to v124
  • I've also tried the Firefox Developer Edition, same problem here
  • I've tried using the "Refresh Firefox" feature and restarting in Troubleshoot Mode (both are also affected by the slow startup, which makes them particularly painful to execute)
  • I've tried manually deleting the `~/.mozilla/` folder (= manually deleting my profiles)

When firefox launches, it does not freezes my OS and does not seem to use many system ressources : CPU usage is normal, RAM as well, and it does not seem to read many things from the disk as well (I've seen some threads where this was the issue).

And here is something interesting that I discovered :

  • loading (including refreshing) `about:profiles` is also slow and this time freezes firefox (OS reports it as not responding, I can't switch tabs and I can't see my mouse). Other about pages seem to work fine (although I did not try them all)

Thanks !

PS : Even if I think it has nothing to do with the issue, I prefer to mention it here : I was messing with virtual machines yesterday when the issue occured for the first time. My disk got full at some point and I don't know but it might have messed with firefox. At this stage, I had not deleted any files that could relate somehow to Firefox, that's why I doubt it would have caused anything harmful to Firefox. (instead, I mounted an empty partition from my disk to get some space)

Asked by Martin Heywang 3 weeks ago

Last reply by jonzn4SUSE 2 weeks ago

OneDrive workbook problem

So I have an Excel workbook in my onedrive from MS, It was working fine on my firefox browser in my Ubuntu OS, last week it started to delete my cell's information whenev… (read more)

So I have an Excel workbook in my onedrive from MS, It was working fine on my firefox browser in my Ubuntu OS, last week it started to delete my cell's information whenever I pressed the enter, tab or arrow keys, I contacted the MS support and they get me to opened the same file on a chrome browser and worked fine... I still want to use my firefox browser but this problem is very annoying, please help me sort it out!!!

Asked by ricardocrbb 3 weeks ago

Last reply by jonzn4SUSE 3 weeks ago

mouse lockup

Firefox Browser 125.0.3, Flatpak Every few minutes, the mouse locks up on Ubuntu 23.10 and it only happens with I have Firefox open. I have have no extension, and history… (read more)

Firefox Browser 125.0.3, Flatpak Every few minutes, the mouse locks up on Ubuntu 23.10 and it only happens with I have Firefox open. I have have no extension, and history is turned off I have lived with this for months on multiple updates hoping for someone working on Firefox would figure out the issue and fix it.

This issue never happens to me on my windows PCs.

Any solutions? thanks Richard

Asked by Richard Hanson 3 weeks ago

Last reply by jonzn4SUSE 3 weeks ago

Encountered a NS_ERROR_DOM_MEDIA_FATAL_ERR in the MediaDecoderStateMachineBase.cpp process while accessing multiple pdf files.

Opened a directory of pdfs from the command line using ```firefox * &``` and went on with my work. Checked the terminal to see these error messages: ``` [Child 19416… (read more)

Opened a directory of pdfs from the command line using ```firefox * &``` and went on with my work. Checked the terminal to see these error messages: ``` [Child 19416, MediaDecoderStateMachine #1] WARNING: Decoder=7f6e75431700 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005): file /builddir/build/BUILD/firefox-125.0.2/dom/media/MediaDecoderStateMachineBase.cpp:167 [Child 19416, MediaDecoderStateMachine #1] WARNING: Decoder=7f6e79a87a00 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005): file /builddir/build/BUILD/firefox-125.0.2/dom/media/MediaDecoderStateMachineBase.cpp:167 [Child 19416, MediaDecoderStateMachine #1] WARNING: Decoder=7f6e84e52400 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005): file /builddir/build/BUILD/firefox-125.0.2/dom/media/MediaDecoderStateMachineBase.cpp:167 ``` I tried recreating this error by restarting the entire process and repeating everything, but to no avail. I'll try to recreate the error a few more times, however if I don't post a message it means I was unsuccessful.

Details: Mozilla Firefox 125.0.2

CPU: Architecture: x86_64

 CPU op-mode(s):         32-bit, 64-bit
 Address sizes:          39 bits physical, 48 bits virtual
 Byte Order:             Little Endian

CPU(s): 8

 On-line CPU(s) list:    0-7

Vendor ID: GenuineIntel

 Model name:             Intel(R) Core(TM) i5-8350U CPU @ 1.70GHz
   CPU family:           6
   Model:                142
   Thread(s) per core:   2
   Core(s) per socket:   4
   Socket(s):            1
   Stepping:             10
   CPU(s) scaling MHz:   22%
   CPU max MHz:          3600.0000
   CPU min MHz:          400.0000
   BogoMIPS:             3799.90
   Flags:                fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
                          mca cmov pat pse36 clflush dts acpi mmx fxsr sse ss
                         e2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constan
                         t_tsc art arch_perfmon pebs bts rep_good nopl xtopol
                         ogy nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes6
                         4 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16
                          xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt ts
                         c_deadline_timer aes xsave avx f16c rdrand lahf_lm a
                         bm 3dnowprefetch cpuid_fault epb pti ssbd ibrs ibpb 
                         stibp tpr_shadow flexpriority ept vpid ept_ad fsgsba
                         se tsc_adjust sgx bmi1 avx2 smep bmi2 erms invpcid m
                         px rdseed adx smap clflushopt intel_pt xsaveopt xsav
                         ec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_no
                         tify hwp_act_window hwp_epp vnmi md_clear flush_l1d 
                         arch_capabilities

Virtualization features:

 Virtualization:         VT-x

Caches (sum of all):

 L1d:                    128 KiB (4 instances)
 L1i:                    128 KiB (4 instances)
 L2:                     1 MiB (4 instances)
 L3:                     6 MiB (1 instance)

NUMA:

 NUMA node(s):           1
 NUMA node0 CPU(s):      0-7

Vulnerabilities:

 Gather data sampling:   Mitigation; Microcode
 Itlb multihit:          KVM: Mitigation: VMX disabled
 L1tf:                   Mitigation; PTE Inversion; VMX conditional cache flu
                         shes, SMT vulnerable
 Mds:                    Mitigation; Clear CPU buffers; SMT vulnerable
 Meltdown:               Mitigation; PTI
 Mmio stale data:        Mitigation; Clear CPU buffers; SMT vulnerable
 Reg file data sampling: Not affected
 Retbleed:               Mitigation; IBRS
 Spec rstack overflow:   Not affected
 Spec store bypass:      Mitigation; Speculative Store Bypass disabled via pr
                         ctl
 Spectre v1:             Mitigation; usercopy/swapgs barriers and __user poin
                         ter sanitization
 Spectre v2:             Mitigation; IBRS; IBPB conditional; STIBP conditiona
                         l; RSB filling; PBRSB-eIBRS Not affected; BHI Not af
                         fected
 Srbds:                  Mitigation; Microcode
 Tsx async abort:        Mitigation; TSX disabled

Asked by mustafa.290101 3 weeks ago

Last reply by cor-el 3 weeks ago

Specific CSS rule in my userChrome.css doesn't work.

Hi thanks for clicking. I'm on Linux, Zorin OS, which is Ubuntu based if I'm not mistaken, very new to Linux. Anyway, I've made a userChrome.css and done some changes I… (read more)

Hi thanks for clicking.

I'm on Linux, Zorin OS, which is Ubuntu based if I'm not mistaken, very new to Linux.

Anyway, I've made a userChrome.css and done some changes I like to Firefox. It has been working fine until I tried to change the tab bar's overflow shadows when there are more tabs than there is space in the bar.

The rest of the css edits I've made in userChrome.css works fine but this overflow shadow reference Firefox just doesn't grab. I can live edit with the Toolbox and then it works fine, but when opening Firefox as default this css definition is as if gone.

Image 1: after live edit with Toolbox Image 2: before live edit with Toolbox Image 3: my userChrome.css

What can I do to fix this?

Thanks / p

Asked by protocol 3 weeks ago

Last reply by cor-el 3 weeks ago

How to disable Firefox's search (Ctrl + F keyboard shortcut) to be used for the website's internal search?

In numerous cases i have found not to be beneficial when website's search function is activated on Ctrl+F keyboard shortcut and where is better to use regular Firefox on-… (read more)

In numerous cases i have found not to be beneficial when website's search function is activated on Ctrl+F keyboard shortcut and where is better to use regular Firefox on-page search instead. I think that the good site has search button/area visible so i can use it when needed.

So please how to disable Firefox's search (Ctrl + F keyboard shortcut) to activate website's internal search? I want to always use regular Firefox on-page search that i now trigger by left Alt (to show the FF menu), click Edit menu, click Find in page.... (since Ctrl+F is occupied by website's internal search).

Asked by #367259 3 weeks ago

Last reply by zeroknight 3 weeks ago

Crashes without reason (Linux)

System OS: Debian (codename: bookworm) Problem description: I had installed a fresh version of Firefox and it's keeping to crash the pages (Error: The page has crashed) … (read more)

System OS: Debian (codename: bookworm) Problem description:

I had installed a fresh version of Firefox and it's keeping to crash the pages (Error: The page has crashed) without any reason. Any troubleshoot methods (including clearing the cache, cookies, history and even restarted the network and pc.... only to fail and keep having same issue.

I had checked if there is no problem with the opened website in another web browser and in it the page was working correctly.


The issue persist from several versions of Firefox

Asked by Mcgiwer 3 weeks ago

Last reply by zeroknight 3 weeks ago

how to disable new Firefox feature?

I heard that the newest version of Firefox (which I have not upgraded to yet) has a feature that makes it easier to accidentally visit a website whose URL is on the clipb… (read more)

I heard that the newest version of Firefox (which I have not upgraded to yet) has a feature that makes it easier to accidentally visit a website whose URL is on the clipboard. I googled to find out how to disable it, and the Featured Snippet said "go to about:config and change clipboard.autocopy to false." Sounded simple, so I did it, but subsequently found out that the article it quotes from is 10 years of age!

My first question, then, is: what does changing "clipboard.autocopy" to false do if it doesn't turn off the brand-new feature?

The second question is, how do I disable the new URL Paste Suggestion feature? Will setting "clipboard.autocopy" disable it? In particular, I want to make sure that the browser does not pre-load or pre-fetch the clipboard URL, and in fact, I wish to pop up a dialog box any time I do "paste and go." People often copy URLs from e-mails to research them before visiting them directly; jumping directly will increase the likelihood of visiting an imposter site.

Asked by 4232jl 3 weeks ago

Last reply by zeroknight 3 weeks ago

I can´t open Firefox

Firefox is not opening. Every time I try to use it, I get the message: " We're sorry. Firefox had a problem and crashed. We’ll try to restore your tabs and windows when … (read more)

Firefox is not opening. Every time I try to use it, I get the message:

" We're sorry. Firefox had a problem and crashed. We’ll try to restore your tabs and windows when it restarts."

I have submitted the crash report: Crash ID: bp-51f17766-7a20-41dc-ae3d-27ab10240501

I am running it on Fedora 40.

Thank you!

Asked by edio.junior 3 weeks ago

Last reply by zeroknight 3 weeks ago

Firefox Debian significantly slower page loads than Chromium Debian

Hello, have been scratching my head for a while on this one. Have a freshly setup install of Debian 12, using Sway (wayland) as my Window Manager. I am really struggling … (read more)

Hello, have been scratching my head for a while on this one. Have a freshly setup install of Debian 12, using Sway (wayland) as my Window Manager. I am really struggling with slowness in Firefox, page loads take easily 15 seconds whereas loading the exact same page in another window at the same time with Chromium Debian build has near instantaneous load times. I've tried the following troubleshooting steps: - Created a new firefox profile - Tried "Troubleshooting Mode" in Firefox - Disabled ipv6 in firefox about:config and in Debian - Tried different DNS servers - Tried different non-debian specific builds of Firefox - Tried Firefox Beta and Firefox Nightly for Debian

None of these steps made any difference, and Chromium has continued to be significantly faster. Am really stuck here and would love to get to the bottom of this as Firefox is the only browser that works with a HiDPI display in Sway without blurryness. Happy to provide any and all diagnostics and reports that are needed. Thanks in advance!

EDIT: It seems to be some kind of networking issue, using a VPN solves it. But still doesn't explain why Chromium would behave differently.

Asked by Samuel (+Uni) 1 month ago

Last reply by zeroknight 3 weeks ago