Showing questions tagged: Show all questions

Firefox Browser crashes

The browser crashes about every two or three days. I have enabled all four boxes in preferences (Priv & Sec settings) but the crash reporter does not appear. Is there… (read more)

The browser crashes about every two or three days. I have enabled all four boxes in preferences (Priv & Sec settings) but the crash reporter does not appear. Is there anywhere in the Fedora Linux system where I can get some info about why this keep happening?

Asked by scmarshall999 2 weeks ago

Last reply by scmarshall999 6 days ago

youtube videos stuttering

Hello i love mozzila firefox from all the other browsers and i use it only and this is my first time getting problem with browsing online i have firefox 83.0 ( 32 bot )… (read more)

Hello i love mozzila firefox from all the other browsers and i use it only and this is my first time getting problem with browsing online i have firefox 83.0 ( 32 bot ) and i'm working with linux (32 bit) youtube was working fine i think, im not sure that this problem happened after updating firefox i don't know which version of firefox i was using but now im on latest version when i shut down my pc and open it i found that my bookmarks deleted and all the history etc.. now Youtube videos stuttering/lagging and its really annoying problem, thx for your time everyone !

Asked by frospy 4 days ago

Last reply by frospy 2 days ago

hello I have a question about cookies and cache

Hello all I have a site that I log into to manage different things and everytime I go the help section it asks me to relogin. I contacted the support for this site and t… (read more)

Hello all I have a site that I log into to manage different things and everytime I go the help section it asks me to relogin. I contacted the support for this site and they say it is a problem of cookies or cache. However, even after I have wiped the cookies and delete the navigation history, I cannot log in.

Is there a magic way to clean cache and cookies, thank you

Kimbert

ps when joiningdata

found this "safeMode": false,

   "supportURL": "https://support.mozilla.org/1/firefox/81.0/Linux/en-US/",
   "numTotalWindows": 1,
   "numRemoteWindows": 1,
   "remoteAutoStart": true,
   "autoStartStatus": 1,
   "policiesStatus": 0,
   "keyLocationServiceGoogleFound": true,
   "keySafebrowsingGoogleFound": true,
   "keyMozillaFound": false 

??? what is this 'remote'!!!

Asked by Kimbert 1 month ago

Last reply by Kimbert 1 day ago

Bookmark to a specific about:config setting ?

CentOS Linux finally upgraded FF 68esr to FF 82esr. Of course this had to break something. For years I have had a bookmark to "about:config?filter=signon.rememberSignoabo… (read more)

CentOS Linux finally upgraded FF 68esr to FF 82esr. Of course this had to break something. For years I have had a bookmark to "about:config?filter=signon.rememberSignoabout:config?filter=signon.rememberSignons" This allowed me to easily toggle on or off the prompt for my master password when I browsed a site for which I had stored credentials. This bookmark no longer works. It takes me to the generic about:config page but does not fill in the setting which I am looking for. Is there a way to fix this?

I used to have some sort of addon or other feature which allowed me to only unlock my saved credentials when I wanted to logon to a site. When that broke or went away I found the about:config setting and created a bookmark to it. Being prompted to unlock my stored credentials every time I hit a site for which I have credentials is very annoying. Leaving my credentials file unlocked is a security concern.

Any advice would be appreciated.

TIA,

Ken

Asked by r5igti 6 days ago

Last reply by r5igti 21 hours ago

How to force enable TLS1.3 in Firefox

Hi, When I try to access:http://cloudhiding.tech/ via Firefox I can check using Wireshark that the connection request being sent is TLSv1.2. How do I force the TLS1.3 con… (read more)

Hi,

When I try to access:http://cloudhiding.tech/ via Firefox I can check using Wireshark that the connection request being sent is TLSv1.2. How do I force the TLS1.3 connection in Firefox Someone, please let me know.

This website http://cloudhiding.tech/ is hosted behind Cloudflare, and thus supports TLS1.3 (I have verified this using a TLS1.3 client).

Asked by f20170099 3 days ago

Last reply by f20170099 3 days ago

pkcs11 "unable to add module", spanish dni

Some time a go I've configured access to the smart card in the Spanish id card in Firefox, and it work. But I'm recently trying to use again and it doesn't. I'm in a Debi… (read more)

Some time a go I've configured access to the smart card in the Spanish id card in Firefox, and it work. But I'm recently trying to use again and it doesn't.

I'm in a Debian 10 with the libpkcs11-dnie installed (with its dependencies) and I've set it up in a firefox-beta. Is where I've added months a go the module (/usr/lib/libpkcs11-dnie.so), then I had logged in and saw the certificate in "Your Certificates".

Since then many updates came but I didn't need again to use this card. I'm trying it now that firefox-beta is 82.0 and the "log in" button is never enabled.

When I've tried with another firefox, for example the esr (78.3.0esr) coming with debian, I have to add this module as it wasn't there. I've clicked "Load" and fill the form with "module name" and "module filename" (the same file that I've mention before) and when I click 'ok', I receive an alert "Unable to add module". Same experience with firefox-stable (81.0.2) and with firefox-devel (82.0b9).

I don't even know if the issue comes from firefox. Is there a way to debug further the origin of this alert message or why this is not being recognized by the application?

Thanks

Asked by srgblnch 1 month ago

Last reply by srgblnch 3 days ago

Initiating sync makes my entire computer slow and almost unresponsive

This seems to be a newish issue - as in, I think it has not been happening until at least a few weeks ago. The computer (linux) is always on, and firefox is also always r… (read more)

This seems to be a newish issue - as in, I think it has not been happening until at least a few weeks ago. The computer (linux) is always on, and firefox is also always running (except when I update to a new version). But I was not using the computer for a while. Today I sat at the computer expecting to see all my tabs that I sent to it via "send tab to device", but as soon as firefox started syncing, everything slowed down to a crawl (to the point where even typing to a terminal would have upwards to several seconds of lag). Weirdly, it doesn't seem as if there's a lot of CPU or IO being used, according to top and iotop - but I was seeing multiple "migration" processes (that went away after quitting firefox), suggesting that there are many threads doing very little work in aggregate. After googling a bit I tried setting sync.log.appender.console to Debug and looking at debug console, which didn't tell me anything interesting - it actually looks as if the sync itself completes fast. And, in fact, my bookmarks seem to have synced to today's state correctly. (restarting after updating to current version does not seem to help; running in safe mode also doesn't seem to help)

1) What's up? How do I stop this from happening?

2) How do I get my "sent" tabs? Even a list for the past 2 weeks would be fine. Working it out from browsing history would be ... a lot of needles in even more piles of hay.

Asked by xKiv 1 week ago

Last reply by xKiv 21 hours ago

Changing linux shortcuts to resemble apple shortcuts

I'm used to using firefox in OSX but I've got some task that I have to complete on a Linux machine. I was wondering if there a way to adjust the bindings for the shortkey… (read more)

I'm used to using firefox in OSX but I've got some task that I have to complete on a Linux machine. I was wondering if there a way to adjust the bindings for the shortkeys so they resemble the key bindings in OSX?

Asked by sfp.kemp 14 hours ago

Last reply by sfp.kemp 2 hours ago

mozilla.cfg cookies aren't locked for users

Hello, FF82.0.2 I want to change and lock the settings "network.cookie.cookieBehavior" and "network.cookie.lifetimePolicy" for user via the mozilla.cfg. Also I'm using th… (read more)

Hello, FF82.0.2 I want to change and lock the settings "network.cookie.cookieBehavior" and "network.cookie.lifetimePolicy" for user via the mozilla.cfg. Also I'm using the policies.json (which would be my preferred option for changing the network.cookie..., but it doesn't work neither)

But none of them locked or changed the settings for the user. Is this a known problem or are there any other settings, which affect the cookiesettings?

I am really new to this and there were already old configs from another colleague (which has left the company and there are no documentations).

Thank you :)

Asked by Soulphy 1 day ago

Last reply by Soulphy 2 hours ago

WebAssembly console messages are all the same (undefined) instead of specific as they were in earlier versions

VERSION: OS: Ubuntu 20.04.1 LTS OS type: 64-bit Firefox: 83.0 (64-bit) Mozilla Firefox for Ubuntu canonical -1.0 ISSUE: All of the WebAssembly / Wasm error messages I rec… (read more)

VERSION: OS: Ubuntu 20.04.1 LTS OS type: 64-bit Firefox: 83.0 (64-bit) Mozilla Firefox for Ubuntu canonical -1.0

ISSUE: All of the WebAssembly / Wasm error messages I receive in the FF console give a generic response instead of specific messages (like previous versions offered).

I recorded some of the previous error messages in content I was creating for others which explained how to resolve those error messages.

This is an example of what I used to see in the console.

BEFORE:


Firefox 70.0.1 CompileError: wasm validation error: at offset 824: popping value from empty stack

Firefox 80 Uncaught (in promise) CompileError: wasm validation error: at offset 47: initializer expression must reference a global immutable import

Firefox 80 Uncaught (in promise) LinkError: imported Memory with incompatible size


Now, when I do the same things that would trigger those errors, the message I get is vague and not specific at all.

AFTER:


Firefox 83 Uncaught (in promise) Error: undefined


This makes it much more difficult to debug my Wasm in the browser and halts me from sharing my findings with others.

I did look in the about:config settings (in case they added a flag) and tried switching

javascript.options.wasm.verbose from ‘false’ to ‘true’

but that was not a solution.

Setting that flag to true only gave more references to the phases of the compilations but did not give me back the error reporting I used to see for Wasm.

I need to know how to enable the actual error messages again for Wasm or understand why the helpful messages were changed into a generic message. I’m hoping that it just an accident they are not displaying.

Asked by bertiell 5 days ago

Firefox "Save as" file list: Why are folders no longer at top?

I recently changed from Ubuntu Gnome to KDE Plasma. Now, when I'm running Firefox (v83) and click "Save as" to save a file from a web page, Firefox gives me a file list w… (read more)

I recently changed from Ubuntu Gnome to KDE Plasma. Now, when I'm running Firefox (v83) and click "Save as" to save a file from a web page, Firefox gives me a file list with directories mixed in alphabetically, rather than at the top. This is new behavior to me; I don't know if it's new with v83 (I was previously running v82), or if it's a KDE implementation issue.

Either way, I HATE having to scroll down through page after page of files and folders to find my destination folder. Since the dialog box also incorporates full-row select, I can't even click in the file list and type the first letter of my destination folder.

Please tell me there is a way to change this behavior and have Firefox's "Save as" dialog sort the files with directories at the top!

Thanks.

Asked by ExFido 4 days ago

Firefox stopped loading page set as default in a profile

I use a couple of different browsers, Firefox and Brave. I have several profiles set up in Firefox depending on specific sites or groups of sites that I can open individu… (read more)

I use a couple of different browsers, Firefox and Brave. I have several profiles set up in Firefox depending on specific sites or groups of sites that I can open individually or together simultaneously. One of these I set up for a recipe management site I use https://recipesage.com. I set up a profile for recipesage and then go to the site, log in and save that page as the default. I then set up a .desktop script in my ~/.local/share/applications folder (I use Ubuntu as my OS of choice) to open that profile along with an image for recipe sage so I can save the "application" to my launcher separate from the regular Firefox icon. It worked fine that way for years until just recently. it no longer works. I deleted and recreated the profile, open it, set the default page, close firefox and restart it and it just spins, never loads the page. If I set the default to the default firefox page and then go to the site manually it works but not if I save it as the default. I have had to switch to using Brave instead which is fine but kind of sad that I can't use Firefox any longer. Any ideas why it all of a sudden broke?

Asked by bjb1959 3 days ago

Firefox does not support ffmpeg wasm version 0.9.5

The ffmpeg wasm library does not work on firefox. I am developing a video editing app using ffmpeg wasm (version 0.9.5). But I am not able to run it in firefox (version 8… (read more)

The ffmpeg wasm library does not work on firefox. I am developing a video editing app using ffmpeg wasm (version 0.9.5). But I am not able to run it in firefox (version 83, Linux Mint 20 Ulyana) Same thing runs perfectly fine in chromium. I googled and the general consensus says firefox does not support latest ffmpeg library features. I have attached a screenshot of browser console.log for clarity on the issue. I checked the browser config and the Shared ArrayBuffer value is set to true.

Asked by lankesh 3 days ago

Disable automatic HTTPS redirection on timeout

I have an embedded system with a HTTP server on it. It doesn't provide HTTPS. When I restart it, the host gets offline from the network for 10 or 20 seconds. When I try t… (read more)

I have an embedded system with a HTTP server on it. It doesn't provide HTTPS. When I restart it, the host gets offline from the network for 10 or 20 seconds. When I try to reload the webpage too early (the host isn't quite ready yet), Firefox automatically redirects me to HTTPS. How can I disable HTTPS redirection on timeout?

Asked by sven.steudte 2 days ago

What if I was on an untrusted site?

Some people say "I'm not visiting unknown sites with my browser". I'm not saying that I'm not visiting unknown ones, but still trying avoid sites that I doubt it. But wh… (read more)

Some people say "I'm not visiting unknown sites with my browser". I'm not saying that I'm not visiting unknown ones, but still trying avoid sites that I doubt it. But what if I accidentely visit some, VirusTotal showed no viruses. How can I be sure that my browser isn't affected. Should I reinstall it, wipe some folders? I use Linux, Firefox 83.0.

Asked by R S 2 days ago

Shortcut Creation for Ubuntu 20.04.1

I have switched from Windows 10 to Ubuntu 20.04.1 and am having trouble creating website shortcuts now. With Windows I used the following method [Support - Create a des… (read more)

I have switched from Windows 10 to Ubuntu 20.04.1 and am having trouble creating website shortcuts now. With Windows I used the following method

From my research it looks this is supposed to work with Ubuntu as well? It is not working for me, is this possible?

Asked by Justin Reina 2 days ago

Firefox often times out accessing paypal.com and other sites using DigiCert certificates

Firefox often times out when accessing paypal.com and other sites that use certificates from DigiCert. The same sites can be accessed reliably, from the same computer at … (read more)

Firefox often times out when accessing paypal.com and other sites that use certificates from DigiCert. The same sites can be accessed reliably, from the same computer at the same time, using chromium-based browsers.

The problem goes away if I disable the check to query OCSP responder, which may indicate the cause of the problem.

Often the sites can be accessed after restarting firefox, but after a few tries the problem recurs. This is not a solution as PayPal is often accessed in the last steps of an online purchase.

Asked by em2jacks 1 day ago

How to remoave a cam from the dialog

Hi, I have following problem. If i start a meeting, like jitsi, I always be prompt for droidcam as camera but i use another android app. So how to remove that and setting… (read more)

Hi, I have following problem. If i start a meeting, like jitsi, I always be prompt for droidcam as camera but i use another android app. So how to remove that and setting up a new one as webcam. I know i can use my little smartphone but, for talking is it enough, but i have to typ words too and this is much more easy an the old laptop. So how can i remove the previous cam, remove it from the cache or what ever it is called, and add a new one without out buying an usb-cam!

greetings hendrik

Asked by hlehmbruch 19 hours ago