Showing questions tagged: Show all questions

Preferred search engine for address bar won't sync

After a deletion of a profile; an attempt to sync back the preferences results in the search bar having the default engine not synchronised. It is overwritten to Google, … (read more)

After a deletion of a profile; an attempt to sync back the preferences results in the search bar having the default engine not synchronised. It is overwritten to Google, despite doing sync for DuckDuckGo. I have done a parallel test on the "tracking protection" and the preference for that one does sync. Thank you for any suggestions!

EDIT: The DuckDuckGo addon accomplishes the desired effect. However, it only hides the problem.

Asked by Carduus 6 days ago

crash "###!!! [Child][MessageChannel] Error: (msgtype=0x35010B,name=PContent::Msg_RecordDiscardedData) Channel closing: too late to send/recv, messages will be lost"

With a python script I have a kiosk-like screen on which there should be a pertpetual changing (delay: 20 secs) between 3 different pages with the same URL. Works fine ..… (read more)

With a python script I have a kiosk-like screen on which there should be a pertpetual changing (delay: 20 secs) between 3 different pages with the same URL.

Works fine ... sometimes for days, sometimes for hours, then it crashes. (I don't join the entire log entries, it's some 5000 lines; so here are the always repeating lines of warnings and errors)

===========================================>

[Parent 3042, Gecko_IOThread] WARNING: pipe error: Datenübergabe unterbrochen (broken pipe): file /build/firefox-esr-HMuf61/firefox-esr-68.11.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 727

      1. !!! [Child][MessageChannel] Error: (msgtype=0x35010B,name=PContent::Msg_RecordDiscardedData) Channel closing: too late to send/recv, messages will be lost

IPDL protocol Error: Received an invalid file descriptor

      1. !!! [Parent][MessageChannel] Error: (msgtype=0x1E0074,name=PBrowser::Msg_StopIMEStateManagement) Channel error: cannot send/recv
      2. !!! [Parent][MessageChannel] Error: (msgtype=0x1E008F,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

[Parent 3042, Gecko_IOThread] WARNING: pipe error (4044): Die Verbindung wurde vom Kommunikationspartner zurückgesetzt: file /build/firefox-esr-HMuf61/firefox-esr-68.11.0esr/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 358

<===========================================

What is happening? And why? Greetings Martin

Asked by martin.schimmels 6 days ago

pkcs11 "unable to add module", spanish dni

Some time a go I've configured access to the smart card in the Spanish id card in Firefox, and it work. But I'm recently trying to use again and it doesn't. I'm in a Debi… (read more)

Some time a go I've configured access to the smart card in the Spanish id card in Firefox, and it work. But I'm recently trying to use again and it doesn't.

I'm in a Debian 10 with the libpkcs11-dnie installed (with its dependencies) and I've set it up in a firefox-beta. Is where I've added months a go the module (/usr/lib/libpkcs11-dnie.so), then I had logged in and saw the certificate in "Your Certificates".

Since then many updates came but I didn't need again to use this card. I'm trying it now that firefox-beta is 82.0 and the "log in" button is never enabled.

When I've tried with another firefox, for example the esr (78.3.0esr) coming with debian, I have to add this module as it wasn't there. I've clicked "Load" and fill the form with "module name" and "module filename" (the same file that I've mention before) and when I click 'ok', I receive an alert "Unable to add module". Same experience with firefox-stable (81.0.2) and with firefox-devel (82.0b9).

I don't even know if the issue comes from firefox. Is there a way to debug further the origin of this alert message or why this is not being recognized by the application?

Thanks

Asked by srgblnch 5 days ago

My system is freezing up - I am running with ubuntu 20.04

this is a copy of something I just sent to the ubuntu forum. It explains my problem: I have been noticing that, sometimes, I can't shut down a program. This has happe… (read more)

this is a copy of something I just sent to the ubuntu forum. It explains my problem:

   I have been noticing that, sometimes, I can't shut down a program. This has happened with firefox, thunderbird and, now, livepatch. When this happens it also means that , again for instance, I am having problems typing this as things freeze. I have tried to shut down stuff from the program (which accepts nothing and is frozen), from the dock, and also tried to run system monitor which started, had the icon but wouldn't open. Basically my machine is in partial lockdown and there doesn't seem to be a damned thing that I can do. I am resisting just pressing buttons (always a mistake) but this is really frustrating. Oh, the livepatch box, that receives input, is also dimmed and will not go away. This little note took me 15 minutes to type.
   It got so bad that I started pushing buttons. The only other thing I had open was Firefox. I shutdown firefox and, suddenly, the livepatch connection, through software and updates, shut down on its own. For me this means that I have a problem with firefox and will be paying them a visit. Still, any thought are welcome as this one is starting to really get to me.
   thank you..................

Asked by greg 5 days ago

How to use the latest download directory for the next download

I've configured my Firefox for Fedora to ask me every time in which directory I want to save the file. The default directory used by Firefox is /run/user/1000/doc/ Even a… (read more)

I've configured my Firefox for Fedora to ask me every time in which directory I want to save the file. The default directory used by Firefox is /run/user/1000/doc/ Even after changing the directory and downloading another file, Firefox keeps reverting to this /run directory. Can I make Firefox stick to the latest directory I used? I do not want to use a fixed Download directory

Asked by joep.beijnsberger 4 days ago

Recent History list in History drop-down menu

The Recent History list in the History drop-down menu is limited to about 40 entries. Everything before that is not shown. How can I increase the number of these entries… (read more)

The Recent History list in the History drop-down menu is limited to about 40 entries. Everything before that is not shown.

How can I increase the number of these entries to say 100?

Asked by thomasvonderelbe 4 days ago

Ubuntu opens portal everytime to open downloaded file

It used to be that downloading something like a pdf and then clicking on it through the downloads dropdown would immediately open the pdf in the default system pdf viewer… (read more)

It used to be that downloading something like a pdf and then clicking on it through the downloads dropdown would immediately open the pdf in the default system pdf viewer. Now I get a pop-up telling me the Portal "Open with" is ready which then presents me with a set of options for where to open the file. I have looked around for anyone else with this problem but haven't found anyone.

Additional info: If I use the show enclosing folder feature it actually shows me a temp folder (image attached)

Asked by btickell 3 days ago

La ventana emergente para hacer examenes de mi aula online vibra de arriba a abajo ininterrumpidamente

Hola. Tenco el explorador Firefox 81.0.2 (64-bit) para ubuntu canonical 1.0 ... mi S.O. es Ubuntu 16.04 LTS con todas las actualizaciones que han salido hasta el momento.… (read more)

Hola. Tenco el explorador Firefox 81.0.2 (64-bit) para ubuntu canonical 1.0 ... mi S.O. es Ubuntu 16.04 LTS con todas las actualizaciones que han salido hasta el momento...

Cada vez que me meto en mi aula online https://campusonline.cesurformacion.com/my/ La ventana emergente para hacer examenes de mi aula online vibra o se mueve rápidamente de arriba a abajo ininterrumpidamente con lo que es dificil seleccionar despues una opción como cerrar la ventana aunque lo consigo a duras penas... Les agradecería que me ayudaran a resolver este problema, Un Saludo

Asked by fjavierml73 3 days ago

Lost all installed Addons and Theme through update

Firefox did an update today, and restarting it, all my installed addons are gone. On top of that, my personal theme is no longer there. Saved passwords, on the other hand… (read more)

Firefox did an update today, and restarting it, all my installed addons are gone. On top of that, my personal theme is no longer there.

Saved passwords, on the other hand, do not seem to be affected.

Any advice on how to restore the addons, in particular? My current version Firefox 76.0 on Fedora. Any help is appreciated!

Asked by martin 3 days ago

Open new tab on the left, not on the right of the tab bar

How to set Firefox to open new tabs on the left, not on the right of the tab list? Hyperlink is ok, it opens on the right of the current tab, but not the Ctrl+T or when o… (read more)

How to set Firefox to open new tabs on the left, not on the right of the tab list?

Hyperlink is ok, it opens on the right of the current tab, but not the Ctrl+T or when opening link from the pinned tab. Tab is placed to the far right. Current setup is not logical. If pinned tabs (important ones which you visit often) are on the beginning, and the tabs you are actively working on are on the opposite end of the tab bar. You want to open new tabs near the pinned ones.

Asked by #367259 4 days ago

Last reply by #367259 3 days ago

Select which GPU firefox uses for hardware acceleration in a multigpu system

Software: Manjaro Linux, GNOME, Xorg, Firefox 81 Hardware: nvidia GTX 1080 and AMD RX 570 I have a multigpu Linux machine and would like to configure Firefox to only use … (read more)

Software: Manjaro Linux, GNOME, Xorg, Firefox 81 Hardware: nvidia GTX 1080 and AMD RX 570

I have a multigpu Linux machine and would like to configure Firefox to only use the AMD card for hardware acceleration.

Rationale: My Xorg is configured to only use the RX 570. My GTX1080 is mostly used to pass through to a Windows VM, but occasionally I do use it in Linux so do not want to disable it completely. This is usually seamless, when the card is not in use: When I start up the Windows VM, it unbinds the GTX1080 from the driver and passes the hardware through. When Firefox is running with hardware acceleration enabled, however, it can not unbind the GTX1080. It seems that Firefox is "using" the nvidia card, so I just want to disable that without disabling hardware acceleration entirely.

Asked by parahaps 3 days ago

UI responsiveness issues - Linux + high GPU usage

Hi! I'm posting this in hopes of getting help with a UI responsiveness problem that seems specific to Linux when GPU usage is very high. I use distributed computing throu… (read more)

Hi! I'm posting this in hopes of getting help with a UI responsiveness problem that seems specific to Linux when GPU usage is very high. I use distributed computing through BOINC when weather is cold enough to allow it, but I've noticed that when my GPU is working on a task, Firefox is very unresponsive in most regards; scrolling lags behind my actual inputs, it takes longer to render new pages, and videos have issues like video/audio desync and audio stuttering.

That would seem normal to me considering my system resources are in heavy use, except for two things: these issues do not occur in Blink-based browsers (I've temporarily switched to Brave because of this issue), and more relevantly, they only occur in Firefox in Linux, not Windows Firefox.

I have already checked if this is because of settings or extensions by creating a new blank profile (which I am using right now), and that's not it - turning off hardware acceleration doesn't help either.

I see the Troubleshooting Information dump has a lot of system and hardware data in it, but I'd be happy to provide more details if needed. Thanks!

Asked by VII.rosa 2 days ago

Is there a way to get Firefox to stop asking for smart card PIV/CCID/OpenPGP PINs on startup?

I've been trying to figure out if there is a way to stop Firefox from continually asking for the PINs to smartcards that it discovers through p11-kit-proxy with pcscd. E… (read more)

I've been trying to figure out if there is a way to stop Firefox from continually asking for the PINs to smartcards that it discovers through p11-kit-proxy with pcscd. Everytime I start firefox I am currently unloading the module to prevent Firefox from asking me for the PINs to smartcards it does not need access to

Asked by thesunistoolong 2 days ago

Firefox release 59 for raspberry pi for Kaios development

Firefox release 59 for raspberry pi for Kaios development. We are a young non profit startup and we use raspberry pi as our primary computer for development. We found fir… (read more)

Firefox release 59 for raspberry pi for Kaios development. We are a young non profit startup and we use raspberry pi as our primary computer for development. We found firefox for raspberry pi but it is the latest version. We want release 59 as only that suppor webdev needed for kaios development

Asked by dev.hellonuh 2 days ago

garbled text display towards end of long page

Hi! For quite some time I run Firefox in KDE over wayland using Gentoo package. Recently I enabled webrender to fix bad flickering while loading sites, and while that wor… (read more)

Hi!

For quite some time I run Firefox in KDE over wayland using Gentoo package. Recently I enabled webrender to fix bad flickering while loading sites, and while that worked I now see garbled text display towards the end of longer web pages. I do not remember which Firefox version it was when I switched on webrender, but the issue persists through a few recent Firefox upgrades till my current 82.0 (this is Gentoo linux build)

Attached screenshot is of the bottom of this page https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.8.15 While top of page is always good looking, garbled text starts somewhere towards the end of page.

I'm not sure if this is a new issue or the same one as in bug 1667534.

Is there any easy option to fix this, or this should be filed as new bug?

Asked by igor.v.kovalenko 4 days ago

Last reply by igor.v.kovalenko 2 days ago

Content of toolbar popup of an addon is not rendered or not visible.

Hi, i recently have a issue, where most of the addons don't show the content of their defined popup. I do the following sequence. - open firefox - add a addon - add it t… (read more)

Hi, i recently have a issue, where most of the addons don't show the content of their defined popup.

I do the following sequence.

- open firefox - add a addon - add it to the toolbar - click on the icon to access its popup

The popup is then opened and the outline of it's size is most likely correctly calculated, but the content is missing.

The reference Addons are passff, with no Content SakaKey, with an partial rendering HTTPSEverywhere, with the full content and the expected behaviour.

I tried to reset the browser via the about:support page, no change. I restarted in safe mode. That was kind of pointless, because without addons, there are no icons to click at^^.

I created a fresh profile, also no change. So i downloaded the latest nightly, started with a fresh profile, and installed one addon, still not working.

I fickled with the browser-style property in the manifest.json of passff, and set it to true, but again it still shows no content.

What is most likely missing on the shared data, i run Ubuntu 20.04 with i3 as a window manager.

Has anyone a idea what i am missing?

Asked by Manu.Bernza 2 days ago

incorrect password

I'm trying to log in from a different machine than my usual one. Firefox says I am using the incorrect password. I have quadruple checked the spelling of my user name … (read more)

I'm trying to log in from a different machine than my usual one. Firefox says I am using the incorrect password. I have quadruple checked the spelling of my user name (email address) and my primary password. I am definitely entering them correctly on the new machine yet firefox insists it is wrong. I checked the password in the account settings of my usual machine, under "accounts.firefox" on Firefox's Lockwise (aka logins & passwords) page and indeed I am using the correct email & password. I also searched my email to make sure that I did not change my password and forgot that I had done so. So how can this be?

Asked by KalaDude 2 days ago

Last reply by KalaDude 2 days ago

Google login and outdated Plugin.

Hi! I am opening this help, because for some months, that I have been using Firefox on Kubunto, it is impossible to log into Google. YouTube is the way I left it in Print… (read more)

Hi! I am opening this help, because for some months, that I have been using Firefox on Kubunto, it is impossible to log into Google. YouTube is the way I left it in Print. And it has a plogin that doesn't update for anything. Which is the Widevine Content Decryption Module provided by Google Inc.

This has brought me a lot of frustration when using firefox on Kubunto. But as I use the system only on the Pen Drive, I have no plans to install Chorme. Because I need the system only there and now.

Of course, I tried in many ways to correct my problem. I even formatted this Kubunto system. I tested with other linux systems. But they all have a problem with the same plugin, in firefox.

Could someone help me with this problem? I always used everything normal. It only started to happen about 3 months ago.

Asked by Zanguet 1 day ago

Playing two audios ( for example, two Youtube videos) on two seperate headphones, or in my case,

the 1st youtube video is played out on the screen, and the other video in my headphones. I would like to give my little brother my pair of headphones to watch youtube, an… (read more)

the 1st youtube video is played out on the screen, and the other video in my headphones.

I would like to give my little brother my pair of headphones to watch youtube, and for my class lectures that I have to watch, I would like to listen to them through the screen, or vice versa. And of course I would split the windows up, his screen of youtube on the left, and mine on the right.

Thank you

Asked by danniel.brown27 20 hours ago