Showing questions tagged: Show all questions
  • Solved
  • Archived

Firefox throws SEC_ERROR_BAD_SIGNATURE error for a site but Chromium says certificate is valid

Hi all, I have an Apache site on Kubuntu 20.04 with a certificate signed by my private CA. I've added the root CA ceritificate in Firefox and in Chromium. Firefox throws … (read more)

Hi all, I have an Apache site on Kubuntu 20.04 with a certificate signed by my private CA. I've added the root CA ceritificate in Firefox and in Chromium.

Firefox throws a SEC_ERROR_BAD_SIGNATURE error

Chromium accept the certificate as valid

What can I do?

Notes: the site url is "https://hdev.h.net" (with an internal IP address inside my lab)

Attached there are:

- the authority settings page
- the certification authority certificate as seen by Firefox
- the site certificate

Firefox version 82.0 Ubuntu Chromium version 86.0.4240.11

Asked by m.busico 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Remove the minimize, maximize, and close buttons

I'm running Ubuntu 20.10 with GNOME Shell extension Unite which can add the minimize, maximize and close buttons to the top bar and remove the buttons from the title bar … (read more)

I'm running Ubuntu 20.10 with GNOME Shell extension Unite which can add the minimize, maximize and close buttons to the top bar and remove the buttons from the title bar of apps. The does not work in Firefox, minimize, maximize & close remain. I'm assuming this is related to Firefox's ability to remove the title bar all together so tabs can be at the top. The Firefox Customize... page allows you to change just about everything else in the UI except these three buttons.

Is there a way to remove Firefox's minimize, maximize and close buttons?

In case it matters I really only care about the Close button (not Close tab) because GNOME Tweaks lets you remove the minimize & maximize buttons from all apps.

Thanks

Asked by Elias K Gardner 1 year ago

Answered by Elias K Gardner 1 year ago

  • Solved
  • Archived

Firefox doesn't support HTML5 while other Browsers do. Latest Ubuntu 20.04. LTS

So the problem is that Firefox doesn't play any HTML5 content. Weirdly except for Youtube. Youtube works just fine. But every other Website shows errors. Even songsterr.c… (read more)

So the problem is that Firefox doesn't play any HTML5 content. Weirdly except for Youtube. Youtube works just fine. But every other Website shows errors. Even songsterr.com. I'm using latest Firefox 76.0.1 on a recent Ubuntu 20. 04 LTS installation. Usual troubleshooting like updates doesnt work because "sudo apt-get upgrade" doesn't find any updates. I tried the same websites in the latest version of Chromium and they work perfectly fine. I couldn't find a mistake in the firefox settings or something so I'm confused. Disabling Plugins didn't change anything and turning of tracking protection didn't either. What is the Problem here and how can I solve it?

Asked by wauwufflp 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

82.0 scroll bar too thin

Searching everywhere and cannot find a solution. Perhaps there is none. Followed suggestions here: https://support.mozilla.org/en-US/questions/1297345 in an attempt to… (read more)

Searching everywhere and cannot find a solution. Perhaps there is none. Followed suggestions here: https://support.mozilla.org/en-US/questions/1297345 in an attempt to increase width of scroll bar but see that just reproduces the default setting.

So the question stands: how to increase width of scroll bar?

The scroll bar is super thin.

Any suggestions for Ubuntu 20.04.1 LTS Firefox 82.0 (64-bit)

Thanks.

Asked by jeffschips 1 year ago

Answered by jeffschips 1 year ago

  • Solved
  • Archived

Firefox hangs Ubuntu 20.04

After installing Ubuntu 20.04 LTS Clicking on Firefox or Thunderbird it hangs the computer and have to switch off the computer on main switch. Reinstall Mozilla once but … (read more)

After installing Ubuntu 20.04 LTS Clicking on Firefox or Thunderbird it hangs the computer and have to switch off the computer on main switch. Reinstall Mozilla once but no difference still hangs Ubuntu. Need help on this one Thank you

Asked by Lumaja 1 year ago

Answered by schnrl 1 year ago

  • Solved
  • Archived

Completely disable Firefox update on Ubuntu

I am using Firefox on an old Ubuntu machine, and found myself unable to disable the auto update feature of Firefox. I understand why Firefox wants to do auto update, but … (read more)

I am using Firefox on an old Ubuntu machine, and found myself unable to disable the auto update feature of Firefox. I understand why Firefox wants to do auto update, but for me personally it's negatively impacting my productivity. Many times I was looking up reference materials only to be told that I need to restart Firefox because it just updated itself. Imagine how frustrating it is, especially when I use the Private Browsing mode a lot to avoid having to clean up browsing history and cached files later. All in all, while the auto update feature might be good for some users, it's just not working for me, so I want it to be disabled.

I tried a couple of things. First, there's nothing in the "Preferences" page related to the auto update. Second, I tried to change the value of "app.update.auto" in the "about:config" page to false, and it still does auto update. Finally, I tried to add a "policies.json" file to "/etc/firefox/", with the following content:

{ "policies":

  {
    "AppAutoUpdate": false,
    "DisableAppUpdate": true,
    "DisableTelemetry": true
   }

}

Yet it still does auto updates. As a matter of fact, it updated itself to version 80 just now. This driving me crazy. Any useful suggestions will be sincerely appreciated.

Asked by dev.1one.w01f 1 year ago

Answered by dev.1one.w01f 1 year ago

  • Solved
  • Archived

DRM content won't play

After installing the DRM content through the browser I still cannot play any videos on Netflix or Udemy. I have run this website (https://www.jeffersonscher.com/sumo/htm… (read more)

After installing the DRM content through the browser I still cannot play any videos on Netflix or Udemy.

I have run this website (https://www.jeffersonscher.com/sumo/html5-video.html) from previous answers to check and the results are attached to the question.

I have also checked media.eme.enabled and it is set to true.

I am very much puzzled by this.

Asked by Alex 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

Installation aborted because the add-on appears to be corrupt

We have a new add-on of our own that we were trying to add to the Firefox browser. This add-on was tested locally and worked fine. However, upon trying to install the off… (read more)

We have a new add-on of our own that we were trying to add to the Firefox browser. This add-on was tested locally and worked fine. However, upon trying to install the official add-on to the browser, it is throwing the following error, "Installation aborted because the add-on appears to be corrupt".

The add-on in question is, https://addons.mozilla.org/en-US/firefox/addon/searchgiggle-search/

Any suggestions to address this issue would be appreciated.

I also noticed another post or two about the same topic. As per those posts, the issue got resolved automatically after some time. Can I expect the same?

Asked by srik.kid2012 1 year ago

Answered by srik.kid2012 1 year ago

  • Solved
  • Archived

Firefox 91 Linux - WebGL stopped working

WebGL has stopped working. I think this has happened with Firefox 91. For example, http://webglsamples.org/aquarium/aquarium.html gives the error Status: WebGL creation f… (read more)

WebGL has stopped working. I think this has happened with Firefox 91.

For example, http://webglsamples.org/aquarium/aquarium.html gives the error Status: WebGL creation failed: * tryNativeGL () * Exhausted GL driver options. (FEATURE_FAILURE_WEBGL_EXHAUSTED_DRIVERS)

I'm running Firefox on Debian on ChromeOS.

On about:support, WebGL 1 Driver Renderer: Red Hat -- virgl WebGL 2 Driver Rendered: Red Hat -- virgl

There are no WebGL errors in about:support

I've tried the Troubleshoot Mode but that made no difference.

Asked by Rob 11 months ago

Answered by Rob 10 months ago

  • Solved
  • Archived

Firefox is not opening correctly

Hi today I opened my linux installation and Firefox is only getting a window with the text: <toolbarbutton id="UITourTooltipClose" class="close-icon" <… (read more)

Hi today I opened my linux installation and Firefox is only getting a window with the text:

             <toolbarbutton id="UITourTooltipClose" class="close-icon"
</pre>

I tried to run from the console with the --MOZ_LOG_FILE flag and the generated file has absolutely no text in it.

Some information about my system: kernel: Linux localhost.localdomain 5.7.7-1-default #1 SMP Wed Jul 1 19:03:27 UTC 2020 (cba119b) x86_64 x86_64 x86_64 GNU/Linux

OS: openSUSE 20200715

DE: KDE 5.72.0 / Plasma 5.19.3

Version: 78.0.2-1.1 (according to zypper info MozillaFirefox command)

Asked by Gresthol 2 years ago

Answered by FredMcD 2 years ago

  • Solved
  • Archived

WebGL stopped working after the Firefox 88 upgrade

Per the title, webgl suddenly stopped working a couple days ago. The error seems to be: WebGL creation failed: * WebglAllowWindowsNativeGl:false restricts context creatio… (read more)

Per the title, webgl suddenly stopped working a couple days ago. The error seems to be:

WebGL creation failed: * WebglAllowWindowsNativeGl:false restricts context creation on this system.

I'm on Ubuntu 21.04 (X, not wayland) with an nvidia graphics card. The "share data" below seems comprehensive, but let me know if any other info will help.

Asked by john588 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

"full window" mode

There is a fullscreen mode that prints a window over the full size of the screen without showing toolbars/navigation/extensions... Is there a "full window" mode that do t… (read more)

There is a fullscreen mode that prints a window over the full size of the screen without showing toolbars/navigation/extensions... Is there a "full window" mode that do the same, but over the full size of a window? It would be a simple webview in a system window but without the control toolbars. It would be very useful when tiling several Firefox windows without wasting space for toolbars/tabs... This mode should be specific for a window since I do not want to loose the controls on the main screen-wide window.

[attached image is a sketch of what I'm looking for]

Asked by Hugo Trentesaux 1 year ago

Answered by TyDraniu 1 year ago

  • Solved
  • Archived

Youtube CORS error

Hi, I faced the problem with Youtube recommendations on a video page. When I watch a video I can't see recommendations, comments and video title (see the image). In conso… (read more)

Hi, I faced the problem with Youtube recommendations on a video page. When I watch a video I can't see recommendations, comments and video title (see the image). In console i get an error: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://googleads.g.doubleclick.net/pagead/id. (Reason: CORS request did not succeed).

I am on arch linux system.

I've tried to: 1. Update all ca-certificate* packages 2. Disable and delete ad-block 3. Use another browser (there is no problem, only in firefox)

This problem is only actual on Youtube for me.

Asked by Yuudai 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

FACEBOOK - Typing a comment causes the screen to scroll on its own.

Starting as of today (Oct 13), the FACEBOOK screen suddenly moves when I am typing a comment. Whenever I hit SHIFT+alpha_letter at the beginning of a line OR simply hit t… (read more)

Starting as of today (Oct 13), the FACEBOOK screen suddenly moves when I am typing a comment. Whenever I hit SHIFT+alpha_letter at the beginning of a line OR simply hit the backspace key, the screen suddenly shifts about a page up, closer to top. This shifts the entry area where I'm typing down and off the screen. Just hitting the backspace to correct a typo causes the screen to scroll on its own. I have to scroll back down to the entry box and if I make another typo, it happens again. It is maddening!

I've restarted in troubleshoot mode and the same thing happens, so it is not an add-on. This is happening on both my Firefox Linux systems AND on a Windows 10 machine, so I don't think it is specifically OS related either. The screen however does stay put, like it is supposed to, using Chrome or Opera.

Is this a Firefox problem or is FACEBOOK messing with Firefox?

Asked by nosoy1 9 months ago

Answered by nosoy1 9 months ago

  • Solved
  • Archived

How can I make DuckDuckGo my default search engine?

I have searched & searched and read & read and have not found Joy. I followed the Firefox DDG install instructions at duckduckgo.com (which succeeded and now that… (read more)

I have searched & searched and read & read and have not found Joy.

I followed the Firefox DDG install instructions at duckduckgo.com (which succeeded and now that it's succeeded can't be duplicated), and here: https://www.linuxmint.com/searchengines/anse.php?sen=DuckDuckGo (which doesn't work), but here: 'Preferences' > 'Search' > 'Default Search Engine' DuckDuckGo doesn't appear in the drop-down list. Help!

Asked by Mark Filipak 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Address Bar Search Not Working

Hi, Firefox 84.0.1 (64-bit) on Linux Mint 18.3 I have the 'Use the address bar for search and navigation' option selected in settings but when I enter a search all I get … (read more)

Hi,

Firefox 84.0.1 (64-bit) on Linux Mint 18.3

I have the 'Use the address bar for search and navigation' option selected in settings but when I enter a search all I get is 'Hmm. That address doesn’t look right. Please check that the URL is correct and try again.'

Any ideas please?

Asked by caned_monkey 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Font wanted isn't the font that's displayed in Linux Ubuntu.

TL/DR: See the image. ;) I'm on Ubuntu 20.04 (Xubuntu flavor), using Firefox 79.0, working on a web site. I'm coding specifically for Arial... and it's returning Times … (read more)

TL/DR: See the image. ;)

I'm on Ubuntu 20.04 (Xubuntu flavor), using Firefox 79.0, working on a web site. I'm coding specifically for Arial... and it's returning Times New Roman.

I have Arial installed, via the ttf-mscorefonts package and also adding them from a Win10 box.

Please, no "But you should do 'font-family: Arial, Veranda, sans-serif'" dismissive answers. Why? Because if I do "font-family: Arial, Veranda" I still get Times New Roman. I can even substitute "Pulsar Beta" here (a font that is installed to my local account) and it still gives me Times New Roman.

If I do "font-family: sans-serif" I get Veranda, not Arial... which is odd because Arial is my default font.

Doing "font-family: Veranda" gets my Times New Roman.

Chrome doesn't have this issue!

As a picture is worth a thousand words, see the pic.

What can I do? I did see some bugs that were fixed in v56, but none of the debugging tips help there.

Asked by STrRedWolf 1 year ago

Answered by STrRedWolf 1 year ago

  • Solved
  • Archived

Firefox can’t establish a connection to the server at ws://127.0.0.1 (plugin or setting is causing this, how to discover exact cause?)

Hello, Firefox 91.0.2 shows in dev. console: Firefox can’t establish a connection to the server at ws://127.0.0.1 The Private browsing window has the issue too, but i am … (read more)

Hello, Firefox 91.0.2 shows in dev. console: Firefox can’t establish a connection to the server at ws://127.0.0.1

The Private browsing window has the issue too, but i am unsure if it really disable all extensions.

When i use different Firefox profile, then the localhost site i am trying to load is loaded without that error. So how to discover please which FIrefox profile setting is preventing the loading please?

Asked by #367259 10 months ago

Answered by #367259 10 months ago

  • Solved
  • Archived

Change default bookmark location to "other" instead of most recently used folder

Is there a way that I can change this setting in config rather than downloading an add-on? This changed with the most recent Firefox update for me (I'm currently on 85.0.… (read more)

Is there a way that I can change this setting in config rather than downloading an add-on? This changed with the most recent Firefox update for me (I'm currently on 85.0.1. for Ubuntu). Currently, the default save behavior is for bookmarks to save to the most recent folder you've picked. My preferred behavior would be for all bookmarks to save to "Other bookmarks" until I can file them away later.

Asked by reginakbuhl 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago