Showing questions tagged: Show all questions

Error code: SSL_ERROR_UNSUPPORTED_VERSION

Hello Firefox Support, I need help to upgrade the version of the security protocol that enables access to my NAS unit. Now the message; "Secure Connection Failed An error… (read more)

Hello Firefox Support, I need help to upgrade the version of the security protocol that enables access to my NAS unit. Now the message;

"Secure Connection Failed An error occurred during a connection to 192.168.1.201. Peer using unsupported version of security protocol. Error code: SSL_ERROR_UNSUPPORTED_VERSION

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

This website might not support the TLS 1.2 protocol, which is the minimum version supported by Firefox."

indicates I no longer can access my page until I find the remedy to this issue. Thank you in advance for cooperation and help with is matter.

Asked by donaldrshaffer 1 month ago

Last reply by cor-el 1 month ago

  • Solved

Prevent websites from opening new tabs

I just reinstalled my operative system, and with that my Firefox settings got reset. I know there is an entry in about:config to prevent ads from opening new tabs and pop… (read more)

I just reinstalled my operative system, and with that my Firefox settings got reset. I know there is an entry in about:config to prevent ads from opening new tabs and pop ups without authorization, even from legit websites like the login pop-up windows when doing a sign in in Google, in those cases to allow the windows it's needed to click on the lock icon next to the URL bar and allow it from there. The problem is that I don't remember the name of that setting and I have spend an hour looking for it on Google.

Asked by ttfh3500 4 months ago

Answered by ttfh3500 4 months ago

Map Icons

The Historic Houses Association (www.historichouses.org) site has an option to show a map of interesting places. When I view this map in Firefox on Android or Windows 11… (read more)

The Historic Houses Association (www.historichouses.org) site has an option to show a map of interesting places. When I view this map in Firefox on Android or Windows 11, the icons show up correctly. For instance in the example map, next to Lincoln. In Android/Windows the icon shows a small castle in a drop pin while here in a Linux desktop it just shows a cross hatched box. The link to the web page still works. The roads in the Android/Windows versions correctly show A1, A46 etc. But here in Linux, you can just make out the road numbers behind the vertical hatching. Over a long period I have seen this has occur on a number of sites but I think that the maps are probably (cannot prove it) Mapbox/OpenStreetMap. But when I look at OpenStreeMap it self, the Road Numbers are fine and when I add a layer involving tags, they show as normal.

I know I could address this inquiry HHA but they will simply say 'they do not support Linux'. The site works in other environments so why not Linux? Also, as I have said, it has occurred on other sites in the past (though I must admit I cannot remember which ones and when - I tried a few while writing this support request) Is it likely that the web pages are being downloaded with a catalogue of Icons but this fails in the Linux version of Firefox? Would this account for the road numbers being corrupted as well?

The PC is running a fairly new (last 10 days) installation of Linux Manjaro with Mate desktop. However, this has been happening for some time (a couple of years) during which time, I have used Linux Mint, Debian and Manjaro, with Mate and Gnome desktops. Firefox is used as provided by Linux Manjaro, including Noscript and Adblocker - I have tried viewing this page with both disabled. The only changes I have made to Firefox settings is to enable 'when you open a link .... switch to it immediately', 'search for text when you start typing' and set 'browser.tabs.closeWindowWithLastTab' to false.

I have put up with the problem because it only affects me, however I am about to load Linux Manjaro on to computers for other less computer literate/tolerant people who will be using similar maps. It would help them if I could get a fix.

Thanks for your time

Asked by clod 1 week ago

Last reply by clod 1 week ago

Firefox vers 91.10esr(64bit):-"cannot load M3U8:levelLoadTimeOut"

Hi!, recently i have been having this browsing problem whenever I open the news website at https://www.cgtn.com/channel/documentary. The site wont load and error is shown… (read more)

Hi!, recently i have been having this browsing problem whenever I open the news website at https://www.cgtn.com/channel/documentary. The site wont load and error is shown- "cannot load M3U8:levelLoadTimeOut". Have tried numerous times but failed to load. However other web sites have no problem and prior to this I am able to surf at all times. What must I do to get back the browsing? Any help is appreciated. Thanks

Asked by xxmanreturns 6 days ago

Last reply by cor-el 2 days ago

After being offline, sometimes Firefox can't connect until restarted

Sometimes, if the computer is offline and Firefox is open, when the computer goes back online Firefox can't connect to any website, with the page "Hmm. We’re having troub… (read more)

Sometimes, if the computer is offline and Firefox is open, when the computer goes back online Firefox can't connect to any website, with the page "Hmm. We’re having trouble finding that site.". The only fix is to close Firefox and open it again. Going offline doesn't always do this, and while I'm not sure of what exactly causes this to happen, a way to easily reproduce it is:

  • Turn off the Wi-Fi;
  • Reboot the computer;
  • Open Firefox;
  • Turn on the Wi-Fi;

After the computer is connected, refreshing the page sends you to "Hmm. We’re having trouble finding that site.". You have to restart Firefox.

A way that doesn't 100% reproduce it, but works enough times, is to reboot the computer without turning off the Wi-Fi, and open Firefox as soon as possible (before the computer manages to connect to the router, which is the part that isn't always consistent). Rarely, it happens after suspending the computer, or after a disconnection due to an unstable connection. I can reproduce it in Firefox's safe mode. I have a hunch that maybe this is related to networking drivers.

I'm using a Lenovo IdeaPad 5 14ARE05 (Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)), Linux NixOS 22.11 (I don't know about Windows).

Ask me for any log you might need.

This is kinda a duplicate of https://support.mozilla.org/en-US/questions/1078253, except that their solution does nothing to me.

Asked by Martino 6 days ago

Last reply by jonzn4SUSE 5 days ago

No sound in Firefox only with Arte.tv direct or replay

Lorsque je veux regarder une émission en direct sur Arte.tv ou une émission en replay, le son n'est pas activé automatiquement. Je dois aller dans les réglages du son de … (read more)

Lorsque je veux regarder une émission en direct sur Arte.tv ou une émission en replay, le son n'est pas activé automatiquement. Je dois aller dans les réglages du son de mon interface Manjaro Linux Cinnamon pour activer le volume sonore qui est à zéro sur ce site. Je ne rencontre pas ce problème avec les sites de France Télévision (France 2 ou France 3). J'utilise la dernière version de Firefox v 101.0.1 64 bits

Asked by Philippe F 6 days ago

Last reply by jonzn4SUSE 9 hours ago

gnat sized mouse pointer Ubuntu Firefox

Same issue as [this poster] . I've seen no correlation between pixelsPerPx and cursor size, but have noticed this behavior doesn't occur in Manjaro's version of FireFox, … (read more)

Same issue as [this poster] . I've seen no correlation between pixelsPerPx and cursor size, but have noticed this behavior doesn't occur in Manjaro's version of FireFox, so I started asking myself, Self, "what might the differences be here?" Answer I got back: they (Ubuntu 22.04) have bowed to the god of SNAPpiness, and Manjaro still hasn't (gets updates from Mozilla rather than the snap store).

Am I on to something here? What else could be the difference between the two flavors of Linux? Any help would be greatly appreciated, my tired eyes have forced me to change default browser to Chrome or Edge, both of which don't seem to respect my privacy like Firefox. Interesting to note that Thunderbird doesn't have the "flea-size cursor" and it also is not using snap for updates.

Asked by mondalealex 6 days ago

Last reply by cor-el 6 days ago

Popup extensions NOT being saved

I have a website stored in the popup exceptions. Yet every time I go to that website, Firefox blocks the popup, despite the fact that the URL/URI stored in the settings i… (read more)

I have a website stored in the popup exceptions. Yet every time I go to that website, Firefox blocks the popup, despite the fact that the URL/URI stored in the settings is EXACTLY the same as the URL/URI of the website being visited.

I then have to press 'allow' every time. Is there any workaround for this please ?

Also, I used to be able to download a PDF from sites directly, but now it goes to view the PDF and then I have to use the 'download' button. Surely there is a fix for this ?

Firefox 101.0.1 (64-bit) on Kubuntu

Asked by oygle 5 days ago

Last reply by oygle 5 days ago

wxmaxima help that uses firefox cannot find the on disk html help files

I run wxmaxima on ubunbtu 20.04. The help menu option calls up firefox (v 101.0.1 (64 bit)) to find the local on disk html files. However this brings up the error message… (read more)

I run wxmaxima on ubunbtu 20.04. The help menu option calls up firefox (v 101.0.1 (64 bit)) to find the local on disk html files. However this brings up the error message:

File not found

Firefox can’t find the file at /usr/share/maxima/5.45.1/doc/html/maxima_singlepage.html#g_t_0025.

But this is a valid path with user access permissions and the file maxima_singlepage.html exists and has user read permissions.

So what is firefox doing in looking for this file?

I have used the ms windows 10 version of wxmaxima and the firefox help works perfectly.

Asked by stuartk54 5 days ago

YouTube super thanks cannot change message

When I try to change the message of a super thanks donation in Firefox on Linux it's not possible. On the other hand when I try the same thing on Chromium it's totally po… (read more)

When I try to change the message of a super thanks donation in Firefox on Linux it's not possible. On the other hand when I try the same thing on Chromium it's totally possible so I wonder why that is happening.

Asked by danieln.slr 5 days ago

Reproducable crash in ubuntu 20.04 from Firefox 102.0 64-bit

Steps to re-create: create a new campagin attempt to change the display image using the hover-button over the image on the page. What happens: I click the "change image" … (read more)

Steps to re-create: create a new campagin attempt to change the display image using the hover-button over the image on the page.

What happens: I click the "change image" button, it gives me the os file picker. I select the file i want and click open and the file picker goes away. The "progress" bar at the top of the image shows up, changes through several states it seems. Then all screens freeze, and the computer stops responding to all output.

Supplemental info: This started happening after an update from ubuntu 18.04 lts to 21 to 22.04 lts. So I know I was not using a flatpak before and I am now.

I've attempted to use strace to figure out what's happening at the time of the freeze I'll include a picture of that if this form does not cause my entire pc to freeze. But didn't really get any useful info from that. I tried reading dmesg at the time of the crash but so far the screen freezes before any relevent information pops up. I've not been able to find any logs about whats going in previous dmesg logs.

Troubleshooting steps: I've attempted the same procedure in firefox's safe mode. This does not seem to stop the crash. I've attempted the same procedure using chrome and this works as it should.

Asked by nogasgofast 4 days ago

Last reply by Paul 4 days ago

Firefox sync does not work on chromebook

I recently got a chromebook and the firefox sync is not working on it. For "last synced" it gives the last time I tried to refresg it but nothing syncs up. I've had it fo… (read more)

I recently got a chromebook and the firefox sync is not working on it. For "last synced" it gives the last time I tried to refresg it but nothing syncs up. I've had it for a few hours and since it's via google play I beleive it's technically the Android version.

Asked by ffrealsync 4 days ago

Last reply by jonzn4SUSE 3 days ago

Feature Request, Cookies API - Help finding cookie source

Hello, I am the developer of the "FlagCookies" - add-on: https://addons.mozilla.org/de/firefox/addon/flag-cookies/ I would like to make a request to include "window id" a… (read more)

Hello,

I am the developer of the "FlagCookies" - add-on: https://addons.mozilla.org/de/firefox/addon/flag-cookies/

I would like to make a request to include "window id" and "tab id" in the cookie "onCookieChanged" -Event triggered dynamically.

At the present state it is not possible to identify where a cookie is originating from, only the "cookies.cookie" values, but no values for "Window" and "Tab Id" which would dramatically help to assign a cookie to a particular domain even if the "cookie.originURL" or "cookie.url" is different from the surfed on website.

As an example, you can visit "https://freenet.de" which loads different ad trackers - which cookies are displayed as "Cross Origin" in Flag Cookies. A screenshot is attached.

In case you need clarification or more information, please let me know.

Asked by uniqs_ 3 days ago

Last reply by jscher2000 - Support Volunteer 3 days ago

  • Solved

Firefox has become very slow lately.

Firefox has become very slow for some two weeks om my desktop with Linux Xubuntu 18.04. Some sites can be approached without problems except for the speed, other sites ar… (read more)

Firefox has become very slow for some two weeks om my desktop with Linux Xubuntu 18.04. Some sites can be approached without problems except for the speed, other sites are opened after some time, but freeze so that scrolling and clicking on links won't work. I tried to find an answer in the Settings......

Asked by edschijf 3 days ago

Answered by edschijf 2 days ago

codeblocks not rendering correctly

I have no problems with chrome but when I pull up some of the websites that have no problem loading up in chrome on firefox I get those half-cut codeblocks, not sure how … (read more)

I have no problems with chrome but when I pull up some of the websites that have no problem loading up in chrome on firefox I get those half-cut codeblocks, not sure how to fix this, any advice would be deeply appreciated!

Asked by shuklamanmohan21 2 days ago

Last reply by Balázs Meskó 11 hours ago

Redirect Issue in firefox browser

I have been using firefox on ubuntu 22 for more than a month and everything was working fine untill 4 days earlier when i first got error relating to security certificate… (read more)

I have been using firefox on ubuntu 22 for more than a month and everything was working fine untill 4 days earlier when i first got error relating to security certificate issue and data hijacking. But i have been using same sites earlier too without any issue. Also those sites are just articles on site without any personal information. From last 2 days i am also getting redirecting issues. First site to redirect to during google search is bestbonusprize.life then if i disable adblocker it just keep redirecting. I don't have any issue accessing same site in google chrome. I just have firefox installed till 4 days earlier, but when i start getting issues i installed chrome to test if i am getting same issue but all work good in chrome. One of the main change from earlier is i was in different location using different wifi provider. It could be one of the issue but i am not sure as other people using same wifi don't have much issues. Plus things work fine in chrome. I tried using anti-malware but malwarebyte is only available for window and i don't know any thing about anti-virus and malware removal for ubuntu as never needed it. Please guide me for securing my firefox browser. Regards.

Asked by traptit1 2 days ago

Last reply by jscher2000 - Support Volunteer 1 day ago

how to disable description popups of bookmarks

How can I stop Firefox from changing what appears on the screen when the cursor simply passes over it? (I suspect that feature of web browsers was created to make navigat… (read more)

How can I stop Firefox from changing what appears on the screen when the cursor simply passes over it? (I suspect that feature of web browsers was created to make navigating quicker while using the touch pad. My touch pad is disabled whenever a mouse is connected to the computer so that feature of web browsers isn't only not needed but is very annoying. Please tell my how to turn that feature off. Bob

Asked by asnt_level_two 2 days ago

  • Solved

Gap to the left of tabs when menu bar is hidden/unchecked

Hello, I am running Firefox v101.0.1 (64-bit) on Linux (Pop!_OS, installed as a flatpak). I am using the default system theme in dark mode, though switching to the Firefo… (read more)

Hello,

I am running Firefox v101.0.1 (64-bit) on Linux (Pop!_OS, installed as a flatpak). I am using the default system theme in dark mode, though switching to the Firefox dark theme or other themes does not change anything. When I allow the Menu Bar (File, Edit, View, etc.) to be present, the browser tabs on the next line are aligned correctly, going all of the way to the left. When I uncheck the Menu Bar, however, a gap appears to the left of the tabs. I have not seen this behavior on Firefox in other environments (Debian, RHEL, Windows), and I'm wondering if there's a way I can remove that gap. I have attached screenshots showing how the tabs are aligned with and without the Menu Bar.

Thanks so much!

Asked by avram.meir 2 days ago

Answered by cor-el 1 day ago

I can't automatically set Firefox to go to a new tab when clicking on DuckDuckGo's search results

I have When you open a link, image or media in a new tab, switch to it immediately" selected, but it doesn't go there when I do select a result from DuckDuckGo or Google.… (read more)

I have When you open a link, image or media in a new tab, switch to it immediately" selected, but it doesn't go there when I do select a result from DuckDuckGo or Google. I need to right click my mouse and select "Open Link in new tab". How do I make this happen?

Asked by George 1 day ago

Last reply by Terry 22 hours ago