Showing questions tagged: Show all questions
  • Solved

Sync does not work on any device

I have never managed to get Firefox Sync to work on my devices, I don't know why. I don't get an error message saying it failed or why it failed. I run Firefox on desktop… (read more)

I have never managed to get Firefox Sync to work on my devices, I don't know why. I don't get an error message saying it failed or why it failed. I run Firefox on desktop (Linux) and Android, both always updated to the latest version.

My use case is simple, I just want my mobile Firefox to have all the bookmarks I have on desktop already.

On Android, when I go to my account settings it says "Las synced: never". Clicking the "Sync now" button does absolutely nothing.

On Desktop I go to Settings - Sync, press the Sync button. It appears to work, though no feedback is ever provided.

When I go to about:sync-log, on desktop, finally an error is shown. It seems to attempt to connect to https://sync-765-us-west-2.sync.services.mozilla.com/1.5/207352084/info/collections and fails. Manually going to the URL also fails on both desktop and mobile. Entire log below

1709188645048 Sync.LogManager DEBUG Flushing file log 1709188645050 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188645050 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188645052 Sync.LogManager DEBUG Log cleanup threshold time: 1708324645052 1709188645052 Sync.LogManager DEBUG Done deleting files. 1709188684156 FirefoxAccounts DEBUG FxAccountsWebChannel message received: fxaccounts:fxa_status 1709188684156 FirefoxAccounts DEBUG fxa_status received 1709188684156 FirefoxAccounts DEBUG service: sync 1709188684156 FirefoxAccounts DEBUG is private browsing: false 1709188684291 FirefoxAccounts DEBUG FxAccountsWebChannel message received: fxaccounts:loaded 1709188684291 FirefoxAccounts WARN Unrecognized FxAccountsWebChannel command: fxaccounts:loaded 1709188690370 FirefoxAccounts DEBUG FxAccountsWebChannel message received: fxaccounts:pair_preferences 1709188690446 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188690446 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188690446 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188690446 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188690496 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188767104 FirefoxAccounts DEBUG FxAccountsProfileClient: Requested profile 1709188767104 FirefoxAccounts DEBUG getOAuthToken enter 1709188767104 FirefoxAccounts TRACE getCachedToken returning cached token 1709188767104 FirefoxAccounts DEBUG getOAuthToken returning a cached token 1709188767104 Services.Common.RESTRequest DEBUG GET request to https://profile.accounts.firefox.com/v1/profile 1709188767361 Services.Common.RESTRequest DEBUG GET https://profile.accounts.firefox.com/v1/profile 304 1709188768376 Sync.RemoteTabs INFO Generating tab list with filter 1709188768377 Sync.RemoteTabs INFO Final tab list has 0 clients with 0 tabs. 1709188991788 FirefoxAccounts ERROR Pairing channel error: Error: WebSocket unexpectedly closed(resource://gre/modules/FxAccountsPairingChannel.sys.mjs:3599:20) JS Stack trace: FxAccountsPairingChannel</_setupListeners/<@FxAccountsPairingChannel.sys.mjs:3599:20 1709189210399 FirefoxAccounts DEBUG FxAccountsWebChannel message received: fxaccounts:fxa_status 1709189210400 FirefoxAccounts DEBUG fxa_status received 1709189210400 FirefoxAccounts DEBUG service: 30b11ae57025e70b 1709189210400 FirefoxAccounts DEBUG is private browsing: false 1709189279244 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1709189285734 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1709189303334 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1709189310511 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1709189312578 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1709189527477 FirefoxAccounts DEBUG FxAccountsProfileClient: Requested profile 1709189527477 FirefoxAccounts DEBUG getOAuthToken enter 1709189527477 FirefoxAccounts TRACE getCachedToken returning cached token 1709189527477 FirefoxAccounts DEBUG getOAuthToken returning a cached token 1709189527477 Services.Common.RESTRequest DEBUG GET request to https://profile.accounts.firefox.com/v1/profile 1709189527975 Services.Common.RESTRequest DEBUG GET https://profile.accounts.firefox.com/v1/profile 304 1709189534135 Sync.Service DEBUG User-Agent: Firefox/123.0 (Linux x86_64) FxSync/1.125.0.20240219145322.desktop 1709189534135 Sync.Service INFO Starting sync at 2024-02-29 06:52:14 in browser session 1LYtwG18bBEH 1709189534135 Sync.Service DEBUG In sync: should login. 1709189534135 Sync.Service INFO User logged in successfully - verifying login. 1709189534135 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709189534135 Sync.SyncAuthManager DEBUG unlockAndVerifyAuthState already has (or can fetch) sync keys 1709189534135 Sync.Status DEBUG Status.login: error.login.reason.network => success.status_ok 1709189534135 Sync.Status DEBUG Status.service: error.login.failed => error.login.failed 1709189534135 Sync.Service DEBUG Fetching unlocked auth state returned success.status_ok 1709189534136 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709189538030 Sync.Resource WARN GET request to https://sync-765-us-west-2.sync.services.mozilla.com/1.5/207352084/info/collections failed: [Exception... "The connection was established, but no data was ever received" nsresult: "0x804b0014 (NS_ERROR_NET_RESET)" location: "<unknown>" data: no] No traceback available 1709189538030 Sync.Service DEBUG verifyLogin failed: [Exception... "The connection was established, but no data was ever received" nsresult: "0x804b0014 (NS_ERROR_NET_RESET)" location: "<unknown>" data: no] No traceback available 1709189538031 Sync.Status DEBUG Status.login: success.status_ok => error.login.reason.network 1709189538031 Sync.Status DEBUG Status.service: error.login.failed => error.login.failed 1709189538031 Sync.Status DEBUG Status.login: error.login.reason.network => error.login.reason.network 1709189538031 Sync.Status DEBUG Status.service: error.login.failed => error.login.failed 1709189538031 Sync.ErrorHandler ERROR Sync encountered a login error 1709189538032 Sync.SyncScheduler DEBUG Clearing sync triggers and the global score. 1709189538032 Sync.SyncScheduler DEBUG Next sync in 3600000 ms. (why=schedule) 1709189538034 Sync.Service DEBUG Exception calling WrappedLock: Error: Login failed: error.login.reason.network(resource://services-sync/service.sys.mjs:1041:15) JS Stack trace: onNotify@service.sys.mjs:1041:15 1709189538034 Sync.Service DEBUG Not syncing: login returned false. 1709189538035 FirefoxAccounts TRACE not checking freshness of profile as it remains recent

Asked by Cosme Benito 1 day ago

Answered by jonzn4SUSE 1 day ago

  • Solved

Linux save dialog limitations

I've just tried to save something from firefox on linux(Manjaro KDE) and was baffled that there doesn't seem to be a way to manually enter the path and navigate to it in … (read more)

I've just tried to save something from firefox on linux(Manjaro KDE) and was baffled that there doesn't seem to be a way to manually enter the path and navigate to it in the save dialog. In addition to that, there are many locations missing and I can't seem to find a way to add new custom or favorites ones either.

All that combined means it was impossible to save my file directly to a network location, which is something I very often need to do. It just seems insane for such a basic feature to be missing and I've found a 4 years old thread about it meaning nothing has been done to fix this since? https://support.mozilla.org/en-US/questions/1279125

The only way I can see would be to mount the network path(not a good solution for one offs) and navigate to it(a symlink can make it closer to one of the existing shortcut but still annoyingly require more clicks) every time but that's very tedious since most of my saving is on a specific server drive.

Asked by SamKook 2 days ago

Answered by jonzn4SUSE 2 days ago

  • Solved

colorfore theme

How can I restore a previous theme? I had a "colorfore" theme that Mozilla offered a few years ago set up in Firefox. It was perfect! I could see everything clearly with … (read more)

How can I restore a previous theme? I had a "colorfore" theme that Mozilla offered a few years ago set up in Firefox. It was perfect! I could see everything clearly with my aging eyesight.Then one of my synced computers needed a new Linux OS installation so I signed out of sync on that machine. Installed the new OS. When I started Firefox the first time I signed into sync. I got my history, bookmarks and bookmark bar, but no custom colors. Now my computer at work has its colors reset to the out of box colors too. I have lost the colorfore colors I have been using for several years now. How can I get the colorfore colors back? Thank you for your attention in this matter. I love Firefox, use it exclusively and contribute to Mozilla. Gregg Scholfield

Asked by Gregg Scholfield 2 days ago

Answered by cor-el 2 days ago

  • Solved

Firefox not preventing sleep

Hello, I have a problem with Firefox on Linux, doesn't seem to be distro specific as I've tried Manjaro/Ubuntu/Neon, when using KDE in that when listening to music on Yo… (read more)

Hello,

I have a problem with Firefox on Linux, doesn't seem to be distro specific as I've tried Manjaro/Ubuntu/Neon, when using KDE in that when listening to music on YouTube music my computer will go to sleep after the elected time. On KDE you can see which applications are preventing sleep and/or screen lock, other applications are listed here but not Firefox.

When playing a video everything works as expected.

I would investigate myself, but I don't know where to start so if someone can point me in the right direction or offer any insights?

Currently using: KDE Neon KDE 6.0 Kernel 6.5.0-21 Wayland

Asked by dclark16 3 days ago

Answered by zeroknight 3 days ago

  • Solved

Using system wide proxy setting in Linux

I have the HTTP_PROXY, HTTPS_PROXY and FTP_PROXY (and their lowercase counterparts) exported and then the firefox binary is started from the shell script. The settings in… (read more)

I have the HTTP_PROXY, HTTPS_PROXY and FTP_PROXY (and their lowercase counterparts) exported and then the firefox binary is started from the shell script. The settings in firefox say it will 'Use system proxy settings'. Nevertheless I do not see the proxy being used as I can not access the web pages that need the proxy. The 'about:config' also does not show that firefox picked up any proxy related information from the shell environment.

I know the proxy address is correct because if I use brave browser instead of firefox (same shell script that launches brave) I can reach the web pages behind the proxy as expected.

Asked by hinko.kocevar 3 days ago

Answered by TyDraniu 3 days ago

  • Solved

Firefox Bookmarks toolbar disappears as soon as any website selected

This issue has arisen on Firefox for Linux Mint (my current version is 123.0 (64bit)). I like Firefox, and I like its bookmarks toolbar, and have used it for many years,… (read more)

This issue has arisen on Firefox for Linux Mint (my current version is 123.0 (64bit)). I like Firefox, and I like its bookmarks toolbar, and have used it for many years, but there seems to be a new bug introduced today:- The bookmarks toolbar is present and correct when I start Firefox, but now it disappears as soon as I select any bookmark, or if I enter any web address or if I open a new tab. The [View >Toolbars > Bookmarks Toolbar > Alway Show] option is already selected, but the toolbar is no longer visible. If I click on it again, the bookmarks toolbar reappears (or I can restart Firefox, and this will also restore the toolbar). But the toolbar now disappears as soon as I use the browser in any way, and so is currently not really of practical use, as it needs constant restoring. Hope you can help resolve this. Many thanks in advance

Asked by pxr1377 4 days ago

Answered by cor-el 4 days ago

  • Locked

this forum board

Locking this thread, please continue here: [/questions/1440721] Can someone please tell me how to answer questions asked, in emails to me, receoved from support helpers. … (read more)

Locking this thread, please continue here: [/questions/1440721]
Can someone please tell me how to answer questions asked, in emails to me, receoved from support helpers. In ~6 emails received so far, my only response option looks like clicking the "Mark It as Solved" button...I can't see how to answer, for example, that I'm using Debian Buster, with KDE. Also, jonzn4SUSE asked me to "see screenshot" of his SUSE distribution, but I can't see that image, nor a file attachment. Thanks again.

Asked by lee.hinkleman 4 days ago

  • Solved

Installing custom Firefox extension

I'm at a loss for words here. I have a website I frequent and it has a really annoying behavior. I'm a developer so finally I mustered the strength to do something about … (read more)

I'm at a loss for words here. I have a website I frequent and it has a really annoying behavior. I'm a developer so finally I mustered the strength to do something about it. I googled how to create an extension in Firefox and within 5 minutes I had a working extension that solved their annoyance. However, I can only load it temporarily. If I close Firefox, it goes away. When I try to actually install it, it says I need to have it signed. I have now spent the better part of an hour trying to find out how to self sign it. I refuse to believe that I have to submit this to Mozilla for me to be able to install my own code. Can someone please send me in the direction of how i self sign and install my own extension. I have no intention of publishing, I only want to run this for myself.

Asked by viktor37 5 days ago

Answered by cor-el 5 days ago

  • Solved

JavaScript in firefox.cfg can't access `document`

As I understand, `autoconfig.js` (with `firefox.cfg`) can be used to have JavaScript run during startup to control Firefox's UI elements. I have set up `autoconfig.js` i… (read more)

As I understand, `autoconfig.js` (with `firefox.cfg`) can be used to have JavaScript run during startup to control Firefox's UI elements.

I have set up `autoconfig.js` in my `/usr/lib/firefox-developer-edition/defaults/pref` folder (I'm on EndeavourOS Linux). As instructed here, I've already put the two required files, `autoconfig.js` and `firefox.cfg` in their correct folders (`/usr/lib/firefox-developer-edition/defaults/pref` and `/usr/lib/firefox-developer-edition` in my machine).

The file `firefox.cfg` contains the following code:

 //
 (() => {
   var tabbar = document.getElementById("TabsToolbar");
 })();


However, every time I run Firefox, this message will appear:

 "Failed to read the configuration file. Please contact your system administrator."


If I empty out the `firefox.cfg` file, Firefox will run normally without showing the error message. It will also run normally if I just have something like this in the file:

 //
 (() => {
   var testVar = "";
 })();


I don't understand why the JavaScript code can't access the Firefox UI elements through `document` or `window.document`. If `autoconfig.js` isn't build for that, what should I use to change my browser's UI elements through JavaScript?

Thank you.

Asked by jazali 5 days ago

Answered by cor-el 5 days ago

  • Solved

What is the Firefox Installer?

I'm trying to migrate to the newest version of Firefox on an old installation of Fedora. I've downloaded and unpacked the installation files but can't identify the insta… (read more)

I'm trying to migrate to the newest version of Firefox on an old installation of Fedora. I've downloaded and unpacked the installation files but can't identify the installer. All I probably need is the name, as I know how to make it executable and run it once I know what file it is.

Asked by sideburns 6 days ago

Answered by sideburns 6 days ago

  • Solved

"this page is slowing down firefox"

How can I turn this message off? Some sites I visit give me that message, it shows up when I'm typing a reply to something which pushes the page lower and fouls up my ab… (read more)

How can I turn this message off? Some sites I visit give me that message, it shows up when I'm typing a reply to something which pushes the page lower and fouls up my ability to keep typing, then if goes away, comes back, goes away ... I just want to kill the message entirely. I'm not worried about speed, there's nothing to fix, I just want the message gone.

Asked by rayandrews 1 week ago

Answered by cor-el 1 week ago

  • Solved

Firefox themes

Saved themes in Firefox color not visible in add-ons manager. Does not fix itself in safe mode. One of the saved themes is a default preset I liked, the other is a preset… (read more)

Saved themes in Firefox color not visible in add-ons manager. Does not fix itself in safe mode. One of the saved themes is a default preset I liked, the other is a preset I made myself, using all options except advanced colors.

Asked by Lord_Voidwrath 1 week ago

Answered by Lord_Voidwrath 1 week ago

  • Solved

youtube ad blocker not blocking ads

I have an add-on ad blocker for youtube and have never gotten ads. This afternoon that stopped. I get ads with every video I click and there is no 'skip ad' on the scr… (read more)

I have an add-on ad blocker for youtube and have never gotten ads. This afternoon that stopped. I get ads with every video I click and there is no 'skip ad' on the screen. I added another top rated youtube add blocker, quit firefox and then opened it again. Before, if I clicked a video it started an ad and I could go back and then hit the video again, but now that doesn't work, but if I select to show the video in a new tab, there are no ads in that tab. What can I do to make the ads stop like they used to and never appear? Yes and my OS is Ubuntu 22.04

Asked by pdsimdars 1 week ago

Answered by TyDraniu 1 week ago

  • Solved

Copy is completely broken in the Linux .deb version of Firefox

As the title states. At least half the time when you try right-click and use the "Copy" function, the option is greyed out. If you try to Ctrl+Shift+C, it opens dev too… (read more)

As the title states. At least half the time when you try right-click and use the "Copy" function, the option is greyed out. If you try to Ctrl+Shift+C, it opens dev tools! This happens on multiple systems that I have that are based on Debian/Ubuntu. So basically, copy functionality is broken for Firefox Linux users...

Asked by cvpsmith 1 week ago

Answered by cor-el 1 week ago

  • Solved

How do I stop "momentum" scrolling?

Hi there, On Firefox, I'm experiencing "momentum" scrolling where, when I scroll using the trackpad, after I lift my fingers off, it keeps scrolling for a bit. This is … (read more)

Hi there,

On Firefox, I'm experiencing "momentum" scrolling where, when I scroll using the trackpad, after I lift my fingers off, it keeps scrolling for a bit.

This is not the same thing as smooth scrolling. Disabling smooth scrolling does not disable this behaviour, and I use smooth scrolling on plenty of programs without it experiencing this "sliding" "momentum" on any of them except Firefox. I've also used Firefox before with trackpads without experiencing this.

How can I disable this?

Asked by revsuine 2 weeks ago

Answered by TyDraniu 2 weeks ago

  • Solved

How to separate inactive tabs ? with either bar or boxes

Initial post: https://forums.debian.net/viewtopic.php?p=792869#p792869 cat history.log-* history.log | grep -i firefox -B2 Start-Date: 2024-02-11 19:48:58 Commandline… (read more)

Initial post: https://forums.debian.net/viewtopic.php?p=792869#p792869

cat history.log-* history.log | grep -i firefox -B2

Start-Date: 2024-02-11 19:48:58 Commandline: /usr/bin/unattended-upgrade Upgrade: firefox-esr:amd64 (102.15.0esr-1~deb11u1, 115.7.0esr-1~deb11u1)

before: https://support.mozilla.org/en-US/kb/search-open-tabs-firefox https://addons.mozilla.org/fr/firefox/addon/simple-tab-groups/ https://www.ghacks.net/2021/03/09/manage-container-tabs-efficiently-from-a-side-panel-with-the-container-tabs-sidebar-extension-for-firefox/ now: https://addons.mozilla.org/fr/firefox/addon/tab-stash/ https://www.majorgeeks.com/files/details/sidebar_tabs.html

How do I put bar between tabs, or, each tab inside an individual box ? I have tried many codes from various forums, but since this update, FF seems to ignore ./chrome/userChrome.css completely.

Asked by Benoit-Pierre DEMAINE 2 weeks ago

Answered by jscher2000 - Support Volunteer 2 weeks ago

  • Solved

Firefox always sets address to https

I assume that it's the same problem as this: https://support.mozilla.org/en-US/questions/1388431 but there is no solution. https only mode is not active browser.fixup.a… (read more)

I assume that it's the same problem as this: https://support.mozilla.org/en-US/questions/1388431 but there is no solution.

https only mode is not active

browser.fixup.alternate.protocol is set to http from https browser.urlbar.autoFill is set to false

Nothing helped.

I get that this default makes sense but since so many local tools don't use http there should be at least 1 working option to disable this behavior at least for certain sites.

Asked by danielw90.dw+firefox 2 weeks ago

Answered by Terry 2 weeks ago

  • Solved

Default browser on linux fails on file:/// URLs.

I just wrote this blog post and someone suggested I contact you. I have my default browser set to Firefox on Linux (Debian Bookworm). When I open an http:// or https:// … (read more)

I just wrote this blog post and someone suggested I contact you.

I have my default browser set to Firefox on Linux (Debian Bookworm). When I open an http:// or https:// URL, it opens in Firefox, but when I open a file:/// URL, it opens in Chromium. It seems that file:/// URL makes it resort to the MIME type.

Is there anything Firefox can do here or is this a Debian or freedesktop.org issue?

Thanks!

Tim

Asked by oylenshpeegul 2 weeks ago

Answered by oylenshpeegul 2 weeks ago

  • Solved

Profile lock prevents launch on workstations with shared remote home

I am using Firefox in a Linux environment with multiple workstations, where I may be logged into more than one workstation at once. The workstations have an auto-mounted … (read more)

I am using Firefox in a Linux environment with multiple workstations, where I may be logged into more than one workstation at once. The workstations have an auto-mounted home file system such that my home directory (including my Firefox profile directory) are shared.

Because of this, when I try to launch Firefox on a second workstation, I get an error saying "Firefox is already running but is not responding". I have read the support articles about this issue, and other community support threads, but none of them address this use case.

I wish to use the same profile, so that I still have all my bookmarks and such, and have them continue to stay up-to-date. How can I do so in this environment?

Asked by tmorris4 3 weeks ago

Answered by cor-el 3 weeks ago