Showing questions tagged: Show all questions
  • Solved
  • Archived

Full screen HTML5 Video Stutters and Choppy - YouTube & Twitch - Firefox 55.0.3 (64-bit) EME Free

Firefox version  : 55.0.3 (64-bit) EME Free Current addons / extensions : None - all removed Problem: Full screen Video Stutters and Choppy - mainl… (read more)

Firefox version  : 55.0.3 (64-bit) EME Free Current addons / extensions : None - all removed

Problem: Full screen Video Stutters and Choppy - mainly on YouTube Html5 as well as on Twitch Html5. Occur only with Firefox on HTML5.

System Specs: OS  : Windows 10 Pro 64bit (OS Build 15063.463) CPU  : i7 3770S Mem  : 8Gb GPU  : nVidia 1030 GT

Asked by NeoTheOnne 4 years ago

Answered by NeoTheOnne 4 years ago

  • Solved
  • Archived

Firefox won't play html5 video on Amazon Prime.

I got amazon prime. I go to play a video. It asks for me to install Flash despite the fact Firefox supports encrypted html5 video. Is this supposed to happen? … (read more)

I got amazon prime. I go to play a video. It asks for me to install Flash despite the fact Firefox supports encrypted html5 video.

Is this supposed to happen?

Asked by UltimateAnsweris42 5 years ago

Answered by jscher2000 5 years ago

  • Archived

Random crashes when i listen to youtube music in the background.

Hello guys! I'm having some periodic crashes when i listen to youtube music in background. It happenes randomly, maybe once a week or sometimes twice a day. I tried remov… (read more)

Hello guys! I'm having some periodic crashes when i listen to youtube music in background. It happenes randomly, maybe once a week or sometimes twice a day.

I tried removing some unnecessary plugins but it didn't help.

Here are my logs in pending folder (or is there any way i can upload them in some readable form?)

https://drive.google.com/open?id=1nSkZKb2SSgUYPoNvrrBBYXNmoCugthPI

Asked by Dzinsham 2 years ago

Last reply by FredMcD 2 years ago

  • Solved
  • Archived

YouTube videos are black when using HTML5 player.

Today when I started up my laptop, Firefox wouldn't play any YouTube video - the audio still works and the preview of the frame when seeking is there, but instead of vide… (read more)

Today when I started up my laptop, Firefox wouldn't play any YouTube video - the audio still works and the preview of the frame when seeking is there, but instead of video there is just a black screen. I have NO intention of installing Flash Player. Please help? Thanks in advance.

Asked by username9001 6 years ago

Answered by guigs 6 years ago

  • Archived

How do I stop "The Primetime Content Decryption Module provided by Adobe Systems, Incorporated plugin has crashed" in Netflix on Firefox 42?

I was watching Netflix fine last night, but now all of the sudden it's giving me this message when I try to watch videos: > The Primetime Content Decryption Module pro… (read more)

I was watching Netflix fine last night, but now all of the sudden it's giving me this message when I try to watch videos:

> The Primetime Content Decryption Module provided by Adobe Systems, Incorporated plugin has crashed

I suppose Netflix is trying to use HTML5 instead of Silverlight, of course getting away from Flash only to come back to Adobe isn't that ideal.

The plugin is automatically downloaded by Firefox, so this is a Firefox issue: https://support.mozilla.org/en-US/kb/enable-drm

Anyway, I have "Play DRM content" selected in Options ==> Content. What else could fix this?

Asked by PatPeter 5 years ago

Last reply by cpearce 5 years ago

  • Archived

Can't put HTML5 Youtube to Fullscreen without Firefox Crashing.

Every time I attempt to put Youtube into Fullscreen mode Firefox crashes. The only add-on I have is U Block. I've already run a fresh install of Firefox, and it still c… (read more)

Every time I attempt to put Youtube into Fullscreen mode Firefox crashes. The only add-on I have is U Block. I've already run a fresh install of Firefox, and it still crashes upon trying to fullscreen. I am running Yosemite on a Macbook Pro 2010. Youtube works fine in the Safari browser, and all other video types (Silverlight for Netflix) work fine on Firefox.

Asked by williawr11 6 years ago

Last reply by FredMcD 6 years ago

  • Archived

Firefox crashes/freezes computer with Youtube, hardware-video-decoding.failed setting ineffective

Ever since the HTML5 player has taken over Youtube, I've had problems with it perma-freezing my computer as soon as any window was opened. Until recently I got around tha… (read more)

Ever since the HTML5 player has taken over Youtube, I've had problems with it perma-freezing my computer as soon as any window was opened. Until recently I got around that by setting media.windows-media-foundation.enabled to false, forcing Youtube to use the Flash player. Lately, though, it's somehow gone back to the HTML5 player with 360p resolution only, so I went digging through the config file again in search of solutions. That's when I found two settings I hadn't noticed before, media.hardware-video-decoding.enabled (which I found true) and media.hardware-video-decoding.failed (which I also found true, though I hadn't touched it before). Re-enabling windows-media-foundation caused the hard-freezes to reoccur, but I discovered that by setting media.hardware-video-decoding.enabled to false I was able to leave the windows-media-foundation option true, and I can now use Youtube's HTML5 player in all resolutions. I conclude from this that the media.hardware-video-decoding.failed setting is bugged somehow, since it didn't seem to prevent the freezes.

Asked by y3kcjd5 5 years ago

Last reply by jscher2000 5 years ago

  • Solved
  • Archived

Video playback not working correctly.

Video playback is not working correctly on Windows 8.1 Pro and Firefox version 43.0.4. I've attached an error message I keep getting on YouTube. I get problems off and on… (read more)

Video playback is not working correctly on Windows 8.1 Pro and Firefox version 43.0.4. I've attached an error message I keep getting on YouTube. I get problems off and on playing video on Dallas Cowboys. com. MSN videos load very slowly and sometimes don't play at all. I've run them in safe mode so I don't think it is the extensions that I use. I have removed Ghostery and Adblock Plus. When I use Google Chrome all these sites load quickly, play with no errors even with Ghostery and Adblock Plus extensions running. What am I missing and how do I fix it?

Asked by peterparseghian 5 years ago

Answered by FredMcD 5 years ago

  • Archived

Poor YouTube HTML5 video performance in Firefox - fine in IE

I have a quite low end system set up, so I'm not expecting miracles from it, but there seems to be some problems playing Youtube videos on Firefox. If I load a video on … (read more)

I have a quite low end system set up, so I'm not expecting miracles from it, but there seems to be some problems playing Youtube videos on Firefox.

If I load a video on Internet Explorer, it will play fine, even on 1080p with CPU usage of about 20%. Firefox often exhibits problems playing videos.

If I launch Firefox immediately from signing in, the videos will play fine. If I navigate to another video, there will usually be dropped frames and high CPU usage.

I understand that Internet Explorer will use the h.264 codec which is GPU accelerated whilst FF will use a more CPU intense task, but that doesn't really explain why sometimes the videos will play fine and others, it won't.

I have tried on a completely clean install of Firefox, so it will unlikely be extensions, profiles or add-ons. I have then changed the timing of the sessions saving and disabled smooth scrolling as advised elsewhere, with no success.

All help gratefully received.

Asked by optomo84 6 years ago

Last reply by TheCheetahwings 6 years ago

  • Solved
  • Archived

YouTube videos stopped playing on V 37.0

Running 37.0 Firefox on Windows 7 - 64 bit. All updates updated. Flash is 17,0,0,134 and checks out at Adobe site. This afternoon YouTube videos stopped playing. In the … (read more)

Running 37.0 Firefox on Windows 7 - 64 bit. All updates updated. Flash is 17,0,0,134 and checks out at Adobe site.

This afternoon YouTube videos stopped playing. In the center of the frame are circling dots. The video appears to have loaded, as I can move the time slider and see frames at the various times, I just does not play, just gives the circling "loading" dots. YouTube runs fine in IE. In Foxfire, if I go to other sites, like news and videos/ads play just fine.

I disabled all add-ons, set Shockwave & Flash to "always activate" and still the YouTube videos will not play. Seem to download, just not play.

Thanks in advance for any help.

Asked by weejee1 6 years ago

Answered by guigs 6 years ago

  • Archived

Cannot play YouTube HTML5 HD 60fps Videos

Cannot play a single HD video on YouTube using FireFox using HTML5 and Flash. The video stutters and then drops frames and an insane rate while the audio keeps going. I u… (read more)

Cannot play a single HD video on YouTube using FireFox using HTML5 and Flash. The video stutters and then drops frames and an insane rate while the audio keeps going. I used to be able to play 720p 60fps videos on Firefox but even those drop frames now. I don't understand why since YouTube works fine on Microsoft Edge but I would much rather continue using FIrefox than that so some help here would be greatly appreciated. My specs (laptop): Windows 10 Pro 64-bit AMD E-450 APU with Radeon HD 6320 Graphics 1.65 GHz 4.00 GB RAM Wired connection.

Thank you.

Asked by Dessembrae 6 years ago

Last reply by cor-el 6 years ago

  • Archived

HTML5 Audio AACPlus Problem

I have made a player in HTML5 with controls <audio> have more experienced problems in matters of running AAC with the mozilla, when testing with Chrome worked perfe… (read more)

I have made a player in HTML5 with controls <audio> have more experienced problems in matters of running AAC with the mozilla, when testing with Chrome worked perfectly and the view speaks manual that compatible with AAC Mozilla more still does not work, I am using a central Shoutcast to transmit Audio, some could help me solve this issue? I am using the following code to get the audio in Chrome, and I believe it has no difference for Mozilla, it is worth remembering that when put into Mp3 wheel usually more when using the AAC player simply disappears from view.

Code: <audio src="http://serverip:port/;" controls autoplay></audio>


OBS: IP and port were concealed for security reasons;

Asked by lucianozanita 5 years ago

Last reply by jscher2000 5 years ago

  • Archived

MacBook Pro overheats when playing video in Firefox

Anytime I play video in Firefox (YouTube, Facebook, other embedded videos) my MacBook Pro heats up rapidly. In general, the computer runs at least 20 degrees hotter when … (read more)

Anytime I play video in Firefox (YouTube, Facebook, other embedded videos) my MacBook Pro heats up rapidly. In general, the computer runs at least 20 degrees hotter when running the video in Firefox as compared to Safari.

Asked by twpaul 4 years ago

Last reply by FredMcD 4 years ago

  • Archived

HTML5 video lags in web browser of firefox

I have an nVidia GeForce 9500 GT on a 32-bit Linux Mate 17.2 system. If I try to watch 1080p videos in a web browser, the videos are lagging, even when they're fully buff… (read more)

I have an nVidia GeForce 9500 GT on a 32-bit Linux Mate 17.2 system. If I try to watch 1080p videos in a web browser, the videos are lagging, even when they're fully buffered. If I download the video and play it outside of a browser, it works fine, and if I play it within a browser on Windows it's also fine. The graphics card driver I have on Linux is the best one, and installed correctly, If I run this Linux via Live USB and go to Youtube in Firefox, I see the videos play in Flash player and 1080p works fine. If I try to play HTML5 video in a media player, it lags. How can I fix this?

Asked by ramiav 6 years ago

Last reply by ramiav 6 years ago

  • Solved
  • Archived

Videos Failing All Over The Place

The majority of videos I try to play all fail. A few short weeks ago everything on YouTube played fine, now it's more of a hassle than it is worth, trying to look at Yo… (read more)

The majority of videos I try to play all fail. A few short weeks ago everything on YouTube played fine, now it's more of a hassle than it is worth, trying to look at YouTube videos.

The majority of websites with embedded links to videos and embedded videos also mostly fail. As of now my Firefox will not play the majority of videos around the web.

Something has changed and I didn't hear about it - videos all of a sudden crashing and burning. Twitter videos will not play. Videos on Grabien.com all fail.

Asked by Chrislongski 4 years ago

Answered by FredMcD 4 years ago

  • Solved
  • Archived

How to get HTML5 Videos working for firefox?

So recently I built a PC. I installed firefox and cannot seem to get HTML 5 video working. I enabled webm in the config to at least get HD on youtube however without that… (read more)

So recently I built a PC. I installed firefox and cannot seem to get HTML 5 video working. I enabled webm in the config to at least get HD on youtube however without that I'd be stuck at it only loading in 360p. When I go to the HTML5 test page from youtube it has no check marks for H.264 and MSE & H.264. Not sure what the problem is. Firefox does HTML 5 fine on my old laptop. I moved my profile from my old firefox to my new firefox so that I would keep all my preferences and so on. Also I am on Widnows 8.1 N if that at all makes a difference.

Asked by CloudHD 6 years ago

Answered by jscher2000 6 years ago

  • Archived

Help! I'm over my honeymoon phase with HTML5 video - maybe we need plugin-container back?

After being puzzled by Firefox making it more difficult to use Adobe Flash Player and apparently being forcibly shown HTML5 I was geeking out and hoping it means Adobe Fl… (read more)

After being puzzled by Firefox making it more difficult to use Adobe Flash Player and apparently being forcibly shown HTML5 I was geeking out and hoping it means Adobe Flash Crasher is on its way into obsolescence and extinction. Although it looks ike Youtube's video quality has decreased, at least for now.

I hate Adobe Flash Player. while I'm sure its coding must be impressive IMO it is the worst video playing software ever. Slow, inconsistent, buggy, crashy, tricky. In my experience it can't do the one thing it exists to do very well: play .FLV files. The .FLV filetype is ok though and there are other programs like RealPlayer and VLC that can technically deal with it, but I guess Adobe doesn't want them meddling.

But now I'm seeing HTML5 is causing similar problems. After each time I rerun Firefox after an APPCRASH (they happen so regularly and predictably) I know it's just a matter of time until the next one. And the cause is almost always YouTube, running FireFox's memory up even when I don't have many tabs open. Then I start getting blotches of the black screen of death and I know that session is now in its death throes. Memory Fox and clearing cache may buy me another 45 minutes, tops.

Is there some way I can have my streamed media confined like we use to have it when FireFox was good and only the video would crash but not the whole application? I'm actually missing that now.

Asked by YoullSee 6 years ago

Last reply by guigs 6 years ago

  • Archived

HTML5 Video is Very Laggy

Playing videos in the small or large player is fine, and 60fps videos look nice and smooth, but when I fullscreen, the video drops down to about 27fps no matter what qual… (read more)

Playing videos in the small or large player is fine, and 60fps videos look nice and smooth, but when I fullscreen, the video drops down to about 27fps no matter what quality it is, and the player itself gets really unresponsive while the video is playing. It takes several seconds to pause, and all the animations are very laggy. Strangely, when I unpause the video or pause using the spacebar, the video reacts almost instantly, but the animation in the middle of the screen is still laggy.

Note: Playback in chromium is fine, and hardware acceleration is disabled because when I enable it, it makes visual artifacting, tearing when scrolling, and extreme lag.

Debug info: http://pastebin.com/R8ajBpes

PC Specs: i5 4690k (integrated graphics disabled via BIOS), radeon hd 7950, eluctronics 500gb pro ssd, gigabyte z97n-wifi, linux mint 17.2

[EDIT]: At 1080p 60fps large player mode (theater) the player's animations will lag, but pausing/unpausing will respond immediately. In this mode the CPU usage ranges from 30 - 75% on each core, which is absolutely absurd, considering my hardware.

Asked by SuperRoboWizard 6 years ago

Last reply by SuperRoboWizard 6 years ago

  • Archived

Frefox sometimes refuses to play any videos on any website (YT, FB...), i dont know the reason, it's pretty much random and requires the restart of the browser.

As the title says. I have flash disabled so only play html5 videos. My firefox client is running only 2 extensions, ad block plus and greasemonkey, but this issue started… (read more)

As the title says.

I have flash disabled so only play html5 videos. My firefox client is running only 2 extensions, ad block plus and greasemonkey, but this issue started before i had the latter and i don't think APB is doing this.

My firefox version is 43.0.4

Asked by rauven 5 years ago

Last reply by rauven 5 years ago

  • Archived

Firefox 43 overheating gpu on youtube html5

hello. firstly sorry my english weak. i hope u guys understand me and my problem. today ill upgrade my firefox 42 to firefox 43. after the update ive problem with gpu tem… (read more)

hello. firstly sorry my english weak. i hope u guys understand me and my problem.

today ill upgrade my firefox 42 to firefox 43.

after the update ive problem with gpu temp on youtube html5 videos. before the update my gpu temp was 40~45 C but now its over 52-55 C if ill get watchin youtube videos

my gpu amd r9 390

ill test flash player gpu temps on twitch its seems normal like 43-45. ill playing csgo its normal again like 45 49

ill try disable hardware acceleretion. its workin actually my gpu temps look normal when disable hardware acc. BUT this time my firefox fonts corrupted

example image

Asked by ffnmg 5 years ago

Last reply by the-edmeister 5 years ago