Showing questions tagged: Show all questions

Majority of text not displaying on certain websites

Hello, I have been getting a problem lately where nearly all the text on a couple of websites does not display. Only a few characters, such as 'T', 'E', 'L' and '4' displ… (read more)

Hello,

I have been getting a problem lately where nearly all the text on a couple of websites does not display. Only a few characters, such as 'T', 'E', 'L' and '4' display. I have attached screenshots of one of these websites - how it displays in Firefox vs. how it displays in Google Chrome. It also happens in the chat function of the online lecture video system my uni uses (Blackboard Collaborate Ultra), which runs in the browser (it's not a separate app).

I did a search for similar problems on mozilla support and tried restarting Firefox in safe mode, however nothing changed.

I'm using Firefox 78.12.0esr on MacOS X 10.11.6

Any help would be appreciated.

Asked by c.rechner 5 hours ago

Last reply by cor-el 5 hours ago

Firefox storages are broken

It has been a while that gmail and whatsapp web version wouldn't load on Firefox. After some time researching I saw that my Firefox ESR storage are broken. Especially: … (read more)

It has been a while that gmail and whatsapp web version wouldn't load on Firefox. After some time researching I saw that my Firefox ESR storage are broken. Especially:

  • QuotaManager
  • Bad: Totally Broken. (fullyBroken)
  • IndexedDB
  • Bad: Totally Broken. (fullyBroken)
  • Cache API
  • Bad: Totally Broken. (fullyBroken)

Is there any way to fix this? I'm using Firefox ESR on Linux and it seems there isn't new Firefox ESR updates.

Asked by thecowmilk 5 days ago

Last reply by cor-el 1 day ago

Firefox Add-On need to open an open dialog from the activeTab page

Hi all, i'm currently developing an add-on that has an import from file feature that needs to open an "Open file" dialog, now the problem is that in order to do that i h… (read more)

Hi all,

i'm currently developing an add-on that has an import from file feature that needs to open an "Open file" dialog, now the problem is that in order to do that i had to do the following:

  • inject some javascript code in the active page as a content script
  • call the execute command from the extension to open the dialog popup (that is actually emulating a click)

I have to do it, because from an extension when a "File open" dialog appear, the extension lose the focus and it is automatically closed, and its context destroyed, so when i actually press open on the dialog, the "caller" is already gone (https://stackoverflow.com/questions/26884140/open-import-file-in-a-chrome-extension/26917671#26917671 you can refer to my stackoverflow question to get an idea of what i was doing)

This works fine in chrome (And it worked for a while on firefox) but probably in the latest months/years (not sure when it happened) it stopped working and when i press the import button nothing happens, after some investigation i found what is the problem: the "block popup" windows option enabled by default (i suppose it is enabled by default i don't remember to have never enabled it), so when i disable it, the feature resume working. What i'm wondering is if there is a way to programmatically add an exception to the popup blocker option while installing the extension, or if there is any way to avoid closing the exception popup when the "File Open" Dialog appears.

Thanks everyone

Asked by ivan.gualandri 2 days ago

Last reply by jscher2000 1 day ago

Access to my Bank-Account Denied! Why ?! How to delete C00kies?My

I cannot get access to my Bank-account. Possibly the cookie are reponsible.I would like to get a hint for deleting the cookies ??!! I get always the Remark/Answer : Acce… (read more)

I cannot get access to my Bank-account. Possibly the cookie are reponsible.I would like to get a hint for deleting the cookies ??!! I get always the Remark/Answer : Access denied.

I'am hoppeful You could help me.

Urgent!!!

Asked by C.G.R. 3 days ago

Last reply by cor-el 3 days ago

POST action turns into a GET, which is incorrect.

Using Apache2 to serve web pages. Debian Linux 5.10.0-8-amd64 #1 SMP Debian 5.10.46-2 (2021-07-20) x86_64 GNU/Linux The following appears in the access.log:- 127.0.0.1 - … (read more)

Using Apache2 to serve web pages.

Debian Linux 5.10.0-8-amd64 #1 SMP Debian 5.10.46-2 (2021-07-20) x86_64 GNU/Linux

The following appears in the access.log:-

127.0.0.1 - - [28/Jul/2021:15:17:42 +1000] "POST /scripts_php/memb_login.php HTTP/1.1" 302 314 "http://dev.webtest.info/htmlpages/login.html" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0" 127.0.0.1 - - [28/Jul/2021:15:17:42 +1000] "GET /scripts_php/memb_login.php HTTP/1.1" 200 499 "http://dev.webtest.info/htmlpages/login.html" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0"

The form method is POST and the action is to call a PHP script which expects a POST array. The "302 314" appears to be correct, but, a GET is returned immediately.

According to w3.org:-

Note: RFC 1945 and RFC 2068 specify that the client is not allowed

     to change the method on the redirected request.  However, most
     existing user agent implementations treat 302 as if it were a 303
     response, performing a GET on the Location field-value regardless
     of the original request method. The status codes 303 and 307 have
     been added for servers that wish to make unambiguously clear which
     kind of reaction is expected of the client.

This has just started to occur after a recent upgrade to Firefox. It might be caused by the browser but there might be some other explanation or configuration setting that needs tweaking. Could somebody please help.

Thanks.

Asked by rob2floripa 4 days ago

Last reply by TyDraniu 4 days ago

I want to set my own zoom levels - like I used to be able to !!!

Is there anyway to set my own zoom levels, like we used to be able to, you know, like 10 years ago? I used to have my own zoom levels that went up 10% all the way to 300%… (read more)

Is there anyway to set my own zoom levels, like we used to be able to, you know, like 10 years ago?

I used to have my own zoom levels that went up 10% all the way to 300%, then started 25% intervals.

For example, my levels from 100% to 200% looked like this: 100%, 110%, 120%, 130%, 140%, 150%, 160%, 170%, 180%, 190%, 200%.

So, is there any way to do this now?

Asked by mozilla171 1 week ago

Last reply by cor-el 5 days ago

CANNOT SET CUSTOM FILTERS on this site and HOW TO CHANGE the default FILE NAME FOR DL!

ADBLOCK CUSTOM FILTERS not working on this site WHAT THE HECK IS THAT AHAH WHAT??? ALSO THIS. After "Refresh"ing Firefox, it now by default saves a file with the page tit… (read more)

ADBLOCK CUSTOM FILTERS not working on this site WHAT THE HECK IS THAT AHAH WHAT??? ALSO THIS. After "Refresh"ing Firefox, it now by default saves a file with the page title, not the filename. I can no longer find out how to change this default behaviour (presumably I'd used an addon that has been deleted). This is extremely inconvenient - many archives have large numbers of filenames like "<number>.txt", e.g. "234567.txt", but all with the same title. I don't understand why keeping the old Firefox default was not made an option when you changed to saving by title!

Asked by Wes 6 days ago

Last reply by FredMcD 6 days ago

How can I get rid of white stripe at top of screen that SPONTANEOUSLY SHOWS UP on loading something on THE SAME PAGE?

FIREFOX IS MUCH WORSE in this regard than other browsers SHOWING ANNOYING sliding STRIP AT THE TOP OF THE SCREEN FREAKING SLIDES left right and is obnoxious frustrating A… (read more)

FIREFOX IS MUCH WORSE in this regard than other browsers SHOWING ANNOYING sliding STRIP AT THE TOP OF THE SCREEN FREAKING SLIDES left right and is obnoxious frustrating AT TIMES whenever THE PAGE LOADS SOMETHING NEW ON THE SAME PAGE without changing the address YOU KNOW WHAT I MEAN? WHAT IS this obnoxious annoying HORSE CRUD no options about and HARDLY ANY INFORMATION ABOUT IT IS FREAKING LUDICROUS and SHOULD HAVE A WAY TO FIX BECAUSE FREAKING INSANE THANK

Asked by Wes 1 week ago

Last reply by FredMcD 1 week ago

Page actions button was removed in version 90: is this definitive?

Are those buttons (behind the "page actions" one) supposed to be definitively absent from version 90 on? They seemed to me one of the most intelligent features in Firefo… (read more)

Are those buttons (behind the "page actions" one) supposed to be definitively absent from version 90 on?

They seemed to me one of the most intelligent features in Firefox interface. Some can be added under "customize" option, but copy link and pint tab are not.

Is this removal based on the idea that addons are supposed to provide the same actions anyway?

Asked by cipricus 1 week ago

Last reply by jscher2000 1 week ago

Firefox crashing

Firefox ESR 78.11.0 version. For some reason lately a few users have been experiencing crashing of firefox. I'm tried going forward to 78.12.0 and backwards to 68.9 and i… (read more)

Firefox ESR 78.11.0 version. For some reason lately a few users have been experiencing crashing of firefox. I'm tried going forward to 78.12.0 and backwards to 68.9 and it still keeps crashing. What could be some other fixes besides refreshing and running in safe mode. It still crashes performing both methods. Thank you!

Asked by bwhitson 1 week ago

Last reply by FredMcD 1 week ago

New Firefox installer?

Hi I recently downloaded Firefox from the main download page https://www.mozilla.org/en-US/firefox/ The actual download link was: https://cdn.stubdownloader.services.mozi… (read more)

Hi

I recently downloaded Firefox from the main download page https://www.mozilla.org/en-US/firefox/ The actual download link was: https://cdn.stubdownloader.services.mozilla.com/builds/firefox-stub/en-US/win/aeb02dfeae750c7fa2abe9c7bc07b48193110ac61e2169456253638270735d21/Firefox%20Installer.exe

I normally check my downloads using https://virusscan.jotti.org or https://virustotal.com before I run them with admin privileges. Anyway when I uploaded to http://www.virustotal.com the first thing I noticed was that it had never seen the hash before! (SHA1 hash is 3a974b7394597de41230f7517c293e4b6386eeab.) Once it was uploaded, it was promptly detected by the Cylance antivirus engine.

Can somebody please get in touch with Cylance? I suppose I could contact them myself; however, I prefer not to report it as a "false positive" on the off-chance that particular download actually is corrupted or I got a man in the middle- after all, it's surprising that VirusTotal has never seen this hash before.

Asked by 4232jl 2 weeks ago

Last reply by James 2 weeks ago

IN-LINUX RPM BASED - LIVE STREAMING VIDEOS NOT PLAYING IN [YOUTUBE]

Hi, Mozila Firefox team and Technical Support Always experienced, the best browser "Firefox". In Linux "RPM based", specially using Red Hat, Oracle Linux, Centos and may … (read more)

Hi, Mozila Firefox team and Technical Support

Always experienced, the best browser "Firefox".

In Linux "RPM based", specially using Red Hat, Oracle Linux, Centos and may be in other distributions,

live streaming videos are not playing using YOUTUBE.

Firefox shows Error: "Your browser can't play this videos".

Note: In Ubuntu Linux, plays correctly no issue.

Riaz Bashir

Asked by mriazkse 2 weeks ago

Last reply by James 2 weeks ago

El Capitan (Mac OS) and Norton - Not speaking to one another

I recently subscribed to Norton after many recommendations since AVG is not as good as it once was. I have not been with Norton for over 20 years due to the issues of Nor… (read more)

I recently subscribed to Norton after many recommendations since AVG is not as good as it once was. I have not been with Norton for over 20 years due to the issues of Norton and earlier Mac applications. However, now, it's like old times -- when I add the Mac El Capitan to be protected by Norton everything looks ok however, when I go to open a page in Firefox, it just becomes a blank page. It won't load.

So, in other words: HELP!

Should I request a refund? Please advise.

Asked by hblaswilson 2 weeks ago

Last reply by FredMcD 2 weeks ago

playing you tube tutorials

Lately you tube tutorials & videos play for a few seconds. than stop. The spinning wheel appears (presumably reloading) and than it continues but WITHOUT sound. Upon… (read more)

Lately you tube tutorials & videos play for a few seconds. than stop. The spinning wheel appears (presumably reloading) and than it continues but WITHOUT sound. Upon restarting Firefox it happens again and again, rendering it useless. If I use google chrome this phenomenon does not appear, same for Opera - only firefox. What to do?

Asked by moskopf 3 weeks ago

Last reply by FredMcD 3 weeks ago

Links to local filesystems on recent firefox versions without extensions(78+)

Hello, So I've been trying to activate local links which would open a local directory in file explorer. I'm trying to do this on a wiki based on MediaWiki running on a lo… (read more)

Hello, So I've been trying to activate local links which would open a local directory in file explorer. I'm trying to do this on a wiki based on MediaWiki running on a local Nginx sever(laragon). The links work as intended on IE, i.e, I click on the link and it opens a file explorer window with the linked directory. However nothing happens when I click on the link using Firefox. Instead I get this error message :

   Security Error: Content at http://url.com may not load or link to file://///.../directory.

I have tried adding these lines to prefs.js but it didn't have any effect : user_pref("capability.policy.policynames", "localfilelinks"); user_pref("capability.policy.localfilelinks.sites","http://localhost"); user_pref("capability.policy.localfilelinks.checkloaduri.enabled", "allAccess");

Is there any possible workaround to activate local links without using an extension?

Asked by ruhban08 3 weeks ago

Last reply by cor-el 3 weeks ago

WATERFOX cookies or page loading failing?

SAME FORUM WEBSITE that stalls on loading and ONLY SHOWS BLANK PAGE if u click favorites window or type in the address and go to it RANDOMLY and you have to reload, NOT E… (read more)

SAME FORUM WEBSITE that stalls on loading and ONLY SHOWS BLANK PAGE if u click favorites window or type in the address and go to it RANDOMLY and you have to reload, NOT EVEN SHOWING A BACK BUTTON to the new tab page is a way strange bug never seen any other browser ahah THANK

Asked by Wes 3 weeks ago

Last reply by cor-el 3 weeks ago

Unwanted update.

I installed an earlier version of Mozilla Foxfire and checked off that I did not want my version to be updated to the latest version. I now see that my version of choi… (read more)

I installed an earlier version of Mozilla Foxfire and checked off that I did not want my version to be updated to the latest version. I now see that my version of choice has been updated without my knowledge or consent. How do I uninstall the unwanted update and how do I keep it from happening over and over again?

Asked by Barb 4 weeks ago

Last reply by FredMcD 4 weeks ago