Showing questions tagged: Show all questions
  • Solved

Using Mozilla.cfg to focus a custom new tab page

Hi everyone, I am having trouble getting my custom new tab page to be focused when opened (instead of the address bar). I am currently using the `autoconfig.js` + `mozill… (read more)

Hi everyone,

I am having trouble getting my custom new tab page to be focused when opened (instead of the address bar).

I am currently using the `autoconfig.js` + `mozilla.cfg` approach to overriding the `AboutNewTab.jsm` service with a custom local file. This is working great with the two files containing this code:

autoconfig.js: ``` pref("general.config.filename", "mozilla.cfg"); pref("general.config.obscure_value", 0); ```

mozilla.cfg: ``` // Custom firefox config

let { classes:Cc, interfaces:Ci, utils:Cu } = Components;

try {

 Cu.import("resource:///modules/AboutNewTab.jsm");
 let newTabURL = "file:///home/vallode/Documents/test/index.html";
 AboutNewTab.newTabURL = newTabURL;

} catch(e) { Cu.reportError(e); } ```

I have been attempting to use the `gBrowser` global to add an event listener to the new tab opening, but with no success. Could anyone point me in the right direction for something like this?

Asked by Vallode 1 month ago

Answered by Vallode 3 weeks ago

  • Solved

Installing search engines from Mycroft Project not working

I've tried to install several search engines via Mycroft Project to use them through the search bar but that doesn't seem to be working. I don't get any notice, it just d… (read more)

I've tried to install several search engines via Mycroft Project to use them through the search bar but that doesn't seem to be working.

I don't get any notice, it just doesn't work.

Also, one of the search engines I've been using (Twitter) seems to have disappeared from my browser. That's what got me to try to install it again, with no luck so far.

(I've dowloaded Firefox Nightly, installed it from scratch, and seem to have the problem.)

Asked by Marcos 1 month ago

Answered by TyDraniu 1 month ago

  • Solved

cannot add search engine to Firefox Developper Edition

Hello, I cannot add a new search engine to Firefox Developper Edition. When I want to add a new search engine with Ready2Search I get an error message: Submitted inform… (read more)

Hello,

I cannot add a new search engine to Firefox Developper Edition. When I want to add a new search engine with Ready2Search I get an error message: Submitted information of your web browser is Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:78.0) Gecko/20100101 Firefox/78.0.

Your use Macintosh and Firefox. However, your Firefox isn't updated. If you'd like to install OpenSearch plug-in to Firefox, you need to update Firefox.

Same trying to add a new search engine with Mycroft Project doesn't work. I have the latest update of Firefox Developper Edition (78.0b9 (64 bits) Mac). How to do this, please help ? Thank you.

Asked by jeanantogul 1 month ago

Answered by TyDraniu 1 month ago

  • Solved

cannot get firefox to start, want to find out why

Dear mozilla community, I cannot get firefox to start, and I need help to troubleshoot this. What I already did: remove and reinstall (apt) rename ~/.mozilla to trigge… (read more)

Dear mozilla community,

I cannot get firefox to start, and I need help to troubleshoot this. What I already did:

  • remove and reinstall (apt)
  • rename ~/.mozilla to trigger recreation
  • start using the command line
  • start in safe mode

The only symptoms are <defunct> processes (see screenshot).

I need more information to find out what went wrong. Where can I find this?


Details

  • apt
  • firefox_78.0+build2-0ubuntu0.16.04.1~mt1_amd64.deb
  • Linux Mint 18.3 Sylvia

Asked by eim_92 1 month ago

Answered by FredMcD 1 month ago

  • Solved

Getting 403 Access Denied on https://www.lowes.com/

When I put https://www.lowes.com/ into the URL bar in Firefox 78 on Windows 10 I get: Access Denied You don't have permission to access "http://www.lowes.com/" on this se… (read more)

When I put https://www.lowes.com/ into the URL bar in Firefox 78 on Windows 10 I get:

Access Denied You don't have permission to access "http://www.lowes.com/" on this server. Reference #18.a92b5dcc.1593486018.1fbf37a9

This site works OK on IE and Edge. I have these exstensions: Adblock Plus Facebook Container HTTPS Everywhere New Tab Override NoScript

I have the site set as Trusted in NoScript.

In Developer Tools/Network the two resources show as Status 403, but nothing is showing as blocked (red text).

Am I doing something wrong?

TIA Tom

Asked by tlemaire2 1 month ago

Answered by ARMAN KHAN 1 month ago

  • Solved

updates blocked by unknown administrator (systeembeheerder)

Since I updated to 77.0.1 firefox has for unknown reason has concluded that there is a system administrator which has disabled updates. It says so in setting (topleft) an… (read more)

Since I updated to 77.0.1 firefox has for unknown reason has concluded that there is a system administrator which has disabled updates. It says so in setting (topleft) and in about firefox (instead of update button). I have been able to change all other settings that I know of. I have also refreshed the browser once, disabled all addons once, and deinstalled it to reinstall the latest version once.

Is there a solution for this bug?

Asked by frisodeboer 1 month ago

Answered by cor-el 1 month ago

  • Solved

Firefox sync is not syncing bookmarks to a new device

I purchased a new device, but the bookmarks are not syncing like it has on prior devices. I have confirmed all setting are exactly as they were previously. No matter what… (read more)

I purchased a new device, but the bookmarks are not syncing like it has on prior devices. I have confirmed all setting are exactly as they were previously. No matter what I try, I can't get my bookmarks to join me on my new device. Is this a known bug?

Asked by mk 1 month ago

Answered by ARMAN KHAN 1 month ago

  • Solved

Block autoplay being ignored on Firefox 78

Prior to the latest version, I had set "media.autoplay.enabled.user-gestures-needed" in about:config to False in addition to blocking both audio and video within the sett… (read more)

Prior to the latest version, I had set "media.autoplay.enabled.user-gestures-needed" in about:config to False in addition to blocking both audio and video within the settings so that nothing would autoplay without my input.

I updated to version 78 yesterday, and it seems that "media.autoplay.enabled.user-gestures-needed" is now gone from within about:config. I'm getting videos autoplaying within sites like YouTube, despite me setting both audio and video to not autoplay.

Is there anything I can do to ensure that nothing starts playing without me allowing it?

Asked by Kakkun 1 month ago

Answered by cor-el 1 month ago

  • Solved

Since FF 78 my browser tab bar is black instead of dark transparent (even when changing to light mode) on MacOS

Pretty much like the title says, FF 78 shows me a solid black, instead of slight translucent, tab bar (background), when I changed to light theme it stayed black too. Any… (read more)

Pretty much like the title says, FF 78 shows me a solid black, instead of slight translucent, tab bar (background), when I changed to light theme it stayed black too.

Any way to solve this?

Asked by Yves 1 month ago

Answered by Yves 1 month ago

  • Solved

Search engine does not work

Please HELP! I have Google as my search engine. When ever I type something in, Yahoo gives me the results! Their in NOTHING in my programs that show Yahoo Thank you Kurt … (read more)

Please HELP! I have Google as my search engine. When ever I type something in, Yahoo gives me the results! Their in NOTHING in my programs that show Yahoo

Thank you

Kurt

Asked by kurtbazner 1 month ago

Answered by jscher2000 1 month ago

  • Solved

Firefox tabs hanging after 78.0.1 update

Just updated to version 78.0.1 (64-bit) on Windows 10 and now my tabs will NOT load/hanging, even after several restarts. PLEASE FIX THIS ASAP, I have work to do!!! … (read more)

Just updated to version 78.0.1 (64-bit) on Windows 10 and now my tabs will NOT load/hanging, even after several restarts. PLEASE FIX THIS ASAP, I have work to do!!!

Asked by cinfulgalaxy 1 month ago

Answered by jscher2000 1 month ago

  • Solved

78.0.1 update: extensions still visible under add-ons but have vanished from top bar

Firefox upgraded to 78.0.1 but my extensions are now inaccessible/invisible. They show as enabled in the about:add-ons tab but no longer appear at the top of the main wi… (read more)

Firefox upgraded to 78.0.1 but my extensions are now inaccessible/invisible. They show as enabled in the about:add-ons tab but no longer appear at the top of the main window - so I casn no longer access them.

Asked by anharker 1 month ago

Answered by cor-el 1 month ago

  • Solved

Autoplay not always blocked

Firefox 78 sometimes fails to block autoplay, e.g. scrolling the front page of reddit.com or a subreddit will intermittently show videos playing. This worked in 77. Some … (read more)

Firefox 78 sometimes fails to block autoplay, e.g. scrolling the front page of reddit.com or a subreddit will intermittently show videos playing.

This worked in 77. Some about:config entries I'd swear were set in 77 have vanished; I tried adding them manually, but the autoplay blocking is still hit and miss.

Also, not sure if Troubleshooting Information uploaded successfully or the page broke (see screenshot).

Asked by Jens Lyn IV 1 month ago

Answered by Jens Lyn IV 1 month ago

  • Solved

with update to Firefox 78.0.1 all of my browser history disappeared and it will not save any of my history

today firefox updated to version 78.0.1 (x64), on Windows 10 build 19041. all of my browsing history was deleted and firefox will no longer save any history … (read more)

today firefox updated to version 78.0.1 (x64), on Windows 10 build 19041. all of my browsing history was deleted and firefox will no longer save any history

Asked by sdbear 1 month ago

Answered by FredMcD 1 month ago

  • Solved

Laggy Firefox

I am facing two issues with Firefox. I am using Firefox on Macbook Pro 2017 with i7 processor and 16GB Ram, but after importing all my bookmarks from chrome its laggy lik… (read more)

I am facing two issues with Firefox. I am using Firefox on Macbook Pro 2017 with i7 processor and 16GB Ram, but after importing all my bookmarks from chrome its laggy like when i move mouse hover the bookmarks its animation response time is slow ie :- Moving cursor up and down the blue animation strip its bit delay comparatively mouse cursor movement.

Secondly i am having issue with YouTube, when i am double click on YouTube video to full-screen its give blank screen for a sec its bit annoying i think it need to fix.

Asked by Iqubal Singh 1 month ago

Answered by cor-el 3 weeks ago

  • Solved

This page keeps refreshing itself

This page keeps refreshing itself. Clicking the Refresh X stops it: https://www.healthline.com/nutrition/decaf-coffee-good-or-bad . . . since I just updated to 78.0.1 (6… (read more)

This page keeps refreshing itself. Clicking the Refresh X stops it:

https://www.healthline.com/nutrition/decaf-coffee-good-or-bad

. . . since I just updated to 78.0.1 (64-bit) . . . ? It looks like a bug to me.

Asked by sludge7051-x 1 month ago

Answered by sludge7051-x 1 month ago