Showing questions tagged: Show all questions
  • Archived

Copying Multi-Account Containers Addon with specific sites per container

I just had a glitch with the latest update to 102b, FF insisted I had an old version and would only let me make a new profile. So I had to set up multi-account containers… (read more)

I just had a glitch with the latest update to 102b, FF insisted I had an old version and would only let me make a new profile. So I had to set up multi-account containers again. I have specific sites opening up in each container, and I'd like to make a copy to make sure that if my profile gets goofed up somehow, I can always easily restore my setup with multiaccount containers just the way I like it.

What do I need to copy, so that with a new profile, all I need to do is copy over some files?

In my profile folder, I see an Extensions folder, as well as an extensions.json and extensions-settings.json.

Are those the only folders/files I'd need to restore multi-account containers on a new profile?

I have thought of using FF Sync, but I keep reading that it is not intended for copying, so much as sharing across different devices, which is not something I'm interested in. Should I just let sync copy my extensions, and then sign back in, in the event I want to restore addons to a new profile?

Asked by prr 12 months ago

Last reply by cor-el 12 months ago

  • Archived

Jar files from GitLab are being turned into .jar.zip files

Since earlier this week my Firefox browser has been turning .jar files from GitLab into .jar.zip files, which prevents them from being used properly until renamed. Attemp… (read more)

Since earlier this week my Firefox browser has been turning .jar files from GitLab into .jar.zip files, which prevents them from being used properly until renamed. Attempting to download the same files on Edge or Chrome works correctly, and attempting to download any jar files from other websites (even GitHub) also works correctly. It seems that GitLab is the only website that is affected by this.

Examples of files being affected (they should be downloaded as normal .jar files): 1. https://gitlab.com/Trafalcraft/antiRedstoneClock/uploads/3b3c84814d76810f826c3803eaca1e66/antiRedstoneClock-1.4.1.jar 2. https://gitlab.com/Aristois/ui-installer/-/jobs/2505715157/artifacts/raw/packager/Aristois-Free.jar 3. https://gitlab.com/Aristois/Installer/-/jobs/2495195255/artifacts/raw/packager/free/Installer-2.0.3.jar

I'm using Firefox developer edition (102.0b3), and already tried using private mode, resetting Firefox, and reinstalling. Since I use GitLab as a main source to upload files, many users have also complained the same problem to me, in which all of the users were running Firefox. After they downloaded with a different browser, it worked for them as well.

Asked by Dyiing 11 months ago

Last reply by jscher2000 - Support Volunteer 11 months ago

  • Archived

View source in external brouser stopped working

Firefox 102 beta stopped opening source of web pages in external editor I have view_source.editor.external set to "true" and view_source.editor.path set to "C:\Program F… (read more)

Firefox 102 beta stopped opening source of web pages in external editor

I have view_source.editor.external set to "true" and view_source.editor.path set to "C:\Program Files\Notepad++\notepad++.exe"

Before version 102, CTRL-U on any web page would open the page's source in the external editor.

In 102, the source is opened in the internal source viewer (in a browser tab).

The console shows:

   this._caUtils.getDefaultExtension is not a function viewSourceUtils.js:413
       getTemporaryFile chrome://global/content/viewSourceUtils.js:413
       openInExternalEditor chrome://global/content/viewSourceUtils.js:265
       openInExternalEditor chrome://global/content/viewSourceUtils.js:216
       BrowserViewSourceOfDocument chrome://browser/content/browser.js:3131
       BrowserViewSource chrome://browser/content/browser.js:3207
       oncommand chrome://browser/content/browser.xhtml:1

Asked by Alex 11 months ago

Last reply by Alex 11 months ago

  • Archived

Error 5000/5001 on iplayer

When I try to play iplayer as of June 2022 it comes up with error 5000/5001. Other tv players are no longer playing either, Channel 4 for some time now. My laptop runs on… (read more)

When I try to play iplayer as of June 2022 it comes up with error 5000/5001. Other tv players are no longer playing either, Channel 4 for some time now. My laptop runs on Windows 8 and I have the latest version of firefox. In plug ins my codec is set on always activate as is Widevine CDM. I tried unchecking 'play DRM controlled content' in settings then checked it again and it has come up with Widevine CDM will be installed shortly, but nothing has happened.

many thanks, frances

Asked by fcorr 11 months ago

Last reply by fcorr 11 months ago

  • Archived

media player codec

The partial code is : < video onclick='playPause()' width='100%' controls > < source src='/videos/".$trimDir."/".basename($s)."' type='video/mp4' > … (read more)

The partial code is :


< video onclick='playPause()' width='100%' controls >

 < source src='/videos/".$trimDir."/".basename($s)."' type='video/mp4' >

</video>

Asked by mwilson1 11 months ago

Last reply by mwilson1 11 months ago

  • Archived

GIF animation is reset when a new image is added to the page.

Hello! Short story: I recently discovered that adding a new GIF image to a page resets the animations of existing GIF images on the page with the same src. Expected beh… (read more)

Hello! Short story: I recently discovered that adding a new GIF image to a page resets the animations of existing GIF images on the page with the same src.

Expected behavior: Adding a new GIF image to the page should not reset the animation of existing images with same src.

Actual result: Adding a new GIF image to the page resets the animation of all existing GIF images on the page with same src.

Code with example: https://codesandbox.io/s/heuristic-platform-jsguir Video demo: https://www.youtube.com/watch?v=k-ZMrrqq_KI

Simplified version of the code showing unexpected behavior: https://codesandbox.io/s/elastic-shtern-vwrcx1

Does anyone know why this is happening? Is this a bug?

Browser: Firefox Developer Edition 102.0b4 (64-bit) OS: Windows 11

Asked by 0050 11 months ago

Last reply by cor-el 11 months ago

  • Archived

Video stops buffering and then take more time to load another seconds.

Firefox version: 102.0b7 OS: Win 11 While watching videos(movies/anime) video takes much time to buffer. If video is of 20 minutes then it loads first few minutes then a… (read more)

Firefox version: 102.0b7 OS: Win 11

While watching videos(movies/anime) video takes much time to buffer. If video is of 20 minutes then it loads first few minutes then after watch time reaches that buffered video then it takes more time buffer.

What I am looking is for, how can I force firefox to buffer full video at once or is there any way to increase buffer size.

Asked by Prashant 11 months ago

Last reply by Aurorum.co 11 months ago

  • Archived

How to completely remove tabs bar using userChrome.css

I have been seaching for the solution for the whole day, and i found the closest one. It Does remove tabs, windows buttoms, but the background bar still remains, and i do… (read more)

I have been seaching for the solution for the whole day, and i found the closest one. It Does remove tabs, windows buttoms, but the background bar still remains, and i dont need it this way. So thats the code i used to make it >>>>>

  1. main-window[tabsintitlebar="true"]:not([extradragspace="true"]) #TabsToolbar .titlebar-spacer {
       border-inline-end: none;

}

  1. main-window:not([extradragspace="true"]) #TabsToolbar > .toolbar-items {
 opacity: 0;
 pointer-events: none;

} /* This makes the bar shorter vertically but removes the 3 window buttons */

  1. main-window #TabsToolbar {
 visibility: collapse !important;

} /* For full screen mode */

  1. TabsToolbar[inFullscreen]{
 display: none !important; 

}

On the screenshot you can see what remains on tabs' bar place I need my browser to end just above the URL string, so there wont be empty space in the top of the monitor. Can you help me find solution for this problem, please?

Asked by CobaltC17 11 months ago

Last reply by cor-el 11 months ago

  • Solved
  • Archived

problem in cursor of "Firefox Edition Developer"

Hello, Do not be tired while i clicked on the normal Web page, Cursor is activate, And blink. it walks a lot on the nerves. please solved this problem, Thank You! … (read more)

Hello, Do not be tired

while i clicked on the normal Web page, Cursor is activate, And blink. it walks a lot on the nerves.

please solved this problem,


Thank You!

Asked by omarfatahidev 11 months ago

Answered by cor-el 11 months ago

  • Archived

"open all in tabs" via context menu for folder in bookmarks toolbar

MacOS FF dev edition 102: I have a folder in my bookmarks toolbar, and I frequently open all of them in tabs. But that option is missing from the context menu on the fold… (read more)

MacOS FF dev edition 102: I have a folder in my bookmarks toolbar, and I frequently open all of them in tabs. But that option is missing from the context menu on the folder. It is there at the bottom of the folder if I click to open the folder, but this is silly. There is an "open all bookmarks" context menu option on the folder, but that opens all the bookmarks in the toolbar, not in that one folder. why is this?

Asked by Steven 11 months ago

Last reply by cor-el 11 months ago

  • Archived

rolling over link pops up URL in status bar but no "in new tab" indication

MacOS FF dev edition 102 When I roll my mouse over a link, in pops up the URL in the bottom left (i.e. status bar as safari calls it) but there's no indication of if the … (read more)

MacOS FF dev edition 102 When I roll my mouse over a link, in pops up the URL in the bottom left (i.e. status bar as safari calls it) but there's no indication of if the link will show in the current tab or a new tab. in safari, the end of the URL states "in new tab" if that's the case.

Asked by Steven 11 months ago

Last reply by Chris Ilias 11 months ago

  • Archived

Wiped out all of my personal info

I turned on my computer like any other normal day this morning, except when I launched firefox it was like it was freshly installed, all my passwords, usernames, cookies,… (read more)

I turned on my computer like any other normal day this morning, except when I launched firefox it was like it was freshly installed, all my passwords, usernames, cookies, saved bookmarks, work related history material is all GONE it's like I just installed firefox for the first time. A lot of these passwords I dont know off the top of my head so I'm going to have to ask my business partners for ALL the passwords... Why did firefox do this? What is the problem??

Asked by hugo.tovar.jr 11 months ago

Last reply by jscher2000 - Support Volunteer 11 months ago

  • Archived

Downloading pdf files fails

Lately when I attempt to download any pdf file I get the 'file name'.pdf with 'failed' as the result (when I check the Download icon on the FF status bar). I looked in m… (read more)

Lately when I attempt to download any pdf file I get the 'file name'.pdf with 'failed' as the result (when I check the Download icon on the FF status bar). I looked in my download directory and I found these 'failed' .pdf files with 0 KB and also some files (same name).pdf.part. I changed the file extension (deleted .part) to .pdf and the files would open in Acrobat. Nobody likes inconsistent problems, but occasionally a pdf will download normally!! But it fails more than it works. Using FF 102.0 (64-bit)

Asked by Wally 11 months ago

Last reply by cor-el 10 months ago

  • Solved
  • Archived

Security Error: Content on about:tab may not load or link file

I had set up a userContent.css file in the past to pull up and fetch an image on my computer to display as a background on the homepage. It worked and did it's job until … (read more)

I had set up a userContent.css file in the past to pull up and fetch an image on my computer to display as a background on the homepage. It worked and did it's job until recently, when I had recently relocated a lot of my files around on my computer. I have redirected everything to where I want it to look, including the userContent.css file to the new location for the image I want as the background. Firefox loads the .css file correctly, and recognizes the file existing, but it won't load the image itself for some odd reason. It states it "may not load or link the file" because of a security error, and thus, can't load the image. I never had to deal with this before. How can I get Firefox to be able to load my image like I want it to? I have screenshots that I can provide, but this site doesn't want to upload them at the moment.

Asked by meddlingguns 11 months ago

Answered by jscher2000 - Support Volunteer 11 months ago

  • Archived

Reproducable crash in ubuntu 20.04 from Firefox 102.0 64-bit

Steps to re-create: create a new campagin attempt to change the display image using the hover-button over the image on the page. What happens: I click the "change image"… (read more)

Steps to re-create: create a new campagin attempt to change the display image using the hover-button over the image on the page.

What happens: I click the "change image" button, it gives me the os file picker. I select the file i want and click open and the file picker goes away. The "progress" bar at the top of the image shows up, changes through several states it seems. Then all screens freeze, and the computer stops responding to all output.

Supplemental info: This started happening after an update from ubuntu 18.04 lts to 21 to 22.04 lts. So I know I was not using a flatpak before and I am now.

I've attempted to use strace to figure out what's happening at the time of the freeze I'll include a picture of that if this form does not cause my entire pc to freeze. But didn't really get any useful info from that. I tried reading dmesg at the time of the crash but so far the screen freezes before any relevent information pops up. I've not been able to find any logs about whats going in previous dmesg logs.

Troubleshooting steps: I've attempted the same procedure in firefox's safe mode. This does not seem to stop the crash. I've attempted the same procedure using chrome and this works as it should.

Asked by nogasgofast 11 months ago

Last reply by jonzn4SUSE 10 months ago