Showing questions tagged: Show all questions
  • Solved
  • Archived

New CSS styles not picked in Firefox.

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren'… (read more)

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren't displayed in the web page nor in the developer tools inspector.

They are visible in Chromium browser and dev tools.

I have cleared the cache and refreshed the page to no avail. It is only when I restart the browser that the new style rules take effect in the browser and show up in the dev tools.

Asked by mt3ch 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Firefox Developer Edition will not start

I cannot get Firefox Developer Edition 84.ob2 to start, I can see it xcome up in Task Manager and then the app say suspended and it stops. Have tried all the suggestions … (read more)

I cannot get Firefox Developer Edition 84.ob2 to start, I can see it xcome up in Task Manager and then the app say suspended and it stops.

Have tried all the suggestions I can see in help but nothing works.

The option of running firefox.exe -p does not work, there is a crash report:

Source Firefox Developer Edition

Summary Stopped working

Date ‎18/‎11/‎2020 08:59

Status Report sent

Description Faulting Application Path: C:\Program Files\Firefox Developer Edition\firefox.exe

Problem signature Problem Event Name: BEX64 Application Name: firefox.exe Application Version: 84.0.0.7625 Application Timestamp: 5fb2ff14 Fault Module Name: StackHash_ac46 Fault Module Version: 0.0.0.0 Fault Module Timestamp: 00000000 Exception Offset: PCH_78_FROM_ntdll+0x000000000009C8F4 Exception Code: c0000005 Exception Data: 0000000000000008 OS Version: 10.0.19041.2.0.0.256.48 Locale ID: 2057 Additional Information 1: ac46 Additional Information 2: ac462b2fd07cc853b652b5104a1cf381 Additional Information 3: 7eba Additional Information 4: 7eba02d16b529d1dadfdb18b9d2da9b8

Extra information about the problem Bucket ID: 845348ebf4affc3e570d018771269f89 (1660985518800150409)

Asked by Mike 1 year ago

Answered by FredMcD 1 year ago

  • Solved
  • Archived

Firefox isn't showing forms on our website created with Formidable Forms

Hi there, I work for a small UK based charity and we use our website to take orders for our programmes, we deliver DARE programmes in the UK. Our website is https://lifes… (read more)

Hi there,

I work for a small UK based charity and we use our website to take orders for our programmes, we deliver DARE programmes in the UK.

Our website is https://lifeskills-education.co.uk.

We use WordPress as our CMS and use Formidable Forms to create forms for people to place orders; these forms work fine in Chrome and Edge, but will not display in Firefox. I have tried everything, disabling third party scripts, all plugins, themes and more, but Firefox refuses to show them. It sees the HTML, but when inspected the HTML is greyed out. It is not greyed out on Chrome.

https://lifeskills-education.co.uk/resources/the-dare-primary-programme/ is the page where an order form should show on the left above the fold. It is titled Place an Order.

There is nothing I can find anywhere that can help me with this issue, Google has come up blank and I am not a web developer so don't have the tech chops to track this down.

Any help appreciated. Thanks.

Stuart

Asked by thebastion 1 year ago

Answered by cor-el 1 year ago

  • Archived

PWA support on Firefox desktop

I have a question regarding PWA support on Firefox desktop. I am not sure how to frame this correctly, but I hope I am able to list the problem statement. Basically, I pl… (read more)

I have a question regarding PWA support on Firefox desktop. I am not sure how to frame this correctly, but I hope I am able to list the problem statement.

Basically, I plan to migrate my existing mobile and desktop website to single PWA based responsive website. Right now, I have mobile website which is a PWA, and a desktop website. Goal is to have a single PWA based responsive website for both mobile and desktop platform. However, I want to make sure the proposed website will work with Firefox desktop. From what I could find Firefox doesn't support option to install PWA as an app with it's own shortcut as it is possible in Chrome. But I want to make sure it supports rest of the features of PWA, and website still works correctly in terms of UI and experience as in case when it is accessed from Chrome browser.

Appreciate a response on this. In case you require more clarity on the problem statement, do let me know.

Asked by SK1010 1 year ago

Last reply by jscher2000 1 year ago

  • Solved

Website will not allow Firefox to display the page if another site has embedded it

I have a new business website http://affordable-tutors.com/about-our-tutors and I tried to put in my video https://youtu.be/EQxd_cowXPg but it gives me the following erro… (read more)

I have a new business website http://affordable-tutors.com/about-our-tutors and I tried to put in my video https://youtu.be/EQxd_cowXPg

but it gives me the following error. Website will not allow Firefox to display the page if another site has embedded it

What can I do?

Yes, I own all the rights for that video.

Asked by Markis 5 months ago

Answered by Markis 5 months ago

  • Archived

Mozilla Firefox does not work when disabling the encryption key TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA (0xc014)

Dear Mozilla team, We are a company that develops web systems. The customer’s security service asks us to close all old encryption keys on the server in order to avoid sy… (read more)

Dear Mozilla team,

We are a company that develops web systems. The customer’s security service asks us to close all old encryption keys on the server in order to avoid system vulnerabilities and use only new keys. We disabled most of the old keys and the system works fine on all browsers. As soon as we turn off the encryption key TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA (0xc014), then all web systems stop working through the Mozilla Firefox browser. (At the same time, everything works correctly on other browsers). The Mozilla Firefox Documentation says that this browser supports new encryption keys and can work without old encryption keys. Link (https://wiki.mozilla.org/Security/Server_Side_TLS). Also on our server are included all the necessary encryption keys for Mozilla Firefox to work.

Do you have any ideas on how to solve this?

Asked by yulyan.karpiy 1 year ago

Last reply by dkeeler 1 year ago

  • Solved
  • Archived

Website formatting issue

Hey team, I hope you are doing great, I'm facing an issue with a table on my page, no matter what I do the image isn't sized correctly. They get compressed and look odd. … (read more)

Hey team,

I hope you are doing great, I'm facing an issue with a table on my page, no matter what I do the image isn't sized correctly. They get compressed and look odd.

I'm not getting this issue on Chrome, can you please have a look at the table on this page and let me know what could be the issue.

I'll be really thankful as I have tried everything that I could think of. The image is also attached for your reference.

Thanks in advance

Asked by webbjason3 1 year ago

Answered by FredMcD 1 year ago

  • Archived

My Website Won't Load

My website ozpt.com does not load on FireFox. It works on CHROME, SAFARI, ANDROID, EDGE etc. But when i try to open in FireFox I get the spinning wheel and it won't load.… (read more)

My website ozpt.com does not load on FireFox. It works on CHROME, SAFARI, ANDROID, EDGE etc. But when i try to open in FireFox I get the spinning wheel and it won't load. Sometimes if i refresh, it will load the one page, then when i click on anther link, it won't load that new page, and back to spinning wheel.

I don't understand why I'm working on all other browsers, but not on FF?

Asked by mgrimaldi520 11 months ago

Last reply by jscher2000 11 months ago

  • Archived

Website layout is showing different than original

Hello, I'm using Firefox to manage my website but when I open my blog in Firefox my site's layout is not showing like the original one with header menu but showing mobile… (read more)

Hello, I'm using Firefox to manage my website but when I open my blog in Firefox my site's layout is not showing like the original one with header menu but showing mobile toggle menu on Desktop, in Chrome it's showing with header menu, I don't know what's the reason behind it, my users also complained about that, can someone open my site in Mozilla to confirm if they are also experiencing it or only me? Screenshot of Mozilla and Chrome is also attached below. Thanks! Here is my blog: https://writions.com/

Asked by kovise1121 8 months ago

Last reply by cor-el 8 months ago

  • Archived

Page wont load - redirecting incorrectly

I am developing a website. I have uploaded the files to my webhost server. When I visit the page I get the following error. The page isn’t redirecting properly An error o… (read more)

I am developing a website. I have uploaded the files to my webhost server. When I visit the page I get the following error.

The page isn’t redirecting properly

An error occurred during a connection to www.themindcreative.net.

This problem can sometimes be caused by disabling or refusing to accept cookies.

Never seen this before, been using this webhost for over a decade and numerous websites. This only started with the new website and after the latest Firefox update. I have a support ticket in with Dreamhost but have not heard back.

Obviuosly I cant just allow all cookies - thats ridiculous. Every other website I visit displays just fine and I have most cookies turned off with the strict/strong tracking protection turned on in Firefox preferences.

Any idea what this 'redirect' error message means? And how to fix it?

Cheers Adam

Asked by adam63 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

FF auto-updated to 89.0.1, now a site won't work, would like to RESTORE deleted/cleared cookies for that site to see if it will help cuz deleted the cookie for it MADE THINGS WORSE! Doesn't work under PRIVATE SESSION either!!

FF auto-updated to 89.0.1, now a site won't work, would like to RESTORE deleted/cleared COOKIES (?!?!) for that site to see if it will help cuz deleted the cookie for it … (read more)

FF auto-updated to 89.0.1, now a site won't work, would like to RESTORE deleted/cleared COOKIES (?!?!) for that site to see if it will help cuz deleted the cookie for it made things worse! Doesn't work under Private FF session either!!

Specifics: I am the Webmaster of (we use WIX to create/manage it) 12cdrc.org and it is working fine using Edge, Chrome, Brave, but no longer works correctly (since 89.0.1, I think happened late last night early this morning on my system) update. Most of the page loads, but the Calendar and display tweets sub-windows will not load! It will be obvious to all where they should be displaying but are not!

So, I tried removing 12cdrc.org cookies. Things got worse! Now the Login won't work either, where I was logged in as my user for the site prior to that.

I tried a Private window/session, and the Login function does work, the Calendar does show, but the tweets sub-section/window still does not display/function.

Background: This is not the first website to malfunction using Firefox... Previous version updates broke the rescuemichigan.com website (none of the pull-down menu functions work, but work fine on/with Brave, Chrome, Edge)! Also mewe.com acts up using FF at times, but a clear of the mewe.com related cookies and relogin at mewe via FF clears up the issues of things not wanting to display correctly or fully on mewe using FF - which is why I thought clearing 12cdrc.org cookies would help in this case (but did not, again, made the malfunctioning worse)!

This makes little sense. I even tried doing D/L of full 89.0.1 install, didn't help.

I'd like to try and RESTORE COOKIES (last thing I want to do is clear all data/cookies for FF) for 12cdrc.org from manual offload of all my userid appdata folder/sub-folders to an external drive (or perhaps appdata backup to Norton cloud backup done a few weeks ago)! But I do not know where to look. Was about to go to my external drive and do complete file search of "12cdrc*.*" to see what would return when I thought I could search Mozilla/FF Help on "Restore Cookies" but only very old question for very old version of FF showed up and it said "IF STILL NEED HELP ASK NEW QUESTION" so here I am doing so!!!

Again, all sites (12CDRC.org, MeWe.com, and RescueMichigan.com) ALL WORK 100% error/issues free using Brave, Chrome, Edge, so this is FIREFOX SPECIFIC and all these issues have started under/after recent FF updates and/or gotten worse, not fixed/better, under updates/upgrades!!!!

Appreciate any Help... 1) like I said, where the Cookies are hidden that I might then recover them from previous save 2) other suggestions?!?!?!

Asked by JLenardDetroit 7 months ago

Last reply by JLenardDetroit 7 months ago

How to add a exception for SSL certificate error

I am developing my web application locally under the url https://local.focuscura.com:5555. When I am trying to access the url I get a "Secure connection failed - SEC_ERRO… (read more)

I am developing my web application locally under the url https://local.focuscura.com:5555. When I am trying to access the url I get a "Secure connection failed - SEC_ERROR_INADEQUATE_KEY_USAGE" error which is normal as the SSL certificate is not a valid one. But I would expect to have a "Add exception" button as I can see on Chrome and Edge for the same url. I tried settings the config parameter "network.stricttransportsecurity.preloadlist" to false and delete the SiteSecurityServiceState.txt as found in https://support.mozilla.org/bm/questions/1206414. But it does not work. I still cannot access that url and no "Add Exception" button is shown. I have FF 91 installed on Win 10.

Asked by adrian_shadow 5 months ago

Last reply by adrian_shadow 5 months ago

  • Solved
  • Archived

shift toward left on click

today I noticed that my webpages, only with Firefox, not with other browser, shift toward left on clicking (any hyperlink) . You can see on this my website my website . … (read more)

today I noticed that my webpages, only with Firefox, not with other browser, shift toward left on clicking (any hyperlink) . You can see on this my website my website .

Asked by dr.bertoldi 1 year ago

Answered by dr.bertoldi 1 year ago

  • Archived

Forcing SSL is DRIVING ME CRAZY as a developer. Needs a disable option.

Dear community, I would like to bring up a topic that is DRIVING ME CRAZY. I am developer and frequently access my own services on unsecured http servers for testing. Spi… (read more)

Dear community,

I would like to bring up a topic that is DRIVING ME CRAZY. I am developer and frequently access my own services on unsecured http servers for testing. Spin up a new docker container, test it, tear it down. No SSL required, no time to mess with encryption.

But if you type in https just a single time for your http server, you are f*#&ed. Sorry for the wording, but this is how it is. You think "OH NO, WHAT DID I DO? NOT AGAIN!!!" Because it is just impossible to access the service with http in the future, Firefox has it locked to SSL (Domain and Port). But of course there is no SSL so it will NEVER work.

Latest example: JetBrains TeamCity. They have a simple Docker container I want to access with Firefox. I spin it up, connect with Firefox with http and it immediately tells me "Secure Connection Failed". WHAT? WHY? I typed http. Why secure? Why can't I simply connect? Using curl on CLI just gives me a beautiful HTML response.

I understand that for the majority of users SSL is a good thing. But shouldn't there at least be an OPTION to disable all this enforced SSL usage? My beloved Firefox is my everyday productivity killer. It makes me sad.

Asked by mib77 1 year ago

Last reply by FredMcD 1 year ago

Plugins & Profile directory

I have tried on windows and on linux, and the same thing happens for both. I don't get the plugins i should have. I want to try and enable java, but its not even appearin… (read more)

I have tried on windows and on linux, and the same thing happens for both. I don't get the plugins i should have. I want to try and enable java, but its not even appearing in the first place. My profile directory is all messed up as well. I don't have a pluginreg.dat, my extensions.sqlite is an extensions.json. I have been reading all the forums but they mention stuff about the files in the profile, but I don't have those files.

Asked by caedenperelliharris 2 months ago

Last reply by FredMcD 2 months ago

  • Archived

My own page not running on Firefox

I have an own WP homepage www.immerunterwegs.ch. It runs on all browsers except firefox. Who knows what is wrong with my page and why it is not running on firefox ? Regar… (read more)

I have an own WP homepage www.immerunterwegs.ch. It runs on all browsers except firefox. Who knows what is wrong with my page and why it is not running on firefox ?

Regards Gian Reto

Asked by grbauder 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

Why, there is no support for ' CSS Backdrop Filter' ?

Hello, I'm on the way to be a web developer. But, when it comes to add Glassmorphism effect, it seems like firefox doesn't support CSS property called "backdrop-filter". … (read more)

Hello, I'm on the way to be a web developer. But, when it comes to add Glassmorphism effect, it seems like firefox doesn't support CSS property called "backdrop-filter". Will there be any support for this in near future?

I'm using Firefox For Linux v88.0 (64-bit).

Asked by abir.sheikh.4044 9 months ago

Last reply by TyDraniu 9 months ago

  • Archived

small fraction of a line when clicking on a link on my web page and then return from that link

I have programmed a website (with partial use of Xara js code). On one page I have a link to impressum, data privacy etc. When I click one of the links and then return to… (read more)

I have programmed a website (with partial use of Xara js code). On one page I have a link to impressum, data privacy etc. When I click one of the links and then return to previous page with "back", I get a small line at a position where no element is located. The line is connected with the last link selected as it changes color when hovering with the mouse over the button.

It seems that the effect appears only in Firefox and not in every installation, and neither in IE11 nor Edge nor Chrome. I have observed the same effect also on my mobile (Samsung S9). The line can be seen in the attached picture. For your developers I can also provide the link to that specific page if necessary.

Asked by Ultra-Junkie 1 year ago

Last reply by Roland Tanglao 1 year ago

  • Archived

this site is not opening in my ios

I'm coordinating my site for various applications, it functions admirably on android or google items however it isn't supporting Firefox form for IOS my supporting connec… (read more)

I'm coordinating my site for various applications, it functions admirably on android or google items however it isn't supporting Firefox form for IOS

my supporting connection is my music goal would anyone be able to assist me with discovering the issues or arrangements?

Asked by michaelhenry199 11 months ago

Last reply by jonzn4SUSE 11 months ago