Showing questions tagged: Show all questions
  • Solved
  • Locked

Firefox update error: Failed to check for updates.

Hello, When I go to update Firefox through the settings > general > firefox updates > check for updates, I am getting the error in the title. I can manually dow… (read more)

Hello,

When I go to update Firefox through the settings > general > firefox updates > check for updates, I am getting the error in the title. I can manually download the app installer and update to the most current version which is what I did for version 125.0.1, yesterday.

I have tried uninstalling and reinstalling firefox, installing the beta branch, refreshing firefox, running in troubleshooting mode, completely deleting all user firefox files, and I still get the error. No DNS resolver issues to the update server. No firewall issues. No network blocking (tested with other devices).

This issue started after March update to 124.0.1 and continues to current stable release 125.0.1.

This issue also seems to extend to checking for extension updates.

Below are browser logs for when i try to check for update or update extensions.

App Update Logs: AUS:AUM AppUpdater:check - currentState=STATE_IDLE AUS:AUM AppUpdater:check - starting update check AUS:SVC CheckerService:checkForUpdates - checkType: 2 AUS:SVC CheckerService:checkForUpdates - Making new check request for check id 86. AUS:SVC CheckerService:getUpdateURL - checkType: 2 AUS:SVC CheckerService:getUpdateURL - update URL: https://aus5.mozilla.org/update/6/Firefox/125.0.1/20240416043247/WINNT_x86_64-msvc-x64/en-US/release/Windows_NT%252010.0.0.0.22631.3447%2520(x64)/ISET%3ASSE4_2%2CMEM%3A32702/default/default/update.xml?force=1 AUS:SVC CheckerService:#updateCheck - sending request to: https://aus5.mozilla.org/update/6/Firefox/125.0.1/20240416043247/WINNT_x86_64-msvc-x64/en-US/release/Windows_NT%252010.0.0.0.22631.3447%2520(x64)/ISET%3ASSE4_2%2CMEM%3A32702/default/default/update.xml?force=1 AUS:SVC CheckerService:#updateCheck - request got 'error' event AUS:SVC CheckerService:#updateCheck - Failed. request.status: 2152398919 AUS:SVC getStatusTextFromCode - transfer error: Data transfer was interrupted (please try again), code: 2152398919 AUS:AUM AppUpdater:check - Update check failed; CHECKING_FAILED

Extension Update Logs: 1713382616474 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382616475 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382616476 addons.update-checker WARN HTTP Request failed for an unknown reason 3 1713382616477 addons.update-checker WARN HTTP Request failed for an unknown reason 2 1713382616478 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382616481 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382616483 addons.update-checker WARN HTTP Request failed for an unknown reason 2 1713382616484 addons.productaddons WARN Failed downloading XML, status: 0, channelStatus: 2152398919, errorCode: 2, reason: error 1713382616486 addons.update-checker WARN HTTP Request failed for an unknown reason 2 1713382616487 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382616489 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382616489 addons.productaddons WARN Failed downloading XML, status: 0, channelStatus: 2152398919, errorCode: 2, reason: error 1713382616493 addons.update-checker WARN HTTP Request failed for an unknown reason 2 1713382616494 addons.update-checker WARN HTTP Request failed for an unknown reason 2 1713382616495 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382616497 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382616502 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382616503 addons.update-checker WARN HTTP Request failed for an unknown reason 2 1713382616504 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382616507 addons.update-checker WARN HTTP Request failed for an unknown reason 2 1713382616512 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382616514 addons.update-checker WARN HTTP Request failed for an unknown reason 1713382617489 addons.update-checker WARN HTTP Request failed for an unknown reason HTTPS-Only Mode: Not upgrading insecure request “http://r3.o.lencr.org/” because it is exempt.

Asked by _dolphins 1 day ago

Answered by _dolphins 9 hours ago

  • Solved
  • Locked
  • Archived

"Enter" don't execute search in Firefox

Today 05-08-2023 when useing Firefox, im no longer able to use enter key to execute a simple google search. But it works fine on Edge. I don't want to be forced to switch… (read more)

Today 05-08-2023 when useing Firefox, im no longer able to use enter key to execute a simple google search. But it works fine on Edge. I don't want to be forced to switch to Edge, how to i fix it?? it just happened randomly. More precisely it's the center of screen search-bar that don't work. I can still use the standard (top) search-bar

I have already tried to update it, close it, nothing works. And i would really like to not lose all my settings by uninstalling it.

Asked by jesperbobbel 8 months ago

Answered by valentinesire 8 months ago

  • Locked
  • Archived

Unable to type a "space"

When typing comments on a web blog, after the spacebar is used, the first letter of the next word eliminates the previously typed space. So what I end up with is all word… (read more)

When typing comments on a web blog, after the spacebar is used, the first letter of the next word eliminates the previously typed space. So what I end up with is all words in a sentence running together. Tried other browsers and they work fine. Changed keyboard as well no joy. Typing is normal in applications like adobe, word, etc..... Only happens during Firefox use......... Uninstalled and reinstalled Firefox, also no help..... How do I fix ?

Asked by doej79779 1 year ago

Last reply by cor-el 1 year ago

  • Solved
  • Locked
  • Archived

Tabs on Bottom

Hi Running Firefox 71.0 (64 bit) Well seems Firefox has been messing this up again. Anyone have the new work around solution to get my tabs back on the bottom again. T… (read more)

Hi

Running Firefox 71.0 (64 bit)

Well seems Firefox has been messing this up again.

Anyone have the new work around solution to get my tabs back on the bottom again. They were fine this morning then shut down and went out to lunch and when I came back they were back on the top again after months of being where I wanted them below my bookmark bar.

Thoughts on this?

Thanks Dave

Asked by scottish2 4 years ago

Answered by cor-el 4 years ago

  • Solved
  • Locked
  • Archived

[SOLVED] Firefox account not syncing Gravatar photo

Hi, On September 15, 2022 I created this thread here on Firefox Support Forum and now I finally have an answer to the question, but as we can see my thread was archived … (read more)

Hi,

On September 15, 2022 I created this thread here on Firefox Support Forum and now I finally have an answer to the question, but as we can see my thread was archived and I can't update anything, so I decided to create a new thread just to mark my previous question as solved and bring it an answer.

I contacted Mozilla Firefox developers and got a response: Firefox is no longer integrated with Gravatar. Considering this, I can tranquilly say there is no bug or problem with my account as I thought. It's a pity that Firefox no longer support Gravatar integration, and even if I use an old version I will face the same "issue" because the Gravatar integration was a online feature linked to the Firefox account*, not to the browser itself.

Info source: https://github.com/mozilla/fxa/issues/15665

- - -

Admins can now archive and close this thread, I only ask to keep it online to help who may need this information in the future. Thanks.

  • Actually I made a mistake when I wrote this, the Gravatar integration was an online feature linked to the Mozilla account, not Firefox. James explained the distinction on #4 post of the current thread.

Last edit: On January 31, 2023 I created this thread on r/firefox but no one answered precisely. This current thread here on Firefox Support Forum also solves what was asked on reddit. The thread created on January 31, 2023 and posted on r/firefox was archived as well, like what happened to my thread with the same theme here on Firefox Support Forum, then I also created a new thread on r/firefox to mark my question as solved.

Asked by Janderson James 8 months ago

Answered by Janderson James 8 months ago

  • Solved
  • Locked
  • Archived

Image corrupt or truncated In DevTools Firefox

Hi, Hope you all are doing well. I recently checked my website [removed] on different browsers. Website is working fine with most of the browser, but when i checked it on… (read more)

Hi, Hope you all are doing well. I recently checked my website [removed] on different browsers. Website is working fine with most of the browser, but when i checked it on Firefox i got an error in DevTools "Image corrupt or truncated". What does it mean? This is a category image and present on sidebar of website. But all other images are same, i mean with same size and format. Why exactly this image is creating an issue?

Kind Regards, Hassan Mujtaba

Asked by info.apktank 6 months ago

Answered by cor-el 6 months ago

  • Solved
  • Locked
  • Archived

The Back Button doesn't work on Youtube.

I noticed that someone else had this question, but instead of answering it, it just got archived. When browsing Youtube, the browser Back Button doesn't work. For examp… (read more)

I noticed that someone else had this question, but instead of answering it, it just got archived.

When browsing Youtube, the browser Back Button doesn't work. For example, if I start on the Youtube main page, then click on a video, it will show the video. But then, when I click the browser's "Back" navigation buttion, it does not take me back to the main page. The URL in the address bar will be the main page, but it will continue to display the video I just watched instead.

This only seems to happen on Youtube. It's been a problem for a while - possibly as much as 2 years or even more. And it doesn't happen every single time. However, it has been happening a lot more frequently lately.

It's almost as if Firefox just doesn't want to refresh.

I've tried clearing the cache. The problem persists. I've dried disabling all add-ons. It still happens. I've tried running it in troubleshooting mode. Still a problem.

I've tried to duplicate this in Microsoft Edge; it doesn't seem to happen there.

Asked by r.thomas.wright 8 months ago

Answered by r.thomas.wright 8 months ago

  • Solved
  • Locked
  • Archived

New tab "+" missing from tab bar with with 20 tabs or more

After the latest update (117.0 64-bit) I now do not see the '+' sign in the tab bar. I have 40 tabs open (please, no negativity - it's always worked for me), but if I cl… (read more)

After the latest update (117.0 64-bit) I now do not see the '+' sign in the tab bar. I have 40 tabs open (please, no negativity - it's always worked for me), but if I close all of the tabs it reappears. Re-open the original 42 tabs and it's gone again. Close them and it reappears, etc. Now for the fun bit: starting from scratch with a new window - the '+' is there, but open 20 more tabs and it goes.

Asked by trgz 7 months ago

Answered by cor-el 7 months ago

  • Locked
  • Archived

Firefox spyware

When I launch Firefox (version 115.0.1), it establishes and maintains multiple connections to '*.googleusercontent.com' until I close Firefox. This is bull shit is totall… (read more)

When I launch Firefox (version 115.0.1), it establishes and maintains multiple connections to '*.googleusercontent.com' until I close Firefox. This is bull shit is totally unacceptable. I have been using Firefox since version 1.0.6 but I will dump Firefox for another web browser if this problem cannot be fixed.

How do I stop these connections being made?

Asked by kolusion1 9 months ago

Last reply by mozel3 8 months ago

  • Locked
  • Archived

Can the Firefox profile manager be used with portableapps

I hope this applies here. I tried using the "-p" command fro Librewolf. Wiped out my sessions and settings. Is there a way to do this in Firefox and or Librewolf? … (read more)

I hope this applies here. I tried using the "-p" command fro Librewolf. Wiped out my sessions and settings.

Is there a way to do this in Firefox and or Librewolf?

Asked by noel_envode 7 months ago

Last reply by Paul 7 months ago

  • Locked

Urgent Assistance Needed: WordPress Plugin Compatibility Issue with Firefox on Finance and Real Estate Website

We're reaching out to our valued community members for urgent assistance with a technical issue affecting our website, dedicated to providing crucial insights into the re… (read more)

We're reaching out to our valued community members for urgent assistance with a technical issue affecting our website, dedicated to providing crucial insights into the realms of home loans, home refinance, VA loans, and mortgage loans.

Recently, we've observed that some of our WordPress plugins are encountering compatibility issues specifically when accessed through the Firefox browser. This concern is impacting the seamless functionality of certain features on our site. Here are a few key details:

Issue: Some WordPress plugins not functioning correctly on Firefox. Website Focus: Finance and Real Estate, covering topics such as home loans, home refinance, VA loans, and mortgage loans. Request: Seeking advice and expertise from the community to address the compatibility issue.

If you have experience in resolving browser-specific plugin issues or insights into ensuring cross-browser compatibility, please share your knowledge. Your assistance will not only benefit our website but also contribute to the broader understanding of maintaining optimal functionality in finance and real estate platforms.

Asked by Michael Wheeler 4 months ago

Last reply by Dayle Stain 4 months ago

  • Locked

XUL Runner This profile was last used with a newer version of this application. Please create a new profile.

What am I supposed to do about this new problem? "XUL Runner This profile was last used with a newer version of this application. Please create a new profile." I did cr… (read more)

What am I supposed to do about this new problem?

"XUL Runner This profile was last used with a newer version of this application. Please create a new profile." I did create a new profile. I have like 4 different profiles now from every time I've had to reinstall Firefox because it keeps crashing and freezing.

Asked by Rafael Lecuona 4 months ago

Last reply by jscher2000 - Support Volunteer 4 months ago

  • Solved
  • Locked

Fixed - After A Bookmarks' Library [Restore] Function, Tag Bookmark Names & Folders Show Duplicated

Something went wrong w/ the mouse, some of my tags disappeared & wasn't able to recover them via Ctrl+Z, so I decided to perform my 1st [Restore] (never had to do 1 b… (read more)

Something went wrong w/ the mouse, some of my tags disappeared & wasn't able to recover them via Ctrl+Z, so I decided to perform my 1st [Restore] (never had to do 1 before), since I had just recently done an [Export Bookmarks] & a [Backup]. Everything seems to have gone Ok, except that for every tag, all of the bookmarks listed under the [Name] column are duplicated. When I right-click & [Show In Folder], they both show in the same folder. When going onto their folder, they are only shown once, so there are no duplicates there. When I attempt to [Delete] 1 of the 2 duplicate entries they both get [Deleted], so I can only conclude that they are 1 in the same. But the question remains, "How can I fix this duplicate condition?"

Another related & interesting behavior is that, from any bookmark folder where you can clearly see there are no duplicated bookmarks, when you do a [Search] from the top-right-hand search-box, the "results" are also "duplicated", although you might need to sort them by clicking on the [Name] column control. So, I can go to any bookmark folder & clearly see that there are no duplicate bookmarks, but when you do a [Search], that's when you get duplicate entries. That leads me to believe that this is the result of the [Search] function, & thus for some odd reason the [Search] is generating "duplicate entries". And then perhaps, both the [Tag]s & the [Search] function are related.

Also, this "duplication" does not happen on newer added bookmarks, after the [Restore] was executed, & it's only a phenomenon that affects those bookmarks that were saved by the Bookmarks' Library [Backup] function, & thus this anomaly was introduced by the [Backup].

Actually, I just realized the problem is more complicated than I thought. The reason any search results in "duplicate bookmarks" is because there are 2 sets of folders, 1 set above the other, & if you don't scroll down all the way you won't see it. So that's why there are actually "2 Sets Of Bookmarks", because there are "2 Sets Of Folders", 1 above the other. The problem is that when you delete any "Duplicate Bookmark" you delete them both, & not just 1 of the 2 bookmarks.

I wonder if it would work, to "Delete All Bookmarks" & then do a [Restore]?

Could "Mozilla Support" answer that?

Don't know why every time I attempt to [Post A Reply] & get an "Error",... So I'm going to post my reply right here,...

Fix: (2024-02-19) Of course, I did some testing before I concluded what was the best approach, but since I noticed all of the "Bookmarks Folders" were duplicated under [Bookmarks Menu], an easy fix is to go to the "bottom duplicated folder", right on top of the [Other Bookmarks] folder, & "Select It" (by clicking on it) & [Delete] it (w/ the [Delete] key on your keyboard). Do this 1 by 1, until you reach the "bottom folder" of the bookmarks' folder you certainly don't want to delete. Close Firefox & then reopen it - to make sure Firefox takes care of any garbage-collection. Then do your Bookmarks' Library [Export Bookmarks To HTML] followed by a [Backup], & you are good to go.

Actually, I don't know what introduced the error. Don't know if it was Firefox's [Restore] function, or it could have been me (by accident) w/ some "unnoticed & unexpected" move of the mouse/trackball, which accidentally duplicated all of the folders w/o me noticing, & that is why all of the "Bookmarks" were "duplicated".

Happy Firefox Browsing,...

Asked by Jimmy 2 months ago

Answered by Jimmy 1 month ago

  • Solved
  • Locked

How to disable protection, or enable dark mode, for Firefox pages

I've always liked the Firefox New Tab page, with Pocket, and until today, DarkReader plugin has always worked. But now it says that it can't because the page is protecte… (read more)

I've always liked the Firefox New Tab page, with Pocket, and until today, DarkReader plugin has always worked. But now it says that it can't because the page is protected.

I tried the solution to use bookmarklets, suggested in https://support.mozilla.org/en-US/questions/1350781, but it didn't have any effect (https://sanketmehta7.github.io/DarkMode-JS-BookMark/

If I can't find a solution, I'll just ditch Pocket, and use Google as my first page, or something. Or maybe ditch Firefox, which doesn't seem to think that dark mode is important. I don't like being blinded by the light.

Asked by Jeff Learman 3 months ago

Answered by cor-el 3 months ago

  • Solved
  • Locked
  • Archived

Washington Post does not display content pages normally

Using FF 100. Last week the Washington Post suddenly will not display article content correctly. Main page is fine, but when I open a story, I get code and a page with ma… (read more)

Using FF 100. Last week the Washington Post suddenly will not display article content correctly. Main page is fine, but when I open a story, I get code and a page with many blank areas. Story content appears with small print.

No problem in Edge nor Chrome.

Asked by hcgoddard 1 year ago

Answered by -elison- 1 year ago

  • Solved
  • Locked
  • Archived

Firefox searching instead of dns resolving internal websites

I have multiple internal websites, which all follow the pattern of [site.one.two] which resolves fine using the internal DNS server i have configured by going to https://… (read more)

I have multiple internal websites, which all follow the pattern of [site.one.two] which resolves fine using the internal DNS server i have configured by going to https://site.one.two and through other programs via site.one.two, and all the [one.two] suffixes are blacklisted from being resolved with DoH in firefox, but it still forces a web-search, even with searching from address bar being turned off, instead of resolving through my local DNS server (local server resolves local domain suffixes, anything else gets resolved through cloudflare DNS). I haven't found a fix in any other forums, and there are enough unique internal addresses that manually adding each and [every site.one.two] as an exception would be something i would like to avoid. Is there any way to tell firefox to resolve through DNS first for addresses or domain suffixes?

Asked by sydmackintosh 8 months ago

Answered by jscher2000 - Support Volunteer 8 months ago