Showing questions tagged: Show all questions
  • Solved
  • Archived

firefox cannot connect to internet

I've been using Firefox 67.0 (64 bit) on Ubuntu 18.04 without problem until yesterday, when firefox stopped loading web pages. I can't even open the page for my ADSL mode… (read more)

I've been using Firefox 67.0 (64 bit) on Ubuntu 18.04 without problem until yesterday, when firefox stopped loading web pages. I can't even open the page for my ADSL modem, which is connected directly to my PC. Firefox sits there with a blank page waiting to connect, and doesn't seem to time out.

I downloaded Firefox 67.0 (64 bit) from the website and installed it in my home directory, and that version works perfectly, but the version that I installed from the Ubuntu repository does not. It looks like some kind of permission problem, but I don't know where to look. Disabling the firewall using UFW has no effect.

Asked by mrwolfe 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

No websites will load in Firefox, but will in other browsers

Using Ubuntu 18.04, 4.15.0-33-generic GNU/Linux, and Mozilla Firefox 67.0. Other browsers work fine, so it is not an internet connectivity issue. Firefox uses no proxy,… (read more)

Using Ubuntu 18.04, 4.15.0-33-generic GNU/Linux, and Mozilla Firefox 67.0. Other browsers work fine, so it is not an internet connectivity issue. Firefox uses no proxy, and has IPv6 disabled. It cannot open a local server like 192.168.1.4, so it is not a DNS resolution issue. If I run it from CLI, I get the following:

Sandbox: seccomp sandbox violation: pid 25975, tid 25983, syscall 53, args 1 1 0 139885284952128 0 139884708835328. [Child 25975, Socket Thread] WARNING: Unable to create pipe named "25975.45.480528193" in server mode error(Function not implemented).: file /build/firefox-xkwMhH/firefox-67.0+build2/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 210

Happens after a recent update, so may go back to earlier version.

Asked by schieber 2 years ago

Answered by cor-el 2 years ago

  • Archived

No webpages will load after update to 67.0

EDIT: Solved this issue by creating a new user profile via "firefox -P" in the terminal, then copying all the files and folders from the old directory file (~/.Mozilla/fi… (read more)

EDIT: Solved this issue by creating a new user profile via "firefox -P" in the terminal, then copying all the files and folders from the old directory file (~/.Mozilla/firefox/<random>.default for a default installation) to the new one. Apparently something was missing from the old user profile, though I'm not sure what.

---

Possible duplicate of https://support.mozilla.org/en-US/questions/1259761 ; I couldn't reply there for some reason.

Hello all! I'm having a strange problem after an automatic update to the newest version of Firefox on my system. I'm running Firefox 67.0 on Ubuntu 18.04.2 LTS.

Every time I try to load a webpage, the browser seems to get stuck somewhere in the process of fetching the data from the site—the page remains white and the status indicator on the bottom left is either absent or perpetually stuck on "Waiting for <host name>..." or sometimes "Connecting to <host name>...". This happens indiscriminately for new tabs and tabs that are already open but not loaded. I can load about: pages like normal, but when I go to about:addons and select "Get Add-ons", it's the same story—the online content never loads into the page.

Other browsers load all web pages like normal, as does Firefox in safe mode. Since everything worked as normal in safe mode, here are some things I've tried to fix the issue, none of which have worked:

  • Disabling all extensions.
  • Disabling hardware acceleration.
  • Switching to the default theme and renaming my userChrome.css file to make Firefox not use it (I don't have a userContent.css).
  • Disabling the JIT JavaScript compiler.
  • Disabling JavaScript altogether.

I honestly can't think of any other reason why pages would load in safe mode but not normally. Any help would be greatly appreciated. If there's any specs, log files or command line output that I should post here just let me know.

Asked by Nomen_Latinum 2 years ago

Last reply by FredMcD 2 years ago

  • Solved
  • Archived

Version 67 on Ubuntu prevents displaying ALL sites

Following the upgrade of Firefox to version 67 running on Ubuntu 16.04, no site can be displayed. All of those sites can be displayed via Chrome. Disabling plugins and ad… (read more)

Following the upgrade of Firefox to version 67 running on Ubuntu 16.04, no site can be displayed. All of those sites can be displayed via Chrome. Disabling plugins and addons has no effect on this. Rebooting the computer has no effect. There were no error messages during the upgrade.

Is this a problem with my configuration? With my installation? A bug in Firefox?

Asked by Ambyo 2 years ago

Answered by cor-el 2 years ago

  • Archived

Firefox did not launch any website

Since update to 67.0.2, firefox did not launch any website on my Kubuntu 18.02 computer. Always the dots in the tab are blinking and on the status line 'waiting for [URL]… (read more)

Since update to 67.0.2, firefox did not launch any website on my Kubuntu 18.02 computer. Always the dots in the tab are blinking and on the status line 'waiting for [URL] ....' is shown.

Any other browser works well. There is no firewall installed.

What can I do?

Asked by pmac61 2 years ago

Last reply by FredMcD 2 years ago