Showing questions tagged: Show all questions

Firefox v122 --profile option is not working properly

Hi, I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap) and when using the --profile option to specify the startup pr… (read more)

Hi,

  I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap)

and when using the --profile option to specify the startup profile it fails to start even on a NEW system that never ran Firefox if I give it a directory that resides on a mounted ext3 filesystem.

  All the permissions are OK and yet running strace I see an error and after a few second will get the

generic pop-up with the error message: (after a few seconds)

Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

 Running the SAME from /tmp works fine, but I need the profile to reside on a persistent storage area

so if the LIVE distro restarts then it can restore the previous session, bookmarks, options, etc...


============================================================
 The 2 directories were created identically and have the exact same permissions:

xubuntu@xubuntu:~$ mkdir /tmp/firefox3

xubuntu@xubuntu:~$ mkdir /media/xubuntu/sys_n01_home/mozilla/firefox3

xubuntu@xubuntu:~$ ls -ald /tmp/firefox3 drwxrwxr-x 17 xubuntu xubuntu 1080 Jan 21 22:05 /tmp/firefox3

xubuntu@xubuntu:~$ ls -ald /media/xubuntu/sys_n01_home/mozilla/firefox3 drwxrwxr-x 17 xubuntu xubuntu 4096 Jan 21 21:13 /media/xubuntu/sys_n01_home/mozilla/firefox3

============================================================

The only difference is that one is mounted on tmpfs and the other is on /dev/nvme0n1p2:

xubuntu@xubuntu:~$ df -k /tmp/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on tmpfs 32560016 351528 32208488 2% /tmp

xubuntu@xubuntu:~$ df -k /media/xubuntu/sys_n01_home/mozilla/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on /dev/nvme0n1p2 195751828 51056068 142695768 27% /media/xubuntu/sys_n01_home


============================================================

When starting firefox with the /tmp/firefox3 profile directory it works fine and starts up:

xubuntu@xubuntu:~$ firefox --profile /tmp/firefox3

newfstatat(AT_FDCWD, "/tmp/firefox3", {st_mode=S_IFDIR|0775, st_size=1040, ...}, 0) = 0 newfstatat(AT_FDCWD, "/tmp/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/tmp/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=-487933736}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0 uname({sysname="Linux", nodename="xubuntu", ...}) = 0


BUT when using the persistent storage on the real filesystem (but SAME exact permissions) it fails:

newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3", {st_mode=S_IFDIR|0775, st_size=4096, ...}, 0) = 0 newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=1519466008}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = -1 EACCES (Permission denied) close(11) = 0

Am I doing anything wrong or is this some weird startup issue / race condition in the parentlock management?

Thank you for looking into this.

  -Sanjiyan

PS: I can upload the full strace file for both scenarios if needed. Thanks again.

     running on an xubuntu distribution "22.04.2 LTS (Jammy Jellyfish)"

Asked by Sanjiyan 2 months ago

Last reply by zeroknight 2 months ago

tab crash on redirect to microsoft authentication

On all sites where I need to login with my work account I get a tab crash when the browser redirects to https://login.microsoftonline.com/ac4b0eb0-811e-4ab0-acca-8a870792… (read more)

On all sites where I need to login with my work account I get a tab crash when the browser redirects to https://login.microsoftonline.com/ac4b0eb0-811e-4ab0-acca-8a87079290dc/oauth2/v2.0/authorize?response_type=id_token&scope=user.read......

This is a recent failure (this week), that occured without any changes on my own account to Firefox developer version 121.0b2(64-bits)

I had to install google chrome to overcome this problem. Chrome has no issues with microsoft authentication.

Please solve as soon as possible, otherwise I will be switching to another browser.

Asked by chris vandert 4 months ago

Last reply by TyDraniu 4 months ago

Tab Grouping app replacement or work-around

I am trying to migrate from a very old version of Firefox (v. 55) to the current one, but there is an app that is more helpful to me that all the other features combined.… (read more)

I am trying to migrate from a very old version of Firefox (v. 55) to the current one, but there is an app that is more helpful to me that all the other features combined. That is the "Tab Grouping" app that will not run in any version of FF higher than v. 55.

In my work, which often includes a tremendous amount of research, I need to be able to quickly go from one group of tabs to another. If I had to open all these sites manually, that would take the better part of the day and frankly I don't have near the mental capacity to remember the tremendous number of tabs. I have had a couple replies (Thanks!) to this question sometime back, but unfortunately none were even close in performance.

So, can anyone direct me to an app that will allow very quick movement from different sets of windows/tab groups (please see screen shots below)? Is there anyway that I can get this app to work in Legacy mode? I have several other old apps that work perfectly well in this mode.

Asked by Wolfgang Rotbart 4 months ago

Last reply by Wolfgang 4 months ago

why do my add-ons keep getting disabled?

why do my add-ons keep getting disabled? ff keeps disabling add-ons that i have used for years and even keep a v. 5 to use the older add-ons and use the latest ff develo… (read more)

why do my add-ons keep getting disabled?

ff keeps disabling add-ons that i have used for years and even keep a v. 5 to use the older add-ons and use the latest ff developer to use w/ more modern websites. ff even disables add-ons that worked perfectly well in ff developer and does not even give me the opportunity to re-enable them like i could before.

is there any way to force my old version to let ME decide what i want disabled/enabled?

Asked by digirl 1 month ago

Last reply by cor-el 1 month ago

Firefox 122.0b9 stops responding when the file dialog is triggered

No crash report, no trace, no anything. I click "Save [insert] as...", and Firefox hangs and stops responding. Windows automatically shuts it off when clicking. Launching… (read more)

No crash report, no trace, no anything. I click "Save [insert] as...", and Firefox hangs and stops responding. Windows automatically shuts it off when clicking. Launching Firefox again sometimes says there was a problem reloading the session, but that's not guaranteed.

Asked by TheTank20 2 months ago

Last reply by zeroknight 2 months ago

New Firefox GPC 120 setting causes problems on Xfinity community forum

I just updated to Firefox 120, and tried the new GPC setting (Tell websites not to sell or share my data). I ran into a problem when I went to the Xfinity community forum… (read more)

I just updated to Firefox 120, and tried the new GPC setting (Tell websites not to sell or share my data). I ran into a problem when I went to the Xfinity community forums (https://forums.xfinity.com/) . It causes a banner on top showing they recognize the setting. There is an "X" in the corner, and some text that says "Hide this banner", but they are not active. Plus, I cannot make a new post or do a general reply (that weird forum software has both local replies to a particular post and general replies to the general thread.)

Is this a bug in Firefox, or a bug in their forum software? I attached a picture of the message it gives.

Asked by andyross 4 months ago

Last reply by zeroknight 4 months ago

Can't find downloaded file after closing the private window

Hey folks, I use the firefox developer edition and I downloaded a zip file in it's private and when the download was complete I closed the window and open the download fo… (read more)

Hey folks, I use the firefox developer edition and I downloaded a zip file in it's private and when the download was complete I closed the window and open the download folder but the file was not there I haven't change the downloads folder location

Asked by Aditya 3 months ago

Last reply by cor-el 3 months ago

Developer Edition switched to dark background and I cannot undo this setting

I change nothing in my settings and I am now on Dark background everywhere despite having: - forced the system settings (OS) to stay in light background - in about:prefer… (read more)

I change nothing in my settings and I am now on Dark background everywhere despite having: - forced the system settings (OS) to stay in light background - in about:preferences appearance I've manually selected (forced) the light background - in about:config I've tried to switch the browser.theme.content-theme to "1" (instead of "0")

this is really frustrating, I would like to get a better "reading" of what happens, as an Engineer I am happy to also squint at logs if needed, please consider adding a preference / settings change log file

Asked by looeegee 3 months ago

Last reply by cor-el 3 months ago

YouTube videos that are too bright

I have a problem on YouTube where videos are too bright, but when i click for example to save that video to watch later it has normally saturated colors. And I'm using wi… (read more)

I have a problem on YouTube where videos are too bright, but when i click for example to save that video to watch later it has normally saturated colors. And I'm using windows. On photo example1 video is too bright, but on example2 it is normal. thanks for help

Asked by bartekarchacki8 5 months ago

Last reply by Bic 1 month ago

Passwords on phone not showing up on laptop

Hello, I use the Firefox browser on my phone and laptop, and have Lockwise on my phone where all the passwords are stored. Until yesterday, all these passwords would alw… (read more)

Hello,

I use the Firefox browser on my phone and laptop, and have Lockwise on my phone where all the passwords are stored. Until yesterday, all these passwords would always appear in my Firefox browser stored passwords. Now, they only show up in Lockwise on my phone and do not show up in the phone or Laptop Firefox browser.

I have followed this guide: https://support.mozilla.org/en-US/kb/end-of-support-firefox-lockwise and am syncing passwords across devices, but this did not solve the problem.

Has anyone else encountered this and know how to fix it?

Thank you.

Asked by spampinatodesign 3 months ago

Last reply by Paul 3 months ago

Websites not working/loading because of CORS

Hello guys, so in the past 2-3 days i started facing Cross-Origin Request Blocked for a lot of websites lets take chatgpt for example, if i visit it i get: Content-Secu… (read more)

Hello guys, so in the past 2-3 days i started facing Cross-Origin Request Blocked for a lot of websites lets take chatgpt for example, if i visit it i get:

Content-Security-Policy warnings 2 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdn.oaistatic.com/_next/static/chunks/sso.74deac81d652476b.js?dpl=f90a861ef09abad575887be5d613ce15a4fdb6d9. (Reason: CORS request did not succeed). Status code: (null). The resource from “https://cdn.oaistatic.com/_next/static/chunks/sso.74deac81d652476b.js?dpl=f90a861ef09abad575887be5d613ce15a4fdb6d9” was blocked due to MIME type (“text/plain”) mismatch (X-Content-Type-Options: nosniff).

and its getting so annoying that its blocking a lot of websites, i tried chromium it works fine and works awesomely no cors no problems. I even tried to disable the firefox protection, dns over https on/off, change my main dns upstream, installed firefox developer, compete uninstall/reinstall, cache clear from installers and from firefox it self nothing is working. I will provide firefox developer edition troubleshooting information but keep in mind it doesnt work on both firefox normal and developer

Please any help would be appreciate it.

Firefox v124.0.2-1

Asked by TMU RecKLesS 1 week ago

Last reply by zeroknight 5 days ago

searches in address bar

I do not want my searches to be reflected in the address bar. I believe in prior versions of Firefox there was a checkbox to delete that provision. I'm using Firefox 12… (read more)

I do not want my searches to be reflected in the address bar. I believe in prior versions of Firefox there was a checkbox to delete that provision. I'm using Firefox 123.0 64-bit with Windows 10 and have been through the setting and more tools areas but found no way to remove that function. I did try the about:config suggestions but still have no joy.

Asked by stevespangler2008 1 month ago

Last reply by jscher2000 - Support Volunteer 1 month ago

can not play live streams at 1080p60

Only in Firefox freeze the live streams in YouTube , Twitch , etc if I set 1080p60 , however if a select 720p60 then the live stream play smoothly . ple… (read more)

Only in Firefox freeze the live streams in YouTube , Twitch , etc if I set 1080p60 , however if a select 720p60 then the live stream play smoothly .

please someone can help me ?

I already try to change somethings in about:config , but nothing change. same issue .

Asked by Ed C:\ 1 month ago

Last reply by zeroknight 1 month ago

Firefox Developer Edition starts up at a fixed position and size

I am running Firefox Developer Edition (123.0b1) on Windows 11 and every time I start Firefox it maximises and then resizes to a set size with the maximise button set to … (read more)

I am running Firefox Developer Edition (123.0b1) on Windows 11 and every time I start Firefox it maximises and then resizes to a set size with the maximise button set to restore size mode (I.e. the window thinks it is maximised). I have followed the steps detailed for this question: https://support.mozilla.org/en-US/questions/1411093 however that does not resolve my issue. This has only started recently after I turned the laptop into a tablet and back again. Once I "restore" the window and then I maximise the window it works as expected. However it is very annoying. Also if I start another instance of Firefox this new instance does not exhibit the same behavior.


Computer: HP Envy OS: Windows 11 with all current updates and as far as I can tell AI is turned off using a group policy.

Asked by graham.harris.1975 2 months ago

Last reply by zeroknight 2 months ago

How to restore cookies which have been deleated by mistake

How to restore cookies which have been deleted by mistake. I have accidently cleared all cookies from the cache. however, some of the important information from one of th… (read more)

How to restore cookies which have been deleted by mistake. I have accidently cleared all cookies from the cache. however, some of the important information from one of the softwares (Zerodha) was stored in the cache as cookies. Now the entire data is lost. How can it be recovered

Asked by Vaidhanathan R 1 month ago

Last reply by cor-el 1 month ago

Twitch - Non-Supported Browser Message

Attempting to log-in on Twitch with Firefox Browser - Developer version 122.0b9 (64-bit) is currently not possible, repeated messages are prompted by the Twitch website a… (read more)

Attempting to log-in on Twitch with Firefox Browser - Developer version 122.0b9 (64-bit) is currently not possible, repeated messages are prompted by the Twitch website about "unsupported browser" and to contact browser support to resolve this issue.

Clearing cache, disabling extensions did not work. Using regular Firefox works without issues, only noticed this being an issue after most recent update for Firefox Dev browser.

Side effect as well since update is that any Cloudflare captcha is impossible and all website that use Cloudflare to "authenticate" that I'm human just outright fail or continue indefinitely.

Asked by BiddinWar 2 months ago

Last reply by zeroknight 2 months ago

Is AdBlock scamming all Firefox users, or do you not want their partnership?

AdBlock has not made any updates for Firefox for eleven months. Do they just not care, or has Mozilla rejected them? The internet is terrible enough as it loves to scam a… (read more)

AdBlock has not made any updates for Firefox for eleven months. Do they just not care, or has Mozilla rejected them? The internet is terrible enough as it loves to scam all users on all sites.

Asked by Benjamin_Minney 3 months ago

Last reply by cor-el 3 months ago

page has infinite reloading

I'm experiencing a problem when I visit certain websites, like 'https://mui.com/x/react-data-grid/'. Every time I try to access this site, the page starts an infinite rel… (read more)

I'm experiencing a problem when I visit certain websites, like 'https://mui.com/x/react-data-grid/'. Every time I try to access this site, the page starts an infinite reloading loop, preventing me from using the website normally.

Asked by elhaddajiotmane 2 months ago

Last reply by zeroknight 2 months ago