Tabs now to small and behavior strange in FF 78.3esr

First I have to say that I absolutely HATE HATE HATE how Mozilla breaks everything with every upgrade now. Hate it. It feels like getting bent over by IE all over again… (read more)

First I have to say that I absolutely HATE HATE HATE how Mozilla breaks everything with every upgrade now. Hate it. It feels like getting bent over by IE all over again.

I upgraded from 68.something to 78.3 esr and now my tabs are teeny tiny and the one that is selected gets bigger and leaks into the web page (see pic). I already fixed the "tabs on top of everything" issue that the upgrade introduced, but now this.

How do I make my regular tabs and pinned tabs bigger like they were before? And stop the current tab from leaking over the bottom boundary into the web page?

Asked by mozilla171 1 day ago

Last reply by mozilla171 57 minutes ago

OK Button greyed out on all file downloads

Similar to this article, "https://support.mozilla.org/en-US/kb/cant-download-or-save-files" I am unable to download any files via browser. I am up to date on versioning (… (read more)

Similar to this article, "https://support.mozilla.org/en-US/kb/cant-download-or-save-files" I am unable to download any files via browser. I am up to date on versioning (Windows 10, v81.0 64-bit), and I tried all of the steps in the article.

I have also tried resetting the "security.dialog enable_delay" value (it was correct at 1000) to 0 and downloads worked again, but setting it back to 1000 (or even 500) and the problem returns.

I also noticed that whether or not I have the General Option set to "use this folder" or "ask each time", I get the same dialog box and the OK button is greyed out.

Asked by mark-k1 7 hours ago

Last reply by mark-k1 45 minutes ago

favicons colors in tabs displayed incorrectly

favicons (icons) in tabs displayed for a light firefox theme. I have a firefox black theme right now. On a black background of the firefox theme, you can not see black ic… (read more)

favicons (icons) in tabs displayed for a light firefox theme. I have a firefox black theme right now. On a black background of the firefox theme, you can not see black icons. I tried to open the same tabs in chrome with a dark theme, there is a white icon, as it should be for the same site that I opened in firefox (there was a black icon in firefox). How can I fix it?

Asked by bomimok569 59 minutes ago

DOM Inspector doesn't automatically refresh after Javascript DOM manipulation

Hello, I came across this issue in my company's web application. We have custom code that creates and populates an iframe, such as: var frm1 = document.createElement("ifr… (read more)

Hello,

I came across this issue in my company's web application. We have custom code that creates and populates an iframe, such as:

var frm1 = document.createElement("iframe"); $(frm1).css('width', width); $(frm1).css('height', height); document.body.appendChild(frm1);

When debugging the application, and executing this code step-by-step, after the appendChild call is executed, the iframe isn't visible in the Inspector tab. However, when I click the haircross icon after the iframe variable name "frm1", then the iframe will show up as expected in the Inspector tab.

In addition, this seems to affect the behaviour of the remaining code. We are using rasterizeHTML.js to render a screenshot of our web application, and it depends on the iframe being populated properly. When using Firefox, executing this code outside of debug mode, or executing it in debug mode without clicking the haircross, often results in an empty screenshot; but when the haircross is clicked and the iframe shows up in the Inspector, the screenshot will always work perfectly.

What could be the cause of this behaviour? Is it possible that Firefox is delaying the DOM operations, only forcing them when the element is directly inspected, and this subsequently causes the plugin to fail as the iframe "wasn't" initialized? Is there a way to force Firefox to execute all pending DOM operations?

Additional information that may be helpful in diagnosing:

  • The issue was tested in Firefox 81, both Windows and Mac versions. In Windows this behaviour will always happen, while in Mac it only happened when running the application in a private/incognito window.
  • The issue was also tested in the current beta version (82) and can still be reproduced there.

Thank you, Rodrigo Santos

Asked by rodrigo.santos 3 hours ago

Having Trouble Loading eBay on Firefox since July or August

Is anyone else having trouble with eBay? Since about July, when I go to eBay on Firefox, it comes up with an HTML version of the site. I can load eBay on Safari but it … (read more)

Is anyone else having trouble with eBay? Since about July, when I go to eBay on Firefox, it comes up with an HTML version of the site. I can load eBay on Safari but it is not as good. I don't want to download an install Google Chrome. Any help would be greatly appreciated. Thanks!

Asked by jcg8874 3 hours ago

Multirow bookmark toolbar won't display all bookmarks in it.

Why won't my multirow bookmarks toolbar display all of the bookmarks in it? No matter what editing I've done to the userChrome.css file in my profile, the toolbar is eit… (read more)

Why won't my multirow bookmarks toolbar display all of the bookmarks in it? No matter what editing I've done to the userChrome.css file in my profile, the toolbar is either 2 or 3 rows and simply refuses to populate the 3d row to any extent - and it should be about 5 rows long. Here is the .css file:

  1. PersonalToolbar{
 --multirow-bmb-n-rows: 5; /* Control how many rows are shown before scrolling */
 --multirow-bmb-row-margin: 4px; /* Control how much spacing is between rows */
 max-height: none !important;

}

  1. PlacesToolbar > hbox{
 display: block;
 width: 100vw;

}

  1. PlacesToolbarItems{
 display: flex;
 flex-wrap: wrap;
 /* --uc-bm-padding is defined in autohide_bookmarks_toolbar.css */
 max-height: calc(var(--multirow-bmb-n-rows) * (4px + 1em + (2 * (var(--multirow-bmb-row-margin) + var(--uc-bm-padding,2px))))) !important;
 overflow-y:auto;
 scrollbar-color: var(--lwt-accent-color) var(--toolbar-bgcolor) ;
 scrollbar-width: thin;

}

This should be doable. Can someone please help me fix this? Thanks.

Asked by webnick 5 days ago

Last reply by webnick 4 hours ago

Yougov chat

I belong to yougov chat. Sometimes this works fine in firefox. Sometimes all I get is a blank page. I have tried FF with add-ons disabled and it makes no difference so… (read more)

I belong to yougov chat. Sometimes this works fine in firefox. Sometimes all I get is a blank page. I have tried FF with add-ons disabled and it makes no difference so they aren't the problem. I have tried temporarily turning off my anti-virus (Kaspersky) and that makes no difference. I have FF tracking protection turned off for it. I have deleted all yougov cookies - no change.

I can't figure out what else to try to find the problem.

Asked by JSMH 4 hours ago

Can't edit URL in new and awful jumbo address bar

It's impossible to edit a URL in the new and terrible address bar. This is a problem, and just one tiny example among many, when a website shows a non English page beca… (read more)

It's impossible to edit a URL in the new and terrible address bar. This is a problem, and just one tiny example among many, when a website shows a non English page because I am in some other country. I used to be able to change .../de/etc. to /en-us/etc. and get the correct page. Now I have to click dots, select to copy, paste into notepad, make the change and paste-and-go.

Can this completely idiotic behavior be changed? Who is this aimed at, anyway? Address bars have worked the same for decades at this point - and whilest enhancing it is fine, disabling something as basic to ALL Windows or Mac as editing is insane.

Asked by Alex 4 days ago

Last reply by Alex 5 hours ago

Scroll-To-Top not working since update

My Scroll-To-Top is not working anymore since the last update was installed. STT is 4.9.1 and I am using FF56.0.2 64 bit. I configure STT and it says saved at the top, bu… (read more)

My Scroll-To-Top is not working anymore since the last update was installed. STT is 4.9.1 and I am using FF56.0.2 64 bit. I configure STT and it says saved at the top, but when FF reopens nothing was saved. Can anyone point me to the xpi download of a previous version please.

Asked by Rad1o 4 days ago

Last reply by Rad1o 5 hours ago

Firefox download location error

I have been facing this problem for quite sometimes. I have set the download location of Firefox browser to the Download folder of my laptop /home/inferni/Downloads. But … (read more)

I have been facing this problem for quite sometimes. I have set the download location of Firefox browser to the Download folder of my laptop /home/inferni/Downloads. But sometimes when I download any file the file gets downloaded to a different location of my laptop /tmp/mozilla_inferni0/<filename> . This gets really annoying when I have to work on the file and it is nowhere to be found in the download location of my laptop and then I have to open the browser and track the file via the download section.

I tried to reset the download location and even reinstalled the browser but of no use. Earlier I used to work on ubuntu 18.04 LTS and then I switched to Fedora 32 but still the problem persists.

Thank you!

Asked by Solomon 5 hours ago

Wie kann man sich automatisch auf Websites anmelden lassen?

Wie kann man sich automatisch anmelden lassen ohne immer wieder neu die Accountdaten einzugeben? Villeicht liegt es an der Dashlane Erweiterung auber auf der Support Webs… (read more)

Wie kann man sich automatisch anmelden lassen ohne immer wieder neu die Accountdaten einzugeben? Villeicht liegt es an der Dashlane Erweiterung auber auf der Support Website von Dashlane steht, dass es nichts mit dem Automatisch anmelden zu tun hat. Früher ging das Problemlos, aber langsam wird es lästig es immer wieder neu einzugeben. Ich freue mich auf eine Antwort von ihnen!

Asked by Tobias N. 5 hours ago

Whatsapp Web not opening on newest version of Firefox

Hi! My computer updated to the latest version of firefox and now Whatsapp Web wont open at all. When I try to load it, it simply isn't acknowledged and stays on the curre… (read more)

Hi! My computer updated to the latest version of firefox and now Whatsapp Web wont open at all. When I try to load it, it simply isn't acknowledged and stays on the current page, as if I didnt take in a proper IP or something. I dont know much about computers or systems and cant figure out what to do. Help! I need to be able to open it on the computer!

Thank you community!

Asked by bergman.danielle 6 hours ago

Disable 'open all in tabs' command?

I finally figured out why Firefox kept warning me about opening too many tabs at once: this command is the first option on the pop up menu when I click and hold a moment… (read more)

I finally figured out why Firefox kept warning me about opening too many tabs at once: this command is the first option on the pop up menu when I click and hold a moment too long on a folder that is part of my bookmarks toolbar (some of these have dozens of bookmarks)

'Open all in tabs'

this is on my Windows 10 PC using Firefox beta.

Is this a command I can hide/delete/inactivate? I'm quite certain I've never wanted to do this and probably will never want to do it, and now on a machine where I use a mouse with right click it is disturbingly easy to click this accidentally. I want to disable the command entirely.

I did check about:config and saw nothing obviously relevant.

Asked by Foxfree99 6 hours ago

Logins & Passwords

I am unable to display my username when trying to log into 'Udemy' website. Under Logins & Passwords my Username and Password is saved for this site. When I click log… (read more)

I am unable to display my username when trying to log into 'Udemy' website. Under Logins & Passwords my Username and Password is saved for this site. When I click login button, the username appears momentarily and then disappears from the login screen. I have to manually type the username each time. However, the password is retained and no issues there.

Could not find any help articles on this particular problem. Tried unclicking hardware acceleration. Still no change.

Other websites appear to function properly except 'udemy'. Is this due to settings in FireFox or something not right with 'udemy' website?

Asked by Paul 9 hours ago

New tab page does not keep my most used tiles for very long, yet ancient tiles are holding their ground.

I have a couple questions about the New Tab page: I can't figure out a way, or if it's possible to make my homepage be what a new tab opens up to. When I first launc… (read more)

I have a couple questions about the New Tab page:

    I can't figure out a way, or if it's possible to make my homepage be what a new tab opens up to.  When I first launch Firefox, it goes to the page I specified in Options.  But when I open a new tab, I have to click the home (shaped) icon to get there.  Is there a way to do this in one click instead of two?  This isn't a huge problem, but I seem to remember that I had that working in the past.  Just wanted to see what the reality of this is.
  The main reason I'm here is because the New Tab page has finally gotten the better of me.  I have 8 X 4 tiles on the New Tab page and quite a few of them are sites I only visited once or twice in the distant past (6 months to 9 or 12 or more).  But my email site (which I visit far more frequently than all the others combined) comes and goes.  One time, I thought it might be "just below the surface" and if I started deleting tiles it would come to the top.  I spent a good 10 or 20 minutes deleting tiles but only even older sites would appear.  Even if it can't be fixed, it would help my mental health to know that this is an actual known occurrence and not some elaborate cloak-and-dagger conspiracy to make me nuts!  (am not actual conspiracy lunatic, just questionable sense of humor)

Asked by Beavis 9 hours ago

Transferred bookmarks to a new profile but all the icons are missing

I've just set up a brand new profile and copied all my important user data across, including the bookmarks (places.sqlite). But now my bookmarks have no icons? I have ove… (read more)

I've just set up a brand new profile and copied all my important user data across, including the bookmarks (places.sqlite).

But now my bookmarks have no icons?

I have over 25,000 bookmarks so I don't want to have to load them all in order to get the icons back!

Asked by MartyJames 9 hours ago