Why are some requests in a page being blocked?

When I use Firefox 78 all requests are allowed. When I use FF 79, some (few) requests are blocked. Those requests break the page from loading properly. There are no messa… (read more)

When I use Firefox 78 all requests are allowed. When I use FF 79, some (few) requests are blocked. Those requests break the page from loading properly. There are no messages in the console that suggest anything is being blocked. And the network tab just shows "blocked" on the request with no indication why it was blocked. I have not requested those URLs be blocked and the context menu has no "Unblock" option. Other requests that were slightly before and very similar looking were not blocked, some that come after and look similar are not blocked.

I have disabled all blocking features in Security & Privacy. Still blocked. (I don't think it was S&P blocking, there are no warnings etc.)

Otherwise, this an "out of the box" install with no changes made. Myself and a colleague are having the same problem with the same URLs being blocked. Other browsers, and earlier versions of FF are fine. Only FF 79 is experiencing the problem. I read the release notes, nothing stood out to me as a reason to block anything without an explanation.

(You won't be able to browse to our Jira, we 403 any requests from the internet. And these resources causing the problem are only needed after you login.)

Any suggestions on how to work out why those specific requests are blocked??

Asked by max_allan 6 days ago

Last reply by max_allan 6 days ago

Images do not display when opened in a new tab, instead downloads.

When i try to look at an image on firefox in it's own tab so i can see it bigger, it instead opts to download it instead of just showing it in the tab itself. This is ann… (read more)

When i try to look at an image on firefox in it's own tab so i can see it bigger, it instead opts to download it instead of just showing it in the tab itself. This is annoying as I don't want to have to make a whole folder just for images that i've seen once and then never look at again. is there an option i might have chosen at some point that enables this? i'm not too sure. please help if someone is able to.

Asked by EnderDaveMC77 6 days ago

Last reply by EnderDaveMC77 6 days ago

Connecting to localhost in Single Site Browser (SSB) mode

I have a basic html index page being served by Ubuntu/Apache at `https://localhost/test.html`. I have `browser.enabled.ssb` set to `true` in about config. When I open a r… (read more)

I have a basic html index page being served by Ubuntu/Apache at `https://localhost/test.html`. I have `browser.enabled.ssb` set to `true` in about config.

When I open a regular browser window (Firefox 78.0.2) I can navigate to, and load `https://localhost/test.html` no problem but when I run `firefox --profile /home/ubuntu/.mozilla/firefox/a5pwja44.default-release --ssb https://localhost/test.html` I get a connection error. (This is the same profile I'm using when I open a new browser window).

Anybody know why this doesn't work or how to fix?

Asked by db10 6 days ago

Last reply by db10 5 days ago

"We're sorry Firefox had a problem and crashed - same fleeting pop-up every time I close down the computer

I use Xubuntu OS and installed Firefox from there many 4 months ago on this my new laptop, from Ubuntu repos. I now do not know what version it was. About a month ago I n… (read more)

I use Xubuntu OS and installed Firefox from there many 4 months ago on this my new laptop, from Ubuntu repos. I now do not know what version it was.

About a month ago I noticed that every time I closed down the computer I saw a flashing image of what appeared to be a message from Firefox. It disappeared before I could read what it was about.

I uninstalled Firefox totally yesterday by purging the system, deleting the folders/files in /etc and /usr relating to it. I downloaded it from repos and installed it again However, the flashing image still appears every time I close down.

I decided to video the close down to pause it and see what this message was about. It was as I said in the subject above. I found two crash reports in about:crashes and have submitted them.

Please tell me how to stop this repeating message.

Also, when uninstalling Firefox I saved the logins and passwords but was unable to use the resulting csv to recover them. Is there a better way than manually?

Asked by theno2soco1 6 days ago

Last reply by theno2soco1 5 days ago

Menu Bar with a Unified Look Possible?

Firefox 78.1 ESR W7 Is there any way to get the menu bar to have a unified appearance? Solid background mixed with a transparent one is not very nice looking. It would l… (read more)

Firefox 78.1 ESR W7

Is there any way to get the menu bar to have a unified appearance? Solid background mixed with a transparent one is not very nice looking. It would look much better if the solid background were also transparent. Anyone have a .css or other solution?

Asked by click-click 5 days ago

Last reply by click-click 5 days ago

Hidden window

I have 3 Firefox windows open. Suddenly, one window is hidden until I click on the icon. Clicking on the icon switches the screen between the one window, and the other tw… (read more)

I have 3 Firefox windows open. Suddenly, one window is hidden until I click on the icon. Clicking on the icon switches the screen between the one window, and the other two windows and my mail program.

Asked by karen_street 4 days ago

Last reply by karen_street 3 days ago

Input delay in search field on Google-related sites

I'm using Firefox 79.0 on Win10 x64. When I'm searching on Google, Facebook or Youtube, there is a 10-20 seconds delay between my input and its display in search field, a… (read more)

I'm using Firefox 79.0 on Win10 x64. When I'm searching on Google, Facebook or Youtube, there is a 10-20 seconds delay between my input and its display in search field, and it's displaying symbols I entered at 1 symbol in 1-2 seconds. After around a minute the delay cuts to minimal and I can use the search normally (but by that time site is already responding to the earlier input which sometimes can be in wrong keyboard layout or misspelled because I didn't see what I was typing until 1 minute after I typed it). I don't have this problems at the websites that are not Google-related, also I don't have it in other browsers. I've tried restarting Firefox (obviously, as this problem persists for weeks now) and/or clearing cache, didn't help.

Asked by Daniela Chris 4 days ago

Last reply by Daniela Chris 4 days ago

Firefox caused(?) Blue screen of Death

Hello, I've experienced a blue screen of death on my machine as listed below, which seems to point that Firefox.exe is the starting point of the BSOD. I had around 8 tabs… (read more)

Hello,

I've experienced a blue screen of death on my machine as listed below, which seems to point that Firefox.exe is the starting point of the BSOD.

I had around 8 tabs open at the time of which 2-3 Twitch.tv channels, Private mode tabs with several websites with a variance of content-typed on them.

However, I had these open in the background while I was playing a game and at some point my computer just rebooted.

It hasn't happened another time (yet) and it is the first time I've had a BSOD for quite some time so it kind of scared me.

I had Hardware Acceleration turned on and Content Process limit was set to 8(Default).

The Nvidia drivers I have installed are: 451.67 (09-07-2020)

*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_SERVICE_EXCEPTION (3b)
An exception happened while executing a system service routine.
Arguments:
Arg1: 00000000c0000005, Exception code that caused the bugcheck
Arg2: fffff802404d800c, Address of the instruction which caused the bugcheck
Arg3: ffff8283464fef90, Address of the context record for the exception that caused the bugcheck
Arg4: 0000000000000000, zero.

Debugging Details:
------------------


KEY_VALUES_STRING: 1

    Key  : Analysis.CPU.Sec
    Value: 2

    Key  : Analysis.DebugAnalysisProvider.CPP
    Value: Create: 8007007e on MIYA

    Key  : Analysis.DebugData
    Value: CreateObject

    Key  : Analysis.DebugModel
    Value: CreateObject

    Key  : Analysis.Elapsed.Sec
    Value: 2

    Key  : Analysis.Memory.CommitPeak.Mb
    Value: 78

    Key  : Analysis.System
    Value: CreateObject


BUGCHECK_CODE:  3b

BUGCHECK_P1: c0000005

BUGCHECK_P2: fffff802404d800c

BUGCHECK_P3: ffff8283464fef90

BUGCHECK_P4: 0

CONTEXT:  ffff8283464fef90 -- (.cxr 0xffff8283464fef90)
rax=0000000000000000 rbx=ffffce0d5ea36080 rcx=fffffffffffffffd
rdx=0000000000000000 rsi=ffffce0d5d3a4080 rdi=0000000000000000
rip=fffff802404d800c rsp=ffff8283464ff998 rbp=ffff8283464ffa80
 r8=ffff95046faf9001  r9=000002016af88590 r10=fffff8024086e2e0
r11=00000000005a3c10 r12=0000020183abe000 r13=0000020183d14078
r14=ffff8283464ffa08 r15=0000000000000001
iopl=0         nv up ei ng nz na pe nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00050282
nt!PsGetCurrentServerSilo+0x2c:
fffff802`404d800c c3              ret
Resetting default scope

BLACKBOXBSD: 1 (!blackboxbsd)


BLACKBOXNTFS: 1 (!blackboxntfs)


BLACKBOXPNP: 1 (!blackboxpnp)


BLACKBOXWINLOGON: 1

CUSTOMER_CRASH_COUNT:  1

'''PROCESS_NAME:  firefox.exe'''

STACK_TEXT:  
ffff8283`464ff998 fffff802`40870c4c : ffffce0d`5d3a4080 ffff8283`464ffa80 ffffce0d`5d3a4080 00000000`00000000 : nt!PsGetCurrentServerSilo+0x2c
ffff8283`464ff9a0 fffff802`4086e304 : ffffce0d`5d3a4080 00000201`73938600 00000000`00000000 00000201`8fa00000 : nt!PsLookupThreadByThreadId+0x3c
ffff8283`464ff9d0 fffff802`405ef475 : ffffce0d`5d3a4080 00000000`00000000 00000000`00000000 00000000`00000000 : nt!NtAlertThreadByThreadId+0x24
ffff8283`464ffa00 00007ff8`4810bb84 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x25
0000005f`fadff848 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x00007ff8`4810bb84


SYMBOL_NAME:  nt!PsGetCurrentServerSilo+2c

MODULE_NAME: nt

IMAGE_NAME:  ntkrnlmp.exe

IMAGE_VERSION:  10.0.19041.388

STACK_COMMAND:  .cxr 0xffff8283464fef90 ; kb

BUCKET_ID_FUNC_OFFSET:  2c

FAILURE_BUCKET_ID:  0x3B_c0000005_nt!PsGetCurrentServerSilo

OS_VERSION:  10.0.19041.1

BUILDLAB_STR:  vb_release

OSPLATFORM_TYPE:  x64

OSNAME:  Windows 10

FAILURE_ID_HASH:  {ca3838bc-6517-b4b6-f083-461080433ddb}

Followup:     MachineOwner
---------

Asked by cosplayking 4 days ago

Last reply by cosplayking 4 days ago

Preventing unwanted animations from playing

Certain URLs like https://smile.amazon.com/s?k=face+shield often include an advertising animation that can't be avoided or stopped. Or at least I haven't found a way. If… (read more)

Certain URLs like https://smile.amazon.com/s?k=face+shield often include an advertising animation that can't be avoided or stopped. Or at least I haven't found a way. If there is, I and a bunch of people I mentioned this to would like to know how. Am using FFox 79.0 64-bit on Windows 10.

Asked by ronks1 3 days ago

Last reply by ronks1 3 days ago

Firefox browser

Firefox try's to restore session when I open it. The option is not set, I have reloaded windows, reloaded Firefox and restored Firefox. None of which helped. I have ch… (read more)

Firefox try's to restore session when I open it. The option is not set, I have reloaded windows, reloaded Firefox and restored Firefox. None of which helped. I have checked the profile, cycled the option to no avail. I am on an HP computer, no help from their tech support, Win 10 , Tech support ?$?, and one previous try on this forum. Anyone got anything, please?

Asked by tom.small 3 days ago

Last reply by tom.small 2 days ago

Firefox will not run on Mac Catalina 10.15.6

I have used Firefox since before it was called Firefox. For the last 3 years I have been using it without problem on my 2017 iMac 27". Suddenly a few days ago I started… (read more)

I have used Firefox since before it was called Firefox. For the last 3 years I have been using it without problem on my 2017 iMac 27". Suddenly a few days ago I started getting this a message 'The application “Firefox.app” can’t be opened.' I have uninstalled, including removing all folders and files containing Firefox or Mozilla and reinstalled versions 75.0b9, 79.0 and 80.ob5. None of which worked. None will open in safe mode. However, if I boot my computer in safe mode, it works. Return to standard mode and nothing. I have followed every suggestion I can find on Firefox's site and Apple's site. It just plain doesn't work. I love Firefox, hate Safari and tolerate Chrome. I would appreciate some help.

Asked by Dan_Moss 3 days ago

Last reply by Dan_Moss 19 hours ago

Bookmarks toolbar - I have to click twice to navigate to it

Hi, Recently I noticed this issue: 1. I start Firefox. 2. I click on a bookmark which is on the bookmark toolbar. 3. The page seems to initiate navigation to that bookmar… (read more)

Hi,

Recently I noticed this issue:

1. I start Firefox. 2. I click on a bookmark which is on the bookmark toolbar. 3. The page seems to initiate navigation to that bookmark, but eventually stays (it never navigates). 4. I click again on the same bookmark. 5. Then, Firefox navigates to it.

I tried disabling Addons and disabling Hardware Acceleration, but it didn't help to fix the issue. This was suggested in this archived thread: https://support.mozilla.org/en-US/questions/1245362

A similar issue happens when I'm already in GMail website and then click on another bookmark, but it refreshes the GMail instead of navigating to the other bookmark. (I hope to reproduce it soon and tell you the results.)

Using Ubuntu 18.04.

Asked by TechiMan 3 days ago

Last reply by TechiMan 2 days ago

Ebay.com does not show up in html it shows up as a txt file with txt links.

Please tell me how to fix ebay.com so it shows up in html. I don't know why that site is the only one that does that but it's strange and unusable like that. thank you! … (read more)

Please tell me how to fix ebay.com so it shows up in html. I don't know why that site is the only one that does that but it's strange and unusable like that.

thank you!

Asked by donna23 3 days ago

Last reply by donna23 2 days ago

As of 08/04/2020, Firefox is crashing on my Windows 10 computer

I followed your instructions with the following results: 1) https://support.mozilla.org/t5/Firefox-crashes/Mozilla-Crash-Reporter/ta-p/1715 Page Not Found 2) %APPDATA%… (read more)

I followed your instructions with the following results:


1) https://support.mozilla.org/t5/Firefox-crashes/Mozilla-Crash-Reporter/ta-p/1715

Page Not Found

2) %APPDATA%\Mozilla\Firefox\Crash Reports\submitted

    Windows can't find  %APPDATA%\Mozilla\Firefox\Crash Reports\submitted. Check the spelling and try again.

3) Error still occurs: Firefox is already running, but is not responding. The old Firefox process must be closed to open a new window.

I have 1) uninstalled/reinstalled Firefox 2) powered down and rebooted

Nothing gets resolved.

Asked by TekMan 2 days ago

Last reply by TekMan 1 day ago

Transferring data from maps.googleapis.com... slows Firefox. Why?

I see the message I've quoted in the subject line "Transferring data from maps.googleapis.com..." in the status bar when I'm on the site of the public library near me. I … (read more)

I see the message I've quoted in the subject line "Transferring data from maps.googleapis.com..." in the status bar when I'm on the site of the public library near me. I am not doing anything with Google Maps. Google Maps is not open in another tab, I have closed Firefox and restarted since the last time I used Google Maps.

I wouldn't care if it didn't slow down Firefox. Sometimes it's stuck there for 30 seconds or more on an otherwise fast connection. Thanks.

Asked by Len 2 days ago

Last reply by Len 2 days ago