PDF download - preserve whitespace in file name

When I open a PDF file in firefox, click the download button, and assign a filename with multiple consecutive spaces in the name, firefox changes the spaces to a single s… (read more)

When I open a PDF file in firefox, click the download button, and assign a filename with multiple consecutive spaces in the name, firefox changes the spaces to a single space.

"asdf asdf.pdf" becomes "asdf asdf.pdf"

How do I fix this?

Asked by sc 6 days ago

very slow seems to be using google analytics. my hope was to get away from google.

This is your slow Google connected browser, and you are asking ME how to fix it? or maybe I should spend 2 or 3 days reading how to get around all the problems, making no… (read more)

This is your slow Google connected browser, and you are asking ME how to fix it? or maybe I should spend 2 or 3 days reading how to get around all the problems, making notes for future reference? LOL I despise google but at least their chrome browser is intuitive. i am really disappointed in firefox browser. I used my microsoft account account to login to SKYPE i did the I am not a robot over 20 times, never got any help or tips from firefox, I did install something that was supposed to make youtube perform better. valid passwords did not work, and were not saved or rather There was no pop up asking if I wanted to save. I was dumb enough to think I could get away from Google! Firefox and duckduckgo are slow versions of Google Chrome etc on and on........

Asked by trueself11 6 days ago

Stop loading some pinned tabs when Firefox starts

How can I stop loading some pinned tabs when Firefox starts? I know I can set about:config to not load all pinned tabs. What I want to do is not load some specific pinned… (read more)

How can I stop loading some pinned tabs when Firefox starts? I know I can set about:config to not load all pinned tabs. What I want to do is not load some specific pinned tabs instead of all pinned tabs. I made a simple addon like the one I attached and tested it, but some tabs are loaded. I have tested this code with about 10 tabs pinned. (When I actually create the addon, I would run browser.tabs.discard() with a specific tab, but this will stop loading all tabs for testing.) This is unstable. Is there any sure way to stop the load?

--- manifest.json {

   "manifest_version": 2,
   "name": "discard test",
   "version": "1.0.0.0",
   "permissions": [

"tabs"

   ],
   "background": {

"scripts": [ "background.js" ]

   }

}

--- background.js browser.runtime.onStartup.addListener(discard_pinned_tabs); function discard_pinned_tabs() {

   browser.tabs.query({pinned: true}).then(async tabs => {

for (let tab of tabs) { await browser.tabs.discard(tab.id);

	    console.log(tab.index, tab.id, tab.discarded, tab.title, tab);

}

   });

}

// browser.tabs.query({pinned: true}).then(async tabs => { // for (let tab of tabs) { // await browser.tabs.discard(tab.id); // console.log(tab.index, tab.id, tab.discarded, tab.title, tab); // } // });

setTimeout(() => {

   browser.tabs.query({pinned: true}).then(tabs => {

for (let tab of tabs) { if (!tab.discarded) { console.log(tab.index, tab.id, tab.discarded, tab.title, tab); } }

   });

}, 5000);

Asked by 馬謖 6 days ago

double tap Apple magic mouse to zoom in?

Hi coming from Chrome I double tapped my magic mouse to zoom in on an area of a page - is this possible on Firefox? I found the "pinch to zoom" add on however that is for… (read more)

Hi coming from Chrome I double tapped my magic mouse to zoom in on an area of a page - is this possible on Firefox?

I found the "pinch to zoom" add on however that is for the Apple trackpad. I can zoom in with CONTROL & scoll on a Mac, though it doesnt zoom in like it did on Chromium based browsers.

Asked by info2711 6 days ago

facebook videos to large in firefox

I can see the entire video i posted from another person that i shared on all other browsers edge IE nad Chrome but not in firefox i have disabled all add on refresh… (read more)

I can see the entire video i posted from another person that i shared on all other browsers edge IE nad Chrome but not in firefox i have disabled all add on refreshed it and can not see entire video on my page it is so ig 1080 how do i ake it fit in firefox

Asked by Mary 6 days ago

appending DNS whitelist automatically

So in my lan which consists of multiple homes, and over 50 devices. With 77 breaking address bar from being an address bar first. I have been getting reports of internal … (read more)

So in my lan which consists of multiple homes, and over 50 devices.

With 77 breaking address bar from being an address bar first. I have been getting reports of internal sites not coming up initially and leaking internal site urls to Google (which I now have to find a way to get them to delete)

I know there exists solutions for corporate environments where all the devices are owned by a single entity.

But the devices are owned by users and is there anyway I can push an appended tld Whitelist without the users having to manually make any changes other than use the internal DHCP and DNS server?

Asked by zachary_daltorio 6 days ago

Bluetooth remote volume control not working when streaming from FireFox.

Suddenly the volume control on remote Bluetooth Bose speakers quit working when streaming from FireFox, but continue to work with all Microsoft programs. Now I can chang… (read more)

Suddenly the volume control on remote Bluetooth Bose speakers quit working when streaming from FireFox, but continue to work with all Microsoft programs. Now I can change the volume of the Bose speakers using the laptop volume control, but no effect with the remote speaker volume control. This happened about the same day that the new Edge was automatically installed by Microsoft on a Win10 laptop. The same websites Bluetooth to the Bose from Edge with full remote volume and computer volume control as do files stored on the laptop played through a Microsoft music player. Funny how that tempts one to change the default to Edge -- conspiracy? Is there something I can tweak either in Bluetooth or in FireFox? Jon I have now confirmed that the problem is with FireFox and not with the bluetooth Bose speakers. The pause/play and volume buttons on the Bose speakers work with Chrome, Edge and Safari as well as music players from Win10 and an iPad -- but do not work from any of those devices with FireFox. Is there something I need to do to FireFox on my end, or is it just broken? Jon

Asked by EakesJ 6 days ago

Failed to Load Module Twitch.tv

For the past month or so I cannot get Twitch.tv to work at all. I consistently get the error message on the site called "Failed to Load Module". Sometimes it loads but fo… (read more)

For the past month or so I cannot get Twitch.tv to work at all. I consistently get the error message on the site called "Failed to Load Module". Sometimes it loads but for the most part it doesn't, and when it does load it usually takes awhile. I've cleared cookies and data history, removed and disabled extensions. Flushed DNS cache. Nothing seems to work. I can get it working on Chrome but not Mozilla. Anyone else having this issue?

Asked by antbassolino 5 days ago

Firefox prevented this page from loading in this way because the page has a content security policy that disallows it

When I go to www.yellowstone.net and try to look at the live stream of Old Faithful I get this message "Firefox prevented this page from loading in this way because the p… (read more)

When I go to www.yellowstone.net and try to look at the live stream of Old Faithful I get this message "Firefox prevented this page from loading in this way because the page has a content security policy that disallows it" This just started happening as I was able to view this site lats week. What do I need to do to be able to fix this issue.

Asked by ecunnar 5 days ago

New Tabs are blank and unable to load pages. Tabs get stuck failing to load pages forever in this state

Recently, Firefox on my main PC has been having trouble opening pages. The same thing happens on my office PC, but less frequently. Today it's come to a point where over … (read more)

Recently, Firefox on my main PC has been having trouble opening pages. The same thing happens on my office PC, but less frequently.

Today it's come to a point where over 50% of the time I try to open a "New Tab" or open a link in a new tab, that new tab will get stuck in a state where it's either showing the URL and making no attempt to load the page, just showing a blank white page (which is wrong, I set it Firefox Home, but it happens with FF:Home or Blank).

I've tried refreshing Firefox, it hasn't made a difference. IF anything the problem is just getting worse and the browser is becoming more and more unusable.

Can anyone help me troubleshoot this? I'm wondering if it's specific to my add-on setup. It shouldn't be, I spent ages disabling add-ons one-by-one to see if it made a difference, then I found the problem even occurs in safe mode / all add-ons disabled.

Is it a recent problem with Firefox? I recall this happenning with an update maybe a year or two ago then it resolved itself, but lately the browser is becoming un-usable for me. Before, when I had tabs jammed like this, I could copy the URL and paste it into a new tab to get back to browsing, but now all the new tabs in my current session are broken like this.

Asked by voodle 5 days ago

Web Developer/Network isn't showing POSTs

I'm trying to debug a network problem and I'm using the WebDeveloper/Network stuff to do it , this on FF77.0.1 on win10. It seems to be simple form stuff, but I can't c… (read more)

I'm trying to debug a network problem and I'm using the WebDeveloper/Network stuff to do it , this on FF77.0.1 on win10. It seems to be simple form stuff, but I can't catch [and analyze] the POST the page is doing. For a while I thought it was just ignoring the POST but as I looked more carefully I could see the POST flash by and was immediately replaced by the GETs it generated. Do I have to do something special to see the POSTs it is sending?

Asked by BernieC 5 days ago

Firefox sync not working after signing in. Can not disconnect the account now.

Hi folks, I have endured the sync problem for months. Today I struggled for solving it. I have a Firefox 68.0.1 esr manual installation on Ubuntu 16.04. The sync worke… (read more)

Hi folks,

I have endured the sync problem for months. Today I struggled for solving it.

I have a Firefox 68.0.1 esr manual installation on Ubuntu 16.04. The sync worked when I signed in the first time. But the bookmark can not longer be updated afterwards.

If I add or delete a bookmark on my Firefox 68.0.1 esr on Windows 10, the change will not be updated to the Linux version. And vice versa.

On the Linux, I tried to disconnect my account (in the preference about:preferences?entrypoint=fxa_app_menu#sync ). I click "Disconnect" and "Just Disconnect" in the prompt, but the account is still logged in.

Another way I tried is to have a fresh new installation of Firefox 68.9 esr. Then I was asked to sign in again. After typing the password, the new bookmarks were updated. But If I make further changes on the other devices, these changes will not be sync to Linux. And I can't disconnect the account on Linux.

It looks like a new install, which resetting the login process can temporarily solve the problem.

Here is the content of the sync-log file. Can you see what is broken? Thanks in advance.


1593396039810 Sync.LogManager DEBUG Flushing file log

1593396039810 FirefoxAccounts TRACE not checking freshness of profile as it remains recent

1593396039815 Sync.LogManager DEBUG Log cleanup threshold time: 1592532039815

1593396039824 Sync.LogManager DEBUG Done deleting files.

1593396177546 FirefoxAccounts DEBUG FxAccountsWebChannel message received: fxaccounts:fxa_status

1593396177546 FirefoxAccounts DEBUG fxa_status received

1593396177546 FirefoxAccounts DEBUG service: 30b11ae57025e70b

1593396177546 FirefoxAccounts DEBUG is private browsing: false

1593396771684 Sync.RemoteTabs INFO Generating tab list with filter

1593396771684 Sync.RemoteTabs INFO Final tab list has 0 clients with 0 tabs.

1593396939808 Sync.Service DEBUG User-Agent: Firefox/68.9.0 (Linux x86_64) FxSync/1.70.0.20200527211442.desktop

1593396939808 Sync.Service INFO Starting sync at 2020-06-28 19:15:39 in browser session hnIS9YAkhTxS

1593396939808 Sync.Service DEBUG In sync: should login.

1593396939808 Sync.Service INFO User logged in successfully - verifying login.

1593396939809 Sync.BrowserIDManager DEBUG unlockAndVerifyAuthState: user declined to unlock master-password

1593396939809 Sync.Status DEBUG Status.login: service.master_password_locked => service.master_password_locked

1593396939809 Sync.Status DEBUG Status.service: error.login.failed => error.login.failed

1593396939809 Sync.Service DEBUG Fetching unlocked auth state returned service.master_password_locked

1593396939809 Sync.ErrorHandler ERROR Sync encountered a login error

1593396939809 Sync.SyncScheduler DEBUG Clearing sync triggers and the global score.

1593396939810 Sync.SyncScheduler DEBUG Couldn't log in: master password is locked.

1593396939810 Sync.SyncScheduler DEBUG Starting client-initiated backoff. Next sync in 900000 ms.

1593396939810 Sync.SyncScheduler DEBUG Next sync in 900000 ms. (why=client-backoff-schedule)

1593396939811 Sync.Service DEBUG Exception calling WrappedLock: Error: Login failed: service.master_password_locked(resource://services-sync/service.js:984:15) JS Stack trace: onNotify@service.js:984:15

Asked by tianci.zju+firefox 5 days ago

firefox lite mode code in html on https://talkomi.com

I like to know what code do I put when people are at for example like this website and be able to surf even though their browser or data is set in lite mode. What code do… (read more)

I like to know what code do I put when people are at for example like this website and be able to surf even though their browser or data is set in lite mode. What code do i need to insert to make sure that they do not bounce back because they are currently in a lite mode?

Asked by caliznmber1 5 days ago

Telling Automator to perform Page actions in Firefox

Hi everyone, I need help with telling Mac's Automator to click on Firefox's "Page actions" and to select "Use This Site in App Mode" (I was able to make that selection av… (read more)

Hi everyone, I need help with telling Mac's Automator to click on Firefox's "Page actions" and to select "Use This Site in App Mode" (I was able to make that selection available getting help from here https://support.mozilla.org/en-US/questions/1292906). Is there a simple command to put in to finish off designing the app?

Thanks!

Asked by Khalid 5 days ago

Why the muted video tag cannot be unmuted?

Dear All I am building a Web application using WebRTC technology. The problem is that I cannot unmute the muted media which has the muted attribute. This is my video tag … (read more)

Dear All

I am building a Web application using WebRTC technology.

The problem is that I cannot unmute the muted media which has the muted attribute.

This is my video tag that receive the remote media stream:

<video id="remoteView" width="320" height="240" autoplay controls muted></video>

The following coding for add local media stream to the remote RTCPeerConnection object.

           setupStream=((stream)=>{
			if (pc){
				var senders=pc.getSenders();
				if (senders.length<1) {
					stream.getTracks().forEach((track)=>{
						logger("0 add "+track.kind+" track");
						pc.addTrack(track,stream);
					});
				} else {
					senders.forEach((sender)=>{
						if (sender.track)
							sender.track.stop();
					});
					stream.getTracks().forEach((track)=>{
						var sender = pc.getSenders().find(function(s) {
							if (s.track)
								return s.track.kind == track.kind;
							else 
								return null;
						});
						if (sender==null) {
							logger("1 add "+track.kind+" track");
							pc.addTrack(track,stream);
						} else {
							logger("0 replace "+track.kind+" track");
							sender.replaceTrack(track);
						}
					});
				}
			}

The following code handle ontrack event:

                      remoteVideo=document.getElementById("remoteView");
                      if (remoteVideo.srcObject==null){
				remoteView.srcObject=event.streams[0];
			} else {
				remoteVideo.srcObject.addTrack(event.track);
			}		


The problem is that when I add 1 audio track to remote RTCPeerConnection object first, and then add 1 video track to remote RTCPeerConnection object, the remote side default control panel unmute button working properly.

However, if I add 1 video track to remote RTCPeerConnection object first, and then add 1 audio track to remote RTCPeerConnection object, the remote side default control panel unmute button does not work. I need to right-click the media player and then select "unmute" to play remote audio.

I am using FireFox version 77.0.1 Chinese edition. I am using windows 10 OS.

Would you tell me what is going on?

Asked by knvbhk 5 days ago

Sync not working

I am signed in on both my iPhone (26.0) and Mac (77.0.1 (64-bit)) but when clicking on my device in Send Tab to Device nothing happens. Also my bookmarks and history are … (read more)

I am signed in on both my iPhone (26.0) and Mac (77.0.1 (64-bit)) but when clicking on my device in Send Tab to Device nothing happens.

Also my bookmarks and history are not syncing up even after clicking sync on both devices.

Any ideas what is going on?

Asked by max48 5 days ago

Just Re-installed Windows and Firefox. Now Firefox won't sync bookmarks, logins or anything else.

So I had to re-install windows and FireFox, I've signed into FireFox, hit Synchronize Now but nothing happens. No Logins, Bookmarks or History. My desktop Bookmarks are s… (read more)

So I had to re-install windows and FireFox, I've signed into FireFox, hit Synchronize Now but nothing happens. No Logins, Bookmarks or History. My desktop Bookmarks are still on my android phone thankfully. Restarting and signing out and back in makes no difference.

Asked by glenthemorrison 5 days ago

Google MAP is not responding, Google Image not responding.

Suddenly I am having couples of troublesome with Firefox browser. Using Windows10,Firefox 77.0.1. Problems: 1. Google MAP is not responding.. no street view icon or other… (read more)

Suddenly I am having couples of troublesome with Firefox browser. Using Windows10,Firefox 77.0.1.

Problems: 1. Google MAP is not responding.. no street view icon or other icon at the corner. 2. Google Image only shows 20 images, and It will not enlarge images when I click one. 3. No display of “I’m not a robot” dialogue. Cannot access the site that requires.

I have uninstall and reinstall Firefox with deleting all the profile folder from AppData folder related to Firefox, but still the same problem. Using other web browser(Opra, chrome), there are no problems, everything works fine. Also using Firefox from another PC with same network, it works fine. So it is just with this main PC..

Than you in advanced, if any solutions.

Asked by masaki415 5 days ago

Auto fill Improvements

I visit to a website(inet.idbibank.co.in) regularly from desktop. Firefox have saved autofill of this website but doesn't autofills properly. THe website first asks me to… (read more)

I visit to a website(inet.idbibank.co.in) regularly from desktop. Firefox have saved autofill of this website but doesn't autofills properly. THe website first asks me to type in only customer ID then loads next page where i have enter password. But the customer ID must be always copied from lockwise as it doesn't get filled automatically. Please look through this feature or improvement. Thank You

Asked by Mukesh T S 5 days ago

Win 10 Pro 1909 18363.836. Browser: Firefox 70.0.1 (default browser) & Windows IE 11. Virus protection: Kaspersky Total Security. "Secure Browser" (Kaspersky) opens immediately with IE 1, with Firefox 70.0.1 the attempt ends in an endless loop.

My operating system: Win 10 Pro 1909 18363.836. My browsers are Firefox 70.0.1 as the default browser and Windows IE 11. Virus protection: Kaspersky Total Security 20.0.1… (read more)

My operating system: Win 10 Pro 1909 18363.836.

My browsers are Firefox 70.0.1 as the default browser and Windows IE 11. Virus protection: Kaspersky Total Security 20.0.14.1085.

The "Secure Browser" from Kaspersky opens immediately with IE 11, with Firefox 70.0.1 the attempt ends in an endless loop that does not open.

Reinstalling the programs brought no improvement. Where is the mistake?

Asked by HJMHOL 5 days ago