• Solved
  • Archived

Disable update popup?

Users have been complaining about update nags for several years, and when a solution is found via about:config, Mozilla typically puts a spanner in the works and deletes … (read more)

Users have been complaining about update nags for several years, and when a solution is found via about:config, Mozilla typically puts a spanner in the works and deletes the relevant config items like 'app.update.silent', 'app.update.doorhanger... etc.

I just want to remove the popup, not the ability to update. I'll update when I'm good and ready, and I don't need a popup each and every day nagging me to do so.

If Mozilla must ape Chrome, then aping Chrome's non-nagging update policy would be a good move.

FF 85.0.2

Asked by Jason 1 year ago

Answered by FredMcD 1 year ago

  • Solved
  • Locked
  • Archived

HERE is the answer to put "TABS BELOW" which will work with Firefox V90 using the - userChrome.css - file

HERE IS THE ANSWER Here is the answer to get TABS BELOW with Firefox V90 . . copy all of this code below the broken line into your - userChrome.css - file and save it. Yo… (read more)

HERE IS THE ANSWER Here is the answer to get TABS BELOW with Firefox V90 . . copy all of this code below the broken line into your - userChrome.css - file and save it. You can modify the 45px in this line if you wish to get an appropriate height . . just experiment with different numbers till you get it right --menubar-height: 45px; /*30px|41px=11px; caption buttons on menubar*/

Also to make the tabs wider or narrower, modify the line which is coded width: 50vw !important;

Finally you must enable - css - in Firefox, by typing about:config into your address bar, and search for toolkit. When all the toolkit options appear change the one which says toolkit.legacyUserProfileCustomizations.stylesheets to TRUE by click the icon in the right hand column. Than close Firefox and reopen, and check how it looks This will enable your - css - file to be read, and interpreted and accepted by the Firefox browser.

-------------------------------------------------------------------
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* TABS: bottom - Firefox 65 and later - updated for 89+ */
/* https://searchfox.org/mozilla-release/source/browser/themes/shared/tabs.inc.css */
/* https://raw.githubusercontent.com/Aris-t2/CustomCSSforFx/master/classic/css/tabs/tabs_below_navigation_toolbar_fx89.css */
/* https://developer.mozilla.org/en-US/docs/Tools/Browser_Toolbox */

/* ROOT - VARS */
/* you can adjust the CSS variables until it looks correct */
/* you can use the Browser Toolbox to get the toolbar heights */

*|*:root {
  --tab-toolbar-navbar-overlap: 0px !important;

  --tab-min-height: 40px !important;
  --tab-min-width:  60px !important;

  --tab-adjust:  0px; /* adjust tab bar - only for 68-73 */
  --tab-caption: 5px; /* caption buttons on tab bar */
}

/* TAB BAR - below nav-bar */
#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10 !important;}
#TabsToolbar {-moz-box-ordinal-group:1000 !important;}

#TabsToolbar {
  display: block !important;
  position: absolute !important;
  bottom: 0 !important;
  width: 50vw !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}

/* navigator-toolbox - PADDING */
*|*:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
  position: relative !important; /*89+*/
  padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*ADJUST*/
  background-color: var(--toolbar-bgcolor) !important;
}

/* TabsToolbar with menubar and titlebar hidden - rules for Firefox 65-73 */
*|*:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"]) #toolbar-menubar[autohide="true"] ~
 #TabsToolbar{
  bottom: var(--tab-adjust); /*ADJUST*/
}

/* TABS: height */
#tabbrowser-tabs,
#tabbrowser-tabs > .tabbrowser-arrowscrollbox,
.tabbrowser-tabs[positionpinnedtabs] > .tabbrowser-tab[pinned] {
  min-height: var(--tab-min-height) !important;
  max-height: var(--tab-min-height) !important;
}

#TabsToolbar {
  height: var(--tab-min-height) !important;
  margin-bottom: 1px !important;
  box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important; /*OPTIONAL*/
  background-color: var(--toolbar-bgcolor) !important;
  color:            var(--toolbar-color) !important;
/*  z-index: 1 !important; */
}

/* indicators *//*
*|*:root[privatebrowsingmode=temporary] .private-browsing-indicator {
  position: absolute !important;
  display: block !important;
  right: 0px !important;
  bottom: 0px !important;
  width: 14px !important;
  pointer-events: none !important;
}
*/
.private-browsing-indicator {display: none !important;}
.accessibility-indicator    {display: none !important;}

/* Indicators - HIDE *//*
*|*:root:not([accessibilitymode])             .accessibility-indicator    {display: none !important}
*|*:root:not([privatebrowsingmode=temporary]) .private-browsing-indicator {display: none !important}
*/

/* Drag Space */
.titlebar-spacer[type="pre-tabs"],
.titlebar-spacer[type="post-tabs"] {
  width: 20px !important;
}

/* Override vertical shifts when moving a tab */
#navigator-toolbox[movingtab] > #titlebar > #TabsToolbar {
  padding-bottom: unset !important;
}

#navigator-toolbox[movingtab] #tabbrowser-tabs {
  padding-bottom: unset !important;
  margin-bottom: unset !important;
}

#navigator-toolbox[movingtab] > #nav-bar {
  margin-top: unset !important;
}

/* Hide window-controls and caption buttons on Tab Bar */
#TabsToolbar #window-controls {display: none !important;}
#TabsToolbar .titlebar-buttonbox-container {display: none !important;}

Asked by Trevor George, Bristol, UK 1 year ago

Answered by Trevor George, Bristol, UK 1 year ago

  • Solved
  • Archived

How to disable: "Your internet connection was restored" notifications?

How to disable: "Your internet connection was restored" notifications? – Terribly annoying and only started in the last version 77.0.1 very recently. I rather switch to a… (read more)

How to disable: "Your internet connection was restored" notifications? – Terribly annoying and only started in the last version 77.0.1 very recently. I rather switch to another browser if I cannot get rid of this. Checked my 3 plug-ins, but cannot find anything there, nor if it is something on Facebook I cannot find it. Any idea?

Asked by eyeless 2 years ago

Answered by McCoy 2 years ago

  • Solved
  • Archived

I keep getting this error : SEC_ERROR_INADEQUATE_KEY_USAGE

On my internal sites I'm getting this error SEC_ERROR_INADEQUATE_KEY_USAGE My other colleagues using FF v82 do not get the error. I have cleared cache and cookies , but … (read more)

On my internal sites I'm getting this error SEC_ERROR_INADEQUATE_KEY_USAGE

My other colleagues using FF v82 do not get the error. I have cleared cache and cookies , but still not working. The browser is not even giving me an option to proceed. How can I get past this ?

Asked by life4demax 1 year ago

Answered by life4demax 1 year ago

  • Solved
  • Archived

Backspace keyboard button not working in Firefox 87

Hello, I just upgraded to Firefox 87 and noticed that I wasn't able to go back to the previous webpage by clicking on the backspace button like what I have done in the pa… (read more)

Hello,

I just upgraded to Firefox 87 and noticed that I wasn't able to go back to the previous webpage by clicking on the backspace button like what I have done in the past if I'm not using a mouse on my laptop and had to click on the back button in the toolbar with the trackpad. I'm not too sure of why that happened with the upgrade and was a little surprised about that. Hope I can be able to get around this in some way if one of you know anything about this. Thanks.

Asked by Anduma22 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Why does Firefox take up so much RAM?

I have been using Firefox for the past 2 years, but only recently have I noticed that Firefox is using 1 GB of RAM! It never increases or decreases and its getting very a… (read more)

I have been using Firefox for the past 2 years, but only recently have I noticed that Firefox is using 1 GB of RAM! It never increases or decreases and its getting very annoying now since I have barely any RAM to run zoom with (which for some reason takes up the rest of my RAM). I can't even run anything else, and thats annoying me a lot since my fan has to keep running. I can't upgrade my RAM because I use a laptop, and my laptop is under warranty and I can't afford to lose the warranty by upgrading the RAM. Is there any other way to decrease memory usage beside using about:memory and pressing the "minimize memory usage" button? Nothing happens when I press the button.

Asked by unknownturtle64 1 year ago

Answered by FredMcD 1 year ago

  • Solved
  • Archived

you must log in to this network before you can access the internet

Hi everyone, I have this message that appears on every web page but my connection is fine: "you must log in to this network before you can access the internet". It appear… (read more)

Hi everyone,

I have this message that appears on every web page but my connection is fine: "you must log in to this network before you can access the internet". It appeared I don't know how (maybe after using my VPN?) and I can't get rid of it. Any idea?

In advance, thanks a lot.

Asked by jean.souviron 1 year ago

Answered by Scribe 1 year ago

  • Solved
  • Archived

Touchpad gestures doesn't work in Firefox. Please add this very useful feature.

Windows 10 gesture two finger swipe left and two finger swipe right doesn't work in Firefox. Two finger swipe left allows user to go history backward and two finger swipe… (read more)

Windows 10 gesture two finger swipe left and two finger swipe right doesn't work in Firefox. Two finger swipe left allows user to go history backward and two finger swipe right allows user to go history forward. These gestures work in Firefox if the user hold Alt key and preform the gestures. But most of the users don't like to hold Alt key and preform the gestures. Please fix that issue.

Asked by Rifat Mahmud 2 years ago

Answered by FredMcD 2 years ago

  • Solved
  • Archived

set "print with system dialog" as default

dear ladies and gentlemen, Firefox has been delivered with the new print dialog since version 82. I have to print around a hundred PDF files at work (usually only the fir… (read more)

dear ladies and gentlemen,

Firefox has been delivered with the new print dialog since version 82.

I have to print around a hundred PDF files at work (usually only the first page of the document). The new print dialog means that there is a lot more work for me here.

Is it possible to set the "old" system print dialog by default or to instruct firefox to always print only the first page of the document by default?

Asked by Bruce Wayne 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Video's won't play

I am running "Firefox Browser 93.0", and I have Windows 10 Pro Version 21H1, OS Build 19043.1288. I am unable to watch certain video's, as an example, the video in this l… (read more)

I am running "Firefox Browser 93.0", and I have Windows 10 Pro Version 21H1, OS Build 19043.1288. I am unable to watch certain video's, as an example, the video in this link: [https://www.wandtv.com/news/illinois-.../article_24b92a86-32c4-11ec-a487-3bb3f17fa133.html] won't play. It use to work, but something has changed, not by me. It will play that same video using the "Edge Browser" so there is nothing wrong with the website. However, I can play this "YouTube Video": [https://www.youtube.com/watch?v=qAJSYk5wMiA] I also tried another link in their website, this is the weather link: [https://www.wandtv.com/weather] it starts to play, but then stops and nothing ever plays. Here is another link I tried on their website: [https://www.wandtv.com/sports/fans-ma.../article_f94f4ade-32e0-11ec-9351-ef71f52b96cd.html] It won't play either. But they all play in the "Edge Browser!" Any ideas on what changed and how do I change it back, so they will play? I prefer Firefox Browser to any other browser! Do you know what the issue could be? I appreciate your time! NiceSeeingYou

Asked by niceseeingyou 11 months ago

Answered by niceseeingyou 11 months ago

  • Solved
  • Archived

"The page isn’t redirecting properly Firefox has detected that the server is redirecting the request for this address in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies."

My system requires me to log in to the internet when I start up. Usually I am given a message and asked to click on a link, which brings up my login page. Since yesterda… (read more)

My system requires me to log in to the internet when I start up. Usually I am given a message and asked to click on a link, which brings up my login page. Since yesterday I have been receiving the following message: The page isn’t redirecting properly

"Firefox has detected that the server is redirecting the request for this address in a way that will never complete.This problem can sometimes be caused by disabling or refusing to accept cookies." I have cleared my cookies and cache and restarted numerous times. This message keeps coming up. I am able to access my home page, but any attempt to click on bookmarked links results in this message, and occasionally it will refuse even that, telling me it's redirected me too many times. Apart from clearing my cookies cache, which doesn't help, what else can I do to fix this problem? Thanks

Asked by liz23 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

firefox snap 89.0, to play video, you need to install the required video codecs

On ubuntu 20.04, the snap version of firefox can't play some videos. Some youtube videos will play but streams won't, and then I get the message "to play video, you need … (read more)

On ubuntu 20.04, the snap version of firefox can't play some videos. Some youtube videos will play but streams won't, and then I get the message "to play video, you need to install the required video codecs". On telegram web and tweetdeck I also get this message while trying to play some video.

Since it's a snap, nothing I do on my system will solve the problem, I cannot install any codecs.

It's firefox 89.0

Asked by Lucas Zanella 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

How do i disable the fullscreen animation?

Heyo, I switched to firefox today and I noticed that on youtube there's an animation (fade in and out) when fullscreening. Is there any way to disable this? Thank… (read more)

Heyo,

       I switched to firefox today and I noticed that on youtube there's an animation (fade in and out) when fullscreening. Is there any way to disable this?

Thanks

Asked by xcakepiggie 2 years ago

Answered by ARMAN KHAN 2 years ago

  • Solved
  • Archived

Download speed in Firefox is very slow

All things I try to download on Firefox are extremely slow compared to other apps like Steam, torrents and other apps. I get 90mb/s on the download speed checks, but when… (read more)

All things I try to download on Firefox are extremely slow compared to other apps like Steam, torrents and other apps. I get 90mb/s on the download speed checks, but when I try to download something on Firefox, it downloads at like, 120 KB/s.

Asked by pedro.santos.valim 1 year ago

Answered by pedro.santos.valim 1 year ago

  • Solved
  • Archived

No sound of firefox windows 10

Hello, I have trouble getting sound playback on firefox (checked 85.0 and 78.7.0esr both 64 bit) on windows 10. I checked sound on youtube, and netflix. I checked other a… (read more)

Hello, I have trouble getting sound playback on firefox (checked 85.0 and 78.7.0esr both 64 bit) on windows 10. I checked sound on youtube, and netflix. I checked other applications like spotify and mpv, and soundplayback there is fine. Also it works on Firefox nightly (87.0a1).

What i have already tried: - restarting my computer - opening windows volume mixer and see if firefox is muted - updating my audio driver - different playback devices (Device over HDMI and Line out) - reinstalling firefox - uninstalling firefox, delete folders in C:\Users\$username\AppData\Local C:\Users\$username\AppData\Roaming - new install with fresh downloaded installer - restart to safe mode

Since firefox nightly is working i suspect that maybe the application name "Firefox" is muted somewhere. This could explain why i can reproduce my error on ESR and stable but not on nightly.

Thank you for your help in advance

Asked by Alice 1 year ago

Answered by Alice 1 year ago

  • Solved
  • Archived

How do I stop Firefox from opening links in a new window?

Currently, I'm using Firefox 82.0.2 on Fedora 31. Recently, it's started opening most, but not all links in a new window instead of the current one. Not on all sites, b… (read more)

Currently, I'm using Firefox 82.0.2 on Fedora 31. Recently, it's started opening most, but not all links in a new window instead of the current one. Not on all sites, but most. As a pair of examples, it opens links to articles on gasbuddy.com in a new window but not on Slashdot, and until a few months ago, it only opened a new window if I right-clicked and selected New Window from the context menu. I'd like to get the old behavior back, as this is quite inconvenient.

Asked by sideburns 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

How to disable the pop-up from a complete download

Ever since the last update, every time I download something on Firefox this download tab pops up every time when the new download is complete. Ive tried disabling every e… (read more)

Ever since the last update, every time I download something on Firefox this download tab pops up every time when the new download is complete. Ive tried disabling every extension, Ive tried the about:config solution I found on this page, setting it to "false" and I havent been able to find anything in tools or settings.. but nothing disables it and its getting annoying. Ive had Firefox for years and this has never happened before.

Asked by jos.bonilla 6 months ago

Answered by cor-el 6 months ago

  • Solved
  • Archived

All http sites are redirecting to https and display "potential security risk ahead" error

In my browser whenever I am opening non secure sites that are only like http://example.com it redirects to https://example.com and display the error. "Warning: Potential … (read more)

In my browser whenever I am opening non secure sites that are only like http://example.com it redirects to https://example.com and display the error. "Warning: Potential Security Risk Ahead" error. I could not know how to fix this error. This is happening all of a sudden. I could not find a way to fix this error.

Asked by vpp.nagaraju1234 2 years ago

Answered by vpp.nagaraju1234 2 years ago

  • Solved
  • Archived

How can I change the DNS Server in FireFox

How can I change the DNS Server in FireFox to whatever DNS I want and not what Mozilla wants? For example: Google DNS 8.8.8.8, 8.8.4.4 or, Open DNS 208.67.222.222 · 208.… (read more)

How can I change the DNS Server in FireFox to whatever DNS I want and not what Mozilla wants?

For example: Google DNS 8.8.8.8, 8.8.4.4 or, Open DNS 208.67.222.222 · 208.67.220.220

Enabling DNS over HTTPS dose not give me FULL control over this. I should be able to put a DNS IP address in there like in Internet Explore.

Asked by iggy67 1 year ago

Answered by Thermalzombie 1 year ago