Firefox download .csv files as .json

Some time in the last month or so Firefox has started downloading .csv files as .json. I need the files in .csv format so I can work with them in Excel. These are large f… (read more)

Some time in the last month or so Firefox has started downloading .csv files as .json. I need the files in .csv format so I can work with them in Excel. These are large files I don't want to deal with the trouble of converting them every time. I've started using Chrome just so the files download correctly. I can't find any setting to change to make .csv the default again.

Asked by Display Name 1 day ago

Last reply by jscher2000 5 minutes ago

DRM content won't play

After installing the DRM content through the browser I still cannot play any videos on Netflix or Udemy. I have run this website (https://www.jeffersonscher.com/sumo/htm… (read more)

After installing the DRM content through the browser I still cannot play any videos on Netflix or Udemy.

I have run this website (https://www.jeffersonscher.com/sumo/html5-video.html) from previous answers to check and the results are attached to the question.

I have also checked media.eme.enabled and it is set to true.

I am very much puzzled by this.

Asked by Alex 14 minutes ago

Last reply by jonzn4SUSE 3 minutes ago

vams.cdc.gov covid vaccine portal showing blank page

Hi, The vams.cdc.gov portal is just showing a blank page, the cdc site says that firefox is a browser to use and also says chrome,safari etc. I need to get on the site be… (read more)

Hi, The vams.cdc.gov portal is just showing a blank page, the cdc site says that firefox is a browser to use and also says chrome,safari etc. I need to get on the site because I have to register my mother for over 75 to get the vaccine. I have a phone modem and windows 7. Trying to download either of the other browsers is a long long long download. Anybody know the fix to getting this portal working. I noticed that it uses the Aura framework ie window.Aura By the way the page source is there, and the title bar does show VAMS Portal, just the blank page though. Thanks for helping if you can. Steve

Asked by bsteveebee 2 hours ago

Last reply by bsteveebee 3 minutes ago

option to customize new bookmark gone (linux)

Suddenly, when on a new page and "bookmark this page" I do NOT (and cannot) get the menu that allows me to pick a folder and/or tag and/or rename the bookmark WHEN I save… (read more)

Suddenly, when on a new page and "bookmark this page" I do NOT (and cannot) get the menu that allows me to pick a folder and/or tag and/or rename the bookmark WHEN I save it. I now have to save the bookmark into OTHER folder and then choose EDIT bookmark.

Asked by info3517 4 hours ago

Last reply by info3517 9 minutes ago

Firefox does not update a site's Favicon in history or bookmarks after the site has changed its icon

This is a bug report, not a question. When I access a web site for the first time, Firefox (version 84.0.2 [64-bit] under Windows 10) displays that site's Favicon in Fire… (read more)

This is a bug report, not a question. When I access a web site for the first time, Firefox (version 84.0.2 [64-bit] under Windows 10) displays that site's Favicon in Firefox's search history. If the site then changes its Favicon, Firefox does not update its own copy of the site's Favicon and continues displaying the old one. I had a site like this in my search history but I had not bookmarked it. The site changed its Favicon but the icon displayed in Firefox's search history remained unchanged. I later bookmarked the site, thinking that this might inspire Firefox to update the Favicon but it did not; Firefox displays the old Favicon in its bookmarks as well.

Asked by daveziffer 1 hour ago

Last reply by daveziffer 15 minutes ago

How do I undo the changes to my computer from using "refresh Firefox?"

By using refresh Firefox to "fix" problems with slowness, I have lost all of my bookmarks and God knows what else. And I can't access the files that were created, all I g… (read more)

By using refresh Firefox to "fix" problems with slowness, I have lost all of my bookmarks and God knows what else. And I can't access the files that were created, all I get is gibberish. Why didn't Firefox inform me that using refresh would fubar ("fouled" up beyond all recognition) my computer? I desperately need to undo the damage caused by using this (dis)service. And how do I contact Firefox to tell them how badly they have screwed me over?

Asked by MozSupIsCrap 30 minutes ago

Last reply by jscher2000 23 minutes ago

Firefox blank Icon in Windows 7

Hi, I dealt with this problem several time and I decided to write down my solution to save of others time. In case you install firefox on Windows 7 and your htm, html fil… (read more)

Hi, I dealt with this problem several time and I decided to write down my solution to save of others time. In case you install firefox on Windows 7 and your htm, html files are showing blank white icon instead of little foxxy one, all you need to do to go for registry as below: - I am using Firefox v.84, ues problem is there since firefox v.2 - - Type regedit and go for "HKEY_CLASSES_ROOT\FirefoxHTML-308046B0AF4A39CB\DefaultIcon", perhabs you see a differentt number beside FirefoxHTML or even no number - - Double click on Default key and change the value to "C:\Program Files\Mozilla Firefox\firefox.exe,1", not to mention without "" - Don't forget to backup whole your registry before editing it - Restart and you will probably see the Firefox icon on your saved html files

Good luck

Asked by Kaveh Izadi 1 hour ago

Last reply by jonzn4SUSE 28 minutes ago

‘mail to’ links & PDF files

A couple of annoying things have happened since I switched to Firefox as my main browser: • clicking on ‘mail to’ links no longer takes me to outlook, which is my main em… (read more)

A couple of annoying things have happened since I switched to Firefox as my main browser: • clicking on ‘mail to’ links no longer takes me to outlook, which is my main email provider • all of my PDF files stored in ‘my documents’ have been converted into Firefox web files I’d like these restored to my previous settings but can’t see how to do this!

Asked by Annegoodwin 6 hours ago

Last reply by jscher2000 28 minutes ago

how do I stop my locations to be broadcasted without my concent? (ISP related)

long story short, if I go on amazon.com it redirects me amazon.com.br without asking me, no pop-ups, no "amazon wants to know you location" it just looks at my IP and sen… (read more)

long story short, if I go on amazon.com it redirects me amazon.com.br without asking me, no pop-ups, no "amazon wants to know you location" it just looks at my IP and send me away, also, if I do something like amazon.co.uk it will prompt me for "would you like to be redirected to amazon.com.br?" and I don't want that either, if I could go to amazon.jp it's all the same for me

note: 1: I used amazon as an example, this happens with eBay, YouTube, Bing, reddit, facebook, PayPal, or any other website that is available on a .br domain 2: I don't want to use a VPN or any Proxy server, I'm not rich, I can't pay 129.99 a year for a browser extesion, and there are free ones, but they bring my 120Mb/s connection to a grinding halt 3: this is most likely my ISP / IP being broadcasting my location without my consent, while some websites do ask me to allow it, my IP most of the time will basically lay open on the table and tell the website "if you wanna look, it's there" 3.2: this is especially annoying with the advertisements saying stuff like "80% of gamers in [USER_CITY] love this RPG" and I'm like, really? a backwater christian town where only 20% of the population have TVs and 5% of those 20% have broadband connection?

in short, I don't want any websites to know where I am

Asked by Kate Hanami 4 hours ago

Last reply by Václav Trpišovský 3 hours ago

Disable picture in picture completely

On multiple websites I visit, picture in picture happens automatically when I scroll past a video or click another section of a page. I find it highly annoying and distr… (read more)

On multiple websites I visit, picture in picture happens automatically when I scroll past a video or click another section of a page. I find it highly annoying and distracting. I would like to disable it completely. How do I do this? I'd appreciate an answer that isn't too technical. Thanks.

Asked by lorifarley93 5 months ago

Last reply by indestructium 4 hours ago

Bookmark toolbar doesn't show every bookmark until I "reset" it with the view menu checkbox (turn it off and on again).

I first noticed it when I plugged in my new screen for the first time. It's quite a bit larger than my old one, and I think Firefox doesn't really recognize it. The spec… (read more)

I first noticed it when I plugged in my new screen for the first time. It's quite a bit larger than my old one, and I think Firefox doesn't really recognize it.

The specific steps I take to fix it temporarily (per session) are as follows:

Press alt to show the menu bar

Select View > Toolbars > Uncheck Bookmarks Toolbar

Same steps again except to check the Bookmarks Toolbar checkbox again. Then everything is normal.

Interestingly it is never the same amount of bookmarks that aren't shown, always differs by 2 or three before it cuts off and shows just empty space.

Thanks.

Asked by thisisntausername 1 hour ago

  • Solved

Youtube gives problem on Firefox, but not on Opera. Solutions?

when I type a comment on youtube, the text often "lags", the letters appear all together after a while, if I try to send the comment I get an error, and if I try to subsc… (read more)

when I type a comment on youtube, the text often "lags", the letters appear all together after a while, if I try to send the comment I get an error, and if I try to subscribe a channel I cannot, instead I get prompted to login while I am already logged. This is going for months, right now the only fix seems to switch to Opera... Can you guys provide solutions to this?

Asked by marcus.aseth 3 days ago

Answered by jonzn4SUSE 23 hours ago

  • Solved

Can not play videos at one website

I have what I think is a specific video problem. Videos from the Washington Post get the message “This video is currently not available”. Other videos, e.g. from the Ne… (read more)

I have what I think is a specific video problem. Videos from the Washington Post get the message “This video is currently not available”. Other videos, e.g. from the New York Times do work. Washington Post videos work with Chrome and Opera.

The problem is on a new Dell Inspiron 5502 running Windows 10 and Ubuntu with dual boot. The problem only occurs under Ubuntu 20.04.1 LTS. It does not occur under Windows Firefox.

The current Firefox is 84.0.2. The problem did occur under 84.0 but I didn’t have time to pursue it.

The add-ons manager under extensions has no entries. Under plugins there is only “OpenH264 Video Codec provided by Cisco Systems”.

Under preferences, performance, hardware acceleration is not selected and the content process limit is left at 8.

Running in safe mode does not help.

I had a different video problem on a pair of the hardware visible at https://support.mozilla.org/questions/1320396?utm_campaign=questions-reply&utm_source=notification&utm_medium=email#answer-1381141 This is a different machine and a different problem.

Asked by alan.schulman 4 days ago

Answered by jonzn4SUSE 2 days ago

Sound on videos and videos stopped working on firefox

Hi everyone! I am looking for some help on how to fix my problem. Yesterday, suddenly videos on Firefox stopped having sound and in one particular website (public televis… (read more)

Hi everyone! I am looking for some help on how to fix my problem. Yesterday, suddenly videos on Firefox stopped having sound and in one particular website (public television) videos stopped working altogether. These are websites that I use on a daily basis and have been using for months. All of these websites and videos work fine on google Chrome. I am using a desktop and Windows 10 and use DuckDuckgo Privacy essentials. These are the things I have done to troubleshoot: -restarted computer _restarted Firefox in Safe Mode -checked the volume mixer -checked the App volume device preferences on Windows -signed off my firefox account and logged in without an account -refreshed Firefox -Uninstalled and installed Firefox

On my laptop (Windows 7) everything still works fine as usual.

Any tip or advice will be much appreciated. Please bare in mind that I have a very basic computer knowledge. many thanks Poppy

Asked by poppy.ocean 3 hours ago

Last reply by jonzn4SUSE 1 hour ago

Error message: A copy of Firefox is already open. But no other copy is open.

Using previous advice found for this problem here, I typed the following into Terminal. The results show I have three profiles, which I'll try to explain below. cd ~/Libr… (read more)

Using previous advice found for this problem here, I typed the following into Terminal. The results show I have three profiles, which I'll try to explain below.

cd ~/Library/Application\ Support/Firefox/Profiles/
ls -l

drwx------@ 41 abababab staff 1312 Jan 15 13:38 0kr25gzy.default-release drwx------@ 71 abababab staff 2272 Jan 15 13:20 8638osoq.default-1513387167461 drwx------@ 37 abababab staff 1184 Jan 16 13:57 k8u9jknd.default-release-1

I use Firefox as my business email and all was working fine until I upgraded Firefox using my Safari browser and created another login profile based on my personal email. That's when the error 'a copy is already open' began. To solve it, I did the above and had two profiles a 'default' and a 'default-release'. I believe I deleted the 'default', and the problem remained. Then I tried a reinstall, and I suppose that's the 'default-release-1' profile, but I really have no idea. The problem for me is that I need to import bookmarks, the business email account linked to Firefox and Host Gator, and all my LinkedIn, MailerLite stuff. I do not want to lose all this and just do a clean reinstall. However, now because I can't open any version of Firefox, I have no way to access the business emails, etc, so I can't recover the Firefox account linked to this business email and get all this stuff back. And I don't know which of the above three profiles I need to delete to get it all working again. Please help!!!

Asked by skskknox 22 hours ago

Last reply by jscher2000 1 hour ago