Showing questions tagged: Show all questions
  • Solved
  • Archived

Firefox crashes most every time try to close. Started since using windows 10.Tried all remedies.

Tried safemode, retune firefox, turn off LastPass.Diable plugins but,FF crashes most every time close, since updating to windows 10. Please advise. Trouble shooting data … (read more)

Tried safemode, retune firefox, turn off LastPass.Diable plugins but,FF crashes most every time close, since updating to windows 10. Please advise. Trouble shooting data says I have windows xp as operating system...That is incorrect....This laptop I bought new from Dell with windows7

Thanks

Asked by j4872 4 years ago

Answered by cor-el 4 years ago

  • Solved
  • Archived

Bookmarks sync problems: Bookmarks keep rearranging themselves in the bookmarks toolbar, and do not sync completely on Windows and Android.

My setup I'm using Firefox 47.0 on Fedora (64-bit GNU/Linux) with GNOME shell, and on Windows 10 (64-bit). I also have Firefox Sync on an Android tablet, but I don't do a… (read more)

My setup

I'm using Firefox 47.0 on Fedora (64-bit GNU/Linux) with GNOME shell, and on Windows 10 (64-bit). I also have Firefox Sync on an Android tablet, but I don't do as much web browsing on my tablet, so I haven't needed to look at the bookmarks there...


The problem(s)

On Fedora, the bookmarks in the Firefox bookmarks toolbar rearrange themselves. The bookmarks in one folder shift from the bottom to the top, and some bookmarks in the toolbar shift from left to right. I arrange my bookmarks by loose priority, so this annoying. Whenever I notice the bookmarks being out of order, I drag them back to where they were, but they always move themselves again later. This has been an ongoing issue for a couple months; I've only seriously attempted to troubleshoot the issue over the past week or so, and I'm not having any luck.

I don't think I've ever noticed the bookmarks moving themselves in the middle of a session, so I believe it's actually happening when I close or launch Firefox. However, reproducing this issue has been tricky, since the bookmarks do not *always* shuffle themselves every time I launch Firefox. Depending on how often I open/close the application, I may notice the bookmarks moving themselves once every other day, or a couple times in a single day.

This may be a separate issue, but I noticed it around the same time: On Windows 10, my bookmarks do not sync at all. There three or four bookmarks in the toolbar, but these do not get updated when I change them on my Linux machine, and none of the other bookmarks have synced to the Windows machine.


Things that I've already tried

I've tried reverting my bookmarks to a recent automatic backup (Library > Import and Backup > Restore). No change.

I've tried disabling all addons. No change.

I tried refreshing Firefox, to "reset to factory defaults". No change.

I tried deleting the file `xulstore.json` in my Firefox profile. No change.

I tried installing and running the Places Maintenance extension. I didn't entirely understand all the text output it generated while running, but I don't think it found any real errors. Anyway, no change.

I tried backing up my exports to a JSON file, then closing Firefox, then deleting the places.sqlite file, then restarting Firefox, and importing the bookmarks JSON file. No change.

Bookmarks still rearrange themselves on Linux and do not sync at all on Windows  :(

Asked by Android-the-Andrew 4 years ago

Answered by Android-the-Andrew 4 years ago

  • Solved
  • Archived

ebay only site shows a mobile site

I have a problem with ebay it shows as a mobile site why? amazon shows fine and all other sites the only add-on i have installed us ublock nothing else. I have tried clea… (read more)

I have a problem with ebay it shows as a mobile site why? amazon shows fine and all other sites the only add-on i have installed us ublock nothing else.

I have tried clearing cookies,temp files, resting firefox even removing ublock reset firfox and even uninstalled firefox with iobit uninstaller and scanned for leftovers after removing it.

I'm on windows 10 pro running build 1703 and it happened in 1607 as well

Thanks for the help in advance

Asked by damolin 3 years ago

Answered by cor-el 3 years ago

  • Solved
  • Archived

Youtube notifications constantly loading, never show up

I am starting this new thread, as the thread showing the issue as noted in my topic applies to me, but is currently going on with lastest firefox. I am using Windows 10 6… (read more)

I am starting this new thread, as the thread showing the issue as noted in my topic applies to me, but is currently going on with lastest firefox.

I am using Windows 10 64 bit and I tried everything, including safe mode, etc. etc. in the other thread ,and nothing is working.

Its not windows 10 because chrome and edge work fine regarding this issue.

I was unable toget 'automatically add' my info here in chrome browser, so I had to do it in FF ,and I'm pasting it here now:

{
  "application": {
    "name": "Firefox",
    "version": "46.0.1",
    "buildID": "20160502172042",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0",
    "safeMode": false,
    "updateChannel": "release",
    "supportURL": "https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-US/",
    "numTotalWindows": 1,
    "numRemoteWindows": 0,
    "remoteAutoStart": false,
    "autoStartStatus": 2
  },
  "lockedPreferences": {},
  "graphics": {
    "numTotalWindows": 1,
    "numAcceleratedWindows": 0,
    "windowLayerManagerType": "Basic",
    "windowLayerManagerRemote": true,
    "supportsHardwareH264": "No; Hardware video decoding disabled or blacklisted",
    "numAcceleratedWindowsMessage": [
      ""
    ],
    "adapterDescription": "AMD Radeon HD 7700 Series",
    "adapterVendorID": "0x1002",
    "adapterDeviceID": "0x683f",
    "adapterSubsysID": "32481682",
    "adapterRAM": "2048",
    "adapterDrivers": "aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64",
    "driverVersion": "16.150.2401.0",
    "driverDate": "4-15-2016",
    "adapterDescription2": "",
    "adapterVendorID2": "",
    "adapterDeviceID2": "",
    "adapterSubsysID2": "",
    "adapterRAM2": "",
    "adapterDrivers2": "",
    "driverVersion2": "",
    "driverDate2": "",
    "isGPU2Active": false,
    "direct2DEnabled": false,
    "directWriteEnabled": false,
    "directWriteVersion": "10.0.10586.0",
    "direct2DEnabledMessage": [
      ""
    ],
    "webglRenderer": "Google Inc. -- ANGLE (AMD Radeon HD 7700 Series Direct3D11 vs_5_0 ps_5_0)",
    "info": {
      "AzureCanvasBackend": "skia",
      "AzureSkiaAccelerated": 0,
      "AzureFallbackCanvasBackend": "cairo",
      "AzureContentBackend": "cairo"
    }
  },
  "javaScript": {
    "incrementalGCEnabled": true
  },
  "accessibility": {
    "isActive": true,
    "forceDisabled": 0
  },
  "libraryVersions": {
    "NSPR": {
      "minVersion": "4.12",
      "version": "4.12"
    },
    "NSS": {
      "minVersion": "3.22.3 Basic ECC",
      "version": "3.22.3 Basic ECC"
    },
    "NSSUTIL": {
      "minVersion": "3.22.3",
      "version": "3.22.3"
    },
    "NSSSSL": {
      "minVersion": "3.22.3 Basic ECC",
      "version": "3.22.3 Basic ECC"
    },
    "NSSSMIME": {
      "minVersion": "3.22.3 Basic ECC",
      "version": "3.22.3 Basic ECC"
    }
  },
  "userJS": {
    "exists": false
  },
  "extensions": [
    {
      "name": "Firefox Hello Beta",
      "version": "1.3.2",
      "isActive": true,
      "id": "loop@mozilla.org"
    },
    {
      "name": "Multi-process staged rollout",
      "version": "1.0",
      "isActive": true,
      "id": "e10srollout@mozilla.org"
    },
    {
      "name": "Pocket",
      "version": "1.0",
      "isActive": true,
      "id": "firefox@getpocket.com"
    },
    {
      "name": "Search and New Tab by Yahoo",
      "version": "1.0.3",
      "isActive": true,
      "id": "jid1-16aeif9OQIRKxA@jetpack"
    },
    {
      "name": "Skype",
      "version": "8.3.0.9150",
      "isActive": true,
      "id": "{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}"
    },
    {
      "name": "anonymoX",
      "version": "2.5.2",
      "isActive": false,
      "id": "client@anonymox.net"
    },
    {
      "name": "Bing Search",
      "version": "1.0.0.6",
      "isActive": false,
      "id": "bingsearch.full@microsoft.com"
    }
  ],
  "experiments": [],
  "modifiedPreferences": {}
}

It's beyond annoying and I avoid FF because of it, so any ideas ?

ty

Asked by cajunctionAI 4 years ago

Answered by FredMcD 4 years ago

  • Solved
  • Archived

Why my Firefox is pixeled?

Today something wear happened, I was in Facebook when firefox freeze then y close it and open again, but when it open everything was pixeled or deformed! I already uninst… (read more)

Today something wear happened, I was in Facebook when firefox freeze then y close it and open again, but when it open everything was pixeled or deformed! I already uninstall it 2 times but nothing change. =(

Asked by Mikelin32 5 years ago

Answered by philipp 5 years ago

  • Solved
  • Archived

Unable to play any flash content in browser

I have cleared caches, uninstalled, reinstalled, searched for any adjustment I could think of that would allow the flash to play. Flash players have been reinstalled, ja… (read more)

I have cleared caches, uninstalled, reinstalled, searched for any adjustment I could think of that would allow the flash to play. Flash players have been reinstalled, java reinstalled. reboooted, rebooted,rebooted. Have turned off all security and it still will not load. Some games even indicate what version of flash is installed but all I get is a plain white screen where the game should be shown. Videos will not load

Asked by lynncaroll 4 years ago

Answered by FredMcD 4 years ago

  • Solved
  • Archived

Totally useless after updating to version 42. Can't load anything.

Since version 42 it's not showing any website properly. Not even in Safe Mode and even after resetting everything countless times. Even after uninstalling and re-installi… (read more)

Since version 42 it's not showing any website properly. Not even in Safe Mode and even after resetting everything countless times. Even after uninstalling and re-installing it's same. Uninstalled and re-installed version 43; with default settings and all issues are still there.

As you can see in images, there are no problem with internet connection. Everything else is working just fine.

Asked by tranquilknight 4 years ago

Answered by tranquilknight 4 years ago

  • Solved
  • Archived

My firefox 43.0.2 won't open anymore, even Refreshed & in Safe Mode

Yesterday it opened normally, today it won't, as said above. I tried renaming the Mozilla Firefox to OldFirefox, and clean install, still won't work. When trying to open … (read more)

Yesterday it opened normally, today it won't, as said above.

I tried renaming the Mozilla Firefox to OldFirefox, and clean install, still won't work.

When trying to open in safe mode, window open but then says : Not responding, and it jam like this.

I even tried to report my 5 latest bp- and it still wasn't conclusive.

Any answer somebody?

BTW my computer is a MacBook Pro with Windows 7 32 bits Legit Boot Camp, si maybe it does make a difference.

My Internet Explorer work, thought.

Thanks!!

Asked by g0ld3nb0y 4 years ago

Answered by jscher2000 4 years ago

  • Solved
  • Archived

New Firefox update. Now it crashes with "Windows can not access ..."

Tried to start Firefox. It did an in requested "update". Now it won't start but rather gives me an error message "Windows can not access the specifies device ..." How do … (read more)

Tried to start Firefox. It did an in requested "update". Now it won't start but rather gives me an error message "Windows can not access the specifies device ..."

How do I fix?

Eric Johnson

Do not include email addresses in your post. We will not email you.

Asked by ejstruan 4 years ago

Answered by ejstruan 4 years ago

  • Solved
  • Archived

whats wrong with firefox???? its reporting EVERY site as unsafe

have a new windows 10 computer and have tried to use Firefox on it but cant as it is reporting EVERY SINGLE WEBSITE as unsafe even MOZILLA , Ive had to take it off as it… (read more)

have a new windows 10 computer and have tried to use Firefox on it but cant as it is reporting EVERY SINGLE WEBSITE as unsafe even MOZILLA , Ive had to take it off as it absolutely useless as it is

Asked by amosf64 3 years ago

Answered by amosf64 3 years ago

  • Solved
  • Archived

Every Firefox update fails, and now Firefox will not even start.

For days, every time I have started Firefox, it asked whether I wanted an update. Every time I clicked Yes to update Firefox, the update failed. So I found the Mozilla … (read more)

For days, every time I have started Firefox, it asked whether I wanted an update. Every time I clicked Yes to update Firefox, the update failed. So I found the Mozilla site for installing the latest version of Firefox. The installation seemed to go fine, but Windows 10 now gives the following message:

"Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item."

I see nothing unusual in the Properties for what seems to be the Firefox executable. Of course, I can switch to GoogleChrome, but I prefer Firefox; in addition, all of my Firefox bookmarks are now gone.

Solution to these problems?

Asked by Wallet 3 years ago

Answered by Wallet 3 years ago

  • Solved
  • Archived

Firefox crashes

Firefox will stop responding, suddenly all of my OS (Windows 10 Pro) will simply stop, freeze, a warning will come up that the program is not responding and if I wait lon… (read more)

Firefox will stop responding, suddenly all of my OS (Windows 10 Pro) will simply stop, freeze, a warning will come up that the program is not responding and if I wait longer it may respond again, the CPU light that it is doing its thing on my laptop goes dead, the only way I can get to use my laptop again is by hard resetting it holding the power button. This happen multiple times a day, and only while browsing using firefox.

It is my preferred browser, but I have noticed its quality to degrade as time goes by.

Asked by Jotage 3 years ago

Answered by Jotage 3 years ago

  • Solved
  • Archived

Linux/Ubuntu and Windows: creating firefox profile for different users from command line

Hi, I would like to create from command line by using the administrator user of a system the same firefox profile with plugin and customization for each user of the same … (read more)

Hi, I would like to create from command line by using the administrator user of a system the same firefox profile with plugin and customization for each user of the same system. I cannot use sync feature for this purpose.

I know from here edit https://developer.mozilla.org/en-US/...d_Line_Options https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options ~J99that the correct syntax is the following firefox -CreateProfile "JoelUser c:\internet\joelusers-moz-profile". On Linux/Ubuntu the following piece of code allows to create a profile for the sudo user


user=$(sudo logname)
firefoxProfile="/home/$user/.mozilla/firefox"
if [ ! -d "$firefoxProfile/m4v6pi7q.profile" ]; then
    rm -rf $firefoxProfile
    firefox -CreateProfile "profile $firefoxProfile/m4v6pi7q.profile"
        
    7z x -y ./m4v6pi7q.profile.7z
    mv ./m4v6pi7q.profile/* "$firefoxProfile/m4v6pi7q.profile"
    sudo chown -R $user:$user "/home/$user/.mozilla/"
    rm -rf m4v6pi7q.profile.7z m4v6pi7q.profile
fi

On Windows the following piece of code allows to create a profile for the administrator user


$ProgramsPath=${env:ProgramFiles}
$FirefoxProfile="$env:USERPROFILE\AppData\Roaming\Mozilla\Firefox\Profiles\u9w6vbcj.profile"
if(-Not (Test-Path $FirefoxProfile))
{
	$LocalProfile="$env:USERPROFILE\AppData\Local\Mozilla\Firefox\Profiles\*"
	if(Test-Path $LocalProfile)
	{
		Remove-Item $LocalProfile -recurse
	}
	
	$RoamingProfile="$env:USERPROFILE\AppData\Roaming\Mozilla\Firefox\Profiles\*"
	if(Test-Path $RoamingProfile)
	{
		Remove-Item $RoamingProfile -recurse
		Remove-Item "$env:USERPROFILE\AppData\Roaming\Mozilla\Firefox\profiles.ini"
	}
	& "$ProgramsPath\Mozilla Firefox\firefox.exe" -CreateProfile "profile $FirefoxProfile"

	& "$ProgramsPath\7-Zip\7z.exe" x -y .\u9w6vbcj.profile.7z
	move .\u9w6vbcj.profile\* $FirefoxProfile -force
	Remove-Item .\u9w6vbcj.profile.7z
	Remove-Item .\u9w6vbcj.profile
}

How can I create firefox profiles from a sudo/administrator user for each user (sudo/administrator and not sudo/administrator) of the system? On Linux/Ubuntu I tried with this code


usersList=$(getent passwd | grep -vE '(nologin|false)$' | \
awk -F: -v min=`awk '/^UID_MIN/ {print $2}' /etc/login.defs` \
-v max=`awk '/^UID_MAX/ {print $2}' /etc/login.defs` \
'{if(($3 >= min)&&($3 <= max)) print $1}' | \
sort -u)

for systemUser in $usersList; do
    echo $systemUser

    firefoxProfile="/home/$systemUser/.mozilla/firefox"
    firefox -CreateProfile "profile $firefoxProfile/m4v6pi7q.profile"
    7z x -y ./m4v6pi7q.profile.7z
    mv ./m4v6pi7q.profile/* "$firefoxProfile/m4v6pi7q.profile"
    chown -R $systemUser:$systemUser "/home/$systemUser/.mozilla/"
    rm -rf m4v6pi7q.profile.7z m4v6pi7q.profile
    
done

but it does not work and this is the output


sudo ./user.sh 
foo
Success: created profile 'profile /home/foo/.mozilla/firefox/m4v6pi7q.profile' at '/home/foo/.mozilla/firefox/m4v6pi7q.profile/prefs.js'
admin
Success: created profile 'profile /home/admin/.mozilla/firefox/m4v6pi7q.profile' at '/home/admin/.mozilla/firefox/m4v6pi7q.profile/prefs.js'
jack
Success: created profile 'profile /home/jack/.mozilla/firefox/m4v6pi7q.profile' at '/home/admin/.mozilla/firefox/m4v6pi7q.profile/prefs.js'
chown: cannot access ‘/home/jack/.mozilla/’: No such file or directory
zorro
Success: created profile 'profile /home/zorro/.mozilla/firefox/m4v6pi7q.profile' at '/home/admin/.mozilla/firefox/m4v6pi7q.profile/prefs.js'
chown: cannot access ‘/home/zorro/.mozilla/’: No such file or directory

Why for the first two users is the directory for profile corretly set, while for the other is the directory of the user that executes the script /home/admin/.mozilla/firefox/m4v6pi7q.profile? I'm sorry for my very long question. Thank you


edit fixed link ~J99

Asked by erotavlas 4 years ago

Answered by erotavlas 4 years ago

  • Solved
  • Archived

Once open, nothing in firefox works. Bookmark bar wont load, cant open options, add ons. Wont open in safe mode either.

I rebooted my computer last night, when I opened firefox afterwards, it just hangs. I cannot open a web page, I cannot open options, my book marks do not show up until I… (read more)

I rebooted my computer last night, when I opened firefox afterwards, it just hangs. I cannot open a web page, I cannot open options, my book marks do not show up until I deselect the option to show, then enable, but nothing loads. I cannot close firefox unless I go into task manager to end it. I have sent 2 bug reports under this email address. I cannot open in safe mode by holding shift and clicking but was able to under the ? menu. No change in safe mode, just continuously loads.

I.E. and all other internet based programs work just fine.

Windows 10 pro AMD 6300 6 core processor 16GB RAM 64 bit OS Norton 360 (have had on and not changed for years).

Let me know what other information could help.

Thanks!

Asked by Poolzer 3 years ago

Answered by Poolzer 3 years ago

  • Solved
  • Archived

Firefox doesn't work even after reinstall

Firefox suddenly stopped working today. When I open it, it tells me that it's already open (which it isn't) and that it can't find or load my profile. If I go directly to… (read more)

Firefox suddenly stopped working today. When I open it, it tells me that it's already open (which it isn't) and that it can't find or load my profile. If I go directly to profiles and create a new one, I can open it, but all my bookmarks are gone. And then if I close and try to reopen it, the same thing happens--I can't open it and get the same error message.

One thing I figured out is that the profile can’t be read only, and I discovered that mine was (why I don't know), but when I try to uncheck read only, it instantly reverts back to read only, which is weird.

I’ve tried reinstalling Firefox several times, but it’s always the same, even with a brand-new installation, I can’t open it and get the same error message. What can I do if reinstalling doesn’t even work?

Asked by carlwhart 3 years ago

Answered by carlwhart 3 years ago

  • Solved
  • Archived

Firefox Won't Start - Claims it is Already Open

Firefox will not start. It claims to be already running, but that doesn't seem to be the case. I have tried creating a new user profile but when I try to open Firefox no… (read more)

Firefox will not start. It claims to be already running, but that doesn't seem to be the case.

I have tried creating a new user profile but when I try to open Firefox now, the "choose user profile" menu pops up. I have tried the new profile and they old one, and both give the same error message. "Firefox cannot use the profile "Default User" because it is in use. To continue, close the running instance of Firefox or choose a different profile."

There is an entry for firefox.exe in the "details" menu of my task manager, and nowhere else. When I try to end that task, I get the following error: "the operation could not be completed - Access is denied."

Due to some troubleshooting research, I've tried deleting the parent.lock file from my profile folder, but I get this error- "the action can't be completed because the file is open in Firefox."

I tried transferring my bookmarks and preferences from Firefox to Chrome, but I got a similar error suggesting that Firefox was already open and I would have to close it first.

I have also turned off my computer and uninstalled and reinstalled Firefox multiple times.

I'd really rather not lose all of my Firefox bookmarks, add-ons, and preferences. I also prefer using Firefox to Chrome, so if anyone can help me out I'd really appreciate it. I don't know what else to try.

My PC runs Windows 10, by the way.

Asked by jimmyjkjr 5 years ago

Answered by cor-el 5 years ago

  • Solved
  • Archived

Firefox loads in taskbar but doesn't display on desktop.

Firefox was working until yesterday. Now it loads in the taskbar and popups mini windows but never opens on the desktop so it can be used. I have uninstalled/reinstalle… (read more)

Firefox was working until yesterday. Now it loads in the taskbar and popups mini windows but never opens on the desktop so it can be used. I have uninstalled/reinstalled, rebooted...nothing helps. HELP!!! I want my Firefox back.

Asked by cascher50 4 years ago

Answered by cascher50 4 years ago

  • Solved
  • Archived

Why has Firefox slowed to the point of unusable?

Firefox slowed to the point where it is unusable. It also stalls, and even crashes. Other browsers work find, and my internet connection speeds are as good as I can exp… (read more)

Firefox slowed to the point where it is unusable. It also stalls, and even crashes. Other browsers work find, and my internet connection speeds are as good as I can expect.

I have uninstalled and reinstalled to no avail.

My machine is Intel QuadCore i5-3470 CPU @ 3.20GHz, 32 GB RAM, running MS Windows 10 Home on an MSI B75MA-P45 motherboard. It was assembled by Net Solution Computers of Morley, Western Australia, and has a SAMSUNG U28D590D VDU driven by an NVIDIA QUADRO K620 Video Card and RealTek High Definition Audio. I have Windows Defender and Malwarebytes as Anti-virus with Firefox and Skype running in the background.

Asked by Vagulus 3 years ago

Answered by FredMcD 3 years ago