Showing questions tagged: Show all questions

Cannot click on email link to display in Firefox

Firefox.exe – Bad Image C\Users\HP\AppData\Local\Mozilla Firefox\xul.dll is either not designed to run on Windows or it contains an error. Try installing the program agai… (read more)

Firefox.exe – Bad Image C\Users\HP\AppData\Local\Mozilla Firefox\xul.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status Oxc000007b.

Asked by Stan Bailey 12 minutes ago

Slower than a 7 year itch

I know this has been asked plenty of times but Firefox is running multiple processes to the point I don't want to use it anymore. I've done google searches on how to stop… (read more)

I know this has been asked plenty of times but Firefox is running multiple processes to the point I don't want to use it anymore. I've done google searches on how to stop this problem and tried everything suggested but nothing works. Any ideas before I say adios to this slow crappy browser? I'm still using windows 7 but not for much longer.

Asked by Jeff H 4 hours ago

Anyway to disable "A script from the extension" "is running on this page"

I am getting sick of the message "A script from the extension...is running on this page" It relates to Adblock Plus which is the extension. I watch a YouTube video and th… (read more)

I am getting sick of the message "A script from the extension...is running on this page" It relates to Adblock Plus which is the extension. I watch a YouTube video and then this message comes up on another YouTube tab I have open and Firefox switches to that tab and ruins my watching the video I was watching.

Is there anyway of disabling the message from ever coming up? I increased the values in dom.max_script_run_time and dom.max_script_run_time_without_important_user_input which was a possible solution I read but that does nothing.

Asked by davebesag 1 week ago

Last reply by davebesag 8 hours ago

Open in New Tab breaks sometimes, clicking link doesn't always work first time, page stops loading before finished, etc...

1: Sometimes when middle-clicking a link to open it in another tab, it will open the new tab with the address of the link I clicked, in the background, but not load it at… (read more)

1: Sometimes when middle-clicking a link to open it in another tab, it will open the new tab with the address of the link I clicked, in the background, but not load it at all.

2: Sometimes when clicking a link (to open in the current tab), it does nothing at all, or selecting an option in a dropdown box won't refresh the page with the new information (for example, zandesk dropdown menus for bug reporting for a developer's game will select the item, but not reload the page with the now relevant boxes to fill out- happens everywhere, noticed it there).

3: Pages will stop loading before they've actually finished loading, like Firefox is cancelling the load because "it's taking too long". I have 400kbps, Firefox, I'm in no rush to STOP loading a page that I'm trying to load...

Asked by tha.destroyah 8 hours ago

I have updated my O/S from Ubuntu 18.04 to 20.10. Nothing else. Now Firefox is nearly useless

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it. Originally I was using Ubuntu 18.04 LTS. I thought it woul… (read more)

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it.

Originally I was using Ubuntu 18.04 LTS.

I thought it would be good to update to GG (20.10) though I did briefly try FF (20.04).

As the install was done on an existing 18.04 version things remained the same for programs, book marks, etc.

Ok, now the crunch: I USE Firefox ""A LOT"". When it loads, there are...... 8 x 6 windows of FireFox and each of those have anywhere from one to ""THIRTY"" tabs loading.

Believe me: ""It worked!!""

I could use it, also run other tasks as well - though a VM was pushing it with the RAM. But the entire machine worked.

Now, I am lucky if FireFox loads at all. Let alone let me browse.

When it loads some of the window's tops are flashing. A screen shot does not really show this. (I tried)

All that has changed is the O/S from 18.04 and Firefox from (what ever it was) to 83.0

I don't want this to be a finger pointing exercise between Mozilla and Ubuntu. I would prefer it is helpful to all.

What have I tried? I've tried starting FireFox with all addons disabled. Still happens.

I am going to try to remember to (next time) launch FireFox from a Terminal and pipe the output to a file to look for things.

The machine I am using has shown it is well up to being able to have this running. I have had it working for a few years like this.

This post is (for now) to establish there is a problem. I will post more information when I get it, rather than waiting to get it then post, as I feel there are a lot of people who have very similar problems and I want it known: ""You are not alone!""


Now a bit of extra stuff.

Other things which are weird: When I am watching stuff - youtube for example - the playback is/WAS jerky. I hadn't touched anything in the settings.

After digging around, I discovered that I had to turn ""OFF"" the hardware acceleration for the graphics. Question: How did it get turned on? (Semi rhetorical)

I have a lot of local pages I open with passwords. When I load them the CPU load goes through the roof and nearly invariably the program just exits. No crash report.

Which is a good 50% of how it happens. The other 50% is the machine just locks up and I have to power it down.

Asked by teeny_weeny 1 day ago

Last reply by teeny_weeny 9 hours ago

speeding up Firefox

I clicked on a popup link from Firefox to speed up my browser. Came back to my computer and everything's gone, all my fast links that I had at the top of my screen, like … (read more)

I clicked on a popup link from Firefox to speed up my browser. Came back to my computer and everything's gone, all my fast links that I had at the top of my screen, like Facebook, Gmail, everything I've saved for quick links over the past 2 years. I want my computer back, just the way I had it. This is a nightmare. I'd much rather my browser run slow (it really wasn't running slow). I tried a system restore, but it didn't restore things the way I had them. Please, what do I do to reverse this nightmare, and please don't ever offer to speed up my browser again.

Asked by ginchinchili 1 day ago

Last reply by ginchinchili 9 hours ago

Constantly Crashing Firefox Tabs

My firefox tabs has been crashing, and it has been getting far far worse. Practically none of the tab will open longer than 5 milliseconds. Other browsers works perfectl… (read more)

My firefox tabs has been crashing, and it has been getting far far worse. Practically none of the tab will open longer than 5 milliseconds. Other browsers works perfectly fine. I tried starting it on safe mode, no good. Tried clean reinstalling firefox, no good.

Can anyone help me why firefox is specifically crashing? About a month ago it worked perfectly fine.


bp-6fcdddcf-9364-454b-b261-eb1ef0201129 bp-6313cc4d-414d-4a6d-a155-f48a20201129 bp-4f4a056c-b467-4b1b-8349-715710201129 bp-58e36541-9f24-4cc4-8173-77b5c0201129 bp-35662b35-b468-483c-bbdb-60c050201129 bp-7bfda4a0-329e-4e00-ae27-30bba0201129 bp-cbf8c777-09bd-435f-aaf8-ccdb10201129

Asked by skypasser 1 day ago

Last reply by cor-el 9 hours ago

Firefox unusable but doesn't crashes, freezes

***************************** The problem When I start firefox I see a blank page (this was not my starting page before the problem occured)(Image linked). The overall gr… (read more)

***************************** The problem When I start firefox I see a blank page (this was not my starting page before the problem occured)(Image linked).

The overall graphical window is not frozen but I can't open any webpage nor any local file. The option pages don't work either nor any of the about:XXX pages.

*************************** What I tired I cleared my cookie/cache. I tried firefox's safe mode. I refreshed firefox. I deleted my profile and created a new profile. I desactivated all my security software. I ran firefox with root privilege. Updated windows. None of that did solved the problem.

This problem persisted after I haved uninstalled Firefox, deleted my profile, deleted all mozilla directories in ProgramData, AppData, Program, cleaned up my disk with window's 10 utilitary and reinstalled firefox (I also tried a simple install unistall so I don't think I broke firefox by deleting files). When reinstalling firefox I tried both a 64 and a 32 bits install with current and older version none worked.

I scanned my PC for malwares, nothing found. I checked my memory as suggested in a troobleshooting page, (no problem found).

Firefox DOES WORKS in window's safe mode.

************************************ Observations I noticed via my firewall that firefox don't even send any package to the internet if I try to acess a website. Firefox does however acces 127.0.0.1 (at least it asks for permission). Firefox doesn't close if I use top right red cross, it does close if, in task bar I right click/close all windows or if I exit within the "three horizontal bar menu" I precise that my connection is ok and that MS Edge is working fine.

I repeat, Firefox works in window's safe mode.

I would really appreciate your help as I can't find any other thing to try.

Asked by a.ranaud00 1 day ago

Last reply by FredMcD 12 hours ago

Automatic launch of Firefox, also when other firefox windows are already open.

Hello, since months I have problem with automatic launch of Firefox on my computer, It's really insupportable. I'm ready to abandon firefox. I'm on windows 10 and I use … (read more)

Hello,

since months I have problem with automatic launch of Firefox on my computer, It's really insupportable. I'm ready to abandon firefox. I'm on windows 10 and I use Firefox 83. There is 3 different sessions on my computer and only one has the problem.... my session. Firefox launch a new windows always and regularely, when the computer start, and all the time during the use of my sessions. If i'm already on Firefox, a new windows open's.... If I close this one, few second after an other open's..... If I put this one on background, about 1 min after again an other open's. Like this always and indefinitevely. Whatever my use of the computer or the site to visit. Even when I don't use internet and use other software to work, Firefox starts up and goes in front of my software. If I let my session opened and I do nothings, after a certain time a lot of firefox windows are open. You can easily understand why I say that It's really insupportable... and this only with Firefox on my session.

My computer is protected with antivirus, and I did a full scan several time, I also tried with an other antivirus software. I used 2 softwares for detect malware... Nothing. I try to uninstall and reinstall Firefox, but the problem still the same after reinstall. I already set the "toolkit.winRegisterApplicationRestart" on "false" but firefox start alone again, again, again...

Does anyone has an idea of what is the problem and what I can do ?

Thanks.

Asked by GHOE70 22 hours ago

Last reply by FredMcD 12 hours ago

Slow Firefox for Deasktop!!!!!!!!!!

Hello, Can you tell me what happen with your browser in around last 1 year? My internet connection is: Download~1000 Mbps,Upload~600 Mbps. See attached photo what is my … (read more)

Hello, Can you tell me what happen with your browser in around last 1 year? My internet connection is: Download~1000 Mbps,Upload~600 Mbps. See attached photo what is my internet,when i test it with different browsers which i have installed on my PC. See what is the statistic for Firefox O.O WTF? I like your browser and use it from very long time,but if will it crash my connection,i will forget for it! Do something!

Asked by Angel Of Death 14 hours ago

Last reply by Angel Of Death 12 hours ago

Why is it so hard to find my recent bookmarks?

I use the star symbol to add bookmarks, and then when I try to look at those bookmarks that I have saved, I can't find them. They do not appear when I load the bookmarks … (read more)

I use the star symbol to add bookmarks, and then when I try to look at those bookmarks that I have saved, I can't find them. They do not appear when I load the bookmarks tool. Instead I see Firefox bookmarks and a list of ancient bookmarks. Please see the attached image. I have clicked on all the links in the attached image, and none of them show me my recent bookmarks. Can someone please tell me where my latest bookmarks are hiding? Thanks.

Asked by b98765 14 hours ago

Last reply by cor-el 13 hours ago

when openinig firefox the logo is displaying like something

the browser is crashing and its taking too much memory and storage even though I have minimized memory usage through about:memory>minimize memory usage but no use afte… (read more)

the browser is crashing and its taking too much memory and storage even though I have minimized memory usage through about:memory>minimize memory usage but no use after few days it the logo is not displaying its displaying like in the figure attached and another thing is its taking tooo much time to open browser and also to load the page even though the net speed is good

Asked by luckyjuly1947 1 day ago

Last reply by cor-el 13 hours ago

HD Youtube videos stutter on only the current Firefox (in my case 78 esr)

Only one Browser has problems with HD videos (1080p + above) on youtube: Firefox in the most current version. I have tested so far only the one current latest version of … (read more)

Only one Browser has problems with HD videos (1080p + above) on youtube: Firefox in the most current version.

I have tested so far only the one current latest version of the ESR branch (78.3.x). But as visible from thousands of articles to this very particular problem (when i search the community help database for "Youtube videos stutter" i get multiple thousands of entries - i read only a handful of them to realize that they are all "closed" and not a single one "solved"), this problem persists since multiple years now.

I have a very old PC by my side with a very old Firefox (benchmark wise slower than my current PC by a factor of at least 3) ESR 52.9, which is able to play the same videos in the same HD resolution without the slightest stutter.

The drivers on that old system are - naturally - outdated by half a decade. THAT OLD OUTDATED system with THAT OLD OUTDATED Firefox is well able to play even multiple HD videos side by side. With-OUT any stutter.

Thus, you can easily deduce by logical reasoning that nighter any outdating of drivers whatsoever nor any outdating of anything else on the system, be it hardware wise or software wise, CAN AT ALL be the culprit of that stuttering.

While the former holds true, what you actually find in the communities help are completely useless and irrational tips of "upgrading the browser to the last version", "upgrading drivers" or "reinstalling any software" or the like.

Let me be clear: Nothing of the latter will ever help in overcoming the stuttering of current firefoxes at all. The only one measure that will help here is to revise the code that is underlying the video pipe.

Since the stuttering regularly only begins after about one to two minutes into the videos, it is strongly suggestive that something in the memory management - probably in the way resources becoming freed after use - is accumulating over time until the stuttering begins. Badly managed garbage collection, perhaps?

Asked by White-Gandalf 1 month ago

Last reply by cor-el 13 hours ago

  • Solved

Firefox not loading some content

I've recently noticed an issue with Firefox not loading some content for me. On one page it failed to load embedded videos, and when I contacted the site to alert them to… (read more)

I've recently noticed an issue with Firefox not loading some content for me. On one page it failed to load embedded videos, and when I contacted the site to alert them to the problem they troubleshooted and the issue seemed to be with my browser. A second time, when trying to use Instagram scheduler Planoly, I discovered that none of the images of my feed would display in the program, and again when I contacted support they could find no issue at their end.

I have followed advice and: - cleared my cache and cookies - disabled extensions one by one - scanned my machine for malware.

Any advice would be much appreciated.

Asked by Linconclusive 1 day ago

Answered by cor-el 1 day ago

pop-downs

My allowed pop-ups (java pop-ups) for some reason now arrive as pop-downs. I am working with multiple screens and in multiple windows. And instead of expected small win… (read more)

My allowed pop-ups (java pop-ups) for some reason now arrive as pop-downs. I am working with multiple screens and in multiple windows. And instead of expected small window appearing at the top of the active window each pop-up appears UNDERNEATH active window and exactly of the same size. and it is a headache to find it after. Any solution?

Asked by tina.molodtsova 16 hours ago

  • Locked

I have updated my O/S from Ubuntu 18.04 to 20.10. Nothing else. Now Firefox is nearly useless

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it. Originally I was using Ubuntu 18.04 LTS. I thought it woul… (read more)

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it.

Originally I was using Ubuntu 18.04 LTS.

I thought it would be good to update to GG (20.10) though I did briefly try FF (20.04).

As the install was done on an existing 18.04 version things remained the same for programs, book marks, etc.

Ok, now the crunch: I USE Firefox ""A LOT"". When it loads, there are...... 8 x 6 windows of FireFox and each of those have anywhere from one to ""THIRTY"" tabs loading.

Believe me: ""It worked!!""

I could use it, also run other tasks as well - though a VM was pushing it with the RAM. But the entire machine worked.

Now, I am lucky if FireFox loads at all. Let alone let me browse.

When it loads some of the window's tops are flashing. A screen shot does not really show this. (I tried)

All that has changed is the O/S from 18.04 and Firefox from (what ever it was) to 83.0

I don't want this to be a finger pointing exercise between Mozilla and Ubuntu. I would prefer it is helpful to all.

What have I tried? I've tried starting FireFox with all addons disabled. Still happens.

I am going to try to remember to (next time) launch FireFox from a Terminal and pipe the output to a file to look for things.

The machine I am using has shown it is well up to being able to have this running. I have had it working for a few years like this.

This post is (for now) to establish there is a problem. I will post more information when I get it, rather than waiting to get it then post, as I feel there are a lot of people who have very similar problems and I want it known: ""You are not alone!""


Now a bit of extra stuff.

Other things which are weird: When I am watching stuff - youtube for example - the playback is/WAS jerky. I hadn't touched anything in the settings.

After digging around, I discovered that I had to turn ""OFF"" the hardware acceleration for the graphics. Question: How did it get turned on? (Semi rhetorical)

I have a lot of local pages I open with passwords. When I load them the CPU load goes through the roof and nearly invariably the program just exits. No crash report.

Which is a good 50% of how it happens. The other 50% is the machine just locks up and I have to power it down.

Asked by teeny_weeny 1 day ago

Last reply by Seburo 17 hours ago

Firefox keeps logging out me from all accounts

Since about a week Firefox logs me out of all accounts when I close the browser. I checked the many threads here and have done everything including: Made sure it's not pr… (read more)

Since about a week Firefox logs me out of all accounts when I close the browser. I checked the many threads here and have done everything including: Made sure it's not private browsing Made sure the history is not set to clear at exit Cookie settings are in default mode Remember history is on This problem started without me changing any settings on the browser. But I did a fresh install too, and that after clearing the Appdata too so that the install is absolutely fresh. It still continues. Facebook, Gmail, Yandex, and all other accounts are autocratically logged off which is absolutely frustrating. Can any Firefox developer please find a solution beyond "make sure the .... " etc. ?

Asked by dapokerista 1 day ago

Last reply by FredMcD 22 hours ago