Mouse cursor disappears when hovering certain content in applications like Balsamiq, Miro, Google Maps

Observed On Firefox 92.0 on WIndows 10 Steps to reproduce 1. I work on a Balsamiq wireframes, I hover a canva Behaviour The mouse cursor disappears Expected … (read more)

    1. Observed On

Firefox 92.0 on WIndows 10

    1. Steps to reproduce

1. I work on a Balsamiq wireframes, I hover a canva

    1. Behaviour

The mouse cursor disappears

    1. Expected behaviour

It should be always visible

    1. Other info

Also noticed with Miro or Google Maps embedded Changing the browser fixed the issue

Asked by Julien 1 day ago

Last reply by Julien 2 minutes ago

firefox "screenshot" command line option

in previous versions of firefox, I was able to create screenshots with the following command line options: /firefox.exe" -P headless --purgecaches --screenshot raw_weathe… (read more)

in previous versions of firefox, I was able to create screenshots with the following command line options:

/firefox.exe" -P headless --purgecaches --screenshot raw_weather.png --window-size=1920,1080 -browser "https://www.google.com/search?&q=weather+in+Washington+DC"

however, with the latest version 92.0.1, the "--screenshot" option no longer works. what has changed? what am I doing wrong?

Asked by nealelliott1 17 hours ago

Last reply by nealelliott1 1 hour ago

language

again after an update the language settings are not working. I change to Dutch(Nederlands belgie) and i got a mix of english and dutch. It's not the first time after an u… (read more)

again after an update the language settings are not working. I change to Dutch(Nederlands belgie) and i got a mix of english and dutch. It's not the first time after an uopdat that this problem occures.

Asked by pagre2213 1 hour ago

Certain downloads repeatedly fail when in Incognito mode, and succeed in Regular mode, even when the requests sent by the browser are 100% word-for-word identical. Request logs provided.

SHORT SUMMARY: A few specific direct downloads from a third-party server successfully finish in Regular browsing mode but fail half-way in Incognito mode. This is reprodu… (read more)

SHORT SUMMARY:

A few specific direct downloads from a third-party server successfully finish in Regular browsing mode but fail half-way in Incognito mode. This is reproducable on numerous tries and persists between Firefox restarts, system reboots, and ISP changes. This difference between Regular and Incognito remains even when the requests that the browser sends are fully word-for-word identical, down to the DNT=1 in the request. There are no issues with downloads in Google Chrome on the same machine, and similarly no issues in Incognito mode an old ESR Firefox (v52) on a really old laptop with WinXP. This problem ONLY appears in Firefox 92. ========================================

FULL DETAILS:

I'm using the latest public release of Firefox, 92.0.1, on Windows 8. I have a habit of using Incognito mode most of the time, and I found out that certain downloads fail in Incognito tabs - but succeed in Regular tabs. A few examples:

http://down.360safe.com/cse/360cse_official.exe http://down.360safe.com/cse/360cse_9.5.0.122.exe http://down.360safe.com/cse/360cse_9.5.0.114.exe http://down.360safe.com/cse/360cse_9.0.1.162.exe

They are direct links to the .exe setups of various versions of an obscure browser called 360 Extreme Browser, recommended for use with WinXP on obsolete hardware since it's supposedly very lightweight. You can run them through VirusTotal if you want. The first link always points to the latest release, the other links are specific releases.

When I open any of them, I am first presented with the regular download dialog box, while Firefox automatically starts downloading the file to %TEMP% in the background, without waiting for my decision (as it always does):

https://i.imgur.com/0D6pH4Z.png

... then, a couple seconds later, I'm presented with the "source file could not be read" error.

https://i.imgur.com/3f6StGQ.png

When I click OK, the first dialog box also disappears, and there is no trace of the (failed) download left in the download widget in the top right.

Alternatively, I can try to be very fast, and as soon as the first dialog box appears, I can quickly click "Save File" and press Enter in the folder selection window that appears. That way, I can confirm the download before it gets a chance to fail. But it fails anyway, except this time I can see the incomplete file in my destination folder, and the failed download in the list of downloads in the top right corner of Firefox. This download fails about 5-15 MBs into the file - it's different between different attempts.

It is my understanding that the "nature" or "mechanism" of the fail is the same, but if it happens while it's downloading to %TEMP% and I haven't selected the folder yet, then I'm presented with an explicit error message and there is no trace of it in the download history, and if it happens when I've already selected the folder, then there is no explicit error message and the failed download is displayed in the download history.

In the latter case, I can then press "Retry download" in the download history. Then, the download will successfully restart (not from zero, but from the percentage that it failed at) and will successfully complete. But the FIRST try, initiated by the tab ("by the page"?) and not by the "download history" widget in the corner, ALWAYS fails at some point between 5-15 MBs.

========================================

INVESTIGATION AND LOGS AND LOTS OF TECHNICAL DETAILS

So you might say, that third-party server is acting weird and is probably misconfigured. But:

  • This download ALWAYS SUCCEEDS without any problems in Regular (not Incognito) tabs. It ALWAYS FAILS in Incognito.
  • This download ALWAYS SUCCEEDS in Google Chrome that I have on this same machine, both in Regular and in Incognito.
  • This download ALWAYS SUCCEEDS in Firefox 52.9 ESR on a really obsolete laptop with WinXP that I have, connected to the same network(s), both in Regular and in Incognito.

To sum up, this fails VERY SPECIFICALLY in Incognito mode in Firefox 92 (current modern version) and NOWHERE ELSE.

All download attempts that are successful (non-Incognito FF 92, Google Chrome, FF 52.9 ESR...) result in a downloaded file with the same correct size and checksum. The download that is successfully RESTARTED after failing in Incognito (read details above) also results in a file with the same size and checksum.

I am not aware of any software on this machine that would be interrupting the download, such as antivirus. In any case, it's interrupted when it reaches a different random size on each different attempt, and it only affects Incognito Firefox and nothing else - not Regular tabs of FF and not Chrome. I have also tried two different ISPs - one that provides me with Ethernet at my place, and my mobile phone ISP. Same behavior between them. The only third-party plugin that I have in Firefox is uBlock. I disabled it completely and this didn't change anything.

I've inspected the requests and responses, using Firefox's own dev tools.

REGULAR TAB (not incognito) = SUCCESSFUL DOWNLOAD

GET http://down.360safe.com/cse/360cse_9.5.0.122.exe

GET /cse/360cse_9.5.0.122.exe HTTP/1.1 Host: down.360safe.com User-Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0 Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 Accept-Language: en-US,en;q=0.5 Accept-Encoding: gzip, deflate Connection: keep-alive Upgrade-Insecure-Requests: 1

Response:

HTTP/1.1 200 OK Date: Tue, 28 Sep 2021 06:38:12 GMT Content-Type: application/octet-stream Content-Length: 45846432 Connection: keep-alive Expires: Tue, 28 Sep 2021 06:48:12 GMT Last-Modified: Fri, 02 Feb 2018 12:20:52 GMT Cache-Control: max-age=600 ETag: "5a7457a4-2bb8fa0" KCS-Via: REVALIDATED from w-f03.lato;MISS from back-f01.dl.lato;REVALIDATED from w-subsrc02.lato;MISS from back-subsrc01.dl.lato K-Cache-status: MISS Accept-Ranges: bytes

INCOGNITO TAB: FAILED DOWNLOAD

GET https://down.360safe.com/cse/360cse_9.5.0.122.exe <- notice the forced switch to HTTPS, caused by Incognito mode

GET /cse/360cse_9.5.0.122.exe HTTP/1.1 Host: down.360safe.com User-Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0 Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 Accept-Language: en-US,en;q=0.5 Accept-Encoding: gzip, deflate, br DNT: 1 Upgrade-Insecure-Requests: 1 Connection: keep-alive Sec-Fetch-Dest: document Sec-Fetch-Mode: navigate Sec-Fetch-Site: none Sec-Fetch-User: ?1

Response:

HTTP/1.1 200 OK Date: Tue, 28 Sep 2021 06:40:54 GMT Content-Type: application/octet-stream Content-Length: 45846432 Connection: keep-alive Expires: Tue, 28 Sep 2021 06:50:54 GMT Last-Modified: Fri, 02 Feb 2018 12:20:52 GMT Cache-Control: max-age=600 ETag: "5a7457a4-2bb8fa0" KCS-Via: REVALIDATED from w-f01.lato;MISS from back-f01.dl.lato;REVALIDATED from w-subsrc01.lato K-Cache-status: MISS Accept-Ranges: bytes

The differences are: Incognito mode forces HTTPS, sends Sec-Fetch- entries in the GET request, and also sends DNT = 1. Everything else is the same.

I then went to Firefox settings and enabled sending DNT *all the time*, even in Regular (non-incognito) tabs. I also tried to download explicitly from the https:// URL in Regular (non-incognito) mode, just like Incognito mode forces https. This resulted in a request that is sent from a Regular tab but is 100% identical to the request sent from Incognito mode. Read below:

GET https://down.360safe.com/cse/360cse_9.5.0.122.exe

GET /cse/360cse_9.5.0.122.exe HTTP/1.1 Host: down.360safe.com User-Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0 Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 Accept-Language: en-US,en;q=0.5 Accept-Encoding: gzip, deflate, br DNT: 1 Connection: keep-alive Upgrade-Insecure-Requests: 1 Sec-Fetch-Dest: document Sec-Fetch-Mode: navigate Sec-Fetch-Site: none Sec-Fetch-User: ?1

Response:

HTTP/1.1 200 OK Date: Tue, 28 Sep 2021 06:45:17 GMT Content-Type: application/octet-stream Content-Length: 45846432 Connection: keep-alive Expires: Tue, 28 Sep 2021 06:55:17 GMT Last-Modified: Fri, 02 Feb 2018 12:20:52 GMT Cache-Control: max-age=600 ETag: "5a7457a4-2bb8fa0" KCS-Via: HIT from w-f05.lato;MISS from back-f03.dl.lato;REVALIDATED from w-subsrc01.lato K-Cache-status: MISS Accept-Ranges: bytes

You can check that this request from a Regular (non-incognito) tab is now word-for-word identical to the request from an Incognito tab. Yet, the download from Incognito STILL fails at ~10 MBs into the file, and the download from Regular STILL succeeds. I fail to see any difference between the requests, whatsoever.

In the Cookies tab, there are "No cookies for this request" for both Regular and Incognito downloads. The Security tab looks 100% identical for Regular and Incognito downloads, and looks like this: https://i.imgur.com/SAhzquW.png (idk how to copy this in plaintext form).

In another online discussion elsewhere while I was troubleshooting this, I was advised to see if network.dns.echconfig.enabled was set to TRUE and to try setting it to FALSE. Not sure what this would change, but I went to check and found that it was already FALSE.

Also, in that discussion elsewhere, I had one more user running Firefox on Windows 10 (according to his publicly displayed user agent) confirm this. But I don't know how to reach him to ask for extensive troubleshooting like mine.

========================================

FINAL SUMMARY:

  • Some specific downloads fail halfway in Incognito Mode in latest Firefox
  • There are no issues in Regular (non-incognito) mode, or in Google Chrome on this same machine, or in obsolete Firefox 52 on another machine
  • This persists across Firefox restarts, reboots, ISP changes
  • This difference between Regular and Incognito modes persists even when you change settings so that the sent GET requests are 100% word-for-word identical

Help me troubleshoot this further? Even if this is caused by that third-party server acting up (for whatever reason), how does it tell between my Regular firefox tab and my Incognito firefox tab when the sent requests are the same? And even if this is caused by something else on my machine or in my network, then the same question applies, how can this "something" tell between my Regular and Incognito tabs?

Asked by jagev53494 1 hour ago

Firefox uploaded 250MB to a random fastly server without any knowledge from the user.

I have just caught Firefox uploading 250MB to a random Fastly server for no reason. I wasn't uploading anything i was just watching some YouTube videos. Should i be alarm… (read more)

I have just caught Firefox uploading 250MB to a random Fastly server for no reason. I wasn't uploading anything i was just watching some YouTube videos. Should i be alarmed? Should i worry about this? Is it normal or do i need to check my PC for malware (MalwareBytes didn't find anything) Any help would be appreciated. Im using Glasswire to check data usage.

Asked by kimos20139 2 hours ago

POCKET

I can’t get rid of Pocket Trending. If I can’t resolve this issue I will delete this browser.

Asked by Pressgang 3 hours ago

PDF preview in Outlook Web App

When previewing a PDF attachment in Outlook Web App, the preview screen shows the message 'something went wrong while the document preview was being created' and no previ… (read more)

When previewing a PDF attachment in Outlook Web App, the preview screen shows the message 'something went wrong while the document preview was being created' and no preview shows.

  • the exact same account and email shows fine in both Edge and Chrome
  • the preview looks fine for Word and Excel files
  • the problem persists in private mode
  • the problem persists after clearing cache and cookies
  • changing Firefox 'actions for applications' settings for PDF makes no difference
  • the problem has been tested and confirmed on two computers using different connections in different locations.

Firefox version 92.01 64-bit

Asked by john655 3 hours ago

Firefox browser for Catalina OS 10.15

I'm having a problem with Firefox. I can't quit or force quit the browser. I used the red button on the browser window to close it; but, still can't get it to quit and … (read more)

I'm having a problem with Firefox. I can't quit or force quit the browser. I used the red button on the browser window to close it; but, still can't get it to quit and now I can't reopen the browser. I tried to restart my computer thinking that might force Firefox to quit; but, it did not work and the computer canceled the shut down process. I've never had this issue with Firefox before. I can't even say which version of Firefox I have. It is a newer version, though.

I did find a similar problem in a different thread; but, the thread was closed; so, I'm starting this one. Please let me know what I can do to fix this.

Asked by pnwfemale 8 hours ago

Firefox crashed contantly!

I return to my hibernating iMac, and 40% of the time, all open windows are closed. Often, the browser has also reset my search engine and no longer loads my default web … (read more)

I return to my hibernating iMac, and 40% of the time, all open windows are closed. Often, the browser has also reset my search engine and no longer loads my default web page.

Asked by John Felock 9 hours ago

MD5 Hash ESR 91.1.0 Changing

So every time I download 91.1.0 from here: https://www.mozilla.org/en-US/firefox/all/#product-desktop-esr The MD5 hash changes. Please let me know what I'm doing wrong...… (read more)

So every time I download 91.1.0 from here: https://www.mozilla.org/en-US/firefox/all/#product-desktop-esr The MD5 hash changes. Please let me know what I'm doing wrong... because I'm pretty sure it's my misunderstanding.

Asked by geary1 4 days ago

Last reply by geary1 10 hours ago

How to Fix Screenshot Capability

Hello, I am using Firefox version 92. The screenshot function is not working, both if I right click and request a screenshot from the slideout menu, and if I request a sc… (read more)

Hello,

I am using Firefox version 92. The screenshot function is not working, both if I right click and request a screenshot from the slideout menu, and if I request a screenshot from the shortcuts/overflow menu (scissors icon). I have attached a screenshot (taken with ‘prntscr” through windows) png of the result that takes place on my screen. The screen will freeze with this image of a large X until I do a refresh of the page. Cntl-Shift-S also does not work. I have tried clearing the cache, running FF in safe mode, refreshing FF, reinstalling FF, and I have ensured that the extensions.screenshots.disabled setting in about:config is set to ‘false’ (also toggled it to ‘true’ and back to ‘false’). I have attached a screenshot of all the settings in about:config that pertain to screenshots.

Thank you for your help.

Asked by Thanks4FF 2 weeks ago

Last reply by Thanks4FF 10 hours ago

Our thumbnails are showing up in every other browser, but not in Firefox

Hello. Recently we started an adult site, https://thepornbutler.com. I cannot figure out why thumbnails are not showing in Firefox. They are showing in all the other brow… (read more)

Hello. Recently we started an adult site, https://thepornbutler.com. I cannot figure out why thumbnails are not showing in Firefox. They are showing in all the other browsers out there. Example page: https://thepornbutler.com/photos/dressed-undressed/ Have you any suggestions or ever heard of this problem? My Firefox up to date: 92.0.1 (64 bit).

Thank you Kevin Loader

Asked by kloader32 11 hours ago

"Custom" Print Option No Longer Works

FF has been my default for decades primarily because of superior print options. I use Custom Print option to print out pages in larger front, but this no longer seems to … (read more)

FF has been my default for decades primarily because of superior print options. I use Custom Print option to print out pages in larger front, but this no longer seems to work in 92.01. At say 115 custom I lose text to right and bottom of page (both in preview and print to PDF).

Asked by rrichard 12 hours ago

Multiple issues with newer version

too many problems with new version released 4-6 weeks ago ... on-line forms don't recognize selections, blank spots in screens where "phantom" text seems to be ... and th… (read more)

too many problems with new version released 4-6 weeks ago ... on-line forms don't recognize selections, blank spots in screens where "phantom" text seems to be ... and the bright white format is hard on the eyes. Please tell me this will change so I don't have to sever a decades

Asked by larry105 12 hours ago

Blacked out letters on Firefox Bookmarks Toolbar and Window tabs

Sometimes (not always!), the entries on my bookmarks toolbar appear with the lower case a's blacked out, and the leading edge of lower case e's as well. Nowhere else on t… (read more)

Sometimes (not always!), the entries on my bookmarks toolbar appear with the lower case a's blacked out, and the leading edge of lower case e's as well. Nowhere else on the page does this happen. Anyone else ever seen this? Is there a fix? Thanks

Asked by dtowson 1 week ago

Last reply by dtowson 14 hours ago

Home Page Shortcuts - Custom image not displaying

I am trying to organize my homepage tiles with shortcuts to the sites I frequent most. Some sites have their logo automatically appear in the tiles, for other websites it… (read more)

I am trying to organize my homepage tiles with shortcuts to the sites I frequent most.

Some sites have their logo automatically appear in the tiles, for other websites it does not.

For those that the logo does not appear automatically, I edit the tile and select "Use a custom image"

Upon entering the URL, the image appears in the preview, but once I save, the tiles appears blank (just a white square).

Any suggestions on what I can do? Ive tried various images for various tiles - it appears as soon as I try to add a custom one it goes blank (see screen shot as example)

Asked by Mlavigne 15 hours ago

Passwords Missing. How do I get them back?

Today I lost all of my passwords stored on Firefox. Many were passwords generated by firefox which are weird and not memorable. I have lost access to many accounts. How d… (read more)

Today I lost all of my passwords stored on Firefox. Many were passwords generated by firefox which are weird and not memorable. I have lost access to many accounts. How do I recover the missing passwords to my accounts?

Asked by coledesigns4u 15 hours ago

Cannot change settings they are greyed out

I am in my account on Firefox version 92.0.1 and when I go into my settings I want to change some but they are greyed out. How do I get this so I can edit them? I went in… (read more)

I am in my account on Firefox version 92.0.1 and when I go into my settings I want to change some but they are greyed out. How do I get this so I can edit them? I went into preference in Firefox then down to Privacy and want to make some changes there but some of the areas such as clear history when Firefox close is greyed out. how DO i make changes in Firefox?

I am not able to change the proxy settings as they are greyed out.

Asked by anilchowdary527 16 hours ago

Last reply by anilchowdary527 15 hours ago

Кривой шрифт на страницах

Всем привет. Почему-то абсолютно на всех вебстраницах шрифт выглядит максимально уродливо. Где то полутонкие буквы, где то они и вовсе съезжают друг на друга. В некоторых… (read more)

Всем привет. Почему-то абсолютно на всех вебстраницах шрифт выглядит максимально уродливо. Где то полутонкие буквы, где то они и вовсе съезжают друг на друга. В некоторых местах длинный дефис превращается в "Ч". С шрифтами игрался, ничего не помогло. Попробовал еще пару браузеров - там все нормально. На скриншоте пример из firefox и из другого браузера.

Asked by vdrochuk 2 days ago

Last reply by vdrochuk 16 hours ago