Firefox window menu options on Mac

Hi Folks, I've recently started working with a Mac (Catalina) and found an oddity that only seems to apply to Firefox. I set up keyboard shortcuts for moving windows betw… (read more)

Hi Folks,

I've recently started working with a Mac (Catalina) and found an oddity that only seems to apply to Firefox. I set up keyboard shortcuts for moving windows between my macbook display and an external monitor using the in-built keyboard options to add shortcuts.

These target the Window>Move to [DISPLAY NAME] menu entries at the top of the screen. For some reason Firefox windows don't have this menu entry and therefore my shortcuts don't move Firefox windows between my screens.

I've included a couple screenshots to demonstrate. It's not a huge deal but I wonder if it's an issue with my machine or just a quirk of Firefox?

Asked by totzo 1 hour ago

Personal Bar not working with sync

Hello, Since i got my Firefox account, i can't manage to sync my personal bar, each time i try to connect with another computer, there is nothing but id and passwords lef… (read more)

Hello,

Since i got my Firefox account, i can't manage to sync my personal bar, each time i try to connect with another computer, there is nothing but id and passwords left, i got to manually add all personal bar bookmarks again. What can i do about this issue ?

Thank you,

Hervé.

Asked by dodehav 3 hours ago

Web browser & online gaming issue

Hi! Recently I started gaming online on steam but it keeps on crashing in the Mozilla browser. Prior to this I had been using Steam on chrome & it seemed to work fine… (read more)

Hi! Recently I started gaming online on steam but it keeps on crashing in the Mozilla browser. Prior to this I had been using Steam on chrome & it seemed to work fine. Any idea what's going on? You can reach me at my mail redfieldjames380@gmail.com or alternatively at here.

Asked by redfieldjames380 4 hours ago

google calendar doesn't print. It loads fine.

When I select Print from the cal menu, I get the window preview which is normal. When selecting PRINT, nothing comes up. It just sits there. It used to bring up a dia… (read more)

When I select Print from the cal menu, I get the window preview which is normal. When selecting PRINT, nothing comes up. It just sits there. It used to bring up a dialog box to select printer (pdf, etc) This happens on multiple Windows machines and has for months. I just tried adding an exception for the pop-up blocker, no effect. Thanks!

Asked by nelreed 13 hours ago

firefox 8.5 win 10pro 64 bit problems - lags

hey i have firefox 8.5 - and a problem since v8.4 and present. Web pages load very slowly - the whole browser is very slow, the load on the frame RAM and CPU is reaching … (read more)

hey i have firefox 8.5 - and a problem since v8.4 and present. Web pages load very slowly - the whole browser is very slow, the load on the frame RAM and CPU is reaching its zenith with the windows open. In one word the browser has become useless. Anticipating responses - 1. In safe mode - browser speeds up slightly, but websites still have lags and take a long time to load. 2. I reinstalled firefox - the errors continued. 3. I turned on firefox without logging in and with add-ons disabled - the browser worked with the errors described above. 4. I turned on firefox and logged into the profile, but turned off the add-ons - firefox - still has errors; I turned on a generation of additions (recommended) - firefox still has bugs. 5. My antivirus is not blacklisted by firefox - and I have no worms etc. 6. Standard or changed settings - firefox doesn't work well. Any suggestions or advice? Websites like FB, YT and others are simply unloadable with such lags. thanks.

Asked by DJ LUX 15 hours ago

Syncing changes in bookmarks

I just started using sync for bookmarks. When I make changes - additions and deletions - I want them to appear on other machines and be permanent on the machine I am usi… (read more)

I just started using sync for bookmarks. When I make changes - additions and deletions - I want them to appear on other machines and be permanent on the machine I am using, but they keep getting added back on, I think from my other machines. What to do?

Asked by pmikolay 18 hours ago

Top sites icons missing

I recently made some custom icons for my top sites: uploaded them online, added the custom image url and they looked great. But they don't seem to be working anymore, I o… (read more)

I recently made some custom icons for my top sites: uploaded them online, added the custom image url and they looked great. But they don't seem to be working anymore, I only had them for a couple of days and can't think of anything I might've done for that to change.

I can add a different image url and it shows up, in fact, I set the icons both in Linux and Windows and they still show up in Windows. I attached a before and after, what's going on? Thanks in advance

Asked by Clara 19 hours ago

Content Security Policy in Firefox

Hi, we have encountered with the CSP issue in Firefox: We have the following CSP <meta> tag in our application: <meta http-equiv="Content-Security-Policy" conte… (read more)

Hi, we have encountered with the CSP issue in Firefox:

We have the following CSP <meta> tag in our application:

<meta http-equiv="Content-Security-Policy" content="default-src 'self';

                  script-src  'self' 'unsafe-eval';
                  style-src 'self' 'unsafe-inline';
                  base-uri 'self';
                  frame-src 'self';
                  media-src 'self';
                  navigate-to 'self';
                  form-action 'self';
                  object-src 'none';
                  connect-src 'self'">

As you see, we did not specified 'unsafe-inline' nor in script-src, nor in default-src. Which means that inline scripts like <script>alert(1)</script> should not be allowed to execute. But it still works in Firefox and we get an alert popup.

In Chrome and Edge the policy works fine, and blocks the script execution.

Please assist on the issue.

With respect, Victorz

Asked by victorz1 19 hours ago

iCloud & Apple TV+ not loading

I'm running the latest version of Firefox (85.0 64bit) on Windows 10. Perhaps I could get help here. I can't login in either https://www.icloud.com/ or https://tv.apple.c… (read more)

I'm running the latest version of Firefox (85.0 64bit) on Windows 10.

Perhaps I could get help here.

I can't login in either https://www.icloud.com/ or https://tv.apple.com/

Screenshots of the problem are attached here. In both websites I see the circle as it is trying to load (on icloud, eventually, get an error "iCloud encountered an error while trying to connect to the server"). I've tried to use these websites with Chrome and Edge and it works normally.

Solutions I've tried but did not work: - cleaned cache and history; - turned off firefox protections against monitoring; - turned off uBlock Origin (it's the only plugin installed besides DuckDuckGo) - tried in private window, does not work as well

Is this a known bug or/and is there any solution? I can try anything you will suggest to me, I really need to open these websites and I do not want to use any other browser besides Firefox.

Asked by headgaar 21 hours ago

Firefox black screen + can't go in the option

Hi I do not know why but since today I have a black screen when I launch firefox. The screen is also black when I go in the option... I tried to uninstall/reinstall and … (read more)

Hi I do not know why but since today I have a black screen when I launch firefox. The screen is also black when I go in the option... I tried to uninstall/reinstall and it didn't fix the problem. I also tried to repair firefox but it was also useless. My graphic drivers are updated btw. Any ideas ?

Asked by arkshayh 21 hours ago

new tabs won't connect to any site

I had an odd thing happen in FF. New tabs would not bring up a site. Old tabs that were open from the previous evening would run. Bing worked fine, though, so it wasn't a… (read more)

I had an odd thing happen in FF. New tabs would not bring up a site. Old tabs that were open from the previous evening would run. Bing worked fine, though, so it wasn't a networking problem. I finally bounced FF and everything worked again. Just wanted to report it. Thanks.

Asked by needsleep 21 hours ago