• Solved

Bookmarks toolbar keeps disappearing

When using private browsing window, bookmarks toolbar keeps disappearing every time I open a new tab or anything else. My setting for show bookmarks is "always show" and … (read more)

When using private browsing window, bookmarks toolbar keeps disappearing every time I open a new tab or anything else. My setting for show bookmarks is "always show" and it works normally in a regular window. It also used to work normally in private browsing until a few days ago. Clicking "show bookmarks toolbar" works until I open any of the bookmarks, then the toolbar disappears again. How do I make the toolbar permanently visible in a private browsing window?

Asked by Kaktus 19 hours ago

Answered by zeroknight 18 hours ago

  • Solved
  • Archived

Connection to server now fails: SEC_ERROR_INADEQUATE_KEY_USAGE

I access a CCTV Network Video Recorder on the same private/LAN that I'm on using an PC via HTTPS. It's been working fine for nearly a year. Recently it won't access via H… (read more)

I access a CCTV Network Video Recorder on the same private/LAN that I'm on using an PC via HTTPS. It's been working fine for nearly a year. Recently it won't access via HTTPS any more with the Error Message "Secure Connection Failed An error occurred during a connection to 192.168.1.30. Certificate key usage inadequate for attempted operation. Error code: SEC_ERROR_INADEQUATE_KEY_USAGE

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the web site owners to inform them of this problem."

I've contacted the vendor but they seem at a bit of a loss. I can connect using HTTP, and an Android App (spit) still works too. I did find a Stack Overflow article from 2020 mentioning a possible corrupt cert9.db and/or cert_override.txt files, but as it's so old I wanted to ask for further advice before I start hacking things around. On another PC using the same browser version on the same network I get the attached response, not the same as the one I get and it will allow me to accept the risk. Can anyone help please?

Asked by fixit9660 6 months ago

Answered by cor-el 6 months ago

  • Solved
  • Archived

Sites (youtube) Crashing often

Hi, Various Sites (sometimes firefox as a whole) keep crashing regularly. I am running Arch Linux (6.4.12, default kernel) with Hyprland WM on an old i7-7700K with a Nvi… (read more)

Hi, Various Sites (sometimes firefox as a whole) keep crashing regularly. I am running Arch Linux (6.4.12, default kernel) with Hyprland WM on an old i7-7700K with a Nvidia GTX980TI. Apart from Firefox the system runs stable. When doing research, or just browsing text based sites, firefox is also very stable, but on some sites like twitch, youtube, or idle games like "Antimatter Dimensions" (ivark.github.io) the browser (or page) crashes regularly. It also happens in Troubleshoot mode, also after a clean re-install (including deleting /.mozilla in /home) and since various versions over the last couple of month. The latest crash report ID is bp-67ed2673-4ed2-452b-bc63-dc1060230831. I know I'm running a niche system, but I really like my setup and apart from those crashes it's amazing, so I hope you can help and point me in the right direction as to what could cause the crashes. Thanks for your time. KR, rehajel

Asked by rehajel 6 months ago

Answered by jonzn4SUSE 6 months ago

  • Solved
  • Archived

403 Forbidden

UPDATE - - problem solved - - Using Firefox Troubleshooting Mode I found that the problem was ''''caused by an added extension '''' which has been turned off (I hope) … (read more)

UPDATE - - problem solved - - Using Firefox Troubleshooting Mode I found that the problem was ''''caused by an added extension '''' which has been turned off (I hope) One thing I don't understand though is that I fixed this in Firefox but it also fixed it in Chrome. All images show up in both, so how does one browser fix a second browser? I have yet to check Safari but I never use that one anyway, so I'm not going to push my luck! Thanks Terry.

- - - I have a LOT (hundreds) of images that do not show up on many pages and each one is labeled,

403 Forbidden in the Network Monitor.

There are images that do show up on the same pages and the amount varies.

Those are labeled with a green 200.

What causes this and how can I fix it so they all show on the pages?

and do I have to fix each and every one? That would take months.

Thanks

Asked by PwF 6 months ago

Answered by Terry 6 months ago

  • Solved
  • Archived

How to get a list of all the open tabs in a Firefox window?

Hello everyone, I've been using Firefox for quite some time and I always keep a bunch of windows open throughout a few workspaces on my laptop. However, this takes up a … (read more)

Hello everyone,

I've been using Firefox for quite some time and I always keep a bunch of windows open throughout a few workspaces on my laptop. However, this takes up a lot of resources and looks very messy. So, I've been thinking of writing a script/extension to simply store all the open links in a window to a named list that I can, then, come back to when I need and reopen. That way, I could possibly have different lists, separated by topic and stored in a single place.

I'm sorry if there is an obvious solution for this, I saw a couple of similar questions have been asked before, but none that I could use as reference.

Thank you for your time, have a nice week!

Asked by pedrobarrostorreaogaiao 6 months ago

Answered by cor-el 6 months ago

  • Solved
  • Archived

Weird symbols

I am using Windows 11 and Firefox 116.0.3. Some characters like ‘ ’ “ ” — become weird symbols in Firefox when I copy and paste text containing them to html source text … (read more)

I am using Windows 11 and Firefox 116.0.3. Some characters like ‘ ’ “ ” — become weird symbols in Firefox when I copy and paste text containing them to html source text file. This started happening earlier this month, never happened before. Why is this happening now?

Asked by the.pelican.web 6 months ago

Answered by the.pelican.web 6 months ago

  • Solved
  • Archived

Download Window Closes Immediately and Some Buttons Don't Work - Need Help

Hello, Firefox friends! I'm having some issues with Firefox on my Ubuntu system and I'm really hoping someone can help me fix them. Problem with Downloads: When I tr… (read more)

Hello, Firefox friends!

I'm having some issues with Firefox on my Ubuntu system and I'm really hoping someone can help me fix them.

   Problem with Downloads: When I try to download something and click on a link, a new tab opens. But then it immediately closes and nothing downloads.
   Button Issues: Some buttons within Firefox just don't seem to work.

I've tried a few things already:

   Checked for Firefox and Ubuntu updates
   Ran Firefox in Troubleshoot Mode
   No antivirus because I'm on Ubuntu

If anyone has faced similar issues or knows how to fix this, please help!

Thank you so much!

Asked by damianczap 6 months ago

Answered by zeroknight 6 months ago

  • Solved
  • Archived

The ''x'' is gone, I want it back, please?

Please, I want my tab's x back no matter how many tabs are open. My monitor is very large so I can see. Looking for close tab after right click, is a problem for my eyes … (read more)

Please, I want my tab's x back no matter how many tabs are open. My monitor is very large so I can see. Looking for close tab after right click, is a problem for my eyes as I have to get up close to my monitor and then it takes too long to find the close tab. Just a few hours ago, the x disappeared, even on the tab I had open, and I didn't have as many tabs open as I usually do.

I did some looking and i found that you had changed it a long time ago but it only just affected me now (my (computer is not even a year old), even my laptop had the x on each tab (although I haven't used it in two weeks). I rely on the tab's x, especially the tab that I have open, no matter how many tabs, there is no x anymore at all, unless i have fewer than seven tabs open on my 27 monitor. I even changed the minimum tab size without result. No x on the tabs, no x on the tab I'm using. Thank you for your time spent reading this old woman's rant, i'm sorry for the bother. I would appreciate your help. Thank you, v.l.duff ginduf@gmail.com

Asked by ginduf 6 months ago

Answered by ginduf 5 months ago

  • Solved

Using system wide proxy setting in Linux

I have the HTTP_PROXY, HTTPS_PROXY and FTP_PROXY (and their lowercase counterparts) exported and then the firefox binary is started from the shell script. The settings in… (read more)

I have the HTTP_PROXY, HTTPS_PROXY and FTP_PROXY (and their lowercase counterparts) exported and then the firefox binary is started from the shell script. The settings in firefox say it will 'Use system proxy settings'. Nevertheless I do not see the proxy being used as I can not access the web pages that need the proxy. The 'about:config' also does not show that firefox picked up any proxy related information from the shell environment.

I know the proxy address is correct because if I use brave browser instead of firefox (same shell script that launches brave) I can reach the web pages behind the proxy as expected.

Asked by hinko.kocevar 1 day ago

Answered by TyDraniu 1 day ago

  • Solved

No option for autofilling credit cards in Privacy & Security settings.

I've been trying to add my credit card to my account on Firefox but I cant seem to find a setting for autofilling in settings. I've looked at the forum but cant find the … (read more)

I've been trying to add my credit card to my account on Firefox but I cant seem to find a setting for autofilling in settings. I've looked at the forum but cant find the "Autofill credit cards" checkbox.

Am I missing something here? I have attached screenshots of what I see in my settings section.

Asked by Brion 1 day ago

Answered by cor-el 1 day ago

  • Solved
  • Archived

"Something went wrong" message

Hello. I have been unable to access product pages of a particular site, I believe, since updated to 106. The pages are viewable with Edge. https://www.officeworks.com.au… (read more)

Hello.

I have been unable to access product pages of a particular site, I believe, since updated to 106. The pages are viewable with Edge. https://www.officeworks.com.au/ The main page and some pages are fine but all product pages returns "Something went wrong". E.g. Office Supplies/Pencils https://www.officeworks.com.au/shop/officeworks/c/office-supplies/pencils?cm_sp=all:menu:office-supplies:::pencils I would like to know if this is Firefox's or the website's fault if so why.

Firefox 106.0.5 Windows 10 19045.2251

Regards,

Asked by qp 1 year ago

Answered by qp 1 year ago

  • Solved

Firefox not preventing sleep

Hello, I have a problem with Firefox on Linux, doesn't seem to be distro specific as I've tried Manjaro/Ubuntu/Neon, when using KDE in that when listening to music on Yo… (read more)

Hello,

I have a problem with Firefox on Linux, doesn't seem to be distro specific as I've tried Manjaro/Ubuntu/Neon, when using KDE in that when listening to music on YouTube music my computer will go to sleep after the elected time. On KDE you can see which applications are preventing sleep and/or screen lock, other applications are listed here but not Firefox.

When playing a video everything works as expected.

I would investigate myself, but I don't know where to start so if someone can point me in the right direction or offer any insights?

Currently using: KDE Neon KDE 6.0 Kernel 6.5.0-21 Wayland

Asked by dclark16 23 hours ago

Answered by zeroknight 22 hours ago

  • Solved
  • Archived

Mac OS - how to add extension shortcus to the tool bar

Hi. I have a Mac running Ventura. I have done a fair amount of searching but can't seem to find instructions on how to add extension shortcuts to the toolbar. I feel stu… (read more)

Hi. I have a Mac running Ventura. I have done a fair amount of searching but can't seem to find instructions on how to add extension shortcuts to the toolbar. I feel stupid asking this question as I have added them previoulsy but just don't remember how it was done.

Asked by ric9 6 months ago

Answered by Terry 6 months ago

  • Solved

Youtube slow only on firefox

YouTube all of a sudden started to slow down and only be able to load videos fast enough in 360p resolution, I tried watching YouTube on Microsoft edge and YouTube handle… (read more)

YouTube all of a sudden started to slow down and only be able to load videos fast enough in 360p resolution, I tried watching YouTube on Microsoft edge and YouTube handled 1080p easily there, I have cleared the cash and made sure my Firefox and Windows are up to date and still the issue persists.

this only seams to occur on YouTube as amazon prime and speed test works without issues

Asked by nadum8 1 day ago

Answered by jonzn4SUSE 1 day ago

  • Solved

BLOCKED by Cloudflare

Since the last Firefox update I have been unable to login to my bank's website. Attached is a screenshot of the message that appears. As a test I tried logging in with … (read more)

Since the last Firefox update I have been unable to login to my bank's website. Attached is a screenshot of the message that appears. As a test I tried logging in with Google Chrome and was successful so it is likely something with the last update of Firefox. Note that I am using Windows 7 and do not want to change to a newer version.

Asked by DONALD SCHARDT 6 days ago

Answered by DONALD SCHARDT 1 day ago

  • Solved

cycling through previous typed chat messages with up and down arrow

Maybe my cat walked over a certain key and disabled something or the new version of firefox won't let me cycle through previous typed chat messages anymore. while streami… (read more)

Maybe my cat walked over a certain key and disabled something or the new version of firefox won't let me cycle through previous typed chat messages anymore. while streaming on twitch i have to repeat certain chat messages which i did by typing the up and down arrows. lately it doesn't work in firefox anymore (OBS has a chat box which still has this function tho) is there an option to disable/enable cycling through previously typed text and which key does that?

Asked by jack.co 23 hours ago

Answered by zeroknight 21 hours ago

  • Solved

Installing custom Firefox extension

I'm at a loss for words here. I have a website I frequent and it has a really annoying behavior. I'm a developer so finally I mustered the strength to do something about … (read more)

I'm at a loss for words here. I have a website I frequent and it has a really annoying behavior. I'm a developer so finally I mustered the strength to do something about it. I googled how to create an extension in Firefox and within 5 minutes I had a working extension that solved their annoyance. However, I can only load it temporarily. If I close Firefox, it goes away. When I try to actually install it, it says I need to have it signed. I have now spent the better part of an hour trying to find out how to self sign it. I refuse to believe that I have to submit this to Mozilla for me to be able to install my own code. Can someone please send me in the direction of how i self sign and install my own extension. I have no intention of publishing, I only want to run this for myself.

Asked by viktor37 3 days ago

Answered by cor-el 3 days ago

  • Solved

JavaScript in firefox.cfg can't access `document`

As I understand, `autoconfig.js` (with `firefox.cfg`) can be used to have JavaScript run during startup to control Firefox's UI elements. I have set up `autoconfig.js` i… (read more)

As I understand, `autoconfig.js` (with `firefox.cfg`) can be used to have JavaScript run during startup to control Firefox's UI elements.

I have set up `autoconfig.js` in my `/usr/lib/firefox-developer-edition/defaults/pref` folder (I'm on EndeavourOS Linux). As instructed here, I've already put the two required files, `autoconfig.js` and `firefox.cfg` in their correct folders (`/usr/lib/firefox-developer-edition/defaults/pref` and `/usr/lib/firefox-developer-edition` in my machine).

The file `firefox.cfg` contains the following code:

 //
 (() => {
   var tabbar = document.getElementById("TabsToolbar");
 })();


However, every time I run Firefox, this message will appear:

 "Failed to read the configuration file. Please contact your system administrator."


If I empty out the `firefox.cfg` file, Firefox will run normally without showing the error message. It will also run normally if I just have something like this in the file:

 //
 (() => {
   var testVar = "";
 })();


I don't understand why the JavaScript code can't access the Firefox UI elements through `document` or `window.document`. If `autoconfig.js` isn't build for that, what should I use to change my browser's UI elements through JavaScript?

Thank you.

Asked by jazali 3 days ago

Answered by cor-el 3 days ago

  • Solved

"Manage bookmarks" always opens at "other bookmarks" (which is empty).

Hi, Folks. When I open "manage bookmarks" (Library), why does it always open at "other bookmarks"? This is at the very bottom of the alphabetical list (and empty) so I al… (read more)

Hi, Folks. When I open "manage bookmarks" (Library), why does it always open at "other bookmarks"? This is at the very bottom of the alphabetical list (and empty) so I always have to scroll back up to the top. I've got a lot of bookmarks, so this is extremely irritating. How do I change this? I've searched for an answer. The only likely solutions suggest removing the "other bookmarks" folder, but the description of how to do that doesn't work. Nowhere can I find a "remove other bookmarks" option. And the delete option is greyed out.

I don't necessarily need to hide or remove it, as long as I can get the bookmarks manager/Library to open at the top, ie. "Bookmarks Menu".

Cheers, Ian

Asked by IanStar 4 weeks ago

Answered by IanStar 3 weeks ago

  • Solved
  • Archived

Cannot log in to certain websites...

When I click on Next on the login page of Hulu, youtube or the Roku websites, nothing happens. No messages about wrong or unrecognized credentials. Just no action or move… (read more)

When I click on Next on the login page of Hulu, youtube or the Roku websites, nothing happens. No messages about wrong or unrecognized credentials. Just no action or movement at all.

Asked by penguinlee 6 months ago

Answered by zeroknight 6 months ago