Showing questions tagged: Show all questions
  • Solved

Disable search if resolve failed

Hi, With recents versions of Firefox (I cant' tell which), when you type an adress and resolve of this adress failed, firefox is running a search with this adress as par… (read more)

Hi,

With recents versions of Firefox (I cant' tell which), when you type an adress and resolve of this adress failed, firefox is running a search with this adress as parameter. I want to disable this feature, as this can be a security problem when typing internal servers private urls. You have to put "http(s)://" to disable the feature I've separated main adress and search input, disabled autocompletion, but the main adress is still making searchs.

Regards

Asked by namjos 3 months ago

Answered by cor-el 3 months ago

  • Solved

Bookmark toolbar arrow is gone/bookmark toolbar seems truncated

Issue: the bookmark toolbar arrow (the one that shows bookmarks that don't fit on the toolbar) is gone from my browser, and the toolbar itself seems truncated (only like … (read more)

Issue: the bookmark toolbar arrow (the one that shows bookmarks that don't fit on the toolbar) is gone from my browser, and the toolbar itself seems truncated (only like 7/8 of the toolbar is filled).

I didn't change any settings or installed any add-ons that could have to do with this. It just disappeared one day, I didn't even notice it at first.

What I tried:

  • I launched Firefox in safe mode, didn't fix it
  • I removed my userChrome.css file, didn't fix it
  • when I cut the bookmarks and paste them into the toolbar, the arrow shows, but when I relaunch the browser it is gone again

See photo for what it looks like (ignore the anonymous favicons, I changed them temporarily with userChrome to preserve privacy, but without userChrome the issue still stands).

Anyone has an idea what happened and how to fix this? Thanks.

Asked by 嚝卮 5 months ago

Answered by 嚝卮 3 months ago

  • Solved

Deleted auto-fill entry still auto-fills in address bar (v83.0)

I'll occasionally run into Firefox auto-filling another website address I don't want, but I just figured out that it's Shift+Delete and not Delete to remove an auto-fill … (read more)

I'll occasionally run into Firefox auto-filling another website address I don't want, but I just figured out that it's Shift+Delete and not Delete to remove an auto-fill entry (a rather asinine change, I thought). Unfortunately, clearing out the unwanted address did not work and the address still auto-fills in the U.R.L. bar (see picture).

If deleting auto-fill entries doesn't actually work, what will?

I've always been curious about this, as well, but how does Firefox determine what address auto-fills if I type in a couple of letters? Does it keep a running tally of how many times I've searched for/visited a particular site and use that data? This would be useful to know for the future.

Asked by haltrman93 5 months ago

Answered by jscher2000 3 months ago

  • Solved

How to remove and reinstal Firefox later on

bonsoir I need to send my PC to the vendor (FNAC) for reparation. I want to clean my confidential files before sending it. Concerning firefox : how to desinstal it from m… (read more)

bonsoir

I need to send my PC to the vendor (FNAC) for reparation. I want to clean my confidential files before sending it. Concerning firefox : how to desinstal it from my PC only, and reinstall it after repair with all the previous parameters and setting already installed ( list of passwords, ...)

said differently, I don't want to cancel it definitly because I use it on another computer and I want to recover it after my PC repair.

If you can help me I will really appreciate

Richard

Asked by auri.mac 5 months ago

Answered by FredMcD 5 months ago

  • Solved

There is no ad-blocker. But Firefox says there is.

I'm on Win10 With Firefox 83.0. I cleared my history yesterday, and now when I try to watch video on CBS.com, I get this message: “This video is unavailable because we we… (read more)

I'm on Win10 With Firefox 83.0. I cleared my history yesterday, and now when I try to watch video on CBS.com, I get this message: “This video is unavailable because we were unable to load a message from our sponsors. If you are using ad-blocking software, please disable it and reload the page. Error Code: 111”. I have no ad-blocking software that I know of. Can anyone give me a clue on what to do?

Asked by Shhhh...... 5 months ago

Answered by pojoho7699 5 months ago

  • Solved

Importing Logins/Passwords

I have a Linux system with Firefox 83.0 installed. I also have a CSV file of logins from an earlier Firefox. How can I import or use this CSV file to move over my login… (read more)

I have a Linux system with Firefox 83.0 installed. I also have a CSV file of logins from an earlier Firefox. How can I import or use this CSV file to move over my logins/passwords. I wish not to use Sync because it is someone else's machine. Robert

Asked by robweir@telus.net 5 months ago

Answered by TyDraniu 5 months ago

  • Solved

Loging into American Express Account

When I try to log into my AMEX account with FF, nothing happens. The screen refreshes itself, but no log in, and no error or other kind of message. I have entered my Us… (read more)

When I try to log into my AMEX account with FF, nothing happens. The screen refreshes itself, but no log in, and no error or other kind of message. I have entered my User Name and Password manually and using Auto fill, no success.

Logging into my AMEX account on Edge and Chrome, works fine.

Suggestions?

Asked by rcferris1 5 months ago

Answered by FredMcD 5 months ago

  • Solved

Cookies for websites setup for ALLOW (replacement for post that "disappeared")

As captured in the long thread "What's the difference between ALLOW and ALLOW for a SESSION?”, with a lot of handholding from jscher2000, I managed to set custom choices… (read more)

As captured in the long thread "What's the difference between ALLOW and ALLOW for a SESSION?”, with a lot of handholding from jscher2000, I managed to set custom choices for privacy and security the way I wanted on my mac computer (blocking all cookies in all windows, with exceptions saved for ALLOW, ALLOW for SESSION and some for BLOCK). To accomplish this, required enabling deletion of cookies when Firefox closes.

My assumption based on information I got in the above mentioned thread, was that even when deletion of cookies is checked for when Firefox is closed, cookies for websites identified as exceptions with ALLOWED, are not deleted.

However, this is not what happens. A specific example is tripcheck.com, which stores custom itineraries for cameras in cookies. I setup quite a few of these custom itineraries and saved them and they were OK until I closed Firefox, when they were deleted, as the cookie was deleted. This website is setup as ALLOW in the Exceptions list.

As explained in the above mentioned thread:

"(2) Scenario Two

[X] Delete cookies and site data when Firefox is closed (checked)

Firefox shortens cookie expiration to session only unless the site has an ALLOW permission in the exceptions list. “.

I am more confused than ever, the settings do not appear to be working the way they are meant to work, not only for session cookies but also for what should be "permanent".

Am I doing something incorrectly or am I misunderstanding how setting should work?

If cookies of websites setup for ALLOW are deleted when Firefox is closed, the setting is defeating what I am trying to accomplish: saving cookies for websites that I use and save data in cookies (such as recognizing the computer, what’s needed for 2 step authentication, etc.).

Thanks.

Asked by Sue 3 months ago

Answered by jscher2000 3 months ago

  • Solved

no import /export option when i click libary

My laptop is getting a new hard drive but I want to save my bookmarks from Mozilla . i googled it but i have no import /export option when i click libary Thanks in adva… (read more)

My laptop is getting a new hard drive but I want to save my bookmarks from Mozilla . i googled it but i have no import /export option when i click libary Thanks in advance

Asked by gavdjohns 5 months ago

Answered by cor-el 5 months ago

  • Solved

Errors on sites using Firefox but not using MS Edge browser

When trying to login to several sites I receive various error messages. If I use Microsoft Edge browser on the same site I don't have the problem. I've tried turning off… (read more)

When trying to login to several sites I receive various error messages. If I use Microsoft Edge browser on the same site I don't have the problem. I've tried turning off enhanced tracking but the error continues. I also tried using a private window.

Asked by nlm2 5 months ago

Answered by FredMcD 5 months ago

  • Solved

My Firefox is not staying on the "Ask to save logins & passwords"

I am using a personal home laptop and the checkbox next to the logins and passwords will not stay checked from one session to another. I am using Windows 10 and do not k… (read more)

I am using a personal home laptop and the checkbox next to the logins and passwords will not stay checked from one session to another. I am using Windows 10 and do not know how to make the checkbox stay checked.

Asked by Theresa Marie 5 months ago

Answered by Theresa Marie 4 months ago

  • Solved

pulseaudio high CPU with no audio playing

Hey there, I have the following issue with Firefox, is this maybe something I should report to the Ubuntu support or directly to Bugzilla? Steps to reproduce: --- Open … (read more)

Hey there,

I have the following issue with Firefox, is this maybe something I should report to the Ubuntu support or directly to Bugzilla?

Steps to reproduce: ---

  1. Open Firefox
  2. Go to a page that contains an embedded video that is not playing automatically, e.g. https://www.rottentomatoes.com/m/sound_of_metal
  3. Do not play the video

Environment --- User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0 Firefox version: 83.0 (64-bit) pulseaudio version: 13.99.2 OS: Ubuntu 20.10 64-bit Gnome version: 3.38.1 Windowing system: Wayland CPU: Intel® Core™ i7-8565U CPU @ 1.80GHz × 8 RAM: 15,5 GiB GPU: Mesa Intel® UHD Graphics 620 (WHL GT2)

Actual results --- pulseaudio process is spawned and rapidly becomes the most CPU consuming process on my machine (especially after a few seconds, when the Web Content ones start to cool down). Even though no sound is actually played! When switching to another tab with no embedded video, pulseaudio keeps overloading the CPU. This only stops after closing Firefox.

Expected results --- I'm not sure this is what should be expected, but I'll give it a shot:

  • pulseaudio process should only be spawned when actually playing a media that requires audio
  • pulseaudio should not be the #1 CPU consuming process
  • pulseaudio process should at the very least not massively use CPU when no sound is playing

Asked by yarma22 5 months ago

Answered by jonzn4SUSE 4 months ago

  • Solved

Firefox closes and reopens constantly without any error messages

Hello! I need help on a very strange problem I had recently with my Firefox. I have Firefox 83.0 64-bit installed on my Windows 7 Home Basic desktop PC. Some time after m… (read more)

Hello! I need help on a very strange problem I had recently with my Firefox. I have Firefox 83.0 64-bit installed on my Windows 7 Home Basic desktop PC. Some time after maybe version 81 and above, I noticed that my Firefox randomly closes and reopens without showing any error messages. I noticed that the most consistent time this phenomenon happens is when I turn on my PC and start Firefox, it almost always closes and reopens, sometimes even more than once. It acts like the browser crashed, but the weird thing is it doesn't show any error message saying that the browser crashed. Once I opened Firefox at least once after I turn on my PC, even if I manually closed it and reopen it later, it will not crash on Firefox startup, it will probably only crash again after I restarted my PC and open Firefox. Also rarely, Firefox randomly closes and reopens whenever I browser whatever website with no reason whatsoever, but this only happens 3 out of 10 times.

I opened Troubleshooting Information to look for clues on what might be causing this, and I noticed "Launcher Process" is "Disabled due to failure". I am not sure what that means though, but I have a feeling this might be related somehow?

If anyone has any idea on what's going on, please help me. Thanks!

Asked by mario62746 5 months ago

Answered by mario62746 4 months ago

  • Solved

Enable to download multiple files with Firefox84

From Firefow84(Windows, multiple files downloading does not start. Step: 1 Select Page Info 2 Select Media tab, and select multiple files(e.g. jpg files), then try to sav… (read more)

From Firefow84(Windows, multiple files downloading does not start.

Step: 1 Select Page Info 2 Select Media tab, and select multiple files(e.g. jpg files), then try to save files

[Observed Behavior] Downloading does not start. If try to close Firefox, remaining downloading popup is displayed

[Expected behavior] Succeed to download

Previous Firefox do not have this issue

Asked by usshy777 4 months ago

Answered by cor-el 4 months ago

  • Solved

Firefox v83 HTTPS only vs the extention 'HTTPS Everywhere'

Hello Can I deïnstall the add-on/ extention 'HTTPS Everywhere' because of your update Firefox to version 83 with the option for HTTPS only? Thank's Rob Ankersmit r.anker… (read more)

Hello Can I deïnstall the add-on/ extention 'HTTPS Everywhere' because of your update Firefox to version 83 with the option for HTTPS only?

Thank's Rob Ankersmit r.ankersmit@upcmail.nl

Asked by r.ankersmit5 5 months ago

Answered by r.ankersmit5 5 months ago

  • Solved

Video playback "Video can't be played because the file is corrupt" despite the file being perfectly fine.

So I've noticed how some video files are able to be played back in Firefox. Some are not able to what so ever, for example I've created a text video using this FFPMEG com… (read more)

So I've noticed how some video files are able to be played back in Firefox. Some are not able to what so ever, for example I've created a text video using this FFPMEG command: ffmpeg -f lavfi -i testsrc=duration=10:size=1280x720:rate=30 testsrc.mp4

which created the following file: https://astolfo.nl/i/z2ada.mp4 Both the uploaded version and the local .mp4 are unable to be played back in Firefox. However opening them up in edge chromium both files play back perfectly. Besides Edge I've also confirmed it plays back nicely in MPV.

I've tried Hardware acceleration, but both having it on and off did not change the fact that these files wouldn't want to playback in Firefox. Safe mode also did not effect this issue.

Asked by dapal003 5 months ago

Answered by jscher2000 5 months ago

  • Locked

Video download helper with Firefox add-on stopped working – driving me bonkers

System Linux mint 18.2 Sonya Video DownloadHelper Version 7.4.0 Browser locale: en-US Production build Built on Tue Dec 15 2020 17:14:16 GMT+0100 (Central European Standa… (read more)

System Linux mint 18.2 Sonya

Video DownloadHelper Version 7.4.0 Browser locale: en-US Production build Built on Tue Dec 15 2020 17:14:16 GMT+0100 (Central European Standard Time) Build options: browser=firefox

I used to be able to record mainly music from YouTube and some other sources using video download helper with the Firefox add-on.

It used to direct me sometimes to using the companion app, then at other times not.

The thing is now that it starts to record with a blue numbered disc showing. It gets almost to the end of the download, then the circle turns red and I get the following type of error messages – see below.

I also do not have the same layout on the 3 colour disc download helper button.

Updated the add-on but cannot find any specific help.

Would be very grateful for a simple fix, or complicated, that – OR, is there a better product??

Seasons greetings


Failed converting "youtube.com/watch?v=Tff9mJN-ZZU"

/opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavfilter.so.7) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavformat.so.58) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavcodec.so.58) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libvpx.so.6) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libaom.so.0)

Or this:

Could not get information from media 'youtube.com/watch?v=Tff9mJN-ZZU' from file '/tmp/vdh-176931dshEZTAKVRT.tmp'. The file might be corrupted.

{

   "file": "/tmp/vdh-176931dshEZTAKVRT.tmp",
   "stat": {
       "dev": 2065,
       "mode": 33188,
       "nlink": 1,
       "uid": 1000,
       "gid": 1000,
       "rdev": 0,
       "blksize": 4096,
       "ino": 8675517,
       "size": 1126724,
       "blocks": 2208,
       "atimeMs": 1609228877938.8481,
       "mtimeMs": 1609228984684.116,
       "ctimeMs": 1609228984684.116,
       "birthtimeMs": 1609228877938.8481,
       "atime": "2020-12-29T08:01:17.939Z",
       "mtime": "2020-12-29T08:03:04.684Z",
       "ctime": "2020-12-29T08:03:04.684Z",
       "birthtime": "2020-12-29T08:01:17.939Z"
   }

} Exit code: 1 /opt/net.downloadhelper.coapp/converter/build/linux/64/ffprobe: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavfilter.so.7) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffprobe: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavformat.so.58) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffprobe: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavcodec.so.58) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffprobe: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libvpx.so.6) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffprobe: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libaom.so.0)

Asked by sneggy 4 months ago

Last reply by FredMcD 4 months ago