Showing questions tagged: Show all questions
  • Solved
  • Archived

How to make "Say hello to a new Firefox" not appear next time I open Firefox

Hello, I'm using Firefox 91.4.1esr (64-bit) from Debian repositories on Bullseye. Every time I open Firefox, a window with a greeting message appears ("Say hello to a ne… (read more)

Hello,

I'm using Firefox 91.4.1esr (64-bit) from Debian repositories on Bullseye. Every time I open Firefox, a window with a greeting message appears ("Say hello to a new Firefox"), and it doesn't matter if, as asked by that window, I choose a theme or not. Is this issue related to my settings? Is this a Debian issue? Is it possible to stop that window from reappearing?

Thanks in advance. And many thanks for making Firefox (I've been using it for so many years I can't recall when I tried it for the first time).

Esteban

Asked by lucchesi.esteban 2 years ago

Answered by lucchesi.esteban 2 years ago

  • Solved
  • Archived

Suggestions

Hello! Please, implement the built-in speed dial, like in Opera and Vivaldi. It's extremely convenient and useful, lots of people need this. I've been using Firefox for m… (read more)

Hello! Please, implement the built-in speed dial, like in Opera and Vivaldi. It's extremely convenient and useful, lots of people need this. I've been using Firefox for more than 10 years and I hate your stupid "Firefox Home" page (sorry) on desktop and Android with icons that add automatically and I can't change and locate. It's inconvenient and completely useless. It would be great if you create something like Opera 12.17 or 12.18 had. In addition, please remove the "close" button in the last tab. I know that I can do it via the "config mode" (browser.tabs.closeWindowWithLastTab), but it's not user-friendly. It's inconvenient when you close the tab just to return home, but the whole browser closes. It makes me nervous. Thank you in advance! You are doing a great job, wish you good luck, and hope that one day Firefox will be more popular than Chromium-based browsers.

Asked by bdbsckxz 2 years ago

Answered by jscher2000 - Support Volunteer 2 years ago

  • Solved
  • Archived

Browsing on local development URLs derives on "Unable to connect"

Hi there, I'm using my PC for local web development. I use Firefox as my regular browser and recently, in order to distinguish between personal time and development time… (read more)

Hi there,

I'm using my PC for local web development. I use Firefox as my regular browser and recently, in order to distinguish between personal time and development time, I've established a new profile just for development purposes.

The local website I can't reach is "site.local.dev". My OS is Ubuntu 20.04 and that URL points to a local IP on my network (resolved via /etc/hosts file on my PC).

Funny thing is that: - In dev-profile: site.local.dev does not work => "Unable to connect" and the URL bar shows https://site.local.dev even if I force it to http:// - In personal-profile: site.local.dev does work :P

I have tried with CLI tools like "wget", "hosts", "ping", "telnet" and so on and the site loads ok. Even I have used Dillo (damn simple web browser) and the site loads ok also.

Things I've tried so far: - Suggestions at https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can - Suggestions at https://support.mozilla.org/en-US/questions/1011327 (similar issue, not exactly the same).

It must be a silly thing but I'm out of options now. Perhaps anybody has faced to this situation in the past: any suggestion on this issue?.

Thanks in advance, Ibon.

Asked by Ibon Castilla Varela 2 years ago

Answered by Ibon Castilla Varela 1 year ago

  • Solved
  • Archived

Prevent websites from opening new tabs

I just reinstalled my operative system, and with that my Firefox settings got reset. I know there is an entry in about:config to prevent ads from opening new tabs and pop… (read more)

I just reinstalled my operative system, and with that my Firefox settings got reset. I know there is an entry in about:config to prevent ads from opening new tabs and pop ups without authorization, even from legit websites like the login pop-up windows when doing a sign in in Google, in those cases to allow the windows it's needed to click on the lock icon next to the URL bar and allow it from there. The problem is that I don't remember the name of that setting and I have spend an hour looking for it on Google.

Asked by ttfh3500 2 years ago

Answered by ttfh3500 2 years ago

  • Solved
  • Archived

Recover pre-previous session

I had a number of tabs open today (~40). Because Firefox started to malfunction, I had to restart Firefox. It happened to me before and I knew that I can restore my previ… (read more)

I had a number of tabs open today (~40). Because Firefox started to malfunction, I had to restart Firefox. It happened to me before and I knew that I can restore my previous session so I safely closed the tabs.

When I restarted it, I opened a tab and then I tried to open the Application Menu, but accidentally closed the window. Now, when I've re-opened Firefox and attempted to restore the previous session only that last tab appeared.

Is it possible to recover the pre-previous session? I use Ubuntu 18.04. Where is this information located? and how can I retrieve it?

Asked by amberbear 2 years ago

Answered by Dropa 2 years ago

  • Solved
  • Archived

Horizontal scrolling w. touchpad doesn't work on linux

I saw this post https://bugzilla.mozilla.org/show_bug.cgi?id=542690 where it seems implied that it should work, but on LMDE 5 w. firefox 98.0.2 64-bit scrolling horizonta… (read more)

I saw this post https://bugzilla.mozilla.org/show_bug.cgi?id=542690 where it seems implied that it should work, but on LMDE 5 w. firefox 98.0.2 64-bit scrolling horizontally w. touchpad doesn't work for scrolling on pages nor for scrolling the tab list at the top.

Asked by maartentenvelden 2 years ago

Answered by maartentenvelden 2 years ago

  • Solved
  • Archived

how is profile blanked, but not fully gone?

Basically, a requested relaunch blanked my profile and I can't get it back. I have a lengthy workaround that will take over an hour to fix from backups, before this inc… (read more)

Basically, a requested relaunch blanked my profile and I can't get it back.

I have a lengthy workaround that will take over an hour to fix from backups, before this incident, but I'd really like to understand what's going on. How can my add-ons, bookmarks, history, logins, etc. be gone? If I did a refresh on purpose, why would my shortcuts remain intact? And, I started by backing up my profile folder to a neutral spot, so why isn't replacing it reversing the changes?

As background: The "about:profiles/Restart With Add-ons disabled" button brings up a small button dialogue to choose "refresh" or default "open." I selected "open" because I didn't want to fix my profile and assumed I would relaunch with only add-ons disabled, so this was a potential point of screw-up. I assume selecting "refresh" would reset application defaults and make a mess exactly like I find myself in now. Shouldn't "Restart with Add-ons disabled/Open" relaunch a temporary and reversible state? Doesn't "refresh" prompt a new default profile?

Considering evidence only, it appears I did something to roast my profile before I backed it up, but that's strange and really out in the weeds, and I'm assuming I wrecked it with my current activity.

The default profile name and path are correct. My shortcut links and labels that I use for a home page are intact but with icons missing, the same appearance as if I deleted the cache; is this detail part of application settings and not profile?

Asked by SkyHook 2 years ago

Answered by FredMcD 2 years ago

  • Solved
  • Archived

Impossible to use an unusual port number in local URL

Hi all :) From a fresh Linux Debian Bullseye I try to connect to a local machine with Firefox (v97 64-bits) by its hostname (avahi server with default domain "local… (read more)

Hi all :)

From a fresh Linux Debian Bullseye I try to connect to a local machine with Firefox (v97 64-bits) by its hostname (avahi server with default domain "local") with the port 6180 bound to a remote web service port (61 is the distant machine IP and 80 is the forwarded port).

When I want to open this URL : http://bionic.local:6180/ FF displays "We can't find this site ... Unable to connect to server at bionic.local ... check your network connection and firewall"

BUT ping bionic.local works perfectly and resolve the good IP address from the Chromium navigator the same URL works without a problem, I can open the distant web site.

This workaround works : add a static resolution in the /etc/hosts file : 192.168.0.71 bionic bionic.local => so FF works in the expected way for now ! But as I said this a workaround and a bad solution.

I supposed too the port was blocked because I accessed an unusual port. So I tried this without success.

How the hell make that FF v97 allows me to use an unusual port ? Or is it bound to the domain "local" which is no more accepted by FF ?

Thank you in advance for your help. With adelphity, lnj

How to do

Asked by estebann 2 years ago

Answered by estebann 2 years ago

  • Solved
  • Archived

Firefox Prevents Local Machine File Access But Firefox Dev Ed Allows It . . .

Local Machine: Dell Inspiron i5-7200 / 16 GB RAM / Local Op Sys: Ubuntu 20.04LTS Firefox version: 99.0 FFDE version: 100.0b5 Node.js version 14.18.1 npm version 6.14.… (read more)

Local Machine: Dell Inspiron i5-7200 / 16 GB RAM / Local Op Sys: Ubuntu 20.04LTS

Firefox version: 99.0 FFDE version: 100.0b5

Node.js version 14.18.1 npm version 6.14.15


I had a Node.js web app running on my local machine all usual browsers like Firefox, Firefox Dev Ed (FFDE), Chromium, Edge, Opera, etc till recently.

Recently it shows an error when run on Firefox (also on Chromium, Opera and Edge) although continuing to run okay on FFDE.

Firefox Error: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at file:///home/sandbar/Desktop/nodeapp-local/undefined. (Reason: CORS request not http).

Edge Error: Access to XMLHttpRequest at 'file:///home/sandbar/Desktop/nodeapp-local/undefined' from origin 'null' has been blocked by CORS policy: Cross origin requests are only supported for protocol schemes: http, data, chrome-extension, edge, https, chrome-untrusted.


Naturally, I need to test the web app on my local machine using several browsers before I should upload it to a server and trial it there.

So how do I configure the browser and/or app to allow access to local machine files ?

Asked by tamjk 2 years ago

Answered by tamjk 1 year ago

  • Solved
  • Archived

Previous and next media keys are not working

I have same problem. I tried same things. Previous and next media keys aren't working on youtube or music player. But play/stop buttons work fine. All media keys are work… (read more)

I have same problem. I tried same things. Previous and next media keys aren't working on youtube or music player. But play/stop buttons work fine. All media keys are working in chromium, for example. Media keys enabled in config: media.hardwaremediakeys.enabled = true

UPD: hardware problem, solved

Asked by bekaldiev2015 2 years ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

Firefox styles are broken, even for pages like about:config

The styles look astonishingly wrong, I really think it is a problem on my end, but cant figure out how to fix it, as you can see in the pictures, text is incorrectly size… (read more)

The styles look astonishingly wrong, I really think it is a problem on my end, but cant figure out how to fix it, as you can see in the pictures, text is incorrectly sized and/or justified, color gradients are also weird looking, as well as sizing of many elements and tons of other things.

I have tried to completely remove Firefox from my system and reinstalling it, that did not seem to fix it. The reason I think is is a problem of mine is because i was playing with fonts (emojis weren't working on my system,not on Firefox tho, now they are in both)

I don't think the things i did with the fonts did anything to Firefox, since this problem only showed up on Firefox, but since the problem arrived just after a reboot while I was installing and removing the fonts, I think its important to mention.

To sum up I think the problem comes from my local configuration of Firefox, I probably did not delete it all before reinstalling, I am running (Arch btw) a current version of EndevourOS.

Asked by zark0 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

Unable to run 'flatpak install firefox' on chromebook

I was following this article https://support.mozilla.org/en-US/kb/run-firefox-chromeos Installed flatpak and repositories but when I try to use flatpak to install firefo… (read more)

I was following this article https://support.mozilla.org/en-US/kb/run-firefox-chromeos

Installed flatpak and repositories but when I try to use flatpak to install firefox I get "No remote refs found similar to ‘firefox’".

I have tried following a few other ways to get it installed, such as using sudo and using sudo su but that has not worked at all.

I followed to flatpak quick setup on Chromebook guide that is linked in the above help article and created the nested containers in crosh as well.

below is what happens if I go to flathub and copy-paste their recommended command to install firefox.

Remote ‘flathub’ found in multiple installations:

  1) system
  2) user

Which do you want to use (0 to abort)? [0-2]: 2 error: Nothing matches org.mozilla.firefox in remote flathub

Asked by Kili Luther 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

Double space is back in firefox for me firefox 99.0

There is a specific challenge that i am facing with Firefox and some of the solutions that i have tried is not helping me to resolve the issue. What's the issue: There a… (read more)

There is a specific challenge that i am facing with Firefox and some of the solutions that i have tried is not helping me to resolve the issue.

What's the issue: There are double spaces issue in Firefox

Where is it : 1) Menu 1.1) It's in the Menu New Tab is seen to me as New Tab (more spaces are for demonstration only) 1.2) All the Menu items which have space are show with more then one space including

  1.2.1) File Menu -> New   Window (and all the drop down menus with spaces)
  1.2.2) Edit Menu -> Select     All (and all the drop down menus with spaces)
  1.2.3) View-> Page     Style (and all the drop down menus with spaces)
   1.2.4) All the rest of the menus where ever there is a space there is a double space

2) URL : I type something in the URL and they are double spaced "this is test" will look like "this is test"

   THIS URL looks to be double spaced on firefox https://support.mozilla.org/en-US/questions/1338204?page=2
   like below

3) Numbers in the browser :

   Any number displayed is double spaced in the browser output (most of the times, most of the web pages)
   
   

4) Bookmarks : All bookmarks are double spaced

5) Settings:

Settings: I have tried some suggestions below and they did not work for me.

browser.proton.contextmenus.enabled browser.proton.contextmenus.enabled is still set to false but seems to have no effect toolkit.legacyUserProfileCustomizations.stylesheets=true browser.proton.contextmenus.enabled=false


6) Reference: I have tried some suggestions below and they did not work for me.

 https://support.mozilla.org/bm/questions/1350754
 https://support.mozilla.org/en-US/questions/1186601
 https://support.mozilla.org/en-US/questions/1338204?page=2
 https://superuser.com/questions/1654597/firefox-menus-became-double-spaced-in-latest-update-i-want-to-return-to-single

Asked by Nataraj 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Crash when loading some tabs on VNC server host

Since the Firefox 99 update loading some pages (for example, the Gmail sign-in page) using Firefox on my Linux Mint machine, that I'm running a VNC remote desktop session… (read more)

Since the Firefox 99 update loading some pages (for example, the Gmail sign-in page) using Firefox on my Linux Mint machine, that I'm running a VNC remote desktop session on, results in a crash.

Crash report ID: bp-5dc1e89d-dc1f-40f2-9dbe-7f4380220419

I've tried running Firefox in safe-mode and the crash doesn't happen, but turning off hardware acceleration, swapping to default themes, removing all extensions, and completely removing Firefox and the .mozilla folder and then re-installing Firefox have not changed the crash behaviour in the absence of the safe-mode flag.

I would appreciate help in identifying what other paths of investigation I can take.

Asked by KhaanephEx 1 year ago

Answered by KhaanephEx 1 year ago

  • Solved
  • Archived

Export all the bookmarks from a loads of profiles from a script

Hello everyone :) From a folder, I have loads of Firefox profiles from different eras. I am looking for a way to export all the bookmarks of each of the profiles to… (read more)

Hello everyone :)

From a folder, I have loads of Firefox profiles from different eras. I am looking for a way to export all the bookmarks of each of the profiles to an HTML file like the manual method (Library > Import and backup > Export bookmarks to formal HTML), but all in an automatic way by script. I like the HTML export from Firefox because it allows you to quickly navigate using keywords, either in links or in the folder names I gave.

Is there a simple solution that would reuse, for example, the same export code as Firefox ?

Thanks in advance With adelphity estebann

Asked by estebann 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Error message when updating Firefox

I downloaded the latest Firefox to my Linux and got this error message: W: Download is performed unsandboxed as root as file ......etc. There's more, but can you tell me … (read more)

I downloaded the latest Firefox to my Linux and got this error message: W: Download is performed unsandboxed as root as file ......etc. There's more, but can you tell me what happened and if I need to worry? I haven't had any trouble using Firefox since the update. I've attached a screen shot of the whole message.

I appreciate any help.

Asked by nexgenn 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

Log in problems on 3rd party websites

On certain websites I notices I have 'unknown errors' when trying to log in. Usually this is remedied by either using Chrome or clearing cookies and the cache. Both of … (read more)

On certain websites I notices I have 'unknown errors' when trying to log in.

Usually this is remedied by either using Chrome or clearing cookies and the cache.

Both of there are inconvenient and result in a great deal of wasted time.

The usual response by these websites is "get Mozilla to fix this".

I'm getting sick of this.

I don't want to switch to Chrome but I will have to if this persists.

Asked by dominicpukallus 1 year ago

Answered by Amelia 1 year ago

  • Solved
  • Archived

Please add a superficial distinguishing label to declared but unused filenames

I am running WikiSpecies on Ubuntu Firefox 64-bit v. 98.0.2. I used to be able to display a collection of unused files with the used ones but showing a red color indicat… (read more)

I am running WikiSpecies on Ubuntu Firefox 64-bit v. 98.0.2.

I used to be able to display a collection of unused files with the used ones but showing a red color indicating that the file was unused (because noone had entered anything other than the file name).

Now, however, ALL files in a directory (e. g., see https://species.wikimedia.org/wiki/Craspedophorus) are shown with the same color, whether they include additional implementation details or not.

Would it be possible for you to restore the "unused" color of empty files? It is bothersome for me to open EVERY file, empty or not, in a directory just to find that most or all of them never have been implemented. Adding a special color -- or other distinctive display -- to unimplemented files would save me a great deal of time.

I am attaching a picture of a typical unimplemented file.

Asked by jwill 1 year ago

Answered by TyDraniu 1 year ago

  • Solved
  • Archived

Unable to show File Picker

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it … (read more)

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it was nowhere near the top of Google's results, I thought I'll share my solution in the hopes that this would help someone facing this same issue.

The hardware:

  • Asus UM425IA Zenbook (AMD Ryzen 7 4700U CPU)

Worked in:

  • Ubuntu 20.04 LTS
  • Firefox provided by APT repository
  • Xorg display server

Not working in:

  • Ubuntu 22.04 LTS
  • Firefox 99.0.1 provided by snap
  • Wayland display server
  • File picker worked briefly on fresh install, but something (not sure what) quickly breaks file picker functionality

The symptoms:

  • Firefox stopped being able to open file picker dialogs
  • Right clicking an image and selecting "Save Image As..." does nothing
  • With forms that accept file upload (such as on this post question page "Add images (optional):"), clicking "Browse" does nothing
  • File downloads work correctly when set to "Save files to ..." under Settings, but nothing happens when set to "Always ask you where to save files"
  • No response to "Ctrl + O" open file shortcut

Similar questions and solutions:

Things I tried that did not work:

  • Disabling hardware acceleration
  • Starting with add-ons disabled
  • Troubleshoot mode
  • Clearing startup cache
  • Clearing cookies and site data
  • Clearing history
  • Refreshing Firefox
  • Creating and using a new profile
  • Deleting the `xulstore.json` file from the profile directory
  • Toggling all permissions under Ubuntu Settings > Applications > Firefox to off and then back to on
  • chmod 777 ~/Downloads
  • Disabling native file picker "ui.allow_platform_file_picker = false"

And finally, what fixed it for me was to go into "about:config" and change "widget.use-xdg-desktop-portal.file-picker" from "2" to "0". Credit to this post that clued me in.

I really hope this saves someone else 2 days of hair pulling and I would appreciate advice from someone more knowledgeable than me on:

  • Why this fixed the problem
  • Whether I should be opening a bug report either against Firefox, or Ubuntu
  • Whether I should also be changing "widget.use-xdg-desktop-portal.mime-handler" and "widget.use-xdg-desktop-portal.settings", both are currently set to "2"

Asked by James Fu 1 year ago

Answered by Kiki 1 year ago

  • Solved
  • Archived

File upload dialog not appearing

I'm running Firefox 99.0.1 on Ubuntu 22.04. Recently (I think since I updated to Ubuntu 22.04 about a week ago), Firefox has been refusing to show me file upload dialogs.… (read more)

I'm running Firefox 99.0.1 on Ubuntu 22.04. Recently (I think since I updated to Ubuntu 22.04 about a week ago), Firefox has been refusing to show me file upload dialogs. When I click a button that's supposed to give me one, nothing happens.

This has been happening with: - The "attach files" button in Gmail - A file upload button on Gradescope (website for managing homework assignments) - File -> Open File... and Ctrl+O.

Dragging and dropping a file onto an email in Gmail does attach the file -- it's just that the button doesn't work.

I've tried restarting, and I've tried running Firefox in Troubleshoot Mode -- so far nothing has fixed the problem. What else should I do?

Asked by allispaul 1 year ago

Answered by jonzn4SUSE 1 year ago