Showing questions tagged: Show all questions
  • Archived

Customize: Where's Space, Flexible Space, or Separator?

Where did they move the toolbar items Space, Flexible Space, and Separator? They're missing, even on the screen shots on support pages: https://support.mozilla.org/en-US/… (read more)

Where did they move the toolbar items Space, Flexible Space, and Separator?

They're missing, even on the screen shots on support pages: https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars

I've grown accustomed to using toolbars on all four edges of the screen (see old screen shot). Please return my ability to space the buttons because they're useless all clumped together.

I love Firefox's ability to be extended and customized but they keep breaking the basics -- If it ain't broke, don't fix it!

Asked by sunnysnaith 4 years ago

Last reply by FredMcD 4 years ago

  • Archived

How to read the Firefox update channel (Release or ESR) from javascript code ?

I need to allow the user to login to my application only if he is using ESR update channel of firefox. I tried to read the value from "navigator.userAgent.search("ESR")"… (read more)

I need to allow the user to login to my application only if he is using ESR update channel of firefox.

I tried to read the value from "navigator.userAgent.search("ESR")" command but this command does not say any thing about update channel.

How can i check firefox has esr update channel or not ? from javascript.

Thanks.

Asked by vinuth 4 years ago

Last reply by user633449 4 years ago

  • Solved
  • Archived

Need to change ntlmv1 settings for users

We are currently using Firefox ESR 38.2.0 with our RHEL 6.7 workstations and need to change the network.negotiate-auth.allow-insecure-ntlm-v1 from the default of TRUE to … (read more)

We are currently using Firefox ESR 38.2.0 with our RHEL 6.7 workstations and need to change the network.negotiate-auth.allow-insecure-ntlm-v1 from the default of TRUE to FALSE.

We tried putting a .js file in /usr/lib64/firefox/defaults/preferences to change it, but the change is ignored.

When we try another setting in the file, such as perf("network.negotiate-auth.allow-insecure-ntlm-v1-https", false), then the change is made, however, with the ntlm-v1 setting, it is ignored in the file.

We can change the user_perf for network.negotiate-auth.allow-insecure-ntlm-v1 on a per user bases, but as an enterprise we would like to make this change for multiple users at once and not on a per profile.

Is there any way to do this, or is creating a script and placing it in /etc/profile.d the best option?

Thanks! Joe Giles

Asked by jagiles 4 years ago

Answered by cor-el 4 years ago

  • Solved
  • Archived

tabs only open when mouse is moving

Updated to 38.2.0 ESR, now new links (tabs) won't load unless I constantly move the cursor. This happened in a previous update and I reloaded an older version. Is there a… (read more)

Updated to 38.2.0 ESR, now new links (tabs) won't load unless I constantly move the cursor. This happened in a previous update and I reloaded an older version. Is there another fix?

Asked by croatcat 4 years ago

Answered by philipp 4 years ago

  • Solved
  • Archived

Firefox 38.2.0 can't access a https website, but IE11 can.

The website to access is https://i.sf-express.com/cn/sc/login.html. IE11 can access it. Firefox 38.2.0 can't access it in both normal and safe mode(all add-on disabled). … (read more)

The website to access is https://i.sf-express.com/cn/sc/login.html.

IE11 can access it.

Firefox 38.2.0 can't access it in both normal and safe mode(all add-on disabled).

Firefox reports error: Secure Connection Failed The connection to the server was reset while the page was loading. The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.

Asked by EELMIK 4 years ago

Answered by cor-el 4 years ago

  • Solved
  • Archived

I have Firefox 38.2.0 and it tells me it's the latest version but online there's version 40+ and it won't let me install it.

my OS is Windows 10. I have Firefox 38.2.0 and it tells me it's the latest version. However, I've received emails telling me to update to the latest version which seems… (read more)

my OS is Windows 10. I have Firefox 38.2.0 and it tells me it's the latest version. However, I've received emails telling me to update to the latest version which seems to be in the 40's. When I go to the site https://www.mozilla.org/en-US/firefox/new/ , it tells me "looks like you're using an older version of Firefox."

So I click on upgrade and it loads a "stub" file. I close down Firefox, go to the folder where the file is located and run it. At the end of the process, it tells me that Firefox is still running and I have to close it for the new version to load. So I go to Task Manager and it tells me that no applications are currently running! I've gone thru this process three times with no positive result.

What to do???

Asked by Hanoch 4 years ago

Answered by jscher2000 4 years ago

  • Archived

Firefox crashes

Crash Reports for shutdownhang | libpthread.so.0@0xa20a https://crash-stats.mozilla.com/report/list?product=Firefox&signature=shutdownhang+|+libpthread.so.0%400xa20a … (read more)

Crash Reports for shutdownhang | libpthread.so.0@0xa20a https://crash-stats.mozilla.com/report/list?product=Firefox&signature=shutdownhang+|+libpthread.so.0%400xa20a ID: e8f47dea-29b7-4a7e-8f69-e94e42150924

Hi I am using FF with an LSP Linux CD - and have had a few crashes recently and it seems to be arising from either anonymoX or FreeMyBrowserextensions. I have an error report generated for anonymoX and wondering who I should sent it to. Here are the details:

Error Details:

Message: TypeError: globalWindow is null Source: browserapi.progressListener.onLocationChange Code: chrome://anonymox/content/modules/browserapi.js line 341 Stack Trace: browserapi.progressListener.onLocationChange@chrome://anonymox/content/modules/browserapi.js:341:9 _callProgressListeners@chrome://browser/content/tabbrowser.xml:527:24 mTabProgressListener/<._callProgressListeners@chrome://browser/content/tabbrowser.xml:587:22 mTabProgressListener/<.onLocationChange@chrome://browser/content/tabbrowser.xml:812:1 openModalWindow@resource://gre/components/nsPrompter.js:370:5 ModalPrompter.prototype.openPrompt@resource://gre/components/nsPrompter.js:553:9 ModalPrompter.prototype.confirm@resource://gre/components/nsPrompter.js:637:9 Prompter.prototype.confirm@resource://gre/components/nsPrompter.js:69:16 Info/this.error@chrome://anonymox/content/modules/utils.js:216:8 browserapi.progressListener.onStateChange@chrome://anonymox/content/modules/browserapi.js:421:5 _callProgressListeners@chrome://browser/content/tabbrowser.xml:527:24 mTabProgressListener/<._callProgressListeners@chrome://browser/content/tabbrowser.xml:587:22 mTabProgressListener/<.onStateChange@chrome://browser/content/tabbrowser.xml:738:1

Version: anonymoX 2.5.1 @ Firefox 38.2.1 @ Linux

Asked by ayoo 4 years ago

Last reply by ayoo 4 years ago

  • Solved
  • Archived

I'd like to change my download directory but the option is greyed out. Can I rectify this?

I have no trouble changing download directory in other browsers on my computer, e.g. Safari. I've attached a screen shot of the general tab of my Firefox preferences. I'v… (read more)

I have no trouble changing download directory in other browsers on my computer, e.g. Safari. I've attached a screen shot of the general tab of my Firefox preferences. I've just noticed in the "Troublshooting Information" attached to this question page that "lockedPreferences" includes "browser.download.useDownloadDir":false ... Please instead of pointing out that that is the problem (if it is), please help me in understanding why this is that way and how to change it.

Asked by xiggystardust 4 years ago

Answered by cor-el 4 years ago

  • Solved
  • Archived

Not in safe mode but remember passwords is grayed out

Hi, I'm using a corporate packaged firefox and the option is not clickable. Is there a way to activate it again in about:config ? I am sure i'm not in safe mode and I k… (read more)

Hi,

I'm using a corporate packaged firefox and the option is not clickable. Is there a way to activate it again in about:config ?

I am sure i'm not in safe mode and I keep my history

thank you,

Asked by contrevents 4 years ago

Answered by philipp 4 years ago

  • Archived

Firefox crashes

I'm getting a series of crashes of Firefox (I have the latest version) ever since I mistakenly "upgraded" to Windows 10. Windows 8.1 was working absolutely fine, what wa… (read more)

I'm getting a series of crashes of Firefox (I have the latest version) ever since I mistakenly "upgraded" to Windows 10. Windows 8.1 was working absolutely fine, what was I thinking??? Anyway, I'm getting crashes and then Firefox offers to restore where I was but then cannot do so. I followed the instructions on getting the Report ID

bp-e3a6676d-d2c3-436b-985b-534b52150819

Asked by Hanoch 4 years ago

Last reply by jscher2000 4 years ago