Showing questions tagged: Show all questions

New FF version colors the active tab and page to an ugly and vey annoying yellow. How do I turn that OFF?

New FF version colors the active tab and page to an ugly and very annoying yellow. How do I turn that OFF? It's neither pleasing nor necessary, and I, for one, hate it. … (read more)

New FF version colors the active tab and page to an ugly and very annoying yellow. How do I turn that OFF? It's neither pleasing nor necessary, and I, for one, hate it.

Asked by Roger Franz 5 months ago

Last reply by zeroknight 5 months ago

Update seems to have removed the "restore previous session" button.

Hello! After updating from 108 to 122, there's no restore previous session button. The recently closed tabs option only returned half of the tabs. Will this bug be repair… (read more)

Hello! After updating from 108 to 122, there's no restore previous session button. The recently closed tabs option only returned half of the tabs. Will this bug be repaired and how can I get back the tabs?

Asked by smcdougal 5 months ago

Last reply by jonzn4SUSE 5 months ago

After the 122.0 update was installed firefox will not allow pictures to be added to facebook.

After the 122.0 update was installed firefox will not allow pictures to be added to facebook. The picture never completes transferring. It starts and then stops with only… (read more)

After the 122.0 update was installed firefox will not allow pictures to be added to facebook. The picture never completes transferring. It starts and then stops with only a minimal partial transfer.. It works on other web browsers like explorer.

Asked by frederick airhart 5 months ago

Last reply by cor-el 5 months ago

History/cookies keep getting randomly deleted

The past few days when i've tried searching for certain pages i go to all the time they won't show up under "firefox suggest" then when i check my history for them the pa… (read more)

The past few days when i've tried searching for certain pages i go to all the time they won't show up under "firefox suggest" then when i check my history for them the pages are just completely gone, today i checked my history for yesterday and even though i started browsing at 8:00 the history only went back to around 13:00 with all the pages before that completely gone, this also causes me to lose all the cookies as well.

Asked by marcusroxburgh5 5 months ago

Last reply by cor-el 5 months ago

FireFox homepage background image

Hello there, Iam facing a problem with changing Firefox homepage background. I tried every solution, tutorial, oldposts etc. nothing seems to work, here is what I tried. … (read more)

Hello there, Iam facing a problem with changing Firefox homepage background. I tried every solution, tutorial, oldposts etc. nothing seems to work, here is what I tried. -1- The chrome folder is in the right folder. -2- the naming of both CSS files userChrome, userContent. -3- enabled CSS files at startup -4- search for both CSS files in the browser toolbox for some reason I cannot find both CSS files, even though they are in the chrome directory. Also, I have 2 chrome folders one of them is located here. "AppData\Roaming\Mozilla\Firefox\Profiles\shaf5qn0.default-release\storage\permanent\chrome" the other one I created myself which is here "AppData\Roaming\Mozilla\Firefox\Profiles\shaf5qn0.default-release\chrome" I tried to delete the first one but I cant, I get an error that this file is being used even though I did close Firefox. What I am missing here?

Asked by Yassen Redwan 5 months ago

Last reply by Agent virtuel 2 months ago

No history or bookmarks

Firefox has stopped saving history and I am unable to save any bookmarks. This seems to have happened recently for no reason I can understand. I haven't made any change… (read more)

Firefox has stopped saving history and I am unable to save any bookmarks. This seems to have happened recently for no reason I can understand. I haven't made any changes. I use a VPN but was doing so before this happened. I have checked all the settings and also deleted the places.sqlite file. When I click <bookmark current tab> nothing happens and history shows as empty.

Asked by sambain 5 months ago

Last reply by cor-el 5 months ago

Firefox sending multiple requests with useragent Mozilla 5.0

I'm getting locked out of a site I visit regularly. Their tech support sent me this reason: ‘Firefox browser (or some extension) is sending multiple requests to us with … (read more)

I'm getting locked out of a site I visit regularly. Their tech support sent me this reason:

‘Firefox browser (or some extension) is sending multiple requests to us with the browser User-agent "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"' This can't be happening from the normal usage, so we automatically block them because they are not the requests from genuine Googlebot crawler.

The possible cause might be using some browser extension that makes the request with Googlebot user agent.
Please make sure to disable all extensions (and remove that you are no longer using) and let me know so we could check on our end if that stopped?"

How do I find what is doing this and how can I fix it?

Steve Thomas

Asked by SteveT 5 months ago

Last reply by zeroknight 5 months ago

Cursor won't show when writing a letter or note. So I don't know where i stop typing? It works here but not when I open my browser to write letter?

Cursor won't show when writing a letter or note. So I don't know where i stop typing? It works here but not when I open my browser to write letter? … (read more)

Cursor won't show when writing a letter or note. So I don't know where i stop typing? It works here but not when I open my browser to write letter?

Asked by JSM 5 months ago

Last reply by zeroknight 5 months ago

Windows 10-Where else is Firefox accessing on my boot drive when it's installed to a secondary drive?

Took me a while to figure out how to get the full installer to install to my faster and larger D drive, but I finally did. Then I discovered it was still accessing C: un… (read more)

Took me a while to figure out how to get the full installer to install to my faster and larger D drive, but I finally did.

Then I discovered it was still accessing C: under: D:\Users\[Username]\AppData\Local D:\Users\[Username]\AppData\Roaming

So I now have my Mozilla folders in both locations pointed to D: with a symbolic link or whatever.

But it STILL seems to be accessing C: to do SOMETHING, and I'm not sure what or where, as searching C: for Firefox or Mozilla turns up nothing.

It still thrashes my C: drive though, especially noticeable if I'm using it for something else at close to 100% and Firefox for example loads a Youtube page that was unused/not in focus for a while.

Somehow it's STILL causing as much activity on C as D and I'm not sure why...if I was maybe I could point more directories to D with more Symbolic links (or whatever they're called...I may be misremembering since I set this up a few weeks ago, but they seem to work fine).

(I gave up on Chrome...I can point a bunch of stuff at D, but sooner or later it breaks its ability to do updates until I move stuff to C...I'm guessing maybe the updater "fixes" something in the background that breaks it. Thankfully Firefox seems to update just fine (I do NOT use the background process, I just check every day), and I got 122 today seemingly fine. No idea why browsers are so weird about getting installed on an alternative drive compared to other programs...it's a pretty common thing to want!)

Asked by Wolf 5 months ago

Last reply by zeroknight 5 months ago

Google Meet is not transmitting video or screen sharing in FF 122

I've looked for solutions, some had weird MTU settings, some needed to enable hardware acceleration in Chrome, but haven't found a solution that works. Created a new prof… (read more)

I've looked for solutions, some had weird MTU settings, some needed to enable hardware acceleration in Chrome, but haven't found a solution that works. Created a new profile to try that out, but still no dice.

I can do a test recording in Google Meet, which displays my video just fine, but when playing back, it's just a black screen, and that is also what happens if I share my screen. Participants get a lot of black.

I've been using Firefox with Google meet for many years, and never had this problem before. I did report the issue in Meet, but it's not likely to attract much attention from Google.

Suggestions much appreciated.

Asked by sdlarsen1 5 months ago

Last reply by jonzn4SUSE 5 months ago

Firefox Browser

I got a notice from Mozilla that Firefox was updated over night. Now when I hit a link it goes to edge instead of Firefox. In the Firefox settings, it still says that F… (read more)

I got a notice from Mozilla that Firefox was updated over night. Now when I hit a link it goes to edge instead of Firefox. In the Firefox settings, it still says that Firefox is my default browser. I do not want to use Edge. How do I fix this. I have used Firefox for many years.

Asked by mmcdonald3945 5 months ago

Last reply by TyDraniu 5 months ago

Firefox v122 --profile option is not working properly

Hi, I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap) and when using the --profile option to specify the startup pr… (read more)

Hi,

  I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap)

and when using the --profile option to specify the startup profile it fails to start even on a NEW system that never ran Firefox if I give it a directory that resides on a mounted ext3 filesystem.

  All the permissions are OK and yet running strace I see an error and after a few second will get the

generic pop-up with the error message: (after a few seconds)

Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

 Running the SAME from /tmp works fine, but I need the profile to reside on a persistent storage area

so if the LIVE distro restarts then it can restore the previous session, bookmarks, options, etc...


============================================================
 The 2 directories were created identically and have the exact same permissions:

xubuntu@xubuntu:~$ mkdir /tmp/firefox3

xubuntu@xubuntu:~$ mkdir /media/xubuntu/sys_n01_home/mozilla/firefox3

xubuntu@xubuntu:~$ ls -ald /tmp/firefox3 drwxrwxr-x 17 xubuntu xubuntu 1080 Jan 21 22:05 /tmp/firefox3

xubuntu@xubuntu:~$ ls -ald /media/xubuntu/sys_n01_home/mozilla/firefox3 drwxrwxr-x 17 xubuntu xubuntu 4096 Jan 21 21:13 /media/xubuntu/sys_n01_home/mozilla/firefox3

============================================================

The only difference is that one is mounted on tmpfs and the other is on /dev/nvme0n1p2:

xubuntu@xubuntu:~$ df -k /tmp/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on tmpfs 32560016 351528 32208488 2% /tmp

xubuntu@xubuntu:~$ df -k /media/xubuntu/sys_n01_home/mozilla/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on /dev/nvme0n1p2 195751828 51056068 142695768 27% /media/xubuntu/sys_n01_home


============================================================

When starting firefox with the /tmp/firefox3 profile directory it works fine and starts up:

xubuntu@xubuntu:~$ firefox --profile /tmp/firefox3

newfstatat(AT_FDCWD, "/tmp/firefox3", {st_mode=S_IFDIR|0775, st_size=1040, ...}, 0) = 0 newfstatat(AT_FDCWD, "/tmp/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/tmp/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=-487933736}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0 uname({sysname="Linux", nodename="xubuntu", ...}) = 0


BUT when using the persistent storage on the real filesystem (but SAME exact permissions) it fails:

newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3", {st_mode=S_IFDIR|0775, st_size=4096, ...}, 0) = 0 newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=1519466008}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = -1 EACCES (Permission denied) close(11) = 0

Am I doing anything wrong or is this some weird startup issue / race condition in the parentlock management?

Thank you for looking into this.

  -Sanjiyan

PS: I can upload the full strace file for both scenarios if needed. Thanks again.

     running on an xubuntu distribution "22.04.2 LTS (Jammy Jellyfish)"

Asked by Sanjiyan 6 months ago

Last reply by zeroknight 5 months ago

Trouble with managing bookmarks

Hey hi, Problem that's been going on for MONTHS now - when I use the bookmark manager to sort out my bookmarks, it will often 'drop' them a few lines above or below wher… (read more)

Hey hi,

Problem that's been going on for MONTHS now - when I use the bookmark manager to sort out my bookmarks, it will often 'drop' them a few lines above or below where I wanted to place them. Trying to move the misplaced bookmarks just means chasing them around the page with them NOT going where I want them, and often moving other bookmarks OUT of place. The only workaround I've found is to kill the manager and reopen it - but this often has to be done SEVERAL times to fix the problem, and it can happen again minutes later on another bookmark. Given I had to give up on the drop down bookmark toolbar because it reverts to the top of the list EVERY TIME I try to use it, I have been using the manager to access everything. The fact that it also doesn't work correctly is making me INCREDIBLY frustrated with your product. Do you have a fix, or should I ditch Firefox and find a better browser?

Asked by jollyrayda 5 months ago

Last reply by zeroknight 5 months ago

Sync Data Missing

Hi I am a web dev, and need FF help on this. All of my sync data is gone, I sign out and back in twice, I checked the profiles there's only one, all of my bookmarks, plu… (read more)

Hi

I am a web dev, and need FF help on this. All of my sync data is gone, I sign out and back in twice, I checked the profiles there's only one, all of my bookmarks, plugins & extensions everything is gone. Please I need those bookmarks some of them were very important to me I can't lose those.

Back-story: I recently want to try two distro that I had been on my list from quite a while now, VanillaOS & BlendOS, I worked on those for 3 or 4 days, before switching back to Arch, on both of them everything was working fine, I had all of my data. On Arch I had to reset my password because I forgot. Then the issue started, at first I thought maybe my internet was slow or something but now on the 2nd my data is still not synced.

I even signed out and back in, I checked the profiles(screenshot below). What should I do?

Asked by Z3R0 5 months ago

Last reply by jonzn4SUSE 5 months ago

Primary Password asked every time I open the browser

Dear community, since some recent update I am asked for a primary password every time I open the browser, which is higly annoying. I like my passwords protected by a pri… (read more)

Dear community,

since some recent update I am asked for a primary password every time I open the browser, which is higly annoying. I like my passwords protected by a primary password and in former times it was only asked for when trying to reveal a saved password. I know this has probably to do with me using Firefox sync, because I use the browser on my Android too but I would like to keep my devices synced. Besides: On my phone I am only asked for a fingerprint when accessing passwords, not every single time I open the app. There must be a way to reconfigure this on a desktop, right?

Asked by Jonah 5 months ago

Last reply by cor-el 5 months ago