Application action settings resets to 'download' after an update

After doing an update to Firefox (currently on 102.0.1), the settings for what happens when I click on a PDF file always seems to reset to 'save file', when what I want (… (read more)

After doing an update to Firefox (currently on 102.0.1), the settings for what happens when I click on a PDF file always seems to reset to 'save file', when what I want (and what I have to keep changing back to) is 'Always ask'.

Is this a known issue or is it something about my environment that causes this?

My system is running Windows 11 on an HP laptop with an AMD 7-5800U CPU and 8Gb of memory. [I'm posting this on my desktop machine which doesn't seem to exhibit the same behaviour - Windows 10 on an Intel 8500 CPU and 16Gb of memory]

thanks for any advice.

Alan

Asked by alan.sharkey 3 weeks ago

Last reply by alan.sharkey 3 days ago

Closing a tab sends Firefox full screen

I notice that this problem was reported way back in 2021, but rather than being resolved it was archived ! Well I suppose that's one way of whittling down problems logge… (read more)

I notice that this problem was reported way back in 2021, but rather than being resolved it was archived ! Well I suppose that's one way of whittling down problems logged on your stack of problems.

I am using 103.0.1 on a Mac Mini running macOS Mojave.

Like you, I'm being lazy and rather than typing a complete explanation of my own, I've simple cut and pasted the description from your previous complainant.

This action is prevalent when I close the right-most tab and whammo, full screen which then causes me to have to mess around to get the window back to the size I WANT IT, and not full screen as your software would seem to want it !

        • Previous complaint ****

Using latest version of Firefox for Mac (although this problem happened with some previous versions as well).

When I have more than one tab open, and I click the X at the corner of a tab to close it, my Firefox window suddenly jumps to full screen. I have to drag the browser window from the edge to get it back to my original size. This behavior happens at other odd times as well, and the suddenly jumping to full screen gets really annoying. Any suggestions as to how I can fix this problem?

        • End of previous complaint ****

I suppose that one potential fix would be to ditch Firefox and revert to Safari, what do you reckon ? I wonder if Safari exhibits this extremely PERVERSE way of working ?

Best regards

Pete Findlow

Asked by peter.findlow 1 day ago

Open external links in recently active window

I am sorry to invoke other browsers here, but I have switched from Chrome and found one feature to be completely intuitive there and impossible in FireFox. I have multipl… (read more)

I am sorry to invoke other browsers here, but I have switched from Chrome and found one feature to be completely intuitive there and impossible in FireFox. I have multiple profiles and want to open external links in the most recently active window. With Chrome, this was as simple as activating the window to open an external link in, then running the external link normally. In Chrome the link would open in any window that was recently active, including private windows. In FireFox it will only open in the first opened window of the first opened profile. I have not found an intuitive way of handling this in FireFox. Is there a setting or trick to it that doesn't involve rewriting URLs?

Asked by Brett 1 day ago

Unable to login to spectrum.net from Firefox - Login works in Chrome

Greetings. For the past several weeks I have been unable to log in to spectrum.net to pay a bill. Currently running Firefox 103.0.1 (64-bit) for Windows on Win 10 Pro 21H… (read more)

Greetings. For the past several weeks I have been unable to log in to spectrum.net to pay a bill. Currently running Firefox 103.0.1 (64-bit) for Windows on Win 10 Pro 21H2. I cleared cache and deleted cookies for spectrum.net, and performed a password reset with spectrum.net. Each login fails with: "We’re sorry, we’re unable to sign you in. Please try again later. IDID-3210."

Contacted Spectrum support, agent reset the password, and was able to log in using Chrome. I then ran Chrome and successfully logged in with the new password, and successfully changed the password and logged in again via Chrome.

Login still fails in Firefox.

Asked by gene.berkowitz 1 day ago

Right clicking link in search results no longer opens new tab

Hi, I've been using Containers in Firefox since I discovered it's existence. I've always been able to right click on a link in a search result and am then given a multit… (read more)

Hi,

I've been using Containers in Firefox since I discovered it's existence. I've always been able to right click on a link in a search result and am then given a multitude of options. Almost invariably, I select "Open link in Personal Container". When I do so nothing happens. No new tab opens. No new instance of Firefox opens. Literally, nothing happens. However, if I click the link, the page that I'd like to view opens. I've not changed any of the settings in Firefox. I've not installed any new software. I've run several security apps and none has reported any malicious software on my system. I prefer to keep my original search page and explore search results on a different tab. Am I able to go back to that mode of working?

Asked by Thomas 4 days ago

Invalid view state on a visual studio website

Getting an invalid view state on my own website written in asp.net visual studio old version 2013, started today never got this problem before. Problem not occurring on … (read more)

Getting an invalid view state on my own website written in asp.net visual studio old version 2013, started today never got this problem before. Problem not occurring on other browsers.

Asked by pat47 1 day ago

Rollo Printer Issues

Hello! I switched to firefox a few months ago. It worked okay with my rollo printer (printing mailing labels) for awhile, but it's suddenly not working right. Labels prin… (read more)

Hello! I switched to firefox a few months ago. It worked okay with my rollo printer (printing mailing labels) for awhile, but it's suddenly not working right. Labels print off at strange sizes and with garbled images and text. It works fine if I print from chrome or from my desktop; just not from the firefox browser. I'm wondering if there was an update recently that broke it and I'm really hoping it can be fixed, because I'd like to keep using this but I run a business and it's far too irritating to have to keep switching to chrome to print stuff... I also am positive this is a firefox issue because my partner is suddenly experiencing the same issue after switching from chrome.

Asked by qquiscula 1 day ago

Files downloaded from Gmail not retaining full file name

Why is Firefox limiting my file name to 3-5 characters instead of the full name as the original document? My Gmail Workspace account is a business account so I need to re… (read more)

Why is Firefox limiting my file name to 3-5 characters instead of the full name as the original document? My Gmail Workspace account is a business account so I need to retain proper naming conventions and original names for files, but Firefox seems to be shortening the file names, and I'm having to completely rename. I can't find any information on how to override this if it's a setting or if anyone else is having the same problem.

I am running Firefox 103.0.1 on macOS Monterey 12.4.

Thanks in advance.

Asked by cmjross1 1 day ago

Cannot watch purchased videos online using Firefox

When I go to Artists Network and log into my account and try to view the videos that I have paid for, by clicking on a link - with Firefox nothing happens. However, they … (read more)

When I go to Artists Network and log into my account and try to view the videos that I have paid for, by clicking on a link - with Firefox nothing happens. However, they work using MS Edge.

Use hardware acceleration is unchecked and my graphics driver is up to date. If Microsoft Edge works why doesn't Firefox?

What is wrong?

Asked by NiagaraMouse 4 days ago

Last reply by NiagaraMouse 2 days ago

Google no longer displaying properly with Firefox 103.0.1

I am on a 2018 Intel Mac Mini running macOS Catalina 10.15.7. After updating to 103, Firefox no longer shows any content on Google related pages (search, Gmail, etc.). Th… (read more)

I am on a 2018 Intel Mac Mini running macOS Catalina 10.15.7. After updating to 103, Firefox no longer shows any content on Google related pages (search, Gmail, etc.). The pages load but no text is visible, only images.

I've tried everything from clearing all caches and browsing history, to going into about:config and changing the sandbox settings. Not sure what else to do as I've been primarily using Firefox for years but these issues have only surfaced after the last couple of updates.

Asked by rna_ink 1 day ago

Last reply by rna_ink 1 hour ago

Secured connection Failed

Secure Connection Failed An error occurred during a connection to www.google.co.in. SSL peer was not expecting a handshake message it received. Error code: SSL_ERROR_HAND… (read more)

Secure Connection Failed

An error occurred during a connection to www.google.co.in. SSL peer was not expecting a handshake message it received. Error code: SSL_ERROR_HANDSHAKE_UNEXPECTED_ALERT

I receive the above message very frequently. Option already tried is- about:config- security.ssl.enable_ocsp_stapling = true/false. By toggling true/false very frequently, I can access the website.

Sometimes it works when it is true, sometimes it works when it is false. This happens all the time. how to get rid of it

Asked by ifplfactory 6 days ago

PDF displaying as blank document.

We are on version 103.0.1 and have started having a problem with the PDF viewer showing blank documents. If you download the document is is good. How can we get the docum… (read more)

We are on version 103.0.1 and have started having a problem with the PDF viewer showing blank documents. If you download the document is is good. How can we get the document to open correctly in the viewer.

Asked by Dale_J_Souza 1 day ago

Last reply by Dale_J_Souza 22 hours ago

FF export to html backup stops half-way !

Hello, My FF export to html backup stops half-way ! Here is the problem: Untill last June 2022 this backup was doing fine to reach the usual more than 65.000 mb. & gr… (read more)

Hello, My FF export to html backup stops half-way ! Here is the problem: Untill last June 2022 this backup was doing fine to reach the usual more than 65.000 mb. & gradually building up with every bookmark I add. But last month all that changed when the option started to stop half-way. Meaning it stopped at the level of more than 17.000 mb !!! Which is unbelievably LOW. Today Aug 3, 2022, I retried the operation on my usb stick. And FF export gave me the same results (with the little difference of the few bookmarks I added in the meantime). I didn't find any solution in the FF help pages to help me settle this problem. So any anything to fix this will be appreciated. I'm running windows 10 home & FF 103.0.1 (32 bit)

Asked by al_wand 6 days ago

Gaming via Firefox: broken audio in Fedora 34 but it works on Debian 10

Hi. I have been experiencing audio problems in Fedora's Firefox when gaming in some web sites like <kbhgames.com>. An example happpens in <https://kbhgames.com/g… (read more)

Hi.

I have been experiencing audio problems in Fedora's Firefox when gaming in some web sites like <kbhgames.com>. An example happpens in <https://kbhgames.com/game/dragon-ball-advanced-adventure>.

All goes well on a 64-bit Debian Buster's Firefox 78.14.0esr. The problem is about a 64-bit Fedora's Firefox 94.0. And yes, the issue is there even when all permissions are loosen.

Besides optional troubleshooting Information being shared, common specs are below for convenience:

* user agent Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:94.0) Gecko/20100101 Firefox/94.0; and

* Kernel (according to uname) Linux charger-rt 5.14.18-200.fc34.x86_64 #1 SMP Fri Nov 12 16:48:10 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux.

Plus, the <about:support>'s Media table

Media Audio Backend pulse-rust Max Channels 2 Preferred Sample Rate 48000 Roundtrip latency (standard deviation) 77.89ms (21.60) Output Devices Name Group Vendor State Preferred Format Channels Rate Latency Built-in Audio Analog Stereo Enabled All default: F32LE, support: S16LE S16BE F32LE F32BE 2 default: 48000, support: 1 - 384000 0 - 0 Input Devices Name Group Vendor State Preferred Format Channels Rate Latency Monitor of Built-in Audio Analog Stereo Enabled None default: F32LE, support: S16LE S16BE F32LE F32BE 2 default: 48000, support: 1 - 384000 0 - 0 Built-in Audio Analog Stereo Enabled All default: F32LE, support: S16LE S16BE F32LE F32BE 2 default: 48000, support: 1 - 384000 0 - 0

Regards.

Asked by Bea 4 days ago

Bookmarks reordering every few seconds

I have my bookmarks toolbar organized by folders. Within the folders, the bookmarks won't stay sorted. I can sort them in the library window, but a few seconds later, as … (read more)

I have my bookmarks toolbar organized by folders. Within the folders, the bookmarks won't stay sorted. I can sort them in the library window, but a few seconds later, as I am watching, they resort themselves seemingly randomly. The same order is shown in the browser sidebar and the library window, and it continues to change every few seconds.

I use Firefox on both my Windows PC and my iPhone, I turned on syncing for a while but turning it off and restarting the browser does not stop this annoying behavior.

In addition, some bookmarks duplicate themselves and I end up with hundreds of the same bookmark. This behavior seems to have ceased when I turned of syncing, maybe this is a second problem?

How can I stop this and keep them sorted and synced, while avoiding the hundreds of duplicated bookmarks?

Asked by stew3 6 days ago

Last reply by stew3 6 days ago

Firefox crashing on certain tabs inluding "https://support.mozilla.org/en-US/products/firefox/fix-problems"

I have updated firfox and tried full refresh. Does not crash in troubleshoot mode, but still does with all themes and extensions disabled. I use : Bitwarden Evernote web… (read more)

I have updated firfox and tried full refresh. Does not crash in troubleshoot mode, but still does with all themes and extensions disabled.

I use :

Bitwarden Evernote web clipper Decentraleyes Privacy badger Ublock origin

Asked by Mark Lewis 4 days ago

Last reply by Mark Lewis 4 days ago

right-click on field puts list in upper left corner

Typically, when you right-click on a field or link or basically anywhere in a webpage the list of options appears or pops up at the point of the cursor. However, for som… (read more)

Typically, when you right-click on a field or link or basically anywhere in a webpage the list of options appears or pops up at the point of the cursor. However, for some time now they all appear in the upper left corner of the Firefox browser.

In the screenshot attached, I performed the right-click from the "Find help..." field. But the list is in the upper left corner. The list appears there regardless of where I right-click on a webpage.

Is there a way to fix this so they appear at the point of the cursor?

Asked by randysw 23 hours ago

Last reply by randysw 19 hours ago

Warnnig Can't open page

Hi, After the last update, when I connect to my regular sites, I keep getting an error massage , some times the site is being opened , but some times the URL I try to rea… (read more)

Hi,

After the last update, when I connect to my regular sites, I keep getting an error massage , some times the site is being opened , but some times the URL I try to reach does not open at all.

Thanks for your help

Asked by dgraveh 4 days ago

Twitch tab stutters

Like in https://support.mozilla.org/en-US/questions/1224759 my twitch tab stutters when i change from a different tab to the twitch tab. I don't have it everytime, it's … (read more)

Like in

https://support.mozilla.org/en-US/questions/1224759

my twitch tab stutters when i change from a different tab to the twitch tab. I don't have it everytime, it's really inconsistent. It appears that my video moves forward some seconds. Suggestions like in the link didn't helped for me.

I tried: - set media.suspend-bkgnd-video.enabled to false and restart -> didn't solve the issue -set media.suspend-bkgnd-video.enabled back to true and restart -> didn't solve the issue -set media.suspend-bkgnd-video.enabled to false set network.http.throttle.version to 1, restart,

 set media.suspend-bkgnd-video.enabled to true again and restart -> nope

- set network.http.throttle.version to 0 and restart -> nope.

I'm really helpful for any ideas. Thanks in advance!

Asked by brychcy_1993 4 days ago