Showing questions tagged: Show all questions

MediaWiki 1.35 login fails with "Secure Connection Failed" and no error code (HTTP/2 related?)

[Update: This works correctly with HTTP/2 disabled, so it is somehow HTTP/2 related. Firefox's partner is terminated with ATS 8.0.2, so this is most likely an interactio… (read more)

[Update: This works correctly with HTTP/2 disabled, so it is somehow HTTP/2 related. Firefox's partner is terminated with ATS 8.0.2, so this is most likely an interaction with Traffic Server, but debugging help is still needed.]

I recently upgraded from Mediawiki 1.31 to 1.35 on Debian 10. Since this upgrade, attempts to log in with Firefox are impossible -- Safari and Chrome work fine. Firefox 96.0 displays the attached error "Secure Connection Failed" but no security error is provided. This seems to be a defect in Firefox, but I am having difficulty diagnosing further.

Looking at both server trace logs as well as the Firefox debugging tools, I see Firefox does an expected POST request to the login page:

 POST https://newwiki.convivian.com/mediawiki/index.php?title=Special:UserLogin&returnto=Main Page

The MediaWiki server replies with a 302 Found and redirect to the Main Page on successful login, but Firefox considers this response insecure on some way that is not indicated. The "Security" tab in DevTools shows no security errors on the transaction.

I am able to reproduce this on multiple machines running Firefox 96.0, as well as with Troubleshooting Mode enabled. No errors occur with other tested browsers.

Is there a way to extract further debugging information from the browser?

Asked by jered 1 week ago

Last reply by jered 5 days ago

Latest Update Crashes

This post is on my Mac Catalina. This morning Firefox updated on my Windows 7 before I closed out. Now that it is evening Firefox does not open on that computer. What … (read more)

This post is on my Mac Catalina. This morning Firefox updated on my Windows 7 before I closed out. Now that it is evening Firefox does not open on that computer. What should I do to fix it since it does not open; it crashes immediately.

Asked by tightpurchaser 1 week ago

Last reply by tightpurchaser 6 days ago

Service Worker cannot register

I am using Firefox 96.0.1 on macOS Monterey 12.1 If you have "'Delete cookies and site data when Firefox is closed checked in Privacy & Security/Cookies and Site Dat… (read more)

I am using Firefox 96.0.1 on macOS Monterey 12.1

If you have "'Delete cookies and site data when Firefox is closed checked in Privacy & Security/Cookies and Site Data then this causes sites that use a service worker to fail registration with the error:

"Failed to register/update a ServiceWorker for scope https://every-layout.dev/: Storage access is restricted in this context due to user settings or private browsing mode."

This *only* occurs with Firefox, Safari, Chrome, Brave etc. all register the service worker OK. I know the workaround is to put in an Exception to Allow but this should not be necessary. In this case the service worker is use to provide access to paid for content and off-line reading.

I contacted the site's developers and they tell me that they have been waiting for ages for Mozilla to fix this issue and suggested I used an alternative browser.

Can anyone explain why Firefox behaves in this way and if this "feature" will be fixed on future releases?

Thanks

John

Asked by kickmaleerie 2 days ago

space bar moves cursor to front of sentence

I prefer Firefox browser on my computer - currently using 96.0.1 a month or so ago, when logged in to godaddy email workspace, the subject line cursor won't stay in plac… (read more)

I prefer Firefox browser on my computer - currently using 96.0.1

 a month or so ago, when logged in to godaddy email workspace, the subject line cursor won't stay in place.

I'll type a word then space resulting in the cursor jumping to the front of the line of text. Sometimes it jumps after the first letter but always with the space bar and only in the subject line of this website.

If I type a word in the subject line, then space, the cursor moves to the front of the line of text... if I continue typing there and use the space bar the cursor doesn't jump. But if I move the cursor behind the first word and space, type another word and space it jumps again.

I worked with godaddy on the issue... after troubleshooting various browsers (this only happens when using Firefox) and other things they asked me to do they point the finger at Firefox. I hope this can be figured out, I do not want to use Chrome for email. thanks!

Asked by revpolymer 22 hours ago

Last reply by revpolymer 47 minutes ago

Set different volume on different tabs

Hi! I have several tabs open at once. In one, I am watching a TV show on Hulu; in another, I have a timer running (I am watching a show while exercising). The problem I a… (read more)

Hi! I have several tabs open at once. In one, I am watching a TV show on Hulu; in another, I have a timer running (I am watching a show while exercising). The problem I am facing is that if I increase my computer's volume loud enough that I can hear the show, then when the timer goes off it is painfully loud. Is there a way to control the volume within Firefox such that the Hulu tab's volume is at, say, 80%, while the timer tab's volume is at, say, 20%? Thanks!

Asked by ammon8r 6 days ago

Credit card nickname

I would like to name my credit cards ("Irl's AMEX", "B's auto Visa"). Safari allows this but Firefox doesn't seem to. Or at least I can't find it. Basically, when I view … (read more)

I would like to name my credit cards ("Irl's AMEX", "B's auto Visa"). Safari allows this but Firefox doesn't seem to. Or at least I can't find it. Basically, when I view a saved credit card, instead of seeing, e.g., "****1234 2025-01" I'd like to see a text entry which I can edit. I'm even willing to do a bit of fancy footwork (add something to the .plist, say). OS X High Sierra, 10.13.6.

Asked by irl1 2 days ago

Fullscreen videos hide system panel on other display in MacOS

Hello everyone, whenever I play a video in fullscreen mode, the system panel is not visible on the other display. For example, the fullscreen video is playing on the seco… (read more)

Hello everyone,

whenever I play a video in fullscreen mode, the system panel is not visible on the other display.

For example, the fullscreen video is playing on the secondary display, while on the integrated one there are no windows open. If I click on the desktop, the panel will be shown again but the focus won't be on Firefox, so I can't control the video with my keyboard.

Is there a way to change this behaviour? I've already tried tinkering with the settings in about:config but I couldn't find the solution.

Asked by Balbuziente 6 days ago

Verification code does not arrive within 5 minutes

Dear Sir, I have my firefox username and password. However, whenever I try to sign in nowadays, I am asked to enter a verification code that is sent to my email address w… (read more)

Dear Sir,

I have my firefox username and password. However, whenever I try to sign in nowadays, I am asked to enter a verification code that is sent to my email address within five minutes. The email does arrive, but never withing 5 minutes. I have tried it many times on different devices. It may be my email issue. However, I cannot change the email account unless I cannot log it. Since I cannot receive the verification code within 5 minutes, I am unable to change any of my personal details.

Please advise.

Yours sincerely, Tan Ngiap Heng

P.S. It was very difficult gettting to this support page. I was asked to log in and verify before continuing for some of the support pages. But like I mentioned, I am unable to receive the verification code within 5 minutes. So I am thankful for this page.

Asked by heng96 2 days ago

Last reply by heng96 11 hours ago

No Passwords/Logins on Firefox Desktop - MAC

When I opened my browser today, and tried to login to one of my sites, I discovered that all but three (3) of my 100s of stored logins and passwords had disappeared. I ch… (read more)

When I opened my browser today, and tried to login to one of my sites, I discovered that all but three (3) of my 100s of stored logins and passwords had disappeared. I checked the Firefox browsers on my phone and iPad and they're all there, just not on my iMac. Yesterday, Firefox bumped me out of my account and I had to log back in. I didn't notice this problem then.

1 - I need to know how to download all my passwords before they disappear from my mobile accounts too. 2 - How do I get them back on my desktop browser?

Asked by nubianpriestess 6 days ago

Login requested to view console window

My localhost is password protected. When I try to open the console window in developer tools, it is promoting me to enter the site username/password again. This could be … (read more)

My localhost is password protected. When I try to open the console window in developer tools, it is promoting me to enter the site username/password again. This could be a bug.

Asked by apasho 2 days ago

Firefox very slug after update to 96.0, 96.01 slihtly better but still sluggish

After updating to Firefox 96.0, Firefox became unusable. Went from happily playing two youtube tabs (one speech, other background music) 2 tabs in separate windows of 10… (read more)

After updating to Firefox 96.0, Firefox became unusable. Went from happily playing two youtube tabs (one speech, other background music) 2 tabs in separate windows of 10 to 12 windows open with more than 10 tabs in each window, although many were inactive, alongside Apple Mail and often one or two other apps open such as Preview, VLC or TextEdit; whereas immediately after update to Firefox 96.0 to taking 10 minutes to load a tab when only 2 or 3 tabs were open, and unable to play youtube videos without continuous breaks totalling far more than the video itself, and unable to play embedded videos in BBC news website when only 2 or 3 tabs open in one window with no other apps running, other apps were very sluggish when Firefox running; all other apps ran fine, as normal when Firefox was not running.

Firefox 96.0.1 improved it's ability. Youtube videos will mostly play now if there is only 2 or 3 tabs open, as with BBC embedded videos, tabs are often now taking 3 to 5 minutes to load.

Downloads were like night & day, Firefox was happily working until updated to FF 96, immediately after update FF was almost impossible to use, updating to 96.0.1 created a little more usability, but still cumbersome and very sluggish to the point of pretty well unusable. Was running FF on 2011 Mac Mini, OS 10.12.6 with 16GB RAM

Asked by peterchandler108 2 days ago

The media could not be loaded, format is not supported.

On a trusted website, for a class which I paid a lot of money to attend, I get this error message, on FireFox only: The media could not be loaded, format is not supported… (read more)

On a trusted website, for a class which I paid a lot of money to attend, I get this error message, on FireFox only: The media could not be loaded, format is not supported.

I used to LOVE Firefox,but I'm getting frigg'n irritated by it right now. Chrome and Safari both open this page. I had this same problem a few days ago, was sent a long list of possible ways to deal with it that were all over my head complicated. I chose the simplest one- to clear caches, and it worked! yay, for a couple of days, now the error is back. I there must be a different solution , or cause, than the cache one - What needs to be turned on or off, so this doesn't happen? Too complicated, too frustrating.

I'd love it if someone could give me some more ideas on this. Macbook Pro 16" 2021, IOS Monterey 12.1

Thank you!

Asked by Paula Z. 2 days ago

firefox shortcuts

All the shortcuts became blank. I can click on "edit", do the editing and click on "add". Though, the shotcuts stay blank. It happens both in normal or incognito pages. T… (read more)

All the shortcuts became blank. I can click on "edit", do the editing and click on "add". Though, the shotcuts stay blank. It happens both in normal or incognito pages. This just happened after using Firefox for years. Hope you can help. M

Asked by m.c.pappone 59 minutes ago

I am unable to use Firefox on my new macbook air. It is not able to access the Web.

how can I get Firefox to operate on my new Air like it does on my old MBAir /moved thread from Firefox for iOS (for iPhone/iPad) to Firefox (desktop) section as you hav… (read more)

how can I get Firefox to operate on my new Air like it does on my old MBAir



/moved thread from Firefox for iOS (for iPhone/iPad) to Firefox (desktop) section as you have macOS.

Asked by jstephensdds 1 day ago

Please don't eliminate the colorways that aren't enabled when updating to version 96

I really do like the new colors and I switch between them often. What is motivating you to remove them starting with Firefox 96? Do I really have to turn off auto update … (read more)

I really do like the new colors and I switch between them often. What is motivating you to remove them starting with Firefox 96? Do I really have to turn off auto update to make sure I have my favorite Colorway enabled before the update?

You've adopted two common phrases and tried to apply them to Colorways:

1 - "limited time only" - This usually means you just have to acquire it during a limited time window; you don't lose it after the time window has passed.

2 - "limited edition" - This usually means a limited number of people can acquire it.

Based on my understanding, neither phrase applies to your Colorways offering.

Would you please reconsider? Mozilla is one of my year-end charitable contributions; does that give me any more clout? :)

Asked by firefox631 2 months ago

Last reply by firefox631 5 days ago

Saml authentication not working in firefox for my application but works with other browsers.

My application is configured with saml authentication and it works with all other browsers but when it comes to firefox it does not work. When anyone access https://myap… (read more)

My application is configured with saml authentication and it works with all other browsers but when it comes to firefox it does not work.

When anyone access https://myapp.example.com it loads the page on firefox and the landing page does have SSO icon , clicking on that it does not re-direct to saml authentication , But with other browser its not the case. Hence kindly advice if any thing needs to be done on this.

Firefox Version : Attached

Asked by neerajbaraiud016 5 days ago