Showing questions tagged: Show all questions
  • Solved

Add search engine with non standard port

Hello, I am trying to add searx as my default search engine. Searx runs on port 8080 on my localhost therefore it's url is https://localhost:8080. I can successfully visi… (read more)

Hello, I am trying to add searx as my default search engine. Searx runs on port 8080 on my localhost therefore it's url is https://localhost:8080. I can successfully visit this url and use searx; however when I add searx using the green button to my search engine list, it strips the port resulting in an error when searching. This is very frustrating with no ability to change this setting as far as I can tell. Is there any work around for this issue?

Asked by trexd 2 weeks ago

Answered by trexd 2 weeks ago

  • Solved
  • Archived

Ebay and Amazon earches resurrect after relaunch

Hello dear Mozilla community! I've faced an issue with search engines configuration for Firefox on macOS. I'm doing the following: Removing all but one One-Click Search… (read more)

Hello dear Mozilla community!

I've faced an issue with search engines configuration for Firefox on macOS. I'm doing the following:

  1. Removing all but one One-Click Search Engines, leaving only one engine in the list (currently my preference is DuckDuckGo): https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-11-17-04-32-41-395a2a.png or https://imgur.com/DKqvzZ9
  2. When I type search request in the address bar I'm seeing nice and clean search suggestions from Search Provider of my choice: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-11-17-04-32-13-a8d46c.png or https://imgur.com/a/slivHlF
  3. Close Firefox
  4. (not sure what other conditions needed)
  5. Open Firefox
  6. When typing search request in the address bar I see that Amazon and Ebay options are back and a suggestion line "This time, search with ..." as added by firefox: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-11-17-04-32-02-4a25db.png or https://imgur.com/vjq0NCf
  7. In the preference I see that those two searches (Ebay and Amazon) were automatically re-added to One-Click Search Engines: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-11-17-04-32-23-91dd1d.png or https://imgur.com/ibnlzLS

That issue is happening to me across different versions of firefox and isn't new. I've been seeing it for a few month hoping that to resolve in a newer versions. But as of right now I'm on 82.0.3 (64-bit) and the issue is still there.

It's a bit annoying as I have to my preferences literally every time I need to restart Firefox (which is especially annoying to do right after restarting FF to switch to a newer version).

Any suggestions and help is welcome!

Best regards, Serhii.

Asked by Serhii 1 year ago

Answered by Serhii 9 months ago

  • Solved
  • Archived

Search engine shortcuts in address bar

I have noticed that when I type "!g" in front of my search string in the address bar, the search is done with google despite using a different search engine. In addition,… (read more)

I have noticed that when I type "!g" in front of my search string in the address bar, the search is done with google despite using a different search engine. In addition, almost every letter on the keyboard will search a particular domain. For example, "!r" searches through reddit.

The weird thing is that I cannot find any documentation of this anywhere, and I cannot find any settings on this anywhere. The only similar thing is being able to use "@" with a custom keyword that has been previously set in the "search engines" menu in the settings. But this menu is limited and it is difficult to add search engines to it, as it requires you to visit that website, find the green plus sign in the tiny looking glass icon on the search bar next to the address bar, and click it and add the search engine. Then you can customize the keyword and then you can use, for example "@w" for example, to search wikipedia. But not every website gives you the option to add their search engine. For example,visiting Reddit results in no green plus sign over the looking glass icon in the search bar next to the address bar, despite the fact that "!r" works just fine.

So this is all very confusing, I hope someone can tell me what is going on. Thanks.

Asked by ZPERO 1 year ago

Answered by Balázs Meskó 11 months ago

  • Solved
  • Archived

How to disable Firefox address bar in v83

So I've recently updated to v83 and find out that that annoying address bar is back. I don't really want to use Chrome.css because I'm not good at programming or anything… (read more)

So I've recently updated to v83 and find out that that annoying address bar is back. I don't really want to use Chrome.css because I'm not good at programming or anything like that and I am afraid I might break my browser.

I have the solutions for v77 on my about:config and tried toggling them true/false and restarting my computer but I think Firefox "fixed" those workarounds.

Anybody have any new suggestions? Or am I stuck with this (I wouldn't mind it so much but it goes to it automatically when I open a new tab and that annoys me. I'm happy the history part of the workaround is still working cause I do NOT want anyone knowing my history. That's my business not theirs).

Asked by susannah121088 1 year ago

Answered by jscher2000 1 year ago

  • Solved
  • Archived

Antivirus Software Bitdefender Wallet Extension disappeared from Firefox

Hi, My Antivirus Software Bitdefender Wallet Extension disappeared from Firefox, I already added this extension but it's not showing up in my Firefox browser, any soluti… (read more)

Hi, My Antivirus Software Bitdefender Wallet Extension disappeared from Firefox, I already added this extension but it's not showing up in my Firefox browser, any solution?

Waiting for your reply asap, thanks.

Cool Regards, Pallas

Asked by PALLAS 12 months ago

Answered by PALLAS 12 months ago

  • Solved
  • Archived

Why doesn't the ad block icon show up on my tool bar any more?

Firefox's ad block icon used to show up on my toolbar. Now it has disappeared and the only way to disable it for some sites is to go into ad-ons and turn it off completel… (read more)

Firefox's ad block icon used to show up on my toolbar. Now it has disappeared and the only way to disable it for some sites is to go into ad-ons and turn it off completely. Where is the icon?

Asked by airebird 12 months ago

Answered by Kiki 12 months ago

  • Solved
  • Archived

CTRL+ CTRL- zooming, is there a way to disable it?

i use google docs for school, and because of that i need to use sub and super scripts often, google has decided that CTRL + , is the shortcut but this also zooms in the p… (read more)

i use google docs for school, and because of that i need to use sub and super scripts often, google has decided that CTRL + , is the shortcut but this also zooms in the page.

Asked by that1guybutnotthefirst 11 months ago

Answered by that1guybutnotthefirst 11 months ago

  • Solved
  • Archived

New wider address bar

I do not like this wide address bar and need to go back to classic look. I tried some links on this support but it does not help. I would also like to to have to reset my… (read more)

I do not like this wide address bar and need to go back to classic look. I tried some links on this support but it does not help. I would also like to to have to reset my preferences after each update. My version is 83.0 on Windows 7.

Thanks

Asked by phil.cote 11 months ago

Answered by cor-el 11 months ago

  • Locked
  • Archived

PR file error - Again!

Ironically, I have to use Google's Chromecast to log this question ...Because Firefox 1) Doesn't work, again, and 2) Mozilla offers zero ways to directly contact them Fo… (read more)

Ironically, I have to use Google's Chromecast to log this question ...Because Firefox 1) Doesn't work, again, and 2) Mozilla offers zero ways to directly contact them

For the past several weeks, I constantly get error notifications: The "PR..." notice that indicated Search issues. I've read the information about it, resolve the issue for a day or two, and BOOM ...It's BACK! I do not have the time or wherewithal to continuously work to figure out and resolve poor browser coding issues. Today, I checked the "Set Defaults" option and it still doesn't work.

I'll check back in a couple weeks to see if an update has resolved the problem. Until then, I'll be 1) copying all my bookmarks (I still don't like their lousy Bookmark Mgmt process), and 2) using a different browser. Mozilla is wasting my time... They better hope I actually come back.

Users should not be expected to put up with BAD CODING for so long. At least not in the land of reality and multiple feasible browser choices.

Asked by Phil 11 months ago

Last reply by FredMcD 11 months ago

  • Solved
  • Archived

Version 84 Restore session not in my drop down menu. Where has it gone?

When my Firefox restarted after a Windows reboot it only restored the tabs in one window, but when I shut it down I had 2 windows open. I can't see how to restore the sec… (read more)

When my Firefox restarted after a Windows reboot it only restored the tabs in one window, but when I shut it down I had 2 windows open. I can't see how to restore the second window, other than going through my history. Having restored 1 window, restore session is not in the drop down menu.

Asked by Gilbern 11 months ago

Answered by Gilbern 11 months ago

  • Solved
  • Archived

Autoplay but just block the video and keep the Volume slider the same across tabs?

I'm not sure if this is the correct place to ask this nor am I sure that this isn't just one of my many installed extensions being wonky -- but is there a way to keep the… (read more)

I'm not sure if this is the correct place to ask this nor am I sure that this isn't just one of my many installed extensions being wonky -- but is there a way to keep the volume meter at the same level across tabs? More specifically, I peruse the old.reddit.com/r/livestreamfail website and I open each thread in a new tab with the option to block the audio and video from autoplaying enabled and the volume meter is always set at 0% on every embedded clip. I wish the behavior of the video player to leave the volume slider at the percentage from the last time I manipulated the volume slider from a previous clip, that way I don't need to touch the volume slider whenever I start playing the new video. Is this the behavior of the twitch video player or is there a config setting I can change to achieve the desired behavior? Shouldn't blocking video inherently block audio too? Why does autoplay option always set the volume to 0%?

I'm on updated OpenSuse Tumbleweed with Firefox version 83.0

My firefox extensions include: Facebook Container, GNOME Shell integration, Reddit Enhancement Suite, SponsorBlock for Youtube, uBlock Origin and Weather

Asked by JDC8521 11 months ago

Answered by jonzn4SUSE 11 months ago

  • Locked
  • Archived

Panel to left of Left Panel

Hello again: I just asked the question about the panel to the left of the left panel... My reason for wanting to remove this new 'panel' is because I can not see the full… (read more)

Hello again:

I just asked the question about the panel to the left of the left panel...

My reason for wanting to remove this new 'panel' is because I can not see the full text of my emails now unless I close the Left Panel.

I do have a wide computer monitor... never had a problem viewing my emails until FF installed the upgrade to 84.0.1.

Thanks

John R

Asked by jrudz00 11 months ago

Last reply by FredMcD 11 months ago

  • Solved
  • Archived

Disable Reader View Toolbar After FF69

When I enable reader mode there is a small floating toolbar I find distracting. I would like to turn it off. I found two previous questions on this topic but neither of … (read more)

When I enable reader mode there is a small floating toolbar I find distracting. I would like to turn it off.

I found two previous questions on this topic but neither of them worked for me.

https://support.mozilla.org/en-US/questions/1082202 https://support.mozilla.org/en-US/questions/1209287

Asked by Michael Ulmen 11 months ago

Answered by Michael Ulmen 11 months ago

  • Locked
  • Archived

Changing URL status bar background/text color

When I'm hovering the mouse over a link, a URL status bar appears at the bottom of the window. Is there any way to change the background and text color of that URL status… (read more)

When I'm hovering the mouse over a link, a URL status bar appears at the bottom of the window. Is there any way to change the background and text color of that URL status bar? I'm attaching an image showing what is that status bar.


Thanks, Itai

Asked by itai590 11 months ago

Last reply by jscher2000 11 months ago

  • Solved
  • Archived

finding out if this method to add backgrounds to the firefox homepage still works

I followed this post to add your own background to the Firefox homepage from a year ago to a T (reading all the posts to not miss anything) but I cant seem to make it wor… (read more)

I followed this post to add your own background to the Firefox homepage from a year ago to a T (reading all the posts to not miss anything) but I cant seem to make it work. I'm wondering if this either doesn't work anymore, or I passed over something very minor somehow. I made sure to edit the URL to match my own and my picture name, I made a userChrome.css, I'm not too sure what to do. I'll have to look over it again later.

https://support.mozilla.org/en-US/questions/1271362

Asked by Spenc 11 months ago

Answered by Spenc 11 months ago

  • Solved
  • Archived

Refresh wiped out CSS file for Tabs on Bottom, again V 84.0.2

As stated above, tabs are back on top... ugh. Windows 7, FF 84.0.02 Made a chrome folder in profile folder made userChrome.css file latest css I could find /* TABS: bo… (read more)

As stated above, tabs are back on top... ugh. Windows 7, FF 84.0.02 Made a chrome folder in profile folder made userChrome.css file

latest css I could find

/* TABS: bottom - Firefox 65 and newer */

#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {
  -moz-box-ordinal-group: 10 !important;
}

#TabsToolbar {
  -moz-box-ordinal-group: 1000 !important;
  display: block !important;
  position: absolute !important;
  bottom: 0 !important;
  width: 100vw !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}

*|*:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
  padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*adjust*/
}

/* Firefox 65-73 */
*|*:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"])
 #toolbar-menubar[autohide="true"] ~ #TabsToolbar{
  bottom: var(--tab-min-height) !important;
  padding-top: calc(var(--tab-min-height) - 20px) !important; /*adjust*/
}

/* TABS: height */
*|*:root {
  --tab-toolbar-navbar-overlap: 0px !important;
  --tab-min-height: 25px !important; /*adjust or omit to use density*/
}

*|*:root #tabbrowser-tabs {
  --tab-min-width: 80px !important; /*adjust or omit to use default*/
}

#TabsToolbar {
  height: var(--tab-min-height) !important;
  margin-bottom: 1px !important;
  box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important; /*omit*/
  background-color: var(--toolbar-bgcolor) !important;
  color: var(--toolbar-color) !important;
}

/* indicators - hide  */
.private-browsing-indicator {display: none !important;}
.accessibility-indicator    {display: none !important;}

/* window controls hide*/
#TabsToolbar #window-controls {display: none !important;}

/* caption buttons - hide */
*|*:root[tabsintitlebar]:not([inFullscreen="true"])
 #toolbar-menubar[autohide="true"] ~ #TabsToolbar
 .titlebar-buttonbox-container {display: none !important;}

Restarted and still tabs on top ! argh TIA Jeff

Asked by lajefz 10 months ago

Answered by cor-el 10 months ago