Showing questions tagged: Show all questions

Lame game

I play a game at Vegas World. It's basically a free online slot machine site. I have played it for years with Chrome. Recently switched to Firefox. Playing an auto spin s… (read more)

I play a game at Vegas World. It's basically a free online slot machine site. I have played it for years with Chrome. Recently switched to Firefox. Playing an auto spin slot game, Firefox gets slow and hangs after about 25 spins. Chrome will go for 10,000 spins. So, Firefox is useless on game sites. I don't really expect a fix or solution. And I don't actually expect to use Firefox by the end of the day.

Asked by wisemagic1 5 months ago

Last reply by zeroknight 5 months ago

Control key and Shift key triggers some weird deleting symptom

How to reproduce the bug: Jump to the address bar, and then press shift, ctrol, alt or windows_start, you can see the address getting deleted. You can also see it in Goog… (read more)

How to reproduce the bug: Jump to the address bar, and then press shift, ctrol, alt or windows_start, you can see the address getting deleted. You can also see it in Google Sheets and Microsoft Excel Online, it just deletes the cell, or a selection of multiple cells. --Interestingly on Google Docs it doesn't delete but just move the cursor to the first character when a string is selected.

 It happens only once per mouse click, or focus change

What I expect: Shift, Control or any mod key should not delete content or move a cursor

Thanks!

Asked by Gunwoo Gim 5 months ago

Last reply by zeroknight 3 months ago

All updates were disabled - Add-on "could not be verified for use in Firefox and has been disabled."

I saw a message that my Add-ons were disabled, and when I checked the Add-ons Manager , each of my many Add-ons had a message similar to: "1Password – Password Manager co… (read more)

I saw a message that my Add-ons were disabled, and when I checked the Add-ons Manager , each of my many Add-ons had a message similar to: "1Password – Password Manager could not be verified for use in Firefox and has been disabled. "

Some searches in the forums suggest that that this can be caused my a certificate at Mozilla expiring, I seem to be the only one with this issue at the moment. All of my Add-ons came through the Mozilla store .

I am using version 123.0.1 (64-bit) on OpenSUSE Leap 15.5, and as far as I can see all of my updates are current (and from the official sources.)

What should I do next? I expect I need to wait for a certificate update or something at Mozilla, but if/when that happens how do I verify it did and re-enable my add-ons?

Asked by `Lex 4 months ago

Last reply by cor-el 4 months ago

''We are having trouble restoring your last browsing session"

On bootup firefox opens a single window which says the following: Sorry. We’re having trouble getting your pages back." We are having trouble restoring your last browsi… (read more)

On bootup firefox opens a single window which says the following:

Sorry. We’re having trouble getting your pages back." We are having trouble restoring your last browsing session. Select Restore Session to try again.

The restore function succeeds in restoring 6 windows from the prior session, but this notice keeps appearing on every bootup.

Here are a few relevant details from about: config

  • browser.sessionstore.max_resumed_crashes (is set to 1)
  • browser.sessionstore.resume_from_crash (is set to true)
  • No 3rd party third party cleaning software
  • Two extensions, tab stash and tree tabs
  • There are no entries in about:crash for this event

Have been using Firefox from 2004 with 5-10 open windows which appear on bootup as they existed from the prior session. This is the first occurance of this error. Appreciate your support. Here are a few system details:

1.) 28gb ram 2.) Linux ~ LMDE 5 (Elsie) 3.) Firefox ESR 115.8 (oesr) 64 bit.

Asked by josborne1 5 months ago

Last reply by jonzn4SUSE 4 months ago

Firefox does not display background color in option tags

I am trying to use a <select> tag to display a color selector. So each <option> has a background color to match its displayed text: ```<select id="stroke… (read more)

I am trying to use a <select> tag to display a color selector. So each <option> has a background color to match its displayed text:

```<select id="strokeColor" name="strokeColor" style="width: 10em;">

             <option value="black" style="background: #000000; text: #FFFFFF">
                     black
             </option>

<option value="aqua" style="background: #00FFFF">

                     aqua
             </option>

<option value="blue" style="background: #0000FF">

                     blue
             </option>

<option value="brown" style="background: #A52A2A">

                     brown
             </option>

<option value="gray" style="background: #808080">

                     gray
             </option>

<option value="green" style="background: #00FF00">

                     green
             </option>

<option value="magenta" style="background: #FF00FF">

                     magenta
             </option>

<option value="orange" style="background: #FFA500">

                     orange
             </option>

<option value="purple" style="background: #800080">

                     purple
             </option>

<option value="red" style="background: #FF0000">

                     red
             </option>

<option value="white" style="background: #FFFFFF">

                     white
             </option>

<option value="yellow" style="background: #FFFF00">

                     yellow
             </option>

<option value="#000000" selected="" style="background: #000000">

                     #000000
             </option>
         </select>```

On Chrome this displays as expected:

https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2024-04-18-22-02-25-eebbd5.png

But on Firefox the background colors are ignored:

https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2024-04-18-22-02-35-bd90ee.png

How can I get Firefox to display the background colors?

Asked by jamescobban 3 months ago

Last reply by Paul 2 months ago

my web browser always crashin firefox all distro gnome kde and xfce

I disabled graphics acceleration and I have the same problem. I tried several distros, it's the same thing each time, Firefox crashes and it's impossible to surf. could s… (read more)

I disabled graphics acceleration and I have the same problem. I tried several distros, it's the same thing each time, Firefox crashes and it's impossible to surf. could someone help me? I'm on opensuse thunbelweed




Signature core::option::expect_failed | webrender::scene_building::NodeIdToIndexMapper::get_spatial_node_index More Reports Search UUID 319ba611-fc97-439f-9456-a9e8d0240613 Date Processed 2024-06-13 05:28:23 UTC Uptime 78 seconds (1 minute and 18 seconds) Install Age 47,424 seconds since version was first installed (13 hours, 10 minutes and 24 seconds) Install Time 2024-06-12 16:15:12 Product Firefox Release Channel release Version 126.0 Build ID 20240509170740 (2024-05-09) Buildhub data OS openSUSE Tumbleweed OS Version 6.9.1-1-default #1 SMP PREEMPT_DYNAMIC Fri May 17 11:59:46 UTC 2024 (0c0b0b5) Build Architecture amd64 CPU Info family 23 model 24 stepping 1 CPU Count 8 Adapter Vendor ID

Advanced Micro Devices, Inc. [AMD/ATI] (0x1002)

Adapter Device ID

Picasso/Raven 2 [Radeon Vega Series / Radeon Vega Mobile Series] (0x15d8)

Startup Crash

False

Process Type parent MOZ_CRASH Reason (Sanitized)

no entry found for key

Crash Reason SIGSEGV / SEGV_MAPERR Crash Address 0x0000000000000000 Available Virtual Memory 4,520,636,416 bytes (4.52 GB) Available Page File 59,609,088 bytes (59.61 MB) Available Physical Memory 2,234,359,808 bytes (2.23 GB) EMCheckCompatibility

True

App Notes

openSUSE TumbleweedFP(D00-L1000-W0000000-T010) WR? WR+ libGL.so.1? libGL.so.1+ EGL? EGL- GL Context? GL Context+ WebGL? WebGL+

Crashing Thread (75), Name: WRScene~ilder#1 Frame Module Signature Source Trust 0 libxul.so RustMozCrash context 1 libxul.so mozglue_static::panic_hook /usr/src/debug/firefox-126.0/mozglue/static/rust/lib.rs:98 inlined 1 libxul.so core::ops::function::Fn::call /usr/src/debug/rustc-1.76.0-src/library/core/src/ops/function.rs:79 cfi 2 libxul.so std::panicking::rust_panic_with_hook cfi 3 libxul.so std::panicking::begin_panic_handler::{{closure}} cfi 4 libxul.so std::sys_common::backtrace::__rust_end_short_backtrace cfi 5 libxul.so rust_begin_unwind cfi 6 libxul.so core::panicking::panic_fmt cfi 7 libxul.so core::option::expect_failed cfi 8 libxul.so core::option::Option<T>::expect /usr/src/debug/rustc-1.76.0-src/library/core/src/option.rs:894 inlined 8 libxul.so <std::collections::hash::map::HashMap<K, V, S> as core::ops::index::Index<&Q>>::index /usr/src/debug/rustc-1.76.0-src/library/std/src/collections/hash/map.rs:1338 inlined 8 libxul.so webrender::scene_building::NodeIdToIndexMapper::get_spatial_node_index /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:141 inlined 8 libxul.so webrender::scene_building::SceneBuilder::get_space /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:1258 cfi 9 libxul.so webrender::scene_building::SceneBuilder::process_common_properties /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:1275 cfi 10 libxul.so webrender::scene_building::SceneBuilder::process_common_properties_with_bounds /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:1320 inlined 10 libxul.so webrender::scene_building::SceneBuilder::build_item /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:1435 cfi 11 libxul.so webrender::scene_building::SceneBuilder::build_all /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:977 inlined 11 libxul.so webrender::scene_building::SceneBuilder::build /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:588 cfi 12 libxul.so webrender::scene_builder_thread::SceneBuilderThread::process_transaction /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_builder_thread.rs:593 inlined 12 libxul.so webrender::scene_builder_thread::SceneBuilderThread::run::{{closure}} /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_builder_thread.rs:314 inlined 12 libxul.so core::iter::adapters::map::map_try_fold::{{closure}} /usr/src/debug/rustc-1.76.0-src/library/core/src/iter/adapters/map.rs:92 inlined 12 libxul.so core::iter::traits::iterator::Iterator::try_fold /usr/src/debug/rustc-1.76.0-src/library/core/src/iter/traits/iterator.rs:2462 inlined 12 libxul.so <core::iter::adapters::map::Map<i> as core::iter::traits::iterator::Iterator>::try_fold /usr/src/debug/rustc-1.76.0-src/library/core/src/iter/adapters/map.rs:118 inlined 12 libxul.so >::call_once /usr/src/debug/rustc-1.76.0-src/library/core/src/panic/unwind_safe.rs:272 inlined 14 libxul.so std::panicking::try::do_call /usr/src/debug/rustc-1.76.0-src/library/std/src/panicking.rs:552 inlined 14 libxul.so std::panicking::try /usr/src/debug/rustc-1.76.0-src/library/std/src/panicking.rs:516 inlined 14 libxul.so std::panic::catch_unwind /usr/src/debug/rustc-1.76.0-src/library/std/src/panic.rs:142 inlined 14 libxul.so std::thread::Builder::spawn_unchecked_::{{closure}} /usr/src/debug/rustc-1.76.0-src/library/std/src/thread/mod.rs:528 inlined 14 libxul.so core::ops::function::FnOnce::call_once{{vtable.shim}} /usr/src/debug/rustc-1.76.0-src/library/core/src/ops/function.rs:250 cfi 15 libxul.so std::sys::unix::thread::Thread::new::thread_start cfi 16 firefox set_alt_signal_stack_and_start(PthreadCreateParams*) cfi 17 libc.so.6 start_thread /usr/src/debug/glibc-2.39/nptl/pthread_create.c:447 cfi 18 libc.so.6 __clone3

Asked by Abdelmalik 1 month ago

Last reply by jonzn4SUSE 1 month ago

Using Node Express-Sessions to set cookie "httpOnly: true, secure: true, SameSite: "None" FF blocks authorization

My web site My web site allows user to login with .ejs Sign-up/Sign-in pages then delivers a React page. This works in Chrome and Safari. Https/SSL are provided by my ho… (read more)

My web site My web site allows user to login with .ejs Sign-up/Sign-in pages then delivers a React page. This works in Chrome and Safari. Https/SSL are provided by my host A2Hosting.

Firefox warns "Cookie “connect.sid” does not have a proper “SameSite” attribute value" when the cookie is set and then blocks the react page after login. If I enter the route that leads to the react page directly I can login and don't get the warning. In both cases the Storage tab in Dev tools shows the same settings for the cookie.
I made sure to remove any cookies for my site before testing the second scenario. I have tested this on Windows, Linux and Android versions of Firefox with the same results.

Here is my Express-Session instantiation ``` app.use(expressSession({

 store: new pgSession({
   pool: pool,
   tableName: 'session'
   // Insert connect-pg-simple options here
 }),
 secret: process.env.SECRET,
 resave: false,
 saveUninitialized: false,

cookie: {

   httpOnly: true,
   Secure: true,
   SameSite: "None",
   path: ['/'],
   maxAge: 60 * 60 * 1000 * 5
 }
 // Insert connect-pg-simple options here

})) ``` I've tried changing the path to include the react app route, I've added it to Cors white list and I converted it to open with an .ejs file instead of .html with no results.

Thanks for your support and for a great browser

Asked by rich.rhaskell 1 month ago

Last reply by jscher2000 - Support Volunteer 1 month ago

can we reduce disk usage?

Firefox uses about half a gig on my disk, that's: '~/.mozilla' and '~/.cache/mozilla' can that be reduced? Either some setting that limits disk use or even a manual del… (read more)

Firefox uses about half a gig on my disk, that's: '~/.mozilla' and '~/.cache/mozilla' can that be reduced? Either some setting that limits disk use or even a manual deletion of ancient stuff?

Asked by rayandrews 1 month ago

Last reply by salphakio 1 month ago

Sync not working due to a downed server

For now one week, I cannot sync my browser using Firefox sync. When checking the logs, I always see : Sync.Resource WARN GET request to https://sync-788-us-west-2.s… (read more)

For now one week, I cannot sync my browser using Firefox sync. When checking the logs, I always see :

Sync.Resource WARN GET request to https://sync-788-us-west-2.sync.services.mozilla.com/1.5/208380794/info/collections failed: [Exception... "The connection was refused" nsresult: "0x804b000d (NS_ERROR_CONNECTION_REFUSED)" location: "<unknown>" data: no] No traceback available

I have tested on multiples wifi network and mobile data and still the same error. After checking, it seem that this server is down, and I don't know were to report this.

Is this the right place to report this or is it a thing I can do to fix that ?

Thanks

Asked by cfouche3005 4 months ago

Last reply by jonzn4SUSE 4 months ago

Synching desktop and mobile Firefox bookmarks

I have a Firefox account in order to use the sync capabilities. After a sync between desktop and phone the desktop bookmarks are on my phone in an extra folder "desktop b… (read more)

I have a Firefox account in order to use the sync capabilities. After a sync between desktop and phone the desktop bookmarks are on my phone in an extra folder "desktop bookmarks" and vice versa the phone bookmarks are in folder "Mobile bookmarks" in my desktop Firefox. Is this normal behaviour? I would expect them in one common folder to have a seamless synching.

Best regards, Walter

Update from tar.bz2 files extracted

Ark extracted Version 119 files into /home/Downloads/Firefox/Firefox. I tried ./update from the BASH command line, but didn't know which argument(s) to add to that comman… (read more)

Ark extracted Version 119 files into /home/Downloads/Firefox/Firefox. I tried ./update from the BASH command line, but didn't know which argument(s) to add to that command. I'm hoping to update Firefox 78.14 ESR to a recent version, whether ESR or not. Thanks for your help.

Asked by lee.hinkleman 4 months ago

Last reply by jonzn4SUSE 4 months ago

audio no firefox

gente, o que aconteceu com o firefox (normal, beta e nightly) que não funciona mais áudio. já tentei de tudo para reconfigurar, baseado em tutoriais na web, porém não se … (read more)

gente, o que aconteceu com o firefox (normal, beta e nightly) que não funciona mais áudio. já tentei de tudo para reconfigurar, baseado em tutoriais na web, porém não se consegue mais ouvir áudio nos firefox.

Asked by nelioj 4 weeks ago

Last reply by jonzn4SUSE 3 weeks ago

Firefox locks up after downloading file

Firefox runs fine most of the time. If I right-click to download an image, or click a link to download a PDF or other file, or Save HTML, I see the "Save file" dialog, cl… (read more)

Firefox runs fine most of the time. If I right-click to download an image, or click a link to download a PDF or other file, or Save HTML, I see the "Save file" dialog, click Save and then Firefox freezes up for a while, maybe a minute or two. Pages won't scroll. I can't switch tabs. I can bring up a different firefox window and it redraws its contents, but I can't scroll or do anything else.

This didn't happen a month ago, then one day after a system upgrade, it happens every time. I'm using FF 123.0.1 on Arch Linux. 64GB RAM, so it's not a memory shortage. I have upgraded one or two times more since the upgrade when this appeared. Chromium is not affected, Thunderbird is fine, and all other software continues to be fine as before, including when saving files. Only FF has this problem.

What is the problem and solution? Are there ways to gather more info to diagnose the problem, if needed?

Asked by Daren Scot Wilson 3 months ago

Last reply by zeroknight 3 months ago

Many major websites play video frames out of sequence.

The video from most websites plays out of sequence. It appears that approximately every one second plays its frames in reverse order. This occurs with most video streamin… (read more)

The video from most websites plays out of sequence. It appears that approximately every one second plays its frames in reverse order. This occurs with most video streaming services and major sites. For example, all Amazon, Sam's Club, Walmart and other website product videos. Occasionally, Amazon product videos just say not compatible. However, YouTube videos with very rare excepts play fine in Firefox. Those problem sites play the videos fine under Edge for Linux. But, I would much rather use Firefox. I'm sure this a codec related issue. Possibly related to the NVIDIA GeForce GT 1030 video card in this computer running openSUSE 15.5. But after much searching, I'm at a loss on how to resolve the problem.

Asked by jerome24 3 months ago

Last reply by cor-el 3 months ago

Youtube streaming video freezes, but audio still going ok

Hi, I watch specific streaming live show on YouTube every week. Unfortunately, I always have to play it in non-Firefox browser, because the video freezes every couple min… (read more)

Hi, I watch specific streaming live show on YouTube every week. Unfortunately, I always have to play it in non-Firefox browser, because the video freezes every couple minutes, while audio track is still playing in the background. Based on the comments from the stream chat, other people have this issue too. Why? How to fix it? It is annoying. Internet connection is ok. Other browsers no issue. OS Linux Mint 20 Ulyana 64-bit Kernel Linux 5.4.0-172-generic x86_64 MATE 1.24.0 Mozilla Firefox 123.0 (64-bit)

Asked by ondrej123 4 months ago

Last reply by zeroknight 4 months ago

Firefox loading local files extremely slowly

Out of nowhere a couple days ago Firefox started loading local html files extremely slowly. I was using Live Server to render the pages, so I turned that on and off, unin… (read more)

Out of nowhere a couple days ago Firefox started loading local html files extremely slowly. I was using Live Server to render the pages, so I turned that on and off, uninstalled and reinstalled to no avail. I tried dragging files in from the original folder on my computer, but even that doesn't work. I tried updating firefox, and then my computer (which is running Fedora Linux 40), but still nothing.

When I try hitting inspect on the page, it only loads the HTML but doesn't let me inspect the JS as it wont load, and it's saying I have a ton of errors too. I can't look at the errors because they wont load, but I know it doesn't have to do with the original file as there was only one error which the page was working fine with before and each time I try opening the file it gives me a different amount of errors.

I tried clearing my cache and cookies, which didn't work either.

Does anyone know how to fix this? I'm having no other errors on other pages.

Asked by FFiii 3 weeks ago

Last reply by cor-el 3 weeks ago

Hold-Key-To_Repeat function (and other keyboard oddities) in Gmail and Discover.com

When composing emails in Gmail holding down a (any) key does not activate key repeating. Also, the there are irregularities when using discover.com in Ver. 124. When edi… (read more)

When composing emails in Gmail holding down a (any) key does not activate key repeating.

Also, the there are irregularities when using discover.com in Ver. 124. When editing my customer profile, keystrokes are not recognized. Nothing happens when typing. I also had difficulty signing-in; this may be coincidental.

Things tried: (1) A different keyboard. Same results. (2) Firefox version 122. The key repeat function worked in Gmail. I could edit my profile at discover.com. (3) Uninstalled and reinstalled ver. 124. All problems persisted. (4) Ran Ver. 124 in troubleshooting mode. All problems persisted. (5) Launched newly downloaded versions of both 122 and 124 (from command line) and ran them simultaneously. The problems persisted in 124 (troubleshooting mode), but 122 worked well. I used two different keyboards with no difference noticed. (6) Downloaded and ran Chromium. All worked well.

Asked by H P Ladds 3 months ago

Last reply by Terrance_h 3 months ago

PDF are often rendered unreadable, with desktop background showing through (screenshot attached)

I often run into issues with PDFs in Firefox Linux. They either appear totally blank (typically after suspend/restore), or they appear with the desktop background showing… (read more)

I often run into issues with PDFs in Firefox Linux. They either appear totally blank (typically after suspend/restore), or they appear with the desktop background showing through (as in the attached screenshot).

Hard refreshing the page doesn't change anything, opening a new tab and opening the PDF again doesn't change anything, opening a new window and loading the PDF doesn't change anything.

The screenshot is with this PDF: https://www.sgsw.ch/home/strom/_jcr_content/Par/sgsw_accordion_list_1838160259/AccordionListPar/sgsw_accordion_12353/AccordionPar/sgsw_downloadlist/DownloadListPar/sgsw_download_1049323524.ocFile/2023-08-31%20Mitteilung%20Elcom%20Erh%C3%B6hung%20Elektrizit%C3%A4tspreise%20f%C3%BCr%20das%20Jahr%202024.pdf

It renders correctly in Chromium.

Firefox 126.0 using the recommended performance settings on Mint 21.3, nvidia quadro p620 using the official nvidia drivers v535.171.04-0ubuntu0.22.04.1

Asked by c+ff 1 month ago

Last reply by jonzn4SUSE 1 month ago

Probleme with 'places.sqlite' -> 'moz_places' Can't retrieve the "real" $LAST_VISITED_URL ?

the last url in moz_places in places.sqlite are not the same as in my history tab I posted here Here is my `last-url.sh` #!/bin/bash rm -rf /tmp/db.sqlite … (read more)

the last url in moz_places in places.sqlite are not the same as in my history tab I posted here

Here is my `last-url.sh`

   #!/bin/bash
   
   rm  -rf /tmp/db.sqlite 
   cp ~/.mozilla/firefox/*.default-esr/places.sqlite /tmp/db.sqlite ;
   LAST_URL=`sqlite3 /tmp/db.sqlite "select url from moz_places order by last_visit_date desc limit 1;"`;
   echo $LAST_URL


My script keeps giving me wrong answer. For exemple, a stackoverflow.com url instead of the youtube.com one even if i reload the page.

I have only one `xxxxxx.default-esr` profile.

Screenshot examples: the "google test" is a brand new visited url, and the others were refreshed pages

Asked by dehya 4 months ago

Last reply by jscher2000 - Support Volunteer 4 months ago