Showing questions tagged: Show all questions

Firefox draining battery life 41% usage

I am having a significant issue with firefox draining my battery. I used chrome up until the new year and then switched over to firefox from chrome. Overall I love firefo… (read more)

I am having a significant issue with firefox draining my battery. I used chrome up until the new year and then switched over to firefox from chrome. Overall I love firefox so much more. The format is way more pleasing. I love how it easily signs me back into everything, BUT IT DRAINS MY COMPUTER SO MUCH. Like i used to have an 8hour + battery span my laptop neverrr died. Now I get through MAX 2 hours of full use before needing to charge, and maybe 4 hours just having it at school but not using it.

I thought my dell suddenly started crashing, ran all these tests, and then I realized the only change was that I had started using Firefox... So sad I think I am going to have to leave it.

I read a lot of articles and did everything suggested. my graphics is webreader , i turned on all the suggested features, i have 2 extensions , the only thing I could maybe think of was that I use an animated theme so maybe that was killing the battery, but like if I can't use my theme than whats the point.

Asked by nebs9921 3 months ago

Last reply by zeroknight 2 months ago

Facebook only halfway works on Firefox

I recently purchased a new Mac Book Pro. After migrating my data from my old one I noticed that when using Firefox my Facebook account was not working properly. I no lo… (read more)

I recently purchased a new Mac Book Pro. After migrating my data from my old one I noticed that when using Firefox my Facebook account was not working properly. I no longer could access my own page or the pages of friends. However, I could access some group accounts I'm associated with. On Safari, everything works fine. I suspect something must have been compromised during the data migration.

I deleted the Firefox app from my new computer and then reinstalled it but to no avail. When I'm in Facebook and try to access my page I get an error message. My OS system to up to date and apparently my Firefox is up to date as well. Any suggestions? Thanks!

Asked by jjenkins9 2 days ago

Last reply by zeroknight 2 days ago

Repeated messages that I use an old version despite having downloaded the most recent version

Hi! I get repeated messages that I use an old version despite having downloaded the most recent version. When i try to start Firefox it won't start, I only get a message… (read more)

Hi!

I get repeated messages that I use an old version despite having downloaded the most recent version. When i try to start Firefox it won't start, I only get a message and the precise wording of the message is" You've launched an older version of Firefox Using an older version of Firefox can corrupt bookmarks and browsing history already saved to an existing Firefox profile. To protect your information, create a new profile for this installation of Firefox." Then I get two choices, either "Exit" or "Create New Profile". If I choose the first, I exit. If I choose the latter and create a new profile then I loose my bookmarks and browsing history. Appreciate any solution you might have

Asked by Jan Nilsson 3 months ago

Last reply by cor-el 3 months ago

Video Content (Twitter/X, Youtube, Previews) Stop Working

So I just picked up a new laptop (ASUS Vivobook 16x), and everything is fresh on it. Additionally, this only affects some video content in Firefox, with Edge browser unaf… (read more)

So I just picked up a new laptop (ASUS Vivobook 16x), and everything is fresh on it. Additionally, this only affects some video content in Firefox, with Edge browser unaffected. In brief, what is happening is that within a couple hours of having the browser open, certain video content stops working, specifically Twitter/X videos just spin, YouTube previews stop working, and videos continually load. Netflix videos continue to work, but hover previews stop functioning. I even check the 'Stats for Nerds' on YT and it shows 0 KB network activity in Firefox.

I've tried every basic action I can think of:

  • Turning off extensions (only use Ublock and Bitwarden)
  • Browser Refresh (x3)
  • Reverting from 120.1 to 120.0, and now 199.0.1
  • Clearing the browser cache
  • Reinstalling NVidia and Intel Drivers
  • Running in Safe Mode

Only by doing a refresh or completely closing/opening the app gets videos to function again. This doesn't affect the old laptop or my desktop, which makes me think it's a rogue driver--but then why would Edge function without error over the same period of time?

Are there any settings to play with in the browser that can help diagnose?

Asked by madekatsu 4 months ago

Last reply by Alexander Thomas 3 months ago

Firefox 120.0.1 Memory Leaks, Windows 11 & 10, not a new issue

Firefox uses too much memory, sometimes 20GB on a 32GB Windows machine. It's usually one or two threads which are hogging incredible amounts of memory. This time I had … (read more)

Firefox uses too much memory, sometimes 20GB on a 32GB Windows machine. It's usually one or two threads which are hogging incredible amounts of memory. This time I had about 30 tabs open.

Today I tried Firefox about:memory "Minimize Memory Usage" several times, and it was largely ineffective.

I did a "create memory dump file" of one 5+GB bloated thread using task manager, but can't find a way to upload the compressed archive with this report for analysis. Finding a way to report this issue was quite a challenge. It seems most help avenues are now missing/moved, and other reports of this type of issue are "Archived".

I tried killing the 2 bloated Firefox threads and checked for tabs which might be missing or malfunctioning. Everything continued to run normally while more than 10GB of memory was returned to system use. Leaving these bloated threads overnight doesn't improve anything, in fact I can often get up and find my machine is completely out of memory because Firefox consumed it all. My smallest machines have 16GB RAM.

These memory issues aren't new. I've been reporting them off and on for more than a decade. They get better for a few months after reporting, then they get bad again in a few more months. The battle to get memory leaks fixed is continuous while Firefox springs more leaks.

I'd like to give you the memory image I generated so you'll at least have some real data to look at and analyze for this report.

The attached task manager snapshot image is a very minor example of this issue. The numbers keep increasing like there are one or more large memory leaks.

Asked by Craiga 4 months ago

Last reply by cor-el 4 months ago

Why can't Firefox copy text anymore?

Why can't Firefox copy text to the clipboard anymore? It won't copy text from a web page, from a URL, or even from about:support "Copy text to clipboard"!!! I'm using ver… (read more)

Why can't Firefox copy text to the clipboard anymore? It won't copy text from a web page, from a URL, or even from about:support "Copy text to clipboard"!!! I'm using version 1.22 64 bit on windows 11. I've reinstalled Firefox but it doesn't make a difference. I've tried "Troubleshoot Mode" and it's still broken!!!

I can paste into Firefox but something has broken copy!

Asked by FirefoxUser73 2 months ago

Last reply by zeroknight 6 days ago

Firefox 119.0 Print Preview missing orientation option!

The "Layout.css.page-size.enabled" configuration parameter = False ,worked effectively in previous versions, but after updating to Firefox 119.0, it no longer works wheth… (read more)

The "Layout.css.page-size.enabled" configuration parameter = False ,worked effectively in previous versions, but after updating to Firefox 119.0, it no longer works whether I set it to True or False.

Orientation option is missing when I try to print documents from a website. The Firefox Print Preview window, which usually allows orientation choices for printing, is now not available.

Please advise. Thanks!

Asked by Maria T. 5 months ago

Last reply by jscher2000 - Support Volunteer 5 months ago

Weird text in firefox fixes itself when firefox is turned off

Firefox displays weird characters in text when some pages are loaded. This appears to happen with Helvetica font and maybe some others. The problem seems to go away when … (read more)

Firefox displays weird characters in text when some pages are loaded. This appears to happen with Helvetica font and maybe some others. The problem seems to go away when firefox is launched in safe mode, and does not occur in other browsers. After a little digging I found when I turn hardware acceleration off the problem seems to fix itself. I'd rather not operate firefox with this option off, and I have a relatively new mac so this shouldn't be an issue. Is there a better way to solve this problem? Attached are pictures of the issue when hardware acceleration is on. As you can see, there are weird characters that display on the right.

Asked by Braden Bouwman 5 months ago

Last reply by cor-el 5 months ago

firefox crash

Hi, I've installed you browser on different devices (Mac and Windows PC). After last upgrade I've a lot of problem. Firefox doesn't work anymore. It crash at the start st… (read more)

Hi, I've installed you browser on different devices (Mac and Windows PC). After last upgrade I've a lot of problem. Firefox doesn't work anymore. It crash at the start stopping itself without charging any internet pages. I think the problem was in your last upgrade file, because I ve the same issue both with windows and Mac platform...please help me.

Thank a lot.

Asked by christian abate 5 months ago

Last reply by cor-el 5 months ago

Youtube is not working in a new tab.

YouTube is not working in a new tab when I open a link on a new tab from you tube. The Shorts are working fine. only in Firefox.. other browsers are good... shorts are w… (read more)

YouTube is not working in a new tab when I open a link on a new tab from you tube. The Shorts are working fine.

only in Firefox.. other browsers are good... shorts are working fine on new tab but normal videos freeze when open in new tab. besides if i press reload on a running video it also react same. it freeze. please help.

Asked by Angry Tiger 5 months ago

Last reply by cor-el 5 months ago

pop up virus warnings

I went to a local website and ended up getting virus warnings, see photo. I doubt if it's real but I don't know how to get rid of the messages, or scan for the virus? I … (read more)

I went to a local website and ended up getting virus warnings, see photo. I doubt if it's real but I don't know how to get rid of the messages, or scan for the virus? I scanned with the Windows virus protection and the computer came back clean. I can and have turned the computer off and back on, no help.

Thanks

Asked by gsteve498 5 months ago

Last reply by zeroknight 5 months ago

Find Bar

Whenever I open the find bar while deleting the phrases and words, it shows the one word highlighted or its phrase highlighted on the find bar whenever I reopen after del… (read more)

Whenever I open the find bar while deleting the phrases and words, it shows the one word highlighted or its phrase highlighted on the find bar whenever I reopen after deleting the phrases and words. I need help for this ?

Asked by rizvi.zainab492 5 months ago

Last reply by cor-el 1 month ago

Google apps dots not showing up on FF home page.

Can't get to Google apps from google home page. Dots for Google apps not there. Only way they appear is to search for something. Otherwise you can't get to apps (no nine … (read more)

Can't get to Google apps from google home page. Dots for Google apps not there. Only way they appear is to search for something. Otherwise you can't get to apps (no nine dots) or even sign in to google. Nosigh-in box either on first open of browser. Thanks for the help.

Asked by mnorman 5 months ago

Last reply by cor-el 5 months ago

Certain parts of the Firefox UI are displaying a weird font rather than standard latin one

Like the title says, certain part of UI, including text fields, are displaying the font shown in the screenshot I added. I tried disabling add-ons and updating the app, b… (read more)

Like the title says, certain part of UI, including text fields, are displaying the font shown in the screenshot I added. I tried disabling add-ons and updating the app, but neither worked.

Asked by Rhea& Padilla 5 months ago

Last reply by zeroknight 5 months ago

Audio on certain sites plays for a split second then mutes, or doesnt play at all.

while using the site https://animesuge.to/home and using any server other than filemoon, the audio will either play for split second and then mute, or it wont play at all… (read more)

while using the site https://animesuge.to/home and using any server other than filemoon, the audio will either play for split second and then mute, or it wont play at all. The video itself plays fine. i tried it using other browsers and it works fine, it only happens while using firefox. i tried turning off all extensions and running in troubleshoot mode but neither of these helped.

Asked by Aagris 5 months ago

Last reply by zeroknight 5 months ago

Browser extensions not working

Hi, I'm using some typical browser extensions (lastpass, HTTPS Everywhere, Privacy Badger, etc.), but all of buttons stopped operating. When I click them, nothing happens… (read more)

Hi, I'm using some typical browser extensions (lastpass, HTTPS Everywhere, Privacy Badger, etc.), but all of buttons stopped operating. When I click them, nothing happens, clicking just makes the icon be shaded like it's pressed. I tried updating the browser, signing out&in, removing, loading and enabling them again. Nothing works. Most frustrating is the lastpass extension, as I actually use it almost daily.

Also I assume that one can't contact mozilla directly about these bugs/issues, only this community chat?

Asked by pihlapa 5 months ago

Last reply by zeroknight 5 months ago