Twitter/x display setting does not save in Firefox, but does using other browsers

So within the past couple of days my twitter/x display setting suddenly switched to "Lights out" from "Default". I can reset it in t/x settings but if I close my browser … (read more)

So within the past couple of days my twitter/x display setting suddenly switched to "Lights out" from "Default". I can reset it in t/x settings but if I close my browser it resets back to "Lights out" on reopen.

However, this same change happened with other browsers chrome and brave, but if I reset it on t/x it remains changed for those browsers if I close them and reopen.

When I say close I do not mean just that window/tab. I mean close the browser completely and restart it.

What do I need to do to get FF to retain this t/x setting?

Using FF 126.0 64bit on Win11

Asked by elboaltins 8 minutes ago

Images Broken on Firefox but Fine on Other Browsers

I'm experiencing an issue, when I visit this website in Firefox, some images appear broken, but they display perfectly in other browsers. Has anyone else encountered this… (read more)

I'm experiencing an issue, when I visit this website in Firefox, some images appear broken, but they display perfectly in other browsers. Has anyone else encountered this problem or have any suggestions on how to fix it?

Asked by Atif 41 minutes ago

Firefox always minimizes to the monitor the taskbar is on

I have two monitors; I keep my taskbar on the right monitor and run Firefox on the left monitor. For some reason, whenever Firefox gets minimized, the window moves to whi… (read more)

I have two monitors; I keep my taskbar on the right monitor and run Firefox on the left monitor. For some reason, whenever Firefox gets minimized, the window moves to whichever monitor the taskbar is on (I've done some testing to confirm it is specifically the monitor the task bar is on). Because I also run a program called max.to to separate my right monitor into different sections, this action of minimizing to, and restoring to, the wrong monitor is also resizing my Firefox window.

Is there any way, any option I've overlooked, that would get Firefox to minimize and restore to whichever monitor is is actually running on?

I've attached an image that shows, as best I can get it, the window moving over to the task bar monitor when minimizing.

Asked by nicholas.mousseau.seb 42 minutes ago

Having trouble seeing webpages in Mozilla Firefox

Hello, Mozilla Community Hope you doing well, I'm contacting you to ask for help with a Mozilla Firefox problem I'm having with trying to visit the following website: Geo… (read more)

Hello, Mozilla Community Hope you doing well, I'm contacting you to ask for help with a Mozilla Firefox problem I'm having with trying to visit the following website: Geometry Spot Games: https://geometryspot.com/ It won't load, and I'm not sure if that's because of a bug in the website, a browser issue, or something else entirely.

Does anyone else have knowledge of this problem or recommendations for a fix? I've attempted removing addons and cleaning the cache in my browser, but the issue still exists.

I would be grateful for any advice or ideas on improving the usability of the website. Thank you in advance for your assistance.

Asked by Getlex Savet 1 hour ago

Screen Popups are opening on

I have Firefox running on Screen #3. The website that I use with my radiology clients opens popups and I want these to open on Screen #3 as well. However, they are openin… (read more)

I have Firefox running on Screen #3. The website that I use with my radiology clients opens popups and I want these to open on Screen #3 as well. However, they are opening on Screening #1. How can I get them to open on Screen #3?

Thank you.

Asked by sunquestdanes 1 hour ago

Enabling video calls on firefox for iOS.

I am now not able to make video calls on my firefox for Mac browser. (It now says "Video calls not supported on this browser). I used this not that long ago, and it worke… (read more)

I am now not able to make video calls on my firefox for Mac browser. (It now says "Video calls not supported on this browser). I used this not that long ago, and it worked. Now it does not for any of my contacts. What can I do to resolve this?




/edit: moved thread from Firefox for iOS (iPhone/iPad) to (desktop) Firefox section as you said you have a Mac (using macOS).

Asked by Smilined52 6 hours ago

lag and glitch

hello team Firefox i am Aquib. i am very older user. my Firefox web browser in mac is very Awesome user experience. no lags no glitch no bugs. higher performance than oth… (read more)

hello team Firefox i am Aquib. i am very older user. my Firefox web browser in mac is very Awesome user experience. no lags no glitch no bugs. higher performance than other browsers. but after Firefox ver-120.0.1 Firefox getting lag and glitch in latest version Firefox please try to check in Youtube and switch mini screen to full screen getting lag please solve this problem. my problem is explain in given Screenshot. please fix it.

Asked by mdaquib847 3 hours ago

Can't play video or video plays with no sound on certain webpages only

Hello, about 1-2 weeks ago a very strange problem occurred - on some pages videos don't play at all or play without a sound. Can anyone help me with this strange situatio… (read more)

Hello, about 1-2 weeks ago a very strange problem occurred - on some pages videos don't play at all or play without a sound. Can anyone help me with this strange situation? For example, every video on youtube.com plays without a problem; on facebook.com every video plays with no sound at all; on some other pages video doesn't play at all. This problem is only with firefox, if I try to open the same videos with another browser everything is fine.

Asked by bobbyfm 22 hours ago

Last reply by bobbyfm 5 hours ago

Firefox allows access to some websites only once after booting computer. Second attempt to enter evokes error message

After I boot my computer, I can access any of the sites I usually use, but only once. If I then close the site and attempt to open it again (or to open any of the other … (read more)

After I boot my computer, I can access any of the sites I usually use, but only once. If I then close the site and attempt to open it again (or to open any of the other affected sites), I get the following message: " Secure Connection Failed

An error occurred during a connection to phoenixcommons.cohousing.site. PR_END_OF_FILE_ERROR

Error code: PR_END_OF_FILE_ERROR

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem."

The site shown in the error message above is the one I most ofen use, but other very common sites (e.g. Google.com) exhibit the same problem:

" Secure Connection Failed

An error occurred during a connection to www.google.com. PR_END_OF_FILE_ERROR

Error code: PR_END_OF_FILE_ERROR

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem."

Yeah, right. I'm supposed to contact Alphabet and inform of the problem?

In contrast, some sites (e.g. The New York Times, The Washington Post) are not affected.

I can paste affected URLs into another browser (I used Brave) and access them with no problems.

Asked by JoAnna Allen 6 hours ago

HTTP to HTTPS redirect causing issues with webpages is not loading and other certificate shenanigans.

I have to configure a lot of networking equipment! One day I might be working on a brand new piece of equipment and the next day trying to log into some ancient piece of … (read more)

I have to configure a lot of networking equipment! One day I might be working on a brand new piece of equipment and the next day trying to log into some ancient piece of equipment because I need to change something and I can't replace it yet. I'm having a major issue with the redirect even if I explicitly type HTTP it forces it to HTTPS ( and no I don't have HTTPS everywhere installed I've actually never used it ). I've noticed recently a few updates back now that if the connection cannot succeed it redirects to HTTP but it can hang up in a weird limbo where it thinks the site doesn't exist. There needs to be a toggle for local addresses explicitly typed "HTTP" to try that first. There also needs a toggle to ignore the security issues when accessing the device with a self assigned certificate as every single networking device has a self assigned a certificate and every time I need to change the setting on a router I have to agree even though I have a greed for the last 10 times when I've access the device or I just reset the device and the self signed certificate changed. And I don't know how you're gonna handle this on mobile but it almost makes using a mobile browser useless because I might as well just get the computer out even if all I have to do is change a password, SSID or just check a setting.

So local addresses need an option to lower the warning level for self signed certificates and to obey the typed protocol!

And there's some sort of bug with the Logic that detects a certificate or non-secure site that breaks when the connection drops. The only way I've been able to get around this is to go to the address bar and hit enter as a reload will not work and a reload skipping cash will not work to bring the site back up.

I've had devices that I thought weren't working only to find out they were working fine after 3 or 4 attempts and restarts only to find it's just that firefox thought the site didn't exist anymore.

And I don't have any other options because chrome is even worse with HTTPS once it gets it's vampire fangs in you're stuck it will not let you go back. And safari you might as will be undead.

Finally getting annoyed enough to write some thing as every time you go change your setting reboot device check setting log back in change saying restart log back in and you have to hit except certificate every single time.

And while I'm here Bring back the checkbox to save/ not save the certificate as I might not want to save the certificate when I know I'm going to reset the device and it's going to be totally different in the next 10 minutes. Or I might not want to save it at all like I go to a website that's misconfigured and the certificates not valid for the domain name that it's using.

Asked by iMark77 7 hours ago

Firefox automatically plays videos; I don't WANT that

BROKEN: Videos automatically play upon landing on a website. I don't want video autoplay. I had that FIXED at one point, but with the new update, all of my settings were… (read more)

BROKEN: Videos automatically play upon landing on a website. I don't want video autoplay. I had that FIXED at one point, but with the new update, all of my settings were discarded, and now I'm back to square one. I do not want video autoplay! Now, on to the next question: many complaints have been lodged on various 'help' pages and forums describing the same problem; my question is, in light of all of these complaints, why hasn't Firefox FIXED this problem and issued an update with the repair patches?! On my version of FF, Mac 126, all video controls in settings have disappeared. WHY? Where did they go? Not that they worked anyway because we had to muck about in about:config with various patches WHICH NO LONGER WORK ON MY MAC! Why is there not a simple ON/OFF switch, in Settings, for those of us who want the choice?! When are FF boffins going to FIX this to our satisfaction, with a WORKING, simple-selectable solution? I await a reply from a knowledgeable Firefox technician, one who preferably works on this part of the browser, please. Help me understand, or make me happy, preferably both.

Asked by trennor 9 hours ago

Hmm. We’re having trouble finding that site. Error messages when opening websites

Every third or fourth website I open, I get the "Hmm. We’re having trouble finding that site." error. if I wait a few seconds and hit try again, it works. Very frustratin… (read more)

Every third or fourth website I open, I get the "Hmm. We’re having trouble finding that site." error. if I wait a few seconds and hit try again, it works. Very frustrating and slows me down every day. Here is what I tried so far:

-Booted firefox in safe mode to make sure it is not any of my extensions. (This did not solve the issue) -Cleared cache time range "everything" (This did not solve the issue) -Made sure my version of firefox is up to date -Updated windows and restarted my computer

Some clues that may help you help me: -This issue only appears on my home PC but not my work PC or laptop -The websites I am opening work fine on other browsers.

Please help! I am getting tired of this

Asked by parthpatel0096 13 hours ago

[Firefox for Developers] Fonts don't show up properly on certain sites.

Hello! I recently decided to switch to Firefox Developer for personal choices and upon looking at certain sites that use custom fonts, a few of them break and show the d… (read more)

Hello!

I recently decided to switch to Firefox Developer for personal choices and upon looking at certain sites that use custom fonts, a few of them break and show the default font (Times New Roman) in their places instead. I've tried many solutions to fix this such as adjusting the settings, downloading TrueType fonts, and even messing with the settings in about:config and still the text would not show up properly. For some strange reason, though, the font's themselves seem to be working on the regular version of Firefox but not the developers' edition. I will post examples of my problem below if that helps.

Thank you!

(1st two images: Taken from the regular version of Firefox) (2nd set of images: Ditto, but taken from Firefox for Developers (3rd image: Settings from my extension that allows custom fonts and CSS changes)

Asked by pony 13 hours ago

Copy/Paste not working- ASKED MANY TIMES AND ISSUE STILL PRESENT

Copy/Paste not working- ASKED MANY TIMES AND ISSUE STILL PRESENT get the same old useless answer, refresh. THAT DOES NOT WORK this platform is really past its use by da… (read more)

Copy/Paste not working- ASKED MANY TIMES AND ISSUE STILL PRESENT

get the same old useless answer, refresh. THAT DOES NOT WORK

this platform is really past its use by date, TOLD BY BANK TO AVOID AND GOV. SITES!!!

when it comes to buying a new pc I will switch out to another browser, shame a good 12 years with FF.

Asked by changeittillitbreaks 13 hours ago

I have this week problems with login into my bank (www.dnb.no) via Firefox. But I have no problems logging in with Edge og Google. I prefer using Firefox it frustrates me being unable to log in via Firefox. I get the message: BID-5000.

I hve discussede the matter with my banks IT-department, but they answer me that recently they have heard about the same problem concerning Firefox login and said that … (read more)

I hve discussede the matter with my banks IT-department, but they answer me that recently they have heard about the same problem concerning Firefox login and said that the problem have to be fixed by Mozilla/Firefox

Asked by olavaga 23 hours ago

Last reply by olavaga 15 hours ago