20 GB RAM usage, pagefile takes up all space on C: - 300 tabs in Tree Tabs

First, this post is basically Congratulations for Firefox upon working almost flowlessly under this extreme heavy load without crashing. Saving/loading sessions works wel… (read more)

First, this post is basically Congratulations for Firefox upon working almost flowlessly under this extreme heavy load without crashing. Saving/loading sessions works well. (which is unexpected but makes me _very_ happy :-)) Firefox exits properly without any exceptions, no matter how long it runs, or how many times the PC is sent to STR mode meanwhile.

Second, everything is fine, except RAM usage. No matter how many RAM is installed, Firefox takes up all of it after a few days of normal operation. I have recently upgraded my PC from 16 to 24 GB of RAM only for this sole reason to see if anything changes, but it did not produce any noticable change, except that it takes 5-7 days for Firefox to fill up all the RAM instead of the 3-4 days before. Disk space on C: drive was nullified by Firefox as the paging file went up to 50 GB.

I want to hunt down this thing. I have approx. 300 tabs, 2 addons, and Hardware Acceleration is disabled since otherwise Fox hangs several times a day (have to be killed from outside). Pics are attached. https://addons.mozilla.org/hu/firefox/addon/tree-tabs/ https://gitlab.com/kroppy/TreeTabs

I'd like to get suggestions where to start.

  1. Disabling or replacing the adblocker ?
  2. Inspecting memory usage on Process Manager (about:processes) and Task Manager (about:performance) pages ?
  3. Installing some external tools like Firemin ?

Please don't suggest neither safe mode nor disabling all addons, since that makes it impossible to reproduce this amount of load, which is the primary reason behind the symptom.

I PrtScr'ed Process Manager and Task Manager, see that RAM sizes per page are normal in Task Manager, but not in Process Manager (10 times more).

CPU usage is totally normal for this load, even when memory is in the heaven. See the TaskMan pic. (I suppose that's because of ad blocking)

Thanks for any ideas,

Peter B. (I'm PC enthusiast)

-- Windows 7 Ultimate SP1 64 bit Firefox 106.0.5 (latest autoupdated) no firewall nor any antivirus - since 20 years with no infection ... AMD FX-6350 Six-core ASUS M5A99FX PRO R2.0 24 GB DDR3 1600 MHz Sapphire Radeon HD 5750 1GB (AMD Catalyst 15.11.1, Nov 18, 2015)

Asked by Peter B. 4 weeks ago

Last reply by Peter B. 3 days ago

Reinstalling Firefox

I am currently having problems with my Firefox browser. For example often if I type something into the google search box at the right of the address bar and hit return no… (read more)

I am currently having problems with my Firefox browser. For example often if I type something into the google search box at the right of the address bar and hit return nothing happens until I go down and select Bing instead of the google setting. Also in hotmail (I am on a desktop) if I go to reply, the original is now ether twice. This does not happen if I use Google browser. But I prefer Firefox as I have used it for years.

My concern is if I delete Firefox and reinstall it, I may lose some of the settings or bookmarks that I have set over the years.

Any suggestions? Please simple as i am old and not computer savvy.

Your help would be so appreciated. I am currently on Firefox 107.0 (64 bit)

Thanks, Anthony

Asked by avwood 1 week ago

Last reply by avwood 4 days ago

Explore possibilities of using System Theme 1.0 in Firefox 91.9.1esr and later.

After moving to Firefox 91.9.1esr I found problem with System theme 1.2. The color of tab add button was changed, and the button is not visible with my Windows 7 classic … (read more)

After moving to Firefox 91.9.1esr I found problem with System theme 1.2. The color of tab add button was changed, and the button is not visible with my Windows 7 classic windows system theme. So, I'm trying to find a way to port System theme 1.0 color scheme to newer firefox versions.

Creation of a simple theme with firefox color extension works. But it is unable to recreate the effects related to active and inactive window color changes. As, I had to use bitmap to get the OS blue color transition pattern.

It seems the system theme is stored in omni.ja file. Modification of the omni.ja seems to be not a practical solution. So, it would be a better way to create an addon theme with the same code as the System Theme 1.0.

The first question is, if it will be possible to create a theme with the same code as a system theme has. Will it be able to perform the same way?

The next question is: Where the source code of the system theme is? I was unable to find it in the Firefox source. It seems, it is not stored in any obvious location.

Asked by sforforsoft 1 week ago

Last reply by sforforsoft 3 days ago

XUL Runner Pop Up Information Message

After the second to the last update to Firefox I started experiencing an information pop up message "Could not determine any profile running in backgroundtask mode!". Is… (read more)

After the second to the last update to Firefox I started experiencing an information pop up message "Could not determine any profile running in backgroundtask mode!".

Is there a fix for this?

Thank you.

Asked by vwilyard 2 months ago

Last reply by vwilyard 5 days ago

Arabic font not looking good on facebook after reinstalling snap version of firefox on ubuntu 22.044

Hi The Arabic font broken on Facebook after reinstalling snap version of Firefox 107 on Ubuntu 22.04 given that the font on YouTube search look fine (but not on Facebook)… (read more)

Hi

The Arabic font broken on Facebook after reinstalling snap version of Firefox 107 on Ubuntu 22.04 given that the font on YouTube search look fine (but not on Facebook). I tried to reinstall Firefox in multiple ways like using the deb version reinstalling the snap one removing the .cache folder and logging out of the session and even rebooting my PC.

Why is my firefox is broken?

what is the solution ? it would be really appreciated

Asked by capacity213 2 weeks ago

Last reply by capacity213 1 week ago

All my PCs have lost settings/ history/ shortcuts on Firefox today.

Hi, we have 4 PCs (3 running Win 10 and one Win 7) which updated themselves today and lost everything. Settings, add-ons, bookmarks, shortcuts all gone; looks like a new … (read more)

Hi, we have 4 PCs (3 running Win 10 and one Win 7) which updated themselves today and lost everything. Settings, add-ons, bookmarks, shortcuts all gone; looks like a new install. I checked the other threads and the profiles; there is only one profile and no backup. How to get my stuff back?

Asked by uspec 1 week ago

Last reply by uspec 4 days ago

Garbled font in Firefox on macOS Monterey (12.6.1)

Hello :) I'm using Firefox 107.0 on macOS 12.6.1 and I'm having weird issues with the displayed font. It appears on the startup screen of Firefox and on websites (see scr… (read more)

Hello :)

I'm using Firefox 107.0 on macOS 12.6.1 and I'm having weird issues with the displayed font. It appears on the startup screen of Firefox and on websites (see screenshots attached).

The garbled font is called ".SF NS".

I've tried turning the option "Allow pages to choose their own fonts, instead of your selections above" on and off without success.

I have also tried enabling and disabling hardware acceleration - also without luck.

The issue does **not** appear in safe mode. Unfortunately resetting the theme and disabling all extensions hasn't helped either :(

I have also downloaded and installed a font called "SFNS Display" but the issue persists.

Uninstalling Firefox (with AppCleaner) and reinstalling hasn't fixed the problem.

I don't know what else to try. Can someone help me please? :)

Asked by Gutenberg 1 week ago

Last reply by Gutenberg 1 week ago

Firefox will not open amazon.com

I can't open amazon.com. I've disabled my antivirus and have tried in 'troubleshoot' mode. I have cleared my cache. I have flushed my DNS. It's been going on for days… (read more)

I can't open amazon.com. I've disabled my antivirus and have tried in 'troubleshoot' mode. I have cleared my cache. I have flushed my DNS. It's been going on for days. I keep timing out. Other sites do not exhibit problems. Chrome DOES open amazon.com quickly.

Asked by jjjerdee 1 week ago

Last reply by jjjerdee 1 day ago

Firefox freeze when loading youtube main website

Been using Firefox for over 6 years as main browser. Yesterday 30th of november 2022 i went in and opened my account page on Youtube. When loading all the preview videos … (read more)

Been using Firefox for over 6 years as main browser. Yesterday 30th of november 2022 i went in and opened my account page on Youtube. When loading all the preview videos on the main page FireFox froze for several seconds. Could do nothing. Never happened to me before.

i tried closing and open browser and go into youtube 15 times. Always the same result. Firefox freezing on load-in for 5-10 seconds.

I thought i had gotten a malware or something. So to be sure , i scanned with MalewareBytes and several times and did a virus scan. Came up with nothing.

I did some searching on google for firefox issue freezing. Found out that users have been having issues with firefox for a long time, several months, with firefox browser freezing. But no real solution to solve it.

I use Mozilla FireFox Version: 107.0.1

No other browser i tested, chrome, Edge, Brave have this issue when visiting youtube. ONLY Firefox!

Just to test something, i went into the network settings in Firefox settings. I changed the pre-selected setting from "use system proxy setting" to "NO proxy" and activated the setting "Activate DNS over HTTPS".

BOOOOOOM --- Problem solved!!!!!

What ever is wrong with Firefox 107.0.1 - i suggest FIX IT ASAP if you want me around as a user. Your browser is NOT OK as of now. I have never ever been forced to change any network setting for ANY browser during my 31 years using the webb. -Ok, almost true, maybe during the Robotics 28.800kb/s days back in 1993 ....

Jokes aside, -Fix your Shit!

Asked by alltiallomejl 6 days ago

Private window icons in Win 10 doesn't work as expected with Profiles

I have shortcuts to launch Firefox in two ways, one with no commands and one with the following command: -P "Personal" --no-remote This used to show two separate Firefox … (read more)

I have shortcuts to launch Firefox in two ways, one with no commands and one with the following command: -P "Personal" --no-remote This used to show two separate Firefox icons on the taskbar. Firefox windows opened in each profile would be grouped with the same profile and kept separate from other profiles. With the latest update I still have two icons, the Default profile has a Firefox icon and the 'Personal' profile has a private browsing icon. Even though there are no private windows open. According to latest updates, if I open private windows then they should be grouped with their own icon. However, whether I have Default or Personal profile windows open, Private windows are grouped with their standard browsing windows.

This is on Win 10, Firefox 107.0.1

Any ideas how to fix this? Ideally I would have the standard Firefox icon on both profiles then, to conform with the private window separation update, my private windows would be separated from the standard windows but also from different profiles.

Asked by scaleb 6 days ago

Virtual tour crashed when loading content

On last update virtualtours made in our websites have a big problem. Console write errors: Failed to allocate internal command buffer. WebGL context was lost. Uncaught … (read more)

On last update virtualtours made in our websites have a big problem. Console write errors:

Failed to allocate internal command buffer. WebGL context was lost. Uncaught Error: Bad WebGL context - maybe context was lost?

Please, open this page, look at it and fixed this.

https://sb360.online/cu0v2n

Asked by arkadiusz.stencel 6 days ago

Last reply by arkadiusz.stencel 6 days ago

When i click on a phone number link on a site i cant get my phone to call it

I used to be able to click on a phone number (Firefox desktop) on say a google search result for a business and have that number come up on my android S21 Phone for me to… (read more)

I used to be able to click on a phone number (Firefox desktop) on say a google search result for a business and have that number come up on my android S21 Phone for me to call.

now when i do that i prompts me to choose an application except there are non.

it used to allow me to call via Skype but that option is also gone.

i have also installed "Phone Link" but hasn't given me a option to use that either.

Asked by kca5781 6 days ago

Browser doesn't appear after first click on link

Hi! I'm using the browser on linux mint 21. It works fine as always but I have this minor and annoying problem with the click on links. Every time I click on a link from … (read more)

Hi!

I'm using the browser on linux mint 21. It works fine as always but I have this minor and annoying problem with the click on links.

Every time I click on a link from an external application firefox open a new tab/window with but doesn't show me the browser. To do that I have to click a second time on the hyperlink and at this point firefox will appear with 2 identical tabs opened.

To avoid that I have to click once and search myself the browser window.

Asked by trik.sedici 6 days ago

tool bar "email link" doesn't work.

The tool bar "email link" doesn't work. When I click on it, it takes me to the Chrome homepage. I want it to open up my gmail and my aol mail. How do I set that up. It wo… (read more)

The tool bar "email link" doesn't work. When I click on it, it takes me to the Chrome homepage. I want it to open up my gmail and my aol mail. How do I set that up.

It works great on my desktop, but not on my laptop.

Asked by AAB 1 week ago

Last reply by AAB 6 days ago

Changing primary email

Hi Team - I would like to change the primary email address on this Mac Mini to the one I use on other devices. When I add the secondary email address I get a message, "A… (read more)

Hi Team - I would like to change the primary email address on this Mac Mini to the one I use on other devices. When I add the secondary email address I get a message, "Account already exists" and the address is not accepted. I guess I could Delete Account and start again but that seems a bit drastic and I don't know what data might be lost. Any pointers please? Thanks, Ian.

Asked by Ian McPherson 6 days ago

Last reply by Ian McPherson 6 days ago

107 update stopped access to costco.ca

I had multiple tabs open that I was using, including the costco.ca page, when the update happened (I can't remember the exact details). All my other open tabs, and all pa… (read more)

I had multiple tabs open that I was using, including the costco.ca page, when the update happened (I can't remember the exact details). All my other open tabs, and all pages since, have worked fine since, but the costco page does not open. At first there were options to check and something about a ceritficate. Now the address shows costco.ca444/Genericerror it says 'Problem loading page' in the tab heading. And the page shows '

The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.'

There is no info on how to fix this - and I've spent way too much time trying to fix it. I added it to the exceptions page. No joy. Works fine in Chrome. Very frustrating.

I have Windows 11 on my PC. Is there a way to fix this? Might be an idea to add a link to how to fix it to the error message. Thanks.

Asked by ltimberg 6 days ago

"https://download.sp.f-secure.com/online-safety/fs_firefox_https.xpi"

The browser plug-in for Spectrum Security Suite (F-Secure) does not appear to download. I do not know where the problem is. It could be with Spectrum software. I did ca… (read more)

The browser plug-in for Spectrum Security Suite (F-Secure) does not appear to download.

I do not know where the problem is. It could be with Spectrum software. I did call them first. The lady on the phone says it is a Firefox problem and to seek help from Mozilla.

When I click on the box for setting up secure browsing (I have tried both boxes (top right and 2nd to bottom left) on the screen in the image attached), I just get a new window open with "https://download.sp.f-secure.com/online-safety/fs_firefox_https.xpi" in the navigation box and the rest is white space. There is no spinning wheel, no bell, nothing.

I do not even know what is supposed to happen, as it has been years since I last set up the protection. I do know based on messages received and the displayed log, the browser protection was still working as of 10 days ago (21 Nov 2022).

I actually do most of my browsing now on Linux but I still play a few games that are Windows only so sometimes browse from this system.

Windows 7 64-bit Ultimate (all patches) Firefox 107.0.1 (64-bit)

Asked by Natalie 6 days ago

Unexpected padding around HTML document on all pages

Running FF 107.0.1 on Mac 10.15.7 and there is unexpected padding around each website I visit. I've disabled all browser extensions. I'm using the default theme. I've tri… (read more)

Running FF 107.0.1 on Mac 10.15.7 and there is unexpected padding around each website I visit. I've disabled all browser extensions. I'm using the default theme. I've tried restarting Firefox. I've tried restarting the computer but the issues seems to persist. I do not see the same rendering behavior when loading these websites on Google Chrome. I'm including screenshots of what I'm seeing.

Asked by Mike Grace 6 days ago

Last reply by Mike Grace 6 days ago

lock ups

One of my favorite web sites is www.cam4.com. It is an adult live streaming web site. My computer freezes when I'm watching one of the "performers". I refresh the page … (read more)

One of my favorite web sites is www.cam4.com. It is an adult live streaming web site. My computer freezes when I'm watching one of the "performers". I refresh the page all is OK for min. or so.

When I use MS Edge I don't get the freezing. Firefox is my default browser for more years than I can count. What is going on? Is there a fix?

Asked by metz3 1 week ago

Last reply by metz3 6 days ago