Showing questions tagged: Show all questions
  • Solved
  • Archived

userChrome

There is no userChrome.css in my profile. If it needs to be created, where do I create it? Yes, I searched for help. What I found was about userChrome.css to solve spec… (read more)

There is no userChrome.css in my profile.

If it needs to be created, where do I create it?

Yes, I searched for help. What I found was about userChrome.css to solve specific problems, but not what to do if it doesn't exist. Is userChrome still supported?

Thank you! Mark.

Asked by Mark Filipak 1 year ago

Answered by Mark Filipak 1 year ago

  • Solved
  • Archived

Firefox breaks my desktop environment's scrollbar style and (gradient) color and in version 98+ refuses css to approximate it

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has t… (read more)

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has to be an exception by itself! Not only that, but it changes my ability to customize its interface, from time to time and even changes access to such ability, on some updates.

My scrollbar customizations in userChrome.css and userContent.css do not work any more (other CSS changes still work, for menu/addressbar/tabbar/bookmarksbar orderint and tab styling). I had to resort to settings in user.js file, to get a 20px width scrollbar, suitable for my big screen, but... it gets very wide when I increase the focus, on some webpages and becomes very ugly! Furthermore, I cannot make sense of the proper use of "ui.themedScrollbar*" settings and the scrollbar and its slider result in the same color. These are my settings in user.js:

user_pref("widget.content.gtk-theme-override", "backwater"); user_pref("widget.non-native-theme.enabled", false); // Use GTK-3.0 gtk.css: set to false user_pref("toolkit.legacyUserProfileCustomizations.stylesheets", true); // Use userChrome.css & userContent.css: set to true user_pref("widget.gtk.alt-theme.scrollbar_active", true); user_pref("widget.non-native-theme.scrollbar.size.override", 20); // If nothing else works, fix scrollbar width to 20px user_pref("widget.non-native-theme.gtk.scrollbar.round-thumb", false); user_pref("widget.non-native-theme.gtk.scrollbar.thumb-size", 1.0); // originally 0.75 user_pref("widget.non-native-theme.gtk.scrollbar.allow-buttons", true); // it was true, anyway... user_pref("layout.css.cached-scrollbar-styles.enabled", false); user_pref("layout.css.color-mix.enabled", true); user_pref("widget.non-native-theme.scrollbar.style", 4); // wide scrollbar theme: set to 4 user_pref("ui.themedScrollbar", "#bad1f5"); user_pref("ui.themedScrollbarInactive", "#668cc4"); user_pref("ui.themedScrollbarThumb", "#e4e4e4"); user_pref("ui.themedScrollbarThumbHover", "#e4e4e4"); user_pref("ui.themedScrollbarThumbActive", "#668cc4"); user_pref("ui.themedScrollbarThumbInactive", "#bad1f5"); user_pref("browser.dom.window.dump.enabled", false); user_pref("extensions.ui.sitepermission.hidden", false); user_pref("fission.experiment.max-origins.qualified", true);

Either with the "ui.themedScrollbar*" settings or without them (and cleared from the prefs.js file), the scrollbar and its slider result in the same color, unless I (tryingly) click on some place on the scrollbar outside its slider; then I can see the slider, _only_ for the duration of the mouse-down event (which causes up or down page-hight scrolling).

The default, very thin scrollbar, as well as my modified wide scrollbar with invisible slider are both useless to me! I have even tried fx-autoconfig (https://github.com/MrOtherGuy/fx-autoconfig) to make the scrollbar CSS work, but no result. At this point, I am considering switching to another browser, despite the trust I have to mozilla, for my data and privacy.

Asked by kavadias 1 year ago

Answered by kavadias 1 year ago

  • Solved
  • Archived

PiP mode resize difference on Windows and Linux

Hello. I recently moved from windows to Linux Mint, and noticed the behavior of the Picture in Picture window is different when resizing. On windows, the aspect ratio is … (read more)

Hello. I recently moved from windows to Linux Mint, and noticed the behavior of the Picture in Picture window is different when resizing. On windows, the aspect ratio is kept. while on Linux, it is free form, making these black bars around the video, so I have to resize it very carefully to not show any black bars.

How can I make the PiP on Linux behave like on Windows? That means resizing keeping the aspect ratio.

Attached are the comparisons between Windows and Linux Mint.

Thank you very much!

Asked by buneco05 7 months ago

Answered by buneco05 5 months ago

  • Solved
  • Archived

Profile changes after update

Hi all, I use to update Firefox with my Linux distribution package: I build the new package then upgrade it on the system. Anytime at the first launch of the new Firefox … (read more)

Hi all, I use to update Firefox with my Linux distribution package: I build the new package then upgrade it on the system. Anytime at the first launch of the new Firefox just installed version, it opens a new blank profile instead of my usual profile. I can set my usual profile as default by launch Firefox Profile Manager. So after update I launch from command line terminal or through launcher bar:

firefox -p

And It starts up profile manager, then I choose my usual profile and check it as default one. After that, when I open Firefox again, it uses my usual profile as expected.

Now the question: - is there a way to automate this procedure so I have not to repeat it anytime after I update the browser?

PS. I noticed my "profiles.ini" file is populated with a lot of profiles sections, likely maybe anytime I update, a new one is added in here. I don't know if it is a regular behavior or not.

Asked by ffoxer 7 months ago

Answered by jscher2000 - Support Volunteer 7 months ago

  • Solved
  • Archived

[SOLVED] cannot save page/file to local drive

Hi, I'm using version 101.0.1 (64 bit) for Ubuntu 22.04. When I open a link of a pdf file, the file is displayed in the built-in viewer, since I chose "Open in Firefox" i… (read more)

Hi, I'm using version 101.0.1 (64 bit) for Ubuntu 22.04. When I open a link of a pdf file, the file is displayed in the built-in viewer, since I chose "Open in Firefox" in my settings. But then if I click the download icon nothing happens. If I click the print icon and choose "print to pdf" in the popup, then clicking on "save" does nothing and I have to click "cancel" to dismiss the popup.

Actually there is no way to save a pdf file but setting PDF app to "Ask always" and then open it with "System handler", but then the file is saved into the default download folder, even though I selected the checkbox "Always ask me where to save files" in my settings.

EDIT: the issue was solved by installing the following packages, as shown in this question :

xdg-desktop-portal xdg-desktop-portal-gtk

Asked by gi4c0ph 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

No video playback

Same problem again with upgrade. After the last upgrade today 9-5-2022 I no longer have video play back on sites such as MSNBC, CNN or Twitter. U-Tube seems to be working… (read more)

Same problem again with upgrade. After the last upgrade today 9-5-2022 I no longer have video play back on sites such as MSNBC, CNN or Twitter. U-Tube seems to be working fine. I have checked and have version 5.0.1 of ffmpg installed if that helps. And I have turned off ad blockers. Firefox 104.0.1 in Fedora 36 workstation. Any help would be greatly appreciated. Thanks in advance. Bob.

Asked by 1bbrazie 1 year ago

Answered by 1bbrazie 1 year ago

  • Solved
  • Archived

How to easily disable annoying PKCS#11 pop-up when Yubikey is plugged in

Hi, I am using Firefox for Linux, and whenever my yubikey is plugged in, firefox will start bothering me for a pkcs#11 password. It always happens on start-up but it get… (read more)

Hi,

I am using Firefox for Linux, and whenever my yubikey is plugged in, firefox will start bothering me for a pkcs#11 password. It always happens on start-up but it gets relentlessly annoying if I happen to be on a site which potentially utilizes certificate auth, which I do not use this yubikey for.

I do however use it for 2fa, which does work perfectly fine.

How do I permanently stop whatever Firefox process keeps bothering me about this PKCS#11 password for functionality that I never use?

Asked by Dave 9 months ago

Answered by Dave 9 months ago

  • Solved
  • Archived

Sync doesn`t sync my tabs

Sync is a nightmare. It is so unintuitive! What exactly would be wrong with having separate Export and Import buttons for each of Settings, Addons, Tabs, History, Bookm… (read more)

Sync is a nightmare. It is so unintuitive! What exactly would be wrong with having separate Export and Import buttons for each of Settings, Addons, Tabs, History, Bookmarks, etc? I have a desktop box and a newer laptop I wanted to get up to date. I pressed the Sync button on the desktop ... By the way, there`s a link below that reads "Connect another device" ... Connect where? Someone is designing these interfaces who has absolutely zero imagination. Anyways, I signed off, moved the ethernet cable to my laptop, signed in, pressed Sync, and voila!, I got my Bookmarks, at least. But I have no idea how to get my tabs and windows. I tried with a "download link" something or other, but it seemed to assume I was sync-ing to a phone, and didn`t work. Any way to get my tabs?

Asked by Dan_W 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Copy-pasting of files not working in Ubuntu 22.04

Hey there, Intro: I recently switched to Linux and (because Brave is so broken) also to Firefox and I am liking it so far. Problem: Unfortunately I can't copy-paste fil… (read more)

Hey there,

Intro: I recently switched to Linux and (because Brave is so broken) also to Firefox and I am liking it so far.

Problem: Unfortunately I can't copy-paste files from Ubuntu Files (Nautilus) to Firefox (I tested image files and also sounds files, neither is working).

Test with Firefox: 1. Download a random photo (e.g. from Unsplash) 2. Select the file and hit ctrl + c in Files/Nautilus 3. I go to the clipboard inspector 4. I hit ctrl + v 5. The image does not show up in the output (see screenshot)

Test with Brave: 1. Do the same as above 2. The image does show up in the output (see screenshot)

Notes: - I am using Linux Ubuntu 22.04 with Wayland - Firefox Version 107.0 (64-bit) for Ubuntu Canonical - 1.0 - I have no extensions installed - I am not using the snap version (so I can scroll smoothly) ... I think I used apt-get install but not 100% sure

Asked by Stephan 1 year ago

Answered by Stephan 1 year ago

  • Solved

what happened to the "-"minimize, "[ ]" adjust screen, "[x]" close screen trio of icons in the top right hand corner of the browser?

I have just encountered another of Mozilla's unwanted, unneeded changes.The three simple little characters that almost all programs show in the upper right hand corner on… (read more)

I have just encountered another of Mozilla's unwanted, unneeded changes.The three simple little characters that almost all programs show in the upper right hand corner on the screen. These are long standing and well understood icons that were easy to use to manage your windows. Need to switch between program windows? Press the - key. Need to enlarge the screen to its fullest, press the open box, finished working with this program/screen, just click the x-box. Pressing the "open box" would adjust the screen so you could use the cursor to make the screen the siz you needed.

It's not just that these features work and are understood, Mozilla makes changes with no explanation, no other options for doing the same thing (exception: I can close the window with File> Exit (or Close)

I just spent a week getting Thunderbird115+ to "work" and now I have to figure out how to recreate what I've lost on Firefox? Like other people seeking support have said, I want the Firefox I know back.

Asked by bdjim 1 month ago

Answered by bdjim 1 month ago

  • Solved
  • Archived

Linux Dock Icon

I am using Pop OS, which is based off of Ubuntu. Somehow I did something, and it made the icon disappear for Firefox. I figured I could easily search the internet and fi… (read more)

I am using Pop OS, which is based off of Ubuntu.

Somehow I did something, and it made the icon disappear for Firefox. I figured I could easily search the internet and find a simple solution.

I temporarily fixed it last night, but here it is missing again.

I could upload a picture, but I don't see what difference that would make. The dock at the bottom has a spot for firefox, but no icon, literally an empty spot, In the application menu it is a blank spot with Firefox worded underneath.

I have uninstalled, reinstalled, purged, deleted the application data in my user folder..

Just annoying. not a huge problem.

Asked by cadearmstrong 1 year ago

Answered by cadearmstrong 1 year ago

  • Solved
  • Archived

Video stopped working

I upgraded Firefox to 109.0 on OpenSUSE Linux today as an update. Firefox no longer plays videos. Chrome is still playing the videos, so the codecs are on my machine. … (read more)

I upgraded Firefox to 109.0 on OpenSUSE Linux today as an update. Firefox no longer plays videos. Chrome is still playing the videos, so the codecs are on my machine. Is there anything I can do to fix this?

Asked by jay.treiman 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

Address Autofill is not an option

I am a UK user and have just installed and started to use Firefox on a brand new Linux Mint installation. As I am transferring from a Windows/Chrome environment, there i… (read more)

I am a UK user and have just installed and started to use Firefox on a brand new Linux Mint installation. As I am transferring from a Windows/Chrome environment, there is a lot of setting up to do. Firefox transferred most of the chrome info for me, and so I was able to get up and running with bookmarks and logins quite quickly. However, there is one problem that I can't seem to resolve.

I have been able to set up my credit card details, and these are prompted when needed, BUT, Firefox will not remember my name, email, phone or address. Thus for every form that I have to fill, I have to enter these details, again and again (and again).

I have looked at settings and see that the 'Autofill Address' option is not present (see attachment).

I have followed and implemented the fix proposed elsewhere, to update/add GB as an address format. This has not made a difference.

Can anyone please help.

Regards,

Mark

Asked by mark_holtom 6 months ago

Answered by zeroknight 6 months ago

  • Solved
  • Archived

Unable to play Videos on Reddit

Hi, I am running Firefox 108.0 on Ubuntu 20.04.5 and videos on Reddit don't play, they just buffer (?). Youtube works fine. I've tried the suggestions on this page: http… (read more)

Hi,

I am running Firefox 108.0 on Ubuntu 20.04.5 and videos on Reddit don't play, they just buffer (?). Youtube works fine. I've tried the suggestions on this page: https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues#search but nothing seems to work.

Thanks

Asked by ghostsview 1 year ago

Answered by ghostsview 1 year ago

  • Solved
  • Archived

Two maps "Andere bladwijzers" (Other bookmarks) in Firefox.

Good morning, Recently I discovered there are two maps called "Andere bladwijzers" in my Firefox browser. I deleted a submap in the second map and noticed this submap had… (read more)

Good morning, Recently I discovered there are two maps called "Andere bladwijzers" in my Firefox browser. I deleted a submap in the second map and noticed this submap had also disappeared in the first map. Is there something I must do or can I leave these two large maps as it is? Thanking you in advance for your reply. With kind regards, Ed Schijf, the Netherlands

Asked by edschijf 1 year ago

Answered by edschijf 1 year ago

  • Solved

Google Maps pegs CPU

Firefox 120.0 on openSUSE Tumbleweed. Google Maps (https://www.google.com/maps) results in CPU being pegged at 100%. No other tabs open. All I have to do is load the… (read more)

Firefox 120.0 on openSUSE Tumbleweed.

Google Maps (https://www.google.com/maps) results in CPU being pegged at 100%. No other tabs open. All I have to do is load the URL and do nothing else. This behavior is repeatable. CPU stays at 100% until tab is closed or browser is shut down. Sometimes the browser will hang and its PID has to be killed.

Offending process:

username 4501 4416 76 11:40 ? 00:05:13 /usr/lib64/firefox/firefox -contentproc -childID 1 -isForBrowser -prefsLen 27513 -prefMapSize 244227 -jsInitLen 228948 -parentBuildID 20231116134553 -greomni /usr/lib64/firefox/omni.ja -appomni /usr/lib64/firefox/browser/omni.ja -appDir /usr/lib64/firefox/browser {659a1e89-c5da-416d-b720-558c24187847} 4416 true tab

Asked by DMW 2 months ago

Answered by DMW 2 months ago

  • Solved
  • Archived

Scrolling Is Delayed about 2 Seconds

I am using a Dell Inspiron 3847 with the standard keyboard which came the system years ago Recently, when viewing a large online page, when I try to scroll down, the sc… (read more)

I am using a Dell Inspiron 3847 with the standard keyboard which came the system years ago

Recently, when viewing a large online page, when I try to scroll down, the scroll doesn't start until about two seconds after I press my scroll key (which is the lower-middle key of the 4 keys between my right-hand "Ctrl" key and the "0" of the 10-key keyboard at the far right of the keyboard).

This delay started happening a few weeks ago. I do not know whether something I did caused it.

How can I scroll my view starting immediately, rather than having to wait two seconds for it to start?

Asked by jwill 1 year ago

Answered by jwill 1 year ago

  • Solved
  • Archived

Unable to upload or download files

Hello all, For some reason, I can no longer upload or download files, with the pop-up window failing to appear entirely. I can upload folders through, for example, Dropb… (read more)

Hello all,

For some reason, I can no longer upload or download files, with the pop-up window failing to appear entirely. I can upload folders through, for example, Dropbox or Google Drive, but individual files don't work.

I've reset my browser, uninstalled and reinstalled it, opened it in troubleshooting mode, disabled enhanced tracking protection, but nothing seemed to work. I've tested another browser, and I was able to upload and download files just fine.

Is there anything I can do to fix this? I'm on Ubuntu 22.04 using Firefox 107.0.1.

Asked by Erika Campbell 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

No audio / video in Firefox 110 Ubuntu - Chrome 110 works fine

These websites won't play audio or video in Firefox 110.0.1, they work in Chrome 110.0.5481.177 https://www.vrt.be/vrtnu/livestream/audio/stubru/ When I click the Play b… (read more)

These websites won't play audio or video in Firefox 110.0.1, they work in Chrome 110.0.5481.177

https://www.vrt.be/vrtnu/livestream/audio/stubru/ When I click the Play button I get an error "Oops, something went wrong, error code 200" which seems to be a general error code. In Chrome the music starts playing instantly.

https://f1tv.formula1.com/ I have a subscription but video won't play. I can press the Play button, sometimes I see a preloader but the screen stays black, no audio or video. In Chrome the content just starts playing, be it live or recorded content.

Steps I took to get audio/video working inb Firefox, but to no avail:

run above websites in private tabs download Firefox again and run it from its folder in Downloads start Firefox in Troubelshoot mode start Firefox in Troubleshoot mode and Refresh Firefox disabled / enabled Plugin Widevine Content Decryption Module provided by Google Inc disabled / enabled Play DRM-controlled content in Settings disabled / enabled Enhanced Tracking protection disablde / enabled allow media autoplay

In other discussions it was opted to remove the PulseAudio config by running the below command and rebooting rm ~/.config/pulse/*

Any help to get this working again would be greatly appreciated!

Asked by NeoRey 11 months ago

Answered by jonzn4SUSE 11 months ago

  • Solved
  • Archived

Need help for community forums

Hi! I'm sorry if this is not the correct topic for this question, but I'm having huge trouble surfing the community forums of Mozilla. Could you please help me to underst… (read more)

Hi! I'm sorry if this is not the correct topic for this question, but I'm having huge trouble surfing the community forums of Mozilla. Could you please help me to understand what is the correct community forum to talk with other users about Firefox Relay service? Or a generic Mozilla community forum...

I need the community's help for technical purposes with the mentioned service.

Thank you very much for your patience. Noè.

Asked by Noè 10 months ago

Answered by James 10 months ago