Showing questions tagged: Show all questions
  • Solved
  • Archived

Search Engine Stuck on Amazon After Updating to Firefox 99.0.1 on Monterey 12.3.1

A short while ago, Firefox was automatically updated to 99.0.1 on my iMac running Monterey 12.3.1. Suddenly, for no apparent reason, the search engine is stuck on Amazon … (read more)

A short while ago, Firefox was automatically updated to 99.0.1 on my iMac running Monterey 12.3.1. Suddenly, for no apparent reason, the search engine is stuck on Amazon with no other search engine options available. I normally use Google.

Even if I go into the Firefox settings to the "Search" panel, it is showing ONLY Amazon as the available option in the pull-down menu under "Default Search Engine". In the "Search Bar" section, I have it set to "Add search bar in tool bar". But even if I set it to "Use the address bar for search and navigation", and then switch it back to "Add search bar in tool bar", Amazon still remains the only available search engine.

As a last step, I installed the "Google Search" add-on by 3Indian to see if I could get back my Google search engine, but Google still doesn't show up as an option anywhere, and I am still stuck with just Amazon.

Is this a bug in the latest Firefox build? Did the developers forget to enable something when they did this build perhaps?

Asked by WordWeaver 1 year ago

Answered by WordWeaver 1 year ago

  • Solved
  • Archived

Firefox is not applying userChrome.css

Hello, so I am not very experienced and recently discovered how to customize Fire Fox using the userChrome.css file. I went through all of the steps that are required in … (read more)

Hello, so I am not very experienced and recently discovered how to customize Fire Fox using the userChrome.css file. I went through all of the steps that are required in order to do this. I set up a folder called chrome in the directory /Users/my name/Library/Application Support/Firefox/Profiles/x1oheo82.default-release To test if it works I wrote this into the userChrome.css file: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

  1. TabsToolbar{ background-color: #FF0000 !important }

and set toolkit.legacyUserProfileCustomizations.stylesheets to true After restarting Fire Fox I saw that nothing changed. I double checked if there was a hidden file extension or if I might be in the wrong directory. I tried different code to see if there was some error in the code but nothing changed. I watched countless tutorials on You Tube and tried to find answers on google but nothing that I did seemed to help. I don't know if it has something to do with the operating system I am running or if it is a limitation of my computer hardware (I am running Fire Fox on an m1 mac).

Asked by Arihx 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

I cannot see saved credit cards in Privacy & Security Firefox 99.01

I cannot see saved credit cards in Privacy & Security Firefox 99.01. I moved from a mac to Windows, and sync'd everything. I have no option to see saved credit card… (read more)

I cannot see saved credit cards in Privacy & Security Firefox 99.01.

I moved from a mac to Windows, and sync'd everything. I have no option to see saved credit cards in Firefox Privacy & Security.

Please help?

Asked by Neil 1 year ago

Answered by Neil 1 year ago

  • Solved
  • Archived

Firefox download list opens by itself multiple times during the day

For about a month how I find that the Firefox download list opens by itself multiple times during the day. Most of the time I'm not even actively using firefox, it's just… (read more)

For about a month how I find that the Firefox download list opens by itself multiple times during the day. Most of the time I'm not even actively using firefox, it's just idling in the background. When it first happened I figured it'd be a quickly patched bug and so didn't ask around about it. But I've had a ff update since then and it still happens. Does anyone know why this is happening? I have not seen reports of this via search.

I'm on ff 9.0.1.

Asked by sparrowtwo 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Firefox blocks FedEx tracking

Hello, I have had a few websites not work properly with Firefox and have needed to open my backup browser (Avast Secure Browser) to use those websites. Right now it is … (read more)

Hello,

I have had a few websites not work properly with Firefox and have needed to open my backup browser (Avast Secure Browser) to use those websites.

Right now it is FedEx that comes to mind again as I kept checking for tracking of packages shipped to me since receiving the tracking info. I queries consistently returned the error message "Unfortunately we are unable to retrieve your tracking results at this time. Please try again later."

Thinking maybe the website was having issues or maintenance (and forgetting I had the same issue with FedEx website the last time I tried tracking there in Firefox), I kept "trying again later".

Then I opened my Avast browser and pasted the same url there and, sure enough, received this report on the display:

Travel History Date or Time City & State Status Monday, April 18, 2022 9:47 PM SPARROWS POINT, MD Departed FedEx location Sunday, April 17, 2022 1:49 PM Shipment information sent to FedEx

I have tried disabling the extension NoScript as well as turning off the "Enhanced tracking protection" and allowing permissions for the FedEx site with no improvement.

I copied and pasted the RAW data as well as the text version from the "about:support" page to send you.

Any suggestions to fix this?

Thank you, Keith McNabb

Asked by kemcnabb 1 year ago

Answered by kemcnabb 1 year ago

  • Solved
  • Archived

Firefox breaks my desktop environment's scrollbar style and (gradient) color and in version 98+ refuses css to approximate it

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has t… (read more)

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has to be an exception by itself! Not only that, but it changes my ability to customize its interface, from time to time and even changes access to such ability, on some updates.

My scrollbar customizations in userChrome.css and userContent.css do not work any more (other CSS changes still work, for menu/addressbar/tabbar/bookmarksbar orderint and tab styling). I had to resort to settings in user.js file, to get a 20px width scrollbar, suitable for my big screen, but... it gets very wide when I increase the focus, on some webpages and becomes very ugly! Furthermore, I cannot make sense of the proper use of "ui.themedScrollbar*" settings and the scrollbar and its slider result in the same color. These are my settings in user.js:

user_pref("widget.content.gtk-theme-override", "backwater"); user_pref("widget.non-native-theme.enabled", false); // Use GTK-3.0 gtk.css: set to false user_pref("toolkit.legacyUserProfileCustomizations.stylesheets", true); // Use userChrome.css & userContent.css: set to true user_pref("widget.gtk.alt-theme.scrollbar_active", true); user_pref("widget.non-native-theme.scrollbar.size.override", 20); // If nothing else works, fix scrollbar width to 20px user_pref("widget.non-native-theme.gtk.scrollbar.round-thumb", false); user_pref("widget.non-native-theme.gtk.scrollbar.thumb-size", 1.0); // originally 0.75 user_pref("widget.non-native-theme.gtk.scrollbar.allow-buttons", true); // it was true, anyway... user_pref("layout.css.cached-scrollbar-styles.enabled", false); user_pref("layout.css.color-mix.enabled", true); user_pref("widget.non-native-theme.scrollbar.style", 4); // wide scrollbar theme: set to 4 user_pref("ui.themedScrollbar", "#bad1f5"); user_pref("ui.themedScrollbarInactive", "#668cc4"); user_pref("ui.themedScrollbarThumb", "#e4e4e4"); user_pref("ui.themedScrollbarThumbHover", "#e4e4e4"); user_pref("ui.themedScrollbarThumbActive", "#668cc4"); user_pref("ui.themedScrollbarThumbInactive", "#bad1f5"); user_pref("browser.dom.window.dump.enabled", false); user_pref("extensions.ui.sitepermission.hidden", false); user_pref("fission.experiment.max-origins.qualified", true);

Either with the "ui.themedScrollbar*" settings or without them (and cleared from the prefs.js file), the scrollbar and its slider result in the same color, unless I (tryingly) click on some place on the scrollbar outside its slider; then I can see the slider, _only_ for the duration of the mouse-down event (which causes up or down page-hight scrolling).

The default, very thin scrollbar, as well as my modified wide scrollbar with invisible slider are both useless to me! I have even tried fx-autoconfig (https://github.com/MrOtherGuy/fx-autoconfig) to make the scrollbar CSS work, but no result. At this point, I am considering switching to another browser, despite the trust I have to mozilla, for my data and privacy.

Asked by kavadias 1 year ago

Answered by kavadias 1 year ago

  • Solved
  • Archived

Bookedmarl URL not visable

Since upgrading to Firefox 99.0.1 when I bookmark a web page into a specific folder, the URL does not appear when I open that folder. A restart of Firefox does not fix th… (read more)

Since upgrading to Firefox 99.0.1 when I bookmark a web page into a specific folder, the URL does not appear when I open that folder. A restart of Firefox does not fix the issue.

But if I try to Bookmark the same page again, I am asked to edit it. So it must be in the folder but it is not visible! Help!

Asked by zeus2022 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

after firefox update to 100.0 - i can't use any of my addons, and cant install new one

After firefox update to 100.0 - i can't use any of my addons, and cant install new one. All my current updates appears in "disabled" status, and there's no "enable" butt… (read more)

After firefox update to 100.0 - i can't use any of my addons, and cant install new one. All my current updates appears in "disabled" status, and there's no "enable" button. I have many addons, so it's the global problem.

Also, i can't install any of updates from addons.mozilla.org, i get message "Installation aborted because the add-on appears to be corrupt". All addon xpi files are downloaded without problem using "save as", also, after clicking "install" on addons website i see download progress.

Please help to resolve this issue!

Asked by Andy 2 years ago

Answered by Andy 1 year ago

  • Solved
  • Archived

Facebook page jumps when typing a reply

When I start to type a reply to a Facebook post, the page scrolls down so that the line I am typing disappears one line below the bottom of the screen. I have to scroll … (read more)

When I start to type a reply to a Facebook post, the page scrolls down so that the line I am typing disappears one line below the bottom of the screen. I have to scroll down to see what I'm typing. Also, it jumps down the same way whenever I hit the backspace key to edit what I'm typing.

I discovered a previous (archived) post on this forum that suggested using "about.config" and making sure that the value setting for browser.backspace_action is equal to 2. But that didn't change the annoying behavior. Is there any other value I should try? It's not clear what the number means.

Nor did setting browser.backspace to true (or to false) seem to help with the unwanted jumping upon use of the backspace key.

This only seems to happen with Facebook, but it's quite annoying.

Asked by jay46 1 year ago

Answered by jay46 1 year ago

  • Solved
  • Archived

Firefox does not display Facebook feed

There are a number of old threads regarding this and having worked through them it is still unresolved. 1) I have cleared cache/cookies 2) I have disabled all extensions … (read more)

There are a number of old threads regarding this and having worked through them it is still unresolved. 1) I have cleared cache/cookies 2) I have disabled all extensions 3) I have turned off tracking 4) I have tried in safe mode - still the same.

This is not just on one website - it is on ALL that have Facebook feeds. It is NOT just on my laptop - I have asked others to try - they have the same result - blank page. ...so please don't suggest re-installing Firefox!!

An example is: https://dragonsdensoftplay.co.uk/News-Events/news-events.html

The feed works ok in other browsers.

Thank you

Asked by gprit1 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

How to recover passwords from logins.json-1.corrupt?

I opened Firefox as usually, but passwords are missing, only logins are available. There is also a file called logins.json-1.corrupt in the profile folder. Renaming it … (read more)

I opened Firefox as usually, but passwords are missing, only logins are available. There is also a file called logins.json-1.corrupt in the profile folder.

Renaming it back to logins.json with restarting the computer does not work.

There are no previous versions of these two files available in the system.

Please let me know how I can recover passwords, may be with a special software.

Thank you!

Asked by DVS75 1 year ago

Answered by DVS75 1 year ago

  • Solved
  • Archived

When fullscreen, only showing bookmarks bar in new tab

Hello. Since I use the bookmark bar and fullscreen mode a lot, I would like to be able to see the bookmark bar in fullscreen, not on every tab, but only in a new (empty) … (read more)

Hello. Since I use the bookmark bar and fullscreen mode a lot, I would like to be able to see the bookmark bar in fullscreen, not on every tab, but only in a new (empty) tab, so that I can avoid disabling fullscreen to access the bookmark bar and at the same time not having any part of the interface visible unless I'm in a new tab. Thanks in advance for any reply!

Asked by Matteo 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Firefox 99 is not applying the chosen content action for MSMoney OFX files - deosn't matter what action is chosen it just saves

Until the last FF release (99), when I downloaded files from my bank for MSMoney FF would apply the action to use the MS Money import handler. Not anymore. FF will now … (read more)

Until the last FF release (99), when I downloaded files from my bank for MSMoney FF would apply the action to use the MS Money import handler. Not anymore. FF will now only save the file. Even if I choose "always ask" it still just saves the file - never asks what to do with it (save or open with). Please fix this. It's worked fine for decades and now doesn't work at all. I tried adding images to show what happens but the ones that show what FF is doing and the FF settings won't upload. Only the banking download page images will upload. They just show that I pick MSMoney as the download format.

Asked by nvanbeancounter 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Amazon, ebay/ other online shopping websites pop up as number 1 result after 1s-2s

whenever I search something that (is / sounds like) a product amazon links or other online shopping links show up as the number 1 results after a short delay. I have been… (read more)

whenever I search something that (is / sounds like) a product amazon links or other online shopping links show up as the number 1 results after a short delay. I have been redirected to amazon many times when I tried to click the #1 result but the amazon link pops up where the #1 result was.I have uplaoded 2 images the one where steam is the #1 result is what i want it to be, the second Image is what happens after a short delay.

Asked by giovanniwells544 2 years ago

Answered by giovanniwells544 1 year ago

  • Solved
  • Archived

Pop-up exceptions not working

Hello, The pop-up blocker exceptions are not working for some sites which I, of course, use a lot. The sites are listed in the exceptions, but Firefox stubbornly continu… (read more)

Hello,

The pop-up blocker exceptions are not working for some sites which I, of course, use a lot. The sites are listed in the exceptions, but Firefox stubbornly continues to block them. I sincerly consider walking away from Firefox (notwithstanding I love it and being a long term user), because it happens with sites I frequently use on a daily base.

I've looked around but none of the solutions work for me as those articles are rather old.

My version of Firefox: 99.0.1 (64bit) running under Windows 10 Pro

Hoping to find a solution here.

Renaud

Asked by Renaud 1 year ago

Answered by Renaud 1 year ago

  • Solved
  • Archived

Website images looking all glitched.

My images look all glitched out and scrambled. It wasn't like this before, and I don't remember if I changed anything in my about:config. I've included what they look li… (read more)

My images look all glitched out and scrambled. It wasn't like this before, and I don't remember if I changed anything in my about:config.

I've included what they look like.

Asked by yumii 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Why do links not work in Firefox, but do on other browsers

The latest example is the button to sign into LinkedIn. It is not working in Firefox, but it does in other browsers. I have other examples just from today. I have used fi… (read more)

The latest example is the button to sign into LinkedIn. It is not working in Firefox, but it does in other browsers. I have other examples just from today. I have used firefox as default for many years. I assume this is a security thing, but these are basic links. I have no add-ons or other complications. Most times, I do not even realize there is a problem, but when I feel something is wrong, I try another browser and it works. Thank you.

Asked by HnLA 1 year ago

Answered by HnLA 1 year ago

  • Solved
  • Archived

Stange 'ghost' over text entry fields

I am having a weird issue in Firefox. This issue happens on all websites, in all text entry fields of any kind. It is like there is another 'ghost box' overlapping each… (read more)

I am having a weird issue in Firefox. This issue happens on all websites, in all text entry fields of any kind.

It is like there is another 'ghost box' overlapping each entry field. It is hard to tell in the pics (was hoping I could post a video), but in the first one you can see the cursor is slightly lower than the actual field. If I type, nothing will appear. Then if I click again, a bit higher, I can type into the actual field.

I have never seen this before but it happens on ALL websites. It is a bit frustrating having to re-click all the time. Also, I was getting concerned there might be some keylogger or weird virus on my machine. Any ideas what is wrong here?

Asked by mysmu 1 year ago

Answered by FredMcD 1 year ago