Showing questions tagged: Show all questions
  • Solved

Disable New High-Contrast Tab Outline

After updating to Beta 122.0b3 (64-bit), the active tab is now highlighted with a simple white outline instead of the coloring surrounding the address bar. My selected th… (read more)

After updating to Beta 122.0b3 (64-bit), the active tab is now highlighted with a simple white outline instead of the coloring surrounding the address bar. My selected theme has not changed, and the same goes for all of my extensions. I could not find this change in the 122.0b Release Notes.

If this behavior is intentional, is there any option to return to the previous behavior (including in about:config)?

Asked by Shabcarb 2 months ago

Answered by jscher2000 - Support Volunteer 2 months ago

  • Solved

Graphical artifacts after the recent Firefox update

It worked nicely for many years, until today. I installed Supraland from Steam, played for a couple of hours, and suddenly my Youtube page went glitchy - not the layout b… (read more)

It worked nicely for many years, until today. I installed Supraland from Steam, played for a couple of hours, and suddenly my Youtube page went glitchy - not the layout but minor elements were getting scrambled, especially text. I'll attach a couple of pictures to show it. In fact, all pages glitch if their content changes even a little. As of typing now, I see the glitches, with a word or another getting butchered. Gifs and videos are full of that.

Windows 10, the current update, Radeon RX 580, the recommended AMD drivers installed (and reinstalled again and again, 23.11.1)

I think I did pretty much everything with Firefox. Disabling hardware acceleration fixes it (but then of course the browser goes slow). Games work fine, including Talos Principle 2 which is intense enough. The clean install, reinstall and all that. I'm writing from the beta stable build now. I've tried to regress to the previous versions too.

It strictly coincides with the game installation but I have no close backups - who knew that some game might just do that. Then, of course, I tried to uninstall it too.

Thoughts?

Asked by clancyrus 1 month ago

Answered by zeroknight 1 month ago

  • Solved
  • Archived

Button on the top right of Firefox window

Hi Today I updated Firefox to version 106.0 and I can't get rid of the "arrow button" from top right (screenshot attached - near the minimize button, I marked it). The fu… (read more)

Hi Today I updated Firefox to version 106.0 and I can't get rid of the "arrow button" from top right (screenshot attached - near the minimize button, I marked it). The function of this button is clear for me - tabs management. But I can manage my tabs without special button for it. I want to remove it. I tried right clicking on it, but the "remove from toolbar" option is unavailable. I tried to customize toolbar, but it won't work either (I can't take it from te toolbar).

How to remove this button?

Asked by jormungandrpl 1 year ago

Answered by Terry 1 year ago

  • Solved
  • Archived

Hanging on text box input

I'm having an issue with a particular text field. When entering any text into said text field, my CPU will shoot to 100% usage on some cores, hang for a bit and then prin… (read more)

I'm having an issue with a particular text field. When entering any text into said text field, my CPU will shoot to 100% usage on some cores, hang for a bit and then print the text after a few seconds. I have an Intel 13900k @ 5.5ghz.

I can't provide a link to the text box as it's a WordPress CMS on my local machine. This issue does not present itself on the competitor browser.

A few troubleshooting steps I've taken:

  • Re-install Firefox
  • New profile
  • Disable all extensions
  • PC safemode + Firefox safe mode
  • Tested dev/nightly/stable (I'm using BETA daily)
  • Disabled accel

Hopefully I'm able to have an expert look at my profiler to help determine what the issue is. I'm not knowledgeable in this area unfortunately. https://share.firefox.dev/3s60ISV

Thank you.

Asked by mattskiiau 6 months ago

Answered by mattskiiau 5 months ago

  • Solved
  • Archived

Cookie Consent option not showing on certain sites (EU area)

Firefox beta release: 116.0b6 (64-bit) On sites such as BBC.com, Youtube.com and Facebook.com I am not getting the normal cookie consent pop-up option which used to aut… (read more)

Firefox beta release: 116.0b6 (64-bit)

On sites such as BBC.com, Youtube.com and Facebook.com I am not getting the normal cookie consent pop-up option which used to automatically show on opening the sites. Other sites are still showing the cookie consent option pop-ups. This means I cannot select if I wish to accept or reject cookies on several sites that used to allow me the option.

In checking about:config, the cookiebanners.service.mode is set to 1, which I believe this the correct setting for enabling the cookies consent pop-up option.

Is there any fix for the cookie consent pop-up not working on certain sites within the EU? I am not using a VPN or pop-up blocker. Tracking protection is set to Standard, cookies and site data are always deleted on closing Firefox and "Do Not Track” signal is set to always. Deleting all installed FF extensions has no effect either.

In other browsers on the same PC, Chrome and Edge, the cookie consent option does still work as it should on the sites mentioned. In Firefox it doesn't.

This is only happening on one PC. My latop has the same FF beta build installed and is not showing this behaviour, it still automatically shows the cookie consent pop-ups when visiting sites such as BBC.com, Youtube.com and Facebook.com.

Asked by Richard Law Bijster 7 months ago

Answered by Richard Law Bijster 7 months ago

  • Solved
  • Archived

PX to pixel display ratio

I use HTML files to create images for a tile based game we play. 6 months ago I was able to create a table with collapsed borders and 0px padding, margins, and borders, … (read more)

I use HTML files to create images for a tile based game we play. 6 months ago I was able to create a table with collapsed borders and 0px padding, margins, and borders, then draw my image with 207 x 207 JPEG TDs in multiple TR rows, then place another GIF image over all the JPEGs with transparent edges. Doing this for a table that was 6 tiles (207px) wide and 4 tiles deep, at ctrl 0, displayed a Firefox combined image that was exactly 1242px x 828px that was completely visible on 24 inch 1920 x 1080 DELL monitor. This allowed me to right click an empty space on my Firefox screen and select Take Screenshot to click on the GIF overlay image and capture that image with all of the tiles that were behind its transparent edges.

For some reason, I have no idea why, my 207px by 207px tile images are now being displayed as 282px by 282px at ctrl 0, and the overall image is now too large to fit on the screen, so taking a screenshot of the proper sized image is no longer possible. For example, at ctrl- ctrl-, the tile images are 221 pixels square, which should be 1326 pixels wide for 6 tiles, but my 1242px wide GIF file displays at 1330 pixels wide, probably due to some kind of rounding error.

I was able to use about:config and change layout.css.devPixelsPerPx from -1.0 to 0.74 and it did solve the problem. But it does so with a lot of warning for changing that default value!

So my question is simple: how does Firefox, on Windows 10, determine its screen pixel to Image px relationship? I need to know what to look at for the proper way to get my px to pixel ratio back to 1 to 1.

This is what the working image looks like while designing the center scoreboard tile https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-08-23-13-36-34-2fa67f.png

and this is what the final image looks like when you take a screenshot of the image https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-08-23-13-36-53-beae42.png

Asked by sandy50 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Firefox Multi Account container advanced proxy setting does not work. Connection Timeout/Refused.

Hello Everyone, After inserting the proxy information, webpages in the container tab refuse to load/connect, I insert the IP address and I've also tried the Fully qualif… (read more)

Hello Everyone,

After inserting the proxy information, webpages in the container tab refuse to load/connect, I insert the IP address and I've also tried the Fully qualified domain name, using the type://host:port syntax, I get "The proxy server is refusing connections" and "The connection has timed out" error messages.

If I setup the proxy via the settings menu the entire browser uses the proxy server address, I am trying to specify a different proxy server for each container.

Asked by fxybrew 1 year ago

Answered by TyDraniu 1 year ago

  • Solved

Firefox 119 doesn’t use system (/usr/share/fonts) or user’s (~/.local/share/fonts) fonts for rendering

I use Kubuntu 23.04 with Firefox from mozillateam/ppa apt repository, got update to FF 119 today (package 119.0+build1-0ubuntu0.23.04.1~mt1) and after the update Firefox … (read more)

I use Kubuntu 23.04 with Firefox from mozillateam/ppa apt repository, got update to FF 119 today (package 119.0+build1-0ubuntu0.23.04.1~mt1) and after the update Firefox stopped using system-wide installed fonts (either from /usr/share/fonts or from ~/.local/share/fonts).

So for example fc-list finds Gentium Plus (/usr/share/fonts), Iosevka and Junicode (~/.local/share/fonts) on my system: % fc-list -f '%{family}: %{file}\n' | rg -i 'gentium plus:' Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-Italic.ttf Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-BoldItalic.ttf Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-Bold.ttf Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-Regular.ttf % fc-list -f '%{family}: %{file}\n' | rg -i 'iosevka:' Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc % fc-list -f '%{family}: %{file}\n' | rg -i 'junicode:' Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-Bold.otf Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-Regular.otf Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-Italic.otf Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-BoldItalic.otf

but when I try to apply the style `font-family: Gentium Plus`, `font-family: Iosevka`, or `font-family: Junicode` to an element, Firefox doesn’t use those fonts and instead in the element inspector I see Noto Serif is being used instead.

Before the update the appropriate system fonts were being chosen for rendering by Firefox.

Asked by Benedykt Jaworski 4 months ago

Answered by zeroknight 4 months ago

  • Solved
  • Archived

open web link when firefox runs cause error : firefox is already running...

Hello, I'm currently running firefox developer edition and i'm facing a weird bug: When firefox is started, opening a web url from outside of firefox window does'nt work … (read more)

Hello, I'm currently running firefox developer edition and i'm facing a weird bug: When firefox is started, opening a web url from outside of firefox window does'nt work and display error message: "Firefox is already running but is not responding...". It expects that i close all instance of firefox instead of just opening url in a new tab.

Do you have any idea?

I'm working on version 105.0b2 with two profiles on an ubuntu 22

Asked by henritouchard 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

firefox 114b5 does not save form data

Firefox 114b5 does not remember form history. I have tested two different websites. I have form history enabled - see attached browser_settings.png. Attached is a screen… (read more)

Firefox 114b5 does not remember form history. I have tested two different websites.

I have form history enabled - see attached browser_settings.png. Attached is a screenshot of the moz_formhistory table in the formhistory.sqlite file.

What do I need to do to enable form history on all websites?

Asked by mwestout1 9 months ago

Answered by cor-el 9 months ago

  • Solved
  • Archived

OPEN URL IN MICROSOFT EDGE (CONTEXT MENU)

I am attempting to build a script (extension) that will open any focused page in Firefox with Microsoft Edge from the context menu. The intention is to utilise the existi… (read more)

I am attempting to build a script (extension) that will open any focused page in Firefox with Microsoft Edge from the context menu. The intention is to utilise the existing microsoft-edge URL Protocol in Windows instead of a native client.

QUESTION WILL MOVE TO https://discourse.mozilla.org/

Asked by deanone 1 year ago

Answered by Paul 1 year ago

  • Solved
  • Archived

firefox developer highlighting elements outlined problem

hello guys I need help with this problem in firefox developed edition Specifically, when I use the Inspector panel to inspect elements on a webpage, the selected element… (read more)

hello guys I need help with this problem in firefox developed edition

Specifically, when I use the Inspector panel to inspect elements on a webpage, the selected elements are outlined with a blue border instead of being filled with color. This is making it difficult for me to visualize the layout and styling of the elements, and I would prefer to have them filled with color instead.

I have tried to find a solution on my own by searching online, but have not been able to find a clear answer. Could you please advise me on how to change the settings in Firefox Developer Edition so that the Inspector panel highlights elements with a fill color instead of just an outline?

Asked by Youcef Hemadou 11 months ago

Answered by Youcef Hemadou 10 months ago

  • Solved
  • Archived

Firefox Developer Edition wont open Discord hyperlinks

Discord hyperlinks will no longer open when Firefox Developer Edition is selected as my default browser. They open fine in both Firefox, Microsoft Edge, and Google Chrome… (read more)

Discord hyperlinks will no longer open when Firefox Developer Edition is selected as my default browser. They open fine in both Firefox, Microsoft Edge, and Google Chrome when selected as Windows 11's default browser. When selecting my default browser it would show 2 instances of Firefox Dev but after uninstalling then reinstalling it there is only one instance in the default app list. I'm not really sure where to go from here. Maybe this is an issue with the latest version of Dev Edition or is this an issue with my Windows?

Thanks

Asked by yohaun 1 year ago

Answered by yohaun 1 year ago

  • Solved
  • Archived

Escape developer's version in favor of stable without losing profiles

Hello. I use developer's version of ff for a few weeks (currently on 107.0b2). I recently decided to switch back to stable version 106. However, when I run it it says ``… (read more)

Hello. I use developer's version of ff for a few weeks (currently on 107.0b2). I recently decided to switch back to stable version 106. However, when I run it it says

``` Using an older version of Firefox can corrupt bookmarks and browsing history already saved to an existing Firefox profile. To protect your information, create a new profile for this installation of Firefox. ```

So, how do I move from developer's version back to stable without losing anything?

(OS: debian 11, if it matters)

Asked by WhiteBlackGoose 1 year ago

Answered by WhiteBlackGoose 1 year ago

  • Solved

PDF files are saved to temp folder before opened

When selecting "Open in Firefox" in the "What do you want to do with this file?" box or on about:preferences and then opening a PDF file on the web, instead of downloadin… (read more)

When selecting "Open in Firefox" in the "What do you want to do with this file?" box or on about:preferences and then opening a PDF file on the web, instead of downloading the file to RAM and opening it with its online address, Firefox downloads the PDF to /tmp/mozilla_${USER}0 and opens it from there. This also adds it to the download history. I have set the about:config flag browser.download.start_downloads_in_tmp_dir to true so the files I just open and don't want to permanently download don't clutter my $HOME/Hämtningar (downloads) folder. I tried to first prevent that by selecting the default action to do when tasked to open a PDF, but that didn't fix it, so I set the about:config flag. Unfortunately, setting the default action stopped Firefox from opening a PDF inline without downloading it and I cannot find any option along the lines of "Preview in Firefox" (as described in this support article ).

Asked by Christian 2 months ago

Answered by zeroknight 2 months ago

  • Solved
  • Archived

Firefox Developer edition 109-b9 breaks focusing in and out of app on Ubuntu 22.10

Noticed yesterday but not as prominent, firefox suddenly steals all window focus, trying to do anything in any other window is pushed into firefox no matter if it is mini… (read more)

Noticed yesterday but not as prominent, firefox suddenly steals all window focus, trying to do anything in any other window is pushed into firefox no matter if it is minimised or in another workspace. I have tested this in a clean install along with a clean profile. Bitwarden and other windows seem to act weird when they are interacted with.

This all works well and good on b8 and stable. I am using wayland (Ubuntu 22.* default), but xwayland is available.

Asked by Oliver Wilkes 1 year ago

Answered by Oliver Wilkes 1 year ago

  • Solved
  • Archived

Not able to "paste" text on Whatsapp web on Firefox Developer

Good day. Im having an issue with my Firefox developer Eidition (v 117.0b9 -64bit), where im not able to "paste" text on whatsapp web since 18th Aug 2023. (pasting imgs … (read more)

Good day.

Im having an issue with my Firefox developer Eidition (v 117.0b9 -64bit), where im not able to "paste" text on whatsapp web since 18th Aug 2023. (pasting imgs is fine though)

Tested other ways to paste using right click / Ctrl+V but it didnt work.. and if i copy something from same whatsapp and re-apply paste, also does not work (again to remind, only pasting text does not work) !

Checking though other browsers "Edge" seems to be ok and i was able to "paste" text normally. I hv yet to check on the issue on normal Firefox Browser.

Using Windows 10. Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz 1.99 GHz RAM 32.0 GB


Since other browsers did not have this issue, i thought of raising this for Firefox devs to hv a look at it. Maybe some update done recently caused this glitch. So im doing my part in sharing feedback to improve an open source software which i use.

Thank you for the amazing browser.

Asked by Abdulaziz_10101 6 months ago

Answered by Paul 6 months ago

  • Solved
  • Archived

Forcing Cmd/Ctrl+click to ALWAYS open the link in a background tab - even in Google Docs?

My preferences are set so that "When you open a link, image or media in a new tab, switch to it immediately" is OFF. Therefore most of the time when I Cmd+click on a link… (read more)

My preferences are set so that "When you open a link, image or media in a new tab, switch to it immediately" is OFF. Therefore most of the time when I Cmd+click on a link, it opens on a new tab that loads in the background. This is what I want.

However, some websites break that behavior. 2 high-profile examples:

  • In Google Docs, if a piece of text links to an URL, clicking on the text shows a small window with the URL. Cmd+click on that URL opens it in a new tab, and takes me to that tab.
  • In Facebook Messenger, if I Cmd+click on a chat, again the chat opens in a new tab and I'm taken there. Additionally, the original tab activates that chat.

Interestingly, in both these cases, I get the right behavior if I right-click on the URL or in the chat and in the contextual menu choose "Open link in new window/tab/container tab": the new tab stays in the background.

So my question is: does anyone know of a way to always make cmd+click behave just like "Open link in new tab", no matter the website?

I'm on Firefox 115b4 on macOS, but this has been like this for years at least.

Asked by hmijail 8 months ago

Answered by hmijail 8 months ago

  • Solved
  • Archived

SEC_ERROR_UNKNOWN_ISSUER with internal CA on Ubuntu 16.04 Thin-Clients

Hi, im getting unknown issuer on my thin-clients with a FF ESR 45.9.0. This FF is tied to the OS (Ubuntu 16.04) and the OS is the most recent compatible version for our … (read more)

Hi,

im getting unknown issuer on my thin-clients with a FF ESR 45.9.0. This FF is tied to the OS (Ubuntu 16.04) and the OS is the most recent compatible version for our version of the thin-clients. So yeah its super old and I'm not able to update any of this. There is no security.enterprise_roots.enabled option available. What would be the best way to solve this issue for ~400 clients. Thanks in Advance Regards Tekkion

Asked by Tekkion 11 months ago

Answered by Tekkion 11 months ago