Showing questions tagged: Show all questions
  • Solved

Unable to play Twitter/Reddit/Facebook Video and GIFs on Firefox 99.0.1 (64-bit)

I have fedora 36 Linux on my laptop and I have installed Firefox from the software store. The version in Help>About>About Firefox shows 99.0.1 (64-bit). I am able t… (read more)

I have fedora 36 Linux on my laptop and I have installed Firefox from the software store. The version in Help>About>About Firefox shows 99.0.1 (64-bit).

I am able to play videos on Youtube but no video or GIF is playing on Twitter/Reddit/Facebook.

I have installed media codecs as per this fedora help

My autoplay setting look like as per the attached image. I do not have any extensions except Bitwarden on Firefox.

I also tried playing videos on Firefox 100 by downloading it directly from firefox website but faced the same issue.

Asked by Bhanu Magotra 3 days ago

Answered by Bhanu Magotra 2 hours ago

  • Solved

Add-ons don't work, and tabs crash, since update to F36

$ dnf list installed | grep firefox firefox.x86_64 100.0-4.fc36 Since upgrading to Fedora 36, Firefox seems to have stopped being stabl… (read more)

$ dnf list installed | grep firefox firefox.x86_64 100.0-4.fc36

Since upgrading to Fedora 36, Firefox seems to have stopped being stable at all. Having any add-ons enabled causes webpages to frequently break. Even in troubleshooting mode, I get a tab crash immediately on start, and infrequently during later browsing.

Troubleshooting mode has the same issues, trying a completely clean profile has the same issues. Chromium works with no issues.

See tab crash report here: https://pastebin.com/wNPFhpgN

Asked by zoknozelte 2 days ago

Answered by FredMcD 2 days ago

  • Solved

I used to be able to go to another window by clicking on a subject in the search engine

Whether I was in the standard Firefox search window, or Google, or DuckDuckGo (my preferred choice), I was able to click on a specific topic in the search window and have… (read more)

Whether I was in the standard Firefox search window, or Google, or DuckDuckGo (my preferred choice), I was able to click on a specific topic in the search window and have it automatically open a new window within the Firefox window settings. I can no longer do this with Firefox 100.

Please fix!

Asked by George 2 days ago

Answered by jscher2000 - Support Volunteer 2 days ago

  • Solved

How do I get my home page in Firefox on all my tabs?

Now on Firefox 100.0.1 On earlier versions of Firefox I was able to set a particular url for my home(opening) page. That is still true. However, on past versions I was … (read more)

Now on Firefox 100.0.1 On earlier versions of Firefox I was able to set a particular url for my home(opening) page. That is still true. However, on past versions I was also able to make *my home page* appear on every tab I opened. On the current edition I get a choice of only Firefox Home Page (default) or Blank page. I cannot get my home page on the new tab. How can I bypass the restrictions of the settings under Home to get my home page on every tab?

That the question I need an answer to. Everything below this is explanation of why I want this and a complaint about how Firefox changes things that I would appreciate being passed on to the developers.

                                                                    <---------------------->

If I choose Firefox Home Page (default), I am *forced* to use the address box to put in my search terms. I have become accustomed to the various search engines with their splash screens - with the nice big search box in the middle of the screen (both horizontally and vertically). It is absolutely unnerving to me to try to type in the box in the middle and have nothing show up there but up above in the address box.

I am a project person in a multi-tasking world, which means whether I like it or not, I have to multitask too. For me to do this successfully, all my tools need to be where I expect and perform as I expect them. Even putting duckduckgo.com in the current home page/new window setting, doesn't get the duckduckgo splash page, but even though I'm not that technically advanced, I found a way of getting it in my home page window. However, the tabs section doesn't offer me an opportunity to put my own choice in.

I wish Firefox would stop tinkering with otherwise minor things. I understand fixing found vulnerabilities. I understand providing new services and technology when they're developed. But why force people to use search and tabs the way Firefox wants them to rather than the way the user is accustomed to.

Asked by bdjim 3 days ago

Answered by FredMcD 3 days ago

  • Solved

Firefox seems to forget download history after a few seconds + Downloads panel does not open

So this issue just started and it's really annoying. In order to actually see the downloads, I first have to enable the menu bar and then go Tools -> Downloads Clickin… (read more)

So this issue just started and it's really annoying.

In order to actually see the downloads, I first have to enable the menu bar and then go Tools -> Downloads

Clicking the ↓ button should open a panel of recent downloads but nothing appears when I click on it. Furthermore, the "download complete" notification that this panel provides are no longer present.

The animation for the panel still works though.

Is there a solution to this?

Asked by ExileFox 6 days ago

Answered by ExileFox 5 days ago

  • Solved

file downloads

The problem is : Some of the time FF just records 0 bytes file and says nothing. I suspect that FF inspect the URL of the links and discard ( perhaps for security reaso… (read more)

The problem is : Some of the time FF just records 0 bytes file and says nothing. I suspect that FF inspect the URL of the links and discard ( perhaps for security reason ) ones that do not begin with HTTP.

The bypass is : One has to copy the link and insert in in the new page of FF.

The solution would be to change FF code.

Thank you.

Asked by Le-Bilboquet 1 week ago

Answered by Le-Bilboquet 6 days ago

  • Solved

Volume control not working on FF99.01 Ubuntu 22.04

FF updated yesterday with the new Ubuntu 22.04 (Pop) update to 99.01. Since the update the volume control inputs are essentially disabled on all web sites, and they defau… (read more)

FF updated yesterday with the new Ubuntu 22.04 (Pop) update to 99.01. Since the update the volume control inputs are essentially disabled on all web sites, and they default to max - even when muted.

Example - youtube - all videos play full volume Reddit - even muted videos play full volume

The volume can now only be controlled by the system slider.

The same behavior does not occur in other browsers - e.g. Chromium, Opera, etc.

Can anyone assist?

Asked by knussear 3 weeks ago

Answered by jonzn4SUSE 3 weeks ago

  • Solved

Netflix on Mozilla 100 / Ubuntu20.04 constantly asks for video codex

I saw where this was a problem with Netflix, Amazon Video and other sites with Fire Fox and that one person even used professional version and still had the same problem.… (read more)

I saw where this was a problem with Netflix, Amazon Video and other sites with Fire Fox and that one person even used professional version and still had the same problem.

What I cannot see is where he got the video codex that allow Netflix to work on Fire Fox version 88, let alone this newest version that Mozilla has created.

Asked by Micheal R. - August 5th, 1988 6 days ago

Answered by jonzn4SUSE 6 days ago

  • Solved

Browsing on local development URLs derives on "Unable to connect"

Hi there, I'm using my PC for local web development. I use Firefox as my regular browser and recently, in order to distinguish between personal time and development time,… (read more)

Hi there,

I'm using my PC for local web development. I use Firefox as my regular browser and recently, in order to distinguish between personal time and development time, I've established a new profile just for development purposes.

The local website I can't reach is "site.local.dev". My OS is Ubuntu 20.04 and that URL points to a local IP on my network (resolved via /etc/hosts file on my PC).

Funny thing is that: - In dev-profile: site.local.dev does not work => "Unable to connect" and the URL bar shows https://site.local.dev even if I force it to http:// - In personal-profile: site.local.dev does work :P

I have tried with CLI tools like "wget", "hosts", "ping", "telnet" and so on and the site loads ok. Even I have used Dillo (damn simple web browser) and the site loads ok also.

Things I've tried so far: - Suggestions at https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can - Suggestions at https://support.mozilla.org/en-US/questions/1011327 (similar issue, not exactly the same).

It must be a silly thing but I'm out of options now. Perhaps anybody has faced to this situation in the past: any suggestion on this issue?.

Thanks in advance, Ibon.

Asked by Ibon Castilla Varela 3 months ago

Answered by Ibon Castilla Varela 1 week ago

  • Solved

Suggestions

Hello! Please, implement the built-in speed dial, like in Opera and Vivaldi. It's extremely convenient and useful, lots of people need this. I've been using Firefox for m… (read more)

Hello! Please, implement the built-in speed dial, like in Opera and Vivaldi. It's extremely convenient and useful, lots of people need this. I've been using Firefox for more than 10 years and I hate your stupid "Firefox Home" page (sorry) on desktop and Android with icons that add automatically and I can't change and locate. It's inconvenient and completely useless. It would be great if you create something like Opera 12.17 or 12.18 had. In addition, please remove the "close" button in the last tab. I know that I can do it via the "config mode" (browser.tabs.closeWindowWithLastTab), but it's not user-friendly. It's inconvenient when you close the tab just to return home, but the whole browser closes. It makes me nervous. Thank you in advance! You are doing a great job, wish you good luck, and hope that one day Firefox will be more popular than Chromium-based browsers.

Asked by bdbsckxz 3 months ago

Answered by jscher2000 - Support Volunteer 3 months ago

  • Solved

Scrolling comment sections not working in the latest Firefox

I just upgraded to Ubuntu 22.04 and along with that I upgraded Firefox. It's no longer possible to scroll the comment section of articles, just the main page. I've seen t… (read more)

I just upgraded to Ubuntu 22.04 and along with that I upgraded Firefox. It's no longer possible to scroll the comment section of articles, just the main page. I've seen this on both the National Review and the NY Times. The scroll bar is also not persistent, it only shows up when the mouse is over it. Is there a way to fix this or is this a bug in Firefox 100.0?

Asked by bjrosen 1 week ago

Answered by Terry 1 week ago

  • Solved

wide spacing between words as well as odd-looking numbers in Firefox

Since a recent update the spacing of words in Firefox's UI as well as on some websites seems to be wider than normal (instead of a singular space it seems as if each spac… (read more)

Since a recent update the spacing of words in Firefox's UI as well as on some websites seems to be wider than normal (instead of a singular space it seems as if each space is now a tab wide). Additionally the numbers have also suffered and are now not presented in a normal font anymore but instead seem bigger and grey instead of white or black. Both of these issues occurred at the same time and appear on the normal User Interface of Firefox (e.g. in the bookmarks or in Firefox's settings and preferences) as well as on some websites/search engines. However when copying the text and numbers from Firefox into a regular text editor everything seems normal and no appearance issues can be noticed. What I've already tried: I've restarted my system multiple times since the issue first occurred. I've removed all contents from /home/user/.mozilla/firefox. I've reinstalled Firefox. I've deleted my cache. I've changed my font preferences in Firefox back to Default(Roboto) after having used Inter before. None of my actions above have changed anything. However, when I log into a different user on my computer and open Firefox there everything seems to be normal, so it seems as if this is a user-specific problem.

Thanks in advance, Emma.

OS: opensuseTumbleweed 20220507 Firefox version: 100.0 (issue has occurred since version 98.0)

Asked by emma.6.62607015e-34 1 week ago

Answered by cor-el 1 week ago

  • Solved

opt-out the saved passwords proposals

Hi, is there a config option to prevent the showing of user/pw proposals when opening a website for which user account data is saved? When i'm logging into a website with… (read more)

Hi,

is there a config option to prevent the showing of user/pw proposals when opening a website for which user account data is saved? When i'm logging into a website with already saved user data, i get account proposals (as ff saves the data "per domain", say if you have 3 accounts to one website, e.g. a test user, an administrator and a cms administrator, they are all presented where needed content may be...) see pict. I would like to opt out this behavior, as i have more than one website with 2 or more accounts.


-- cu

jth

Asked by jth 1 week ago

Answered by cor-el 1 week ago

  • Solved

How to unbind Ctrl+K?

I was using Ctrl+K on some websites to do things like site-specific search, task bars, and so forth, but recently Firefox started capturing it for focusing on the search/… (read more)

I was using Ctrl+K on some websites to do things like site-specific search, task bars, and so forth, but recently Firefox started capturing it for focusing on the search/address bar (https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#w_search).

Is there a way to unbind `Ctrl+K` in Firefox?

Asked by astrojuanlu 1 week ago

Answered by astrojuanlu 1 week ago

  • Solved

"Open Containing Folder" can't open file folder, instead it opens the file itself

Similar to: https://support.mozilla.org/en-US/questions/1329194 https://support.mozilla.org/en-US/questions/1298089 In KDE 5.24.4, Linux. I started to have some issues wi… (read more)

Similar to: https://support.mozilla.org/en-US/questions/1329194 https://support.mozilla.org/en-US/questions/1298089

In KDE 5.24.4, Linux. I started to have some issues with "Open containing folder" probably because I installed many Gnome apps which may cause bad configurations in my system.

I suspect this cause this issue even though I don't really have gnome file manager:

https://polywogsys.livejournal.com/309405.html "Gnome based file managers, Nemo/Caja/Nautilus provide the entry org.freedesktop.FileManager1. So it doesn't matter what you set as your default application for the filemanager mimetype - as per the freedesktop.org standard, firefox will always select a filemanager based on dbus (if it's there)"

But because the mimetype points to "dolphin", I dont really have other explanation either: $ xdg-mime query default inode/directory org.kde.dolphin.desktop

Asked by gjoe 1 week ago

Answered by gjoe 1 week ago

  • Solved

Firefox use what to choose folder in KDE Plasma?

I use firefox since I go to college. When I got some problems, I try to check firefox use what to pick folder? I use Manjaro Plasma. I find chrominum use kdialog. But fi… (read more)

I use firefox since I go to college. When I got some problems, I try to check firefox use what to pick folder? I use Manjaro Plasma. I find chrominum use kdialog. But firefox looks not though both use gtk3 as UI

Firefox choose folder got wrong when use a USB HDD

Asked by kearney 2 weeks ago

Answered by kearney 2 weeks ago

  • Solved

After disabling developer tools annoying tab keeps opening.

I'm using Ubuntu 18.04. Developer tools kept popping up so I went into about:config & set everything to false. Now an equally annoying tab keeps opening up asking to… (read more)

I'm using Ubuntu 18.04. Developer tools kept popping up so I went into about:config & set everything to false. Now an equally annoying tab keeps opening up asking to enable them. I don't just get this hitting F12. Just like before I disabled, this keeps popping up for seemingly no reason. Guess I'm accidentally doing something with the mouse. I don't have a clue how to use developer tools. Wish I could just wipe it out completely.

Asked by jcs916 2 weeks ago

Answered by Seburo 2 weeks ago

  • Solved

Firefox breaks my desktop environment's scrollbar style and (gradient) color and in version 98+ refuses css to approximate it

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has t… (read more)

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has to be an exception by itself! Not only that, but it changes my ability to customize its interface, from time to time and even changes access to such ability, on some updates.

My scrollbar customizations in userChrome.css and userContent.css do not work any more (other CSS changes still work, for menu/addressbar/tabbar/bookmarksbar orderint and tab styling). I had to resort to settings in user.js file, to get a 20px width scrollbar, suitable for my big screen, but... it gets very wide when I increase the focus, on some webpages and becomes very ugly! Furthermore, I cannot make sense of the proper use of "ui.themedScrollbar*" settings and the scrollbar and its slider result in the same color. These are my settings in user.js:

user_pref("widget.content.gtk-theme-override", "backwater"); user_pref("widget.non-native-theme.enabled", false); // Use GTK-3.0 gtk.css: set to false user_pref("toolkit.legacyUserProfileCustomizations.stylesheets", true); // Use userChrome.css & userContent.css: set to true user_pref("widget.gtk.alt-theme.scrollbar_active", true); user_pref("widget.non-native-theme.scrollbar.size.override", 20); // If nothing else works, fix scrollbar width to 20px user_pref("widget.non-native-theme.gtk.scrollbar.round-thumb", false); user_pref("widget.non-native-theme.gtk.scrollbar.thumb-size", 1.0); // originally 0.75 user_pref("widget.non-native-theme.gtk.scrollbar.allow-buttons", true); // it was true, anyway... user_pref("layout.css.cached-scrollbar-styles.enabled", false); user_pref("layout.css.color-mix.enabled", true); user_pref("widget.non-native-theme.scrollbar.style", 4); // wide scrollbar theme: set to 4 user_pref("ui.themedScrollbar", "#bad1f5"); user_pref("ui.themedScrollbarInactive", "#668cc4"); user_pref("ui.themedScrollbarThumb", "#e4e4e4"); user_pref("ui.themedScrollbarThumbHover", "#e4e4e4"); user_pref("ui.themedScrollbarThumbActive", "#668cc4"); user_pref("ui.themedScrollbarThumbInactive", "#bad1f5"); user_pref("browser.dom.window.dump.enabled", false); user_pref("extensions.ui.sitepermission.hidden", false); user_pref("fission.experiment.max-origins.qualified", true);

Either with the "ui.themedScrollbar*" settings or without them (and cleared from the prefs.js file), the scrollbar and its slider result in the same color, unless I (tryingly) click on some place on the scrollbar outside its slider; then I can see the slider, _only_ for the duration of the mouse-down event (which causes up or down page-hight scrolling).

The default, very thin scrollbar, as well as my modified wide scrollbar with invisible slider are both useless to me! I have even tried fx-autoconfig (https://github.com/MrOtherGuy/fx-autoconfig) to make the scrollbar CSS work, but no result. At this point, I am considering switching to another browser, despite the trust I have to mozilla, for my data and privacy.

Asked by kavadias 2 weeks ago

Answered by kavadias 2 weeks ago

  • Solved

how to avoid the graying of most of the url in the location bar?

In the location bar (aka url bar aka address bar), the base domain name ("example.com") is displayed as normal text, whereas everything else in the url is displayed in gr… (read more)

In the location bar (aka url bar aka address bar), the base domain name ("example.com") is displayed as normal text, whereas everything else in the url is displayed in gray. For example, if the displayed url is https://foo.example.com/bar, the "https://foo." and "/bar" are in gray.

Is it possible to get the whole url displayed as normal text, i.e., black, and avoid this "graying out" of some of it?

In my searches so far, I've found various other customizations for the location bar via userChrome.css, but not this one. Any help appreciated.

I'm using firefox 91.8.0esr (64-bit) as currently packaged for centos7 (x86_64), though presumably this is not system-dependent.

Asked by karlberry 2 weeks ago

Answered by MarkRH 2 weeks ago