Can't open links from other apps, error "Firefox is already running"

I'm running Arch btw, with GNOME Shell 3.38.3 and Firefox 86.0 (64-bit). If I have Firefox already open and I click on a link inside of another app, Firefox displays the … (read more)

I'm running Arch btw, with GNOME Shell 3.38.3 and Firefox 86.0 (64-bit).

If I have Firefox already open and I click on a link inside of another app, Firefox displays the following error message and the link fails to open.

Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

However, if I close Firefox and then click the link again, Firefox will correctly open the link.

Asked by jpina452 7 hours ago

Choose pane configuration in inspect element

Hi, When I use inspect element, there's obviously the main HTML pane, and then the tabbed pane with CSS rules and the sort. When I pop out inspect element to its own wind… (read more)

Hi,

When I use inspect element, there's obviously the main HTML pane, and then the tabbed pane with CSS rules and the sort. When I pop out inspect element to its own window, it looks like the first image attached. However, dragging it and maximizing it on my second monitor makes it look like the second image. Obviously, this is less than ideal for this layout. As far as I'm aware, this is purely a responsive layout, with no user overrides (3-pane mode's docs only say "At narrower browser window widths, the tabs appear below the CSS Rules pane.) My question then, is if there is a way to override this? If so, I'm all ears, and if not, I do think that's something that should be considered.

Asked by Shawn 8 hours ago

"a webpage might be slowing down your browser." frequent persistent yellow pop up bug crashing my webpages. please make it stop!?

hello there and good evening:3 my husband and i are having this repetitive and extremely frequent bright yellow pop up with a robot that states "a webpage might be slowin… (read more)

hello there and good evening:3 my husband and i are having this repetitive and extremely frequent bright yellow pop up with a robot that states "a webpage might be slowing down your browser." then the option to wait, or stop it. i've ran out of patience with this notification to the point to where even though i'de hate to, i would have no choice but to switch back to chrome just to stop being spammed by this pop up while im trying to relax. it happens more frequently on youtube and walmart.com, and i just want it to stop because it seems as if when it does show up, once it starts it never stops, and it actually slows down my webpage to the point of becoming unresponsive and stalling/crashing my only webpage open at the time. my husband has the same issue and we both use windows desktop. it only started appearing after the latest update. please, can someone help me make this thing go away? its very stressful and i cant browse in peace anymore on firefox. yes we have turned off all background processes, and we both have scowered settings troubleshooting for hours at a time to no avail, it just never stops and it behaving like a really bad bug.

Asked by Sprinkles91 8 hours ago

I accidentally lost the recommended articles

I accidentally lost the recommended articles which can be saved to pocket (optional). There should be a checkbox that asks: ARE YOU SURE ? There must be an EASY way to ge… (read more)

I accidentally lost the recommended articles which can be saved to pocket (optional). There should be a checkbox that asks: ARE YOU SURE ? There must be an EASY way to get the articles back. While I'm here I'd like to say that a lot of the help files or comments don't have any pictures. A picture IS worth a thousand words so it would be nice to have more of that. Someone could ask you what someone else looked like and you could sit there and type a long time or (so much faster) show them a picture if you have one, right ? Let's go a step further and use a dismantled car engine. Even more complex. Are you starting to get it ?  :-)

Asked by Ray 8 hours ago

  • Solved

Firefox set to erase data on close is forgetting extension logins when it didn't before

I had to reinstall Windows recently. For some reason, Firefox no longer seems to keep me logged in to Lastpass and Pushbullet. More than half of the time I load a new ses… (read more)

I had to reinstall Windows recently. For some reason, Firefox no longer seems to keep me logged in to Lastpass and Pushbullet. More than half of the time I load a new session, Lastpass will give me a cookies notice but does remember my details in the fields, whereas Pushbullet shoves a login screen in my face and I have to go through the hassle of signing in with Google.

My browser has always been set to erase everything on close, but this has never effected extensions, so I'm surprised it suddenly does so. I don't think my settings are any different than they have been previously. I've tried making the lastpass and pushbullet websites as exceptions and playing with various privacy settings but am unable to replicate the 'correct' behaviour I had before.

Am I missing something here please? Has something changed in recent versions of Firefox?

Settings are: Standard tracking protection Always do not track Delete cookies and site data when Firefox is closed is checked with Lastpass.com and Pushbullet.com as exceptions All options under 'Logins and passwords' unchecked Always use private browsing mode, remember browsing and download history, and remember search and form history are all unchecked Clear history when firefox closes is checked, and in settings, all boxes are checked

Asked by Lewis7247 8 hours ago

Answered by jscher2000 8 hours ago

html <audio>

Can anyone tell me why the following html code doesn't work: <audio autoplay> <source src="file.mp3" type="audio/mpeg"> Your browser does not support the a… (read more)

Can anyone tell me why the following html code doesn't work:

<audio autoplay>
  <source src="file.mp3" type="audio/mpeg">
Your browser does not support the audio element.
</audio>

I must say, it does work in Microsoft Edge, but in no other browser, including Firefox. And how could I make it work? I want the audio file to start playing when the page is opened, in the background, no controls, no loops...

Thanks in advance for any help.

Asked by Jos 1 day ago

Last reply by jscher2000 9 hours ago

Firefox resets every morning

Every time I wake up, firefox has reset like i am opening it for the first time. i have to log in every morning, which is different from other browsers. i am wondering, i… (read more)

Every time I wake up, firefox has reset like i am opening it for the first time. i have to log in every morning, which is different from other browsers. i am wondering, is this a feature, or a bug. it also resets extensions, bookmarks, and logins. this is very annoying for me.

Asked by Lewis Dunn 9 hours ago

Last reply by cor-el 9 hours ago

Recently there has been a 10 second delay when clicking links in firefox

It occurs in Safe Mode as well. Is this a man in the middle attack, ISP throttling, or something else? Whatever it is, it is very irritating. The firefox window freezes… (read more)

It occurs in Safe Mode as well. Is this a man in the middle attack, ISP throttling, or something else?

Whatever it is, it is very irritating. The firefox window freezes for 10 seconds after clicking a link. On Windows 8, Firefox 86.0, 64-bit.

Asked by fullscreener_notoolbar 9 hours ago

Last reply by jscher2000 9 hours ago

Search engines limited to language version

Hello everyone. I tried switching Firefox (Windows 10) from Polish to English. (It is nice to see a program in your native language. However, most manuals, tutorials, for… (read more)

Hello everyone.

I tried switching Firefox (Windows 10) from Polish to English. (It is nice to see a program in your native language. However, most manuals, tutorials, forums etc. on the Web are in English, so using English version of apps wherever possible feels straightforward and consistent). I found one functionality that is browser language dependent for no reason - availability of search engines. Specifically, allegro.pl (Polish auction site). It's there by default when Firefox language is set to Polish. When I switch to English, it disappears along with other default Polish search engines, only to be replaced by English ones.

When I try a "manual" setup of search engines, allegro.pl is nowhere to be found. Firefox settings -> find search engines - no official allegro search engine (just some fan-made add-ons). Go to allegro.pl -> Firefox search bar - I expected the icon of magnifier with green plus sign that would add the search engine of current site - again it's not there.

Is there any workaround? Cheers, Rafał

Asked by Rafau 1 day ago

Last reply by Rafau 19 hours ago

  • Solved

Two-sided Printing is now BACKWARDS

Recently, I noticed Firefox has a new printer dialogue box. When that dialogue box starting showing up, all of my two-sided print jobs are BACKWARDS. The back page is fli… (read more)

Recently, I noticed Firefox has a new printer dialogue box. When that dialogue box starting showing up, all of my two-sided print jobs are BACKWARDS. The back page is flipped 180 degrees from the front page. WRONG!

As a sanity check, I double-checked with Chrome and Opera. No problem. Double-sided print jobs print as usual (i.e., when you flip the page over in the horizontal direction, the print orientation remains correct).

HP1320 laser printer. Win 7 / 64 bit. HP printer driver.

Somehow, the new Firefox Browser printer dialogue overlay is overriding the HP printer driver. Please fix!

Asked by jl11 18 hours ago

Answered by jscher2000 17 hours ago

PROBLEMA FIREFOX 86

SENHORES, VOCÊS CRIARAM UM NAVEGADOR MARAVILHOSO, MAS NO MENU CONFIGURAÇÃO E IMPRESSÃO, EU FIQUEI UM DIA INTEIRO PROCURANDO PARA VER SE CONSEGUIA ACHAR O BOTÃO CONFIGURAR… (read more)

SENHORES, VOCÊS CRIARAM UM NAVEGADOR MARAVILHOSO, MAS NO MENU CONFIGURAÇÃO E IMPRESSÃO, EU FIQUEI UM DIA INTEIRO PROCURANDO PARA VER SE CONSEGUIA ACHAR O BOTÃO CONFIGURAR PAGINA, PORQUE EU USO UMA IMPRESSORA EPSON FX 890 E PARA QUE IMPRIMA O QUE PRECISO ELA PRECISA SER CONFIGURADA COM CABEÇALHO 0, RODAPÉ 0, DIREITA 5,0 E ESQUERDA 5,0 DE MARGEM, MAS EU NÃO ACHEI EM CANTO NENHUM O BOTÃO CONFIGURAR PAGINA DE IMPRESSÃO PARA QUE PUDESSE USAR A IMPRESSORA SEM O DESALINHAMENTO DO PAPEL. EU ACHEI ESTE BOTÃO NO FIREFOX 83 DEPOIS DISSO NÃO ACHEI NOUTRAS VERSÕES. É UM BOTÃO IMPORTANTÍSSIMO PRECISO ACHA-LO NA VERSÃO 86 SE EXISTIR. SOCORRO. NÃO ACHEI NA INTERNET UM TUTORIAL QUE ME AJUDASSE TODOS DIZEM PARA CLICAR NO BOTÃO CONFIGURAR PAGINA, MAS NA VERSÃO 86 ELE NÃO ESTA EM CANTO NENHUM.

Asked by delegaciascp 11 hours ago

  • Solved

Cannot change default search engine from DuckDuckGo to something else

Even in safe mode, I cannot make a change to my default search engine stick; it always reverts to DuckDuckGo. After changing the default search engine in Preferences->… (read more)

Even in safe mode, I cannot make a change to my default search engine stick; it always reverts to DuckDuckGo.

After changing the default search engine in Preferences->Search to, say, Ecosia Search, typing a space character in the address+search bar goes from a generic world favicon to DuckDuckGo. Restarting with a cleared cache doesn't help.

None of my addons are related to search except Ecosia Search. Even with Ecosia Search removed, I get the same behavior, the default search engine reverts to DuckDuckGo. In any case, safe mode with all addons disabled doesn't change that behavior.

If i remove DuckDuckGo from the list of search engines, I cannot search at all and I cannot choose a default search enigne from the drop down list in Preferences->Search.

Note that I can always choose an alternate search engine in the drop down search menu, and that works. Setting a default search engine doesn't work.

Any suggestions on how to make a search engine other than DuckDuckGo be my default search engine would be appreciated. As a bonus, an explanation of why I'm having this difficulty would be wonderful.

TIA.

Asked by Vladimir G. Ivanović 16 hours ago

Answered by cor-el 13 hours ago

How to retrieve an add-on account

Hi, I'm the administrator for Dol Celeb, a website and there is some years ago, i've created an account for themes : https://addons.mozilla.org/fr/firefox/addon/dol-celeb… (read more)

Hi,

I'm the administrator for Dol Celeb, a website and there is some years ago, i've created an account for themes : https://addons.mozilla.org/fr/firefox/addon/dol-celeb/

We have changed or website design and i'd like to create a new theme for my community. The problem, i've no longer access to this account and i've no idea how to retrieve it. I've still got all Dol Celeb mail address but that seems no one is the related to this account.

Is there a way to do something ? It should be nice to retrieve this official page we have created.

Thanks by advance for your help

Asked by Ervael 12 hours ago

Last reply by cor-el 11 hours ago

Why do PDF's from Outlook all of a sudden open in Firefox? How do I turn this off?

Yes, I have set the options to open, see attached. If I go to a website and click on a PDF it will open in Adobe Reader. When I go to Outlook.live.com for my email and c… (read more)

Yes, I have set the options to open, see attached. If I go to a website and click on a PDF it will open in Adobe Reader. When I go to Outlook.live.com for my email and click on the PDF it opens them in a Firefox preview. When I print them from Firefox it takes an average of 5 minutes per page. If I download and open in Adobe it takes seconds to print the entire file.

Asked by johnaclayman 13 hours ago

Last reply by Fedtsten 11 hours ago

Firefox account problem

All PC's mentioned below are on the same router and LAN, and all are using Firefox 86 x64 on Windows 10. I have been a Firefox user for many, many years (I started using … (read more)

All PC's mentioned below are on the same router and LAN, and all are using Firefox 86 x64 on Windows 10.

I have been a Firefox user for many, many years (I started using browsers in the 90's, 'nuff said). But having recently reinstalled a PC, I found myself unable to initiate sync on the new Firefox install there. I kept getting the error "NetworkError when attempting to fetch resource." in a red box when I entered my password. Perplexed, I tried creating a support ticket on another of my PC's (let's call it #2) - same error there when trying to sign in to Firefox support! I then tried to use that browser to access my account by going to Account Settings -> Manage Account. I was met with a circle animation - and a completely blank webpage.

This post is being created from my third PC, where, for some odd reason, the Manage Account function actually works, and where I was also able to sign into support. I made a change to my bookmarks on PC/Firefox #2, to see if sync was still working - and it did come through to PC #3. After that, I was finally able to start a sync on PC #1 (the newly installed one).

But I am still unable to do anything with my account on PC #2. Can't sign in to support, can't access Manage Account. And this cannot be purely about the profile or installation, as the issue was affecting PC #1 as well.

It seems like Mozilla's account management is really wobbly, and my prime suspect is the shift to "Firefox Accounts" on the support pages recently. But I'm open to being proved wrong.

Just hoping someone out there can tell me what this issue is, and how I fix it. The fact that I was unable to sign in to my Firefox Account from a completely new Firefox install makes me very uncomfortable. And my primary PC (#2) is still unable to manage that account, or sign in to the support pages.

Thanks in advance.

Asked by Fedtsten 12 hours ago

displaying arabic name when launching zoom from firefox browser

For some reason, when I launch Zoom from Firefox, I cannot display my name automatically in Arabic. If I log in to someone else's meeting, it works fine, and if I log in … (read more)

For some reason, when I launch Zoom from Firefox, I cannot display my name automatically in Arabic. If I log in to someone else's meeting, it works fine, and if I log in via a different browser like Chrome it works fine. It is only if I launch Zoom from firefox. Any suggestions?

Asked by jonathan.huppert 12 hours ago

persevering data retoring session

I sought without answer to see how to PREVENT restoring previous sessions, freezing my computer because FF did not clear previous sessions, internet access freezing when … (read more)

I sought without answer to see how to PREVENT restoring previous sessions, freezing my computer because FF did not clear previous sessions, internet access freezing when social media sites weren't cleared, as they used to be. And then, reading the solution on, how to access restoresession options, I come upon about:config and search browser.session I see the problem. Instead of setting options to clear previous history, FF now has uncountable options which - hide browsers I've deletes, like Bing - maintain restoring sessions up to 5, 10, 32 times, even though I've set the option to never - keep data I wanted deleted, in Top sites, in pocket, in other options - set Google as the default translator even though I've chosen not to use it I am seriously disappointed in Firefox and Mozilla. I have used it since I found it one- two ? decades ago because it WASN'T wired into the top-heavy, data-excessive, intrusive-spying behemoths of Google and Microsoft. Did Google buy you out, or something? I do notice that the wonderful creative-commons data options have been swallowed up by those icons of not-for-profit and community sharing, google-android, every for-profit phone companies (ATT, Verizon,etc.) How sad and ironic. I found my solution was, select 0 for many, many browser.?? options and deleting the history I found in various switches. Posting this to share my disillusion.

Asked by tina 17 hours ago

Last reply by cor-el 12 hours ago